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Questions and Support



Using the Companion Content



The companion content for this title includes example and configuration files that will help you get the most out of your Inside Out book. These files, and other information, can be downloaded from the Companion Content page located at:
http://go.microsoft.com/fwlink/?Linkid=198961


Support Information



Every effort has been made to ensure the accuracy of the contents of the book. If anything seems to have slipped through the cracks, visit the book’s home page at http://oreilly.com/catalog/9780735626881. There are links there that you can click to submit errata and to provide other kinds of feedback.
If you have questions or comments regarding this book, please send them to Microsoft Press using this email address:
msinput@microsoft.com
Please note that product support is not offered through this address. For support information, visit Microsoft’s Web site at http://support.microsoft.com.

We Want to Hear from You



We welcome your feedback about this book. Please share your comments and ideas through the following short survey:
http://microsoft.com/learning/booksurvey.
Your participation helps Microsoft Press create books that better meet your needs and your standards.
Note
We hope that you will give us detailed feedback in our survey. If you have questions about our publishing program, upcoming titles, or Microsoft Press in general, we encourage you to interact with us using Twitter at http://twitter.com/MicrosoftPress. For support issues, use only the email address shown previously.


Conventions and Features Used in This Book



This book uses special text and design conventions to help you find the information you need more easily.
Text Conventions



	Convention
	Meaning

	Abbreviated commands for navigating the ribbon
	For your convenience, this book uses abbreviated commands. For example, “Click Home, Insert, Insert Cells” means that you should click the Home tab on the ribbon, then click the Insert button, and finally click the Insert Cells command.

	Boldface type
	Boldface indicates text that you type.

	Initial Capital Letters
	The first letters of the names of tabs, dialog boxes, dialog box elements, and commands are capitalized. Example: the Save As dialog box.

	Italicized type
	Italicized type indicates new terms.

	Plus sign (+) in text
	Keyboard shortcuts are indicated by a plus sign (+) separating key names. For example, Ctrl+Alt+Delete means that you press the Ctrl, Alt, and Delete keys at the same time.





Design Conventions



Tip
INSIDE OUT This Statement Illustrates an Example of an “Inside Out” Heading
These are the book’s signature tips. In these tips, you get the straight scoop on what’s going on with the software—inside information about why a feature works the way it does. You’ll also find handy workarounds to deal with software problems.

Sidebar
Sidebars provide helpful hints, timesaving tricks, or alternative procedures related to the task being discussed.

TROUBLESHOOTING
This statement illustrates an example of a “Troubleshooting” problem statement.
Look for these sidebars to find solutions to common problems you might encounter. Troubleshooting sidebars appear next to related information in the chapters. You can also use “Index to Troubleshooting Topics” at the back of the book to look up problems by topic.

Note
Cross-references point you to locations in the book that offer additional information about the topic being discussed.

Caution
Cautions identify potential problems that you should look out for when you’re completing a task or that you must address before you can complete a task.

Note
Notes offer additional information related to the task being discussed.

When an example has a related file that is included on the companion Web site, this icon appears in the margin. You can use these files to follow along with the book’s examples. The companion Web site is located at http://go.microsoft.com/fwlink/?Linkid=198961.

Part 1. Examining the Excel Environment




Chapter 1
Chapter 2
Chapter 3
Chapter 4


Chapter 1. What’s New in Microsoft Excel 2010



New and Improved for 2010
If You Missed the Last Upgrade
Retired in 2007
If You Missed the Last Two Upgrades
Onward
OVER the years, Microsoft has devoted considerable resources to usability research, including a suite of onsite laboratories, which has contributed innumerable incremental changes to the ease of use, functionality, and appearance of Microsoft Office. The 2007 release truly marked a paradigm shift—the most significant change since Office 95. For those who are wary of change, Office 2010 is a significant refinement; the beta was widely distributed, heavily tested, and well behaved. So if you—out of fear, prudence, or thrift—have been waiting for the next version, the waiting was the hardest part.
[image: image with no caption]

New and Improved for 2010



First, we’ll highlight the new features in the 2010 release of Microsoft Excel. Later, we’ll talk about features that have been “retired” from the program and summarize the features that will be new to you if you skipped the last upgrade or two.
Backstage View



Users of Excel 2007 had to adjust to the Microsoft Office Button replacing the File menu, but in Excel 2010, the File tab replaces the Office Button, so the File menu is kind of back, but there’s a lot more going on there now. The new File tab opens what Microsoft calls Backstage view, a single location where you find essential controls and information about your documents and where most of Excel’s behind-the-scenes options and settings reside. The traditional File menu commands are here, too—for opening, saving, and creating new files; using templates; printing; and sharing information with others. Click the File tab on the ribbon to open Backstage view, shown in Figure 1-1. The features contained in Backstage view are discussed throughout the book, but for more, see Introducing Backstage View on page 41.
[image: Clicking the File tab reveals Backstage view, where a lot is going on behind the scenes.]

Figure 1-1. Clicking the File tab reveals Backstage view, where a lot is going on behind the scenes.


Ribbon Customization



Users of the static ribbon in Excel 2007 will be happy to know that Excel 2010 allows you to create your own, as shown in Figure 1-2. You can freely rearrange command groups; change the order and position of tabs; remove groups; create custom commands, groups, and tabs; and show or hide existing tabs. For more information, see Customizing the Ribbon on page 83.
[image: Now you can easily change the ribbon to your liking.]

Figure 1-2. Now you can easily change the ribbon to your liking.


Sparklines



Sparklines are tiny charts that fit within a cell and give you a visual summary alongside your data, as shown in Figure 1-3. To create one, click the Insert tab and click one of the buttons in the Sparklines group to get started. See Chapter 20, for more information.
[image: Sparklines are cell-sized charts you can put anywhere.]

Figure 1-3. Sparklines are cell-sized charts you can put anywhere.


Paste Preview



For those who feel that the ability to undo an action isn’t quite enough, Excel now allows you to preview how copied information will look before you paste it. Copy, click where you intend to paste in the workbook, click the Paste menu (on the Home tab in the Clipboard group), hover over the option buttons (as shown in Figure 1-4), and watch what each one will do if you actually click it. You can also right-click where you want to paste, and the shortcut menu that pops up displays applicable paste option buttons that exhibit the same live preview functionality. Make a selection, and click to paste. For more information, see Previewing Before You Paste on page 199.
[image: Click where you want to paste, then hover over options on the Paste menu to preview them.]

Figure 1-4. Click where you want to paste, then hover over options on the Paste menu to preview them.


Improved Picture Editing



Now when you want to insert a picture in a workbook, you can edit it directly in Excel 2010—you no longer need to prepare it in advance using a photo-editing program. After you insert a picture (Insert tab, Picture button), the Picture Tools tab appears whenever the picture is selected, as shown in Figure 1-5.

Office Web Apps



Providing a familiar Microsoft Office experience when you are away from your computer, Office Web Apps allow you to work with Excel, Word, PowerPoint, and OneNote files from just about anywhere through browser-based viewing and lightweight editing. Office Web Apps, shown in Figure 1-6, are available in various flavors through both free and fee accounts on Windows Live, Hotmail, SharePoint, and other online portals. For more information, see Chapter 26.
[image: You can do a lot of photo editing directly in Excel 2010.]

Figure 1-5. You can do a lot of photo editing directly in Excel 2010.

[image: Office Web Apps allow browser-based access and light editing of Excel workbooks.]

Figure 1-6. Office Web Apps allow browser-based access and light editing of Excel workbooks.


Slicers



Slicers, a new addition to the PivotTable interface, provide an easier way to drill down through large PivotTables so that you can see exactly the data you need without being distracted by data you don’t need. A single slicer can be connected to more than one table, which means that if you set up a group of PivotTables to display a common set of data from multiple perspectives, you can use a single slicer to change the filter for all related tables at once. For more information, see Filtering with Slicers on page -.
[image: Slicers are independently movable and sizable windows that make filtering PivotTable data easier.]

Figure 1-7. Slicers are independently movable and sizable windows that make filtering PivotTable data easier.


Improved Conditional Formatting



New conditional formatting options let you quickly visualize and comprehend data. You will find more styles, icons, and data bars, and you now have the ability to highlight specified items (such as the maximum or minimum value) in a few clicks. In the Styles group on the Home tab, click Conditional Formatting. For more information, see Formatting Conditionally on page 309.

New Functions and Functional Consistency



Microsoft added a number of statistical and financial functions that extend or refine existing functionality. These functions have been added largely to conform to standard industry practices—and perhaps to increase formula readability a bit. All “legacy” versions of the updated functions remain fully supported and are listed in the Help table of contents as “Compatibility Functions” under the Function Reference heading. You’ll know exactly which functions are new because they are all “dotted” forms with a mid-period, such as CEILING.PRECISE.
Most of the new functions are statistical distribution functions. For example, the COVAR function, a measure of deviation between data sets, has been replaced by COVARIANCE.P and COVARIANCE.S, which apply to an entire population of data (P) or a representative sample (S). The original COVAR function is still included and works fine, of course. Most of these new functions are discussed in Chapter 17.

Improved Math Equation Support



[image: image with no caption]

Create and display math equations with the rich set of equation-editing tools in Excel 2010. On the Insert tab, in the Symbols group, click Equation to insert a new equation and activate the Equation Tools Design tab shown in Figure 1-8. If you click the arrow adjacent to the Equation button (which also appears on the Equation Tools Design tab), you can select from a group of preconstructed equations (including the binomial theorem equation shown in Figure 1-8) as a starting point.
[image: The new equation-editing tools make it easy to construct complex equations.]

Figure 1-8. The new equation-editing tools make it easy to construct complex equations.


Improved Charting Capacity



Two-dimensional charts in Excel 2007 were limited to 32,000 data points per series. Chart series are now limited only by system memory.

Additional SmartArt Graphics



Incorporate great-looking graphics into your professional documents without a large consulting team or time commitment. On the Insert tab, in the Illustrations group, click SmartArt, and then select a SmartArt layout. The SmartArt Tools Design and Format tabs appear whenever your insertion point is in a SmartArt graphic.

64-Bit Edition



Excel 2010 offers 64-bit scalability for the Excel guru or analyst working with massive, memory-intensive datasets and provides support for gigabyte-size spreadsheets. If you purchased the 64-bit version, select the 64-bit option when you install Excel.

Office Mobile 2010



Microsoft Office Mobile brings the Office 2010 tools you use every day to the mini screen of your mobile device. View charts, graphs, and images just as you see them on your main computer. Office Mobile 2010 is available for Windows Mobile smartphones. Visit office.microsoft.com for more information.



If You Missed the Last Upgrade



Just in case you leapfrogged a software upgrade and missed the last big Microsoft Office release, here is a brief description of a few features that are essentially new to you but were introduced in the previous release:
	Results-oriented user interface The old toolbars and menu bar have been replaced by a single toolbar and a new “dashboard” called the ribbon, which has a task-oriented structure and easily recognizable tools. Most of the old menus have been reborn as tabs. For more information, see Chapter 3.

	Graphics enhancements Excel has improved greatly over the years as a platform for graphics and design, and the 2007 release incorporated a few subtle enhancements, including a robust SmartArt feature; improvements to conditional formatting, shapes, and charting; and new document themes and cell styles. For more information about graphics tools, including SmartArt, see Chapter 10.

	Improved formatting Microsoft built a lot more intelligence into the formatting features of Excel 2007—including themes, cell styles, galleries, and live previews—that allow you to rest the pointer on an item in a palette of options to see what will happen when and if you click. For more information about themes, cell styles, and other formatting features, see Chapter 9.

	Page Layout view Really more than a view, Page Layout view became a working mode with rulers and page previews in which you have full editing functionality and control over the appearance of your documents. For more about output options, including Page Layout view, see Chapter 11.

	New templates Excel 2007 shipped with more built-in templates for popular uses, such as balance sheets and expense reports, and provided direct dialog-box access to a vast template library at Microsoft Office Online. For more information about using templates, see Chapter 9.

	Updated conditional-formatting features Conditional formatting has been around for a while, but recent enhancements have made it more accessible and compelling—with gradients and data bars, conditionally triggered icon sets, and more. For detailed information, see Formatting Conditionally on page 309.

	Increased capacity and speed The new XML file format and other internal improvements gave Excel 2007 greatly increased capacities in just about every specification—for example, spreadsheets that can hold more than one million rows of data, 64 levels of nesting in formulas, and built-in support for multicore processors and multithreaded chipsets. Other major specification changes included:
	The total number of available columns: 16,384 (was 256).

	The total number of available rows: 1,048,576 (was 65,536).

	The total amount of computer memory: Excel can now use the maximum allowed by Windows (was 1 megabyte).

	The number of unique colors allowed in a single workbook: 4.3 billion (was 56).

	The number of conditional format conditions on a cell: Limited only by available memory (was 3).

	The number of levels of sorting you can perform on a range or table: 64 (was 3).

	The number of items allowed in the Filter drop-down list: 10,000 (was 1,000).

	The total number of unique cell formats in a workbook: 64,000 (was 4,000)

	The maximum number of characters allowed in formulas: 8,000 (was 1,000).

	The number of levels of nesting that Excel allows in formulas: 64 (was 7).

	The maximum number of arguments allowed to a function: 255 (was 30).

	The maximum number of items returned by the Find command: 2 billion (was 64,000).

	The number of rows allowed in a PivotTable: 1 million (was 64,000).

	The number of columns allowed in a PivotTable: 16,000 (was 255).

	The maximum number of unique items within a single PivotTable field: 1 million (was 32,000).

	The maximum length of the MDX name for a PivotTable item, the string length for a relational Pivot Table, the caption length, and field label length: 32,000 (was 255).

	The number of fields that a single PivotTable can have: 16,000 (was 255).

	The number of array formulas that can refer to another worksheet: Limited only by available memory (was 65,000).

	Limit to the number of rows that you can refer to in an array formula: None (was 64,000).

	The number of categories allowed for custom functions: 255 (was 32).

	Excel now supports multicore processors and multithreaded chipsets.




	Better and easier tables Excel 2007 introduced a more robust table feature, incorporating PivotTable-like intelligence with easier formatting and editing. New features included the Table Styles gallery, structured referencing, the Remove Duplicates feature, and more. For more information about tables, see Chapter 22.

	Improved PivotTables and PivotCharts Excel 2007 added a few key improvements to PivotTable filtering, design, and layout. The greatly improved appearance of the charting features enabled more compelling PivotCharts. For more information about PivotTables and PivotCharts, see Chapter 23.

	Better database connectivity Along with better PivotTables, Excel 2007 provided built-in access to SQL Server Analysis Services and included support for the Unified Dimensional Model (UDM) as well as for online analytical processing (OLAP) browsers and key performance indicators (KPIs). For more information about connectivity issues, see Chapter 24.

	Formula AutoComplete Typing functions in formulas became a little easier in Excel 2007. When you type an equal sign followed by any letter, you get a drop-down list of functions that start with that letter, along with a ScreenTip description of the highlighted function. Type another letter, and the list is filtered again. If you have defined cell range names in your workbook, these appear in the list as well. For more information about functions and AutoComplete, see Chapter 13.

	Tools for creating formulas In Excel 2007, the formula bar became manually resizable to let you display or hide lengthy formulas. This allowed you to enter longer formulas than before, with more levels of nesting (parenthetical expressions within expressions). The Name Manager dialog box provided greater organization and editing possibilities. In addition, Excel 2007 included many small improvements in the way it works internally, including improvements in subtotals and regression formulas. See Chapter 12.

	Built-in Analysis Toolpak functions The trusty statistical functions of the venerable Analysis Toolpak were fully integrated into the program in 2007. For more information about using formulas and functions, see Chapter 12.

	Enhanced charting features Excel 2007 included lots of new chart types, updated graphics, and a new set of Chart Tools contextual tabs, all of which made experimentation and modification a whole lot easier. Microsoft Office PowerPoint 2007 and Office Word 2007 started using the same charting engine as Excel. The shared charting capabilities made creating charts much easier and more powerful within those applications, and generally made charts in all 2007 Microsoft Office system documents more consistent and easier to share, link, copy, and update. For more information about charts, see Part 6, Part 6.

	XLSX file format The Microsoft Office Open XML file formats (with the extension .xlsx in Excel) provided better integration with external data sources and resulted in significantly smaller file sizes. For more information about file formats, see Exploring File Management Fundamentals on page 42.

	Improved sorting and filtering The Sort command, which previously allowed only 3 levels of sorting at a time, was improved to allow 64 levels in Excel 2007. The Filter feature was improved, and the Remove Duplicates button helped make managing database information easier, letting you specify in which columns to look for duplicate information. For more information about sorting and filtering, see Chapter 22.

	Enhanced security features Microsoft added a number of new features in Excel 2007, including the Trust Center and a digital signatures interface to help secure documents you share with others. For more information, see Chapter 4.




Retired in 2007



Software companies are reluctant to remove features from programs for fear of disrupting the workflow of customers who are using older versions of the programs. The most visible (and vocal) customers are large corporations with countless desktops. Nonetheless, sometimes companies have to make the hard choices if features are not used often, if they cause more problems than they are worth, or if their functionality has been assimilated into a new and better feature. Here are a few things that were retired (or assimilated) in the 2007 release of Excel, so if you skipped that release, this is for you, too.
	The Office Assistant The animated Help characters were, shall we say, not as popular as was hoped. Alas, poor Clippit, we hardly knew ye. Please send remembrances to the Microsoft Bob Memorial Fund for Homeless Virtual Personalities.

	Natural-language formulas (NLFs) This feature was well-intentioned but confusing and buggy. If you use NLFs in an existing workbook, Excel informs you when you open it and converts them to static cell references. Note, however, that the new structured references are better at this sort of task anyway. See Using Structured References on page 498.

	Lists At one point, Microsoft’s usability studies found that making lists was one of the most common tasks mentioned by users of Excel, and Microsoft added a number of features that addressed “list management.” So Microsoft expanded on that functionality with a new tables feature and stopped using the term “list” in the program. See Chapter 22.

	Open file formats The list of supported file formats used to be long indeed. Microsoft kept adding more formats with each edition. Many of them are no longer relevant or can be handled using another import or export method. The following formats are no longer available in the Files Of Type list in the File Open dialog box: WK1, WK4, WJ3, WKS, WK3, WK1 FMT, WJ3 FJ3, WK3 FM3, WK1 ALL, WJ2, WQ1, WJ1, WKS, DBF 2, and Microsoft Excel Chart (.XLC).

	Save file formats Microsoft also removed many outdated file formats from the Save dialog boxes, including some of its own Excel file formats. You can use external converters in older versions of Excel to open files saved in the new Excel 2007 format. The following save formats are no longer available: Excel 97– Excel 2003 & 5.0/95 Workbook, Excel 3.0 Macro, Excel 2.1 Macro, Excel 4.0 Macro, Excel 2.1 Worksheet, Excel 4.0 Worksheet, Excel 3.0 Worksheet, Excel Chart (.XLC), Excel 4.0 Workbook, DBF 4, DBF 3, WK1, WK4, WKS, WK3, WK1 FMT, WK1 ALL, DBF 2, WQ1, and WK3 FM3.

	Lotus 1-2-3 support Although you can’t save or open Lotus 1-2-3 files in Excel anymore, you can still use Lotus keyboard shortcuts such as pressing the slash (/) key to access the menus and then pressing “accelerator” keys to move down the menu tree. For accessibility’s sake, these keyboard accelerators remain, but they are somewhat hidden. When you press the slash key, you will see KeyTips—little pop-ups containing a single letter that appear adjacent to the names of tabs and commands. This functionality replaces the little underlines that appeared under the equivalent letter of each menu command in previous versions of Excel. And you can still activate what are called transition options (as in transitioning from Lotus 1-2-3 to Excel), which govern the behavior of navigation keys as well as formula entry and evaluation.




If You Missed the Last Two Upgrades



If you are one of the people who have been clinging to Excel 2002 and managed to hang in there all this time, well… hey, it’s time to upgrade. Here is a summary of the things that were changed in Excel 2003:
	Online assistance Web-based assistance became a priority with direct Help connections to Microsoft. The online Help system automatically looked for additional topics on the Microsoft Web site, making the system more complete, timely, and accurate. Online/offline integration was seamless—you just connect to the Internet, and the Help system automatically availed itself of online content. In addition, Microsoft added new features that controlled and enhanced Web interactions and customer feedback.

	Side-by-side comparison of worksheets The Compare Side By Side command made it easy to identify differences between two worksheets by letting you scroll through both worksheets simultaneously. In Excel 2007, Microsoft transformed this command into a button named View Side By Side.

	Improved statistical functions A number of the built-in statistical analysis functions became more accurate in Excel 2003; past versions of these functions had produced slightly different rounding results.

	Task panes Microsoft added the Research task pane, offering a wide variety of reference information and expanded resources through your Internet connection. The Research feature now lives on the Review tab on the ribbon.

	Information Rights Management The Information Rights Management (IRM) features introduced in Excel 2003 provided a measure of control over unauthorized access to your workbooks. Microsoft updated this feature in 2007 and 2010.

	List management Enhanced list management features in Excel 2003 helped ensure list integrity and made it easier to upload list ranges to Windows SharePoint Services sites. Excel 2007 discarded the concept of lists and upgraded to the concept of tables.




Onward



Taken together, the improvements made in Microsoft Office 2010 and Excel 2010 represent baby steps compared to the last release, but the baby is still pretty big, and there are definitely a few very important steps in this release. If you skipped the 2007 release, we’re talking giant steps, and a lot of them. Read on!

Chapter 2. Exploring Excel Fundamentals



What Happens After You Install Excel?
Examining the Excel 2010 Workspace
Exploring File Management Fundamentals
Importing and Exporting Files
Using the Help System
Recovering from Crashes
BEFORE you can get the feel of the controls, you need to know where they are and what they do. This chapter discusses the Microsoft Excel 2010 tools and accessories.
What Happens After You Install Excel?



This is really basic, but we have a moral obligation to briefly mention it anyway. You can start Excel 2010 in two principal ways:
	In Windows, click Start, Microsoft Excel 2010 (or click All Programs, Microsoft Office, Microsoft Excel 2010).

	In Windows Explorer, double-click any Excel 2010 file or shortcut.



Activating Excel



When you start Excel for the first time, you are asked to register, or activate, the program. The easiest way to do this is by letting Excel register online, assuming your computer is connected to the Internet. (You’re going to want that—we’ll talk later.) Online registration is fast and painless and a lot easier than taking a postcard to the mailbox. It is also highly recommended. Alternatively, you can click Cancel and activate Excel later by clicking the File tab, clicking Help, and clicking Activate. You have to go through the activation process at some point—you can start Excel 50 times without activating it before the program stops being cooperative. After activation is complete (it takes only a few seconds), click the File tab and click Help to display a screen similar to the one in Figure 2-1.
You might have qualms about any kind of owner registration, but with software it’s really a good idea—trust us. When you register, you’re automatically in the loop for fixes (there will certainly be a or service pack available within a year or so), updates, and “special offers.” Registering a garden tool, on the other hand, may not be worth the annoyance of registering, but if you essentially get a new tool for free in a few months, you just might want to go for it. You won’t see too many upgrades for weed whackers, of course, but with software you can rely on getting an upgrade or update of some kind.
[image: The File tab’s Help screen displays your program’s current state of activation.]

Figure 2-1. The File tab’s Help screen displays your program’s current state of activation.


Getting Updates



Microsoft service packs begin to appear a year or so after the most recent software version is released. Microsoft usually releases at least one service pack for each new version of Office and Excel and often releases more than one for Windows. Service packs comprise good bits of software code that replace bad bits, circumvent errors, or otherwise intercept known problems. These updates might even activate new features that were “hidden” because they were only partially implemented when the software finally had to ship.
Service packs are always free, but they are not very well advertised. If your computer is connected to the Internet, here’s the easiest way to keep your Office software current (and you get the latest updates for Windows as well). Click the File tab, and then click Help. Clicking Check For Updates under Tools For Working With Office opens your browser, connects you to update.microsoft.com, and displays any updates that are available for Office, Windows, and other Microsoft products you have installed. You can take care of business right away, as shown in Figure 2-2.
[image: Keep your Microsoft products current.]

Figure 2-2. Keep your Microsoft products current.

Legacy of the Great Feature Wars
Software almost never ships with “showstopper” bugs anymore; rigorous beta testing generally takes care of these problems. That said, all companies routinely ship software that is riddled with bugs—it’s the way of the software marketing world. Every software company is equally guilty. But why?
As the battle for market share raged among application developers in the 1980s and 1990s, the mantra among developers was “Ship, ship, ship!” They raced to see how fast they could release the next version of their products for several reasons. First, software products lived or died because of feature checklists published in major computer magazines. If the new version of a program didn’t make it into, for example, the annual “Big Spreadsheet Showdown Issue,” the development group was in deep doo-doo. So, product managers had incentive to link software development schedules with magazine publication dates. Second, most of the money earned by “mature” products such as Excel comes from upgrades, so software marketers pushed to ship new versions every year. But not only did customers have a hard time justifying the purchase of annual upgrades, developers had a hard time keeping pace. It takes time to develop ideas, write code, integrate it with existing code, and then document, design, manufacture, market, and distribute. Plus, the more “mature” the program, the more complex and unpredictable it becomes. Chaos theory starts to rear its ugly head. Finally, these programs have to remain compatible with “legacy” systems; programs need to recognize their own old file formats, and features that may have been rendered essentially obsolete still have to be reconciled with new features.
Completely debugging a program as complex as Excel could take years. Some think it is impossible to absolutely eliminate all potential malfunctions in any program. Software companies determine an acceptable threshold and severity of bugs to ship in a “finished” product. The good news is that these leftover bugs are usually so esoteric that most folks never have to deal with them. So, the next time someone happens to run across one and complains about how “buggy” a particular program is, you can reply with authority, “Aren’t they all?”




Examining the Excel 2010 Workspace



This section takes you on a tour of not only the dashboard of Excel 2010 but also the trunk and the glove compartment. We might even slip on some gloves and take a peek under the floor mats.
Facts About Worksheets



Here are some tidbits of information about the grid called the worksheet, shown in Figure 2-3.
	Column letters range from A through XFD. (After column Z comes column AA, after column ZZ comes column AAA, and so on, up to XFD.) Row numbers range from 1 through 1,048,576.

	The currently selected cell is referred to as the active cell. When you select a range of cells, only the cell in the upper-left corner is considered the active cell. The reference of the active cell appears in the Name box on the left end of the formula bar.

	The headings for the columns and rows containing selected cells are highlighted, making it easier to identify the location of selected cells.

	With 16,000 columns and 1,048,576 rows, your worksheet contains more than 16 billion individual cells. Before you try to unravel the mysteries of the universe on a single worksheet, however, remember that the number of cells you can use at one time is limited by the amount of memory your computer has. Although Excel allocates memory only to cells containing data, you might have trouble actually using all the cells on one worksheet, no matter how much memory you have.



[image: There is a huge amount of available space on a worksheet.]

Figure 2-3. There is a huge amount of available space on a worksheet.

The Porthole Window
The workbook window is like a porthole through which you can see only a portion of a worksheet. To illustrate, suppose you were to cut a small, square hole in a piece of cardboard and place the cardboard over this page. At any given time, you could see only a portion of the page through the hole. By moving the cardboard around the page, however, you could eventually read the entire page through the window in your piece of cardboard. Viewing worksheets in Excel is much the same. You can also open another window to view different sections of the same worksheet simultaneously.


Using the Workbook Window



A new workbook, shown floating (that is, neither maximized nor minimized) in Figure 2-4, originally consists of three individual worksheets.
[image: Workbooks initially comprise three worksheets.]

Figure 2-4. Workbooks initially comprise three worksheets.

Note
For more information about using workbooks, see Chapter 7.

Workbooks are great organizational tools. For example, you can keep in the same workbook all the documents that relate to a specific project, department, or individual. Workbooks can eliminate a considerable amount of clutter on your hard disk. The more documents you have to manage, the more valuable workbooks become. You can use workbooks as a multiuser management tool. For example, you can organize worksheets in groups for individual tasks or individual users. You can also share a workbook so that more than one person can work on it at the same time.
If you routinely create folders on your hard disk to contain groups of related files, you can think of workbooks as folders where you can keep all related worksheets.
Note
For more information about using and sharing workbooks, see Chapter 26.

The Title Bar



At the top of the Excel workspace is the title bar, which displays the application name along with the name of the workbook in which you are currently working. If the window is floating, as shown in Figure 2-4, the workbook name appears at the top of the window instead of at the top of the Excel workspace. (For more information about maximizing and minimizing your Excel workbook, see Resizing the Window on page 25.)

Getting Around in the Workbook



At the bottom of the workbook window are controls you can use to move from worksheet to worksheet in a workbook. Figure 2-5 shows these navigational controls.
[image: Use the workbook navigational controls to move among undisplayed worksheets.]

Figure 2-5. Use the workbook navigational controls to move among undisplayed worksheets.

If You Have a Wheel Mouse
If you have one, you can use the wheel on your Microsoft IntelliMouse pointing device (or any wheel-equipped mouse) to scroll through your worksheet. Turn the wheel toward you to scroll down or away from you to scroll up. To scroll left to right, press the wheel button, and drag the mouse in the direction you want to move. (This is alternatively referred to as panning.) When you press the wheel button, a gray directional device appears, which is anchored to the spot where you first pressed the wheel button. The speed of panning depends on how far you drag away from the anchored directional device. As you press the button down and drag, a black arrow appears, pointing in the direction you’re dragging:
[image: image with no caption]

You can change the default behavior of the wheel from scrolling to zooming. To do so, click the File tab, and then click Options. In the Advanced category, below Editing Options, select the Zoom On Roll With IntelliMouse check box.
Note
For more information, see Zooming Worksheets on page 167.


You need the tab-scrolling buttons shown in Figure 2-5 only when your workbook contains more sheet tabs than can be displayed at one time.

Workbook Navigation Tips



Many features and controls can help you navigate through the rows, columns, and worksheets in a workbook. Here are the highlights:
	Use the sheet tab navigation buttons to view all the sheet tabs in your workbook; click a tab to view the contents of that worksheet.

	Drag the tab split box to the right if you want to see more sheet tabs at the expense of the horizontal scroll bar’s width. To return to the usual tab display, double-click the tab split bar.

	Press Ctrl+Page Down to activate the next worksheet in the workbook; press Ctrl+Page Up to activate the previous worksheet.

	Press Ctrl+Home to jump to cell A1 from anywhere on a worksheet.

	Right-click any scroll bar to display a shortcut menu dedicated to scrolling actions, as shown in Figure 2-6.
[image: Right-click a scroll bar to display a shortcut menu of navigational commands. Only the active workbook window has scroll bars.]

Figure 2-6. Right-click a scroll bar to display a shortcut menu of navigational commands. Only the active workbook window has scroll bars.


	Drag the scroll box (also known as the scroll thumb) to move around the worksheet. Click the scroll bar anywhere outside the scroll box to move one screen at a time in the direction in which you clicked.

	The size of the scroll box changes depending on the size of the scrollable area. For example, the scroll boxes shown in Figure 2-6 are more than half as large as the scroll bars themselves, indicating there is little more to see in the active area of the worksheet—nothing, in fact, because this is a blank worksheet. As you add data to more columns and rows than can appear on a single screen, the scroll boxes get proportionally smaller, giving you immediate feedback about the size of the worksheet. A tiny scroll thumb indicates a huge worksheet.

	Using the scroll arrows at either end of the scroll bars, you can move through the worksheet one column or row at a time.

	The Name box at the left end of the formula bar always displays the active cell reference, regardless of where you scroll the window.

	To scroll the worksheet without changing the active cell, press Scroll Lock. For example, to scroll to the right one full screen without moving the active cell, press Scroll Lock, and then press Ctrl+Right Arrow.



Note
The active area of a worksheet is simply the rectangular area that encompasses all the data the worksheet contains. So, if you have just three rows and columns of actual data in the top-left corner of the worksheet, the active area would be A1:C3. If, on the same worksheet, a stray character (even a space) happens to be in cell AB1299, the active area would be A1:AB1299. On a new blank worksheet, however, Excel considers the default active area to be roughly what you can see on the screen, even before you enter any data.


Resizing the Window



At the right end of the workbook window title bar are the Minimize, Maximize/Restore, and Close buttons. When your workbook window is maximized, the active window opens at full size in the Excel workspace.
After you maximize the window, a button with two small boxes—the Restore button—takes the place of the Maximize button. When you click the Restore button, the active window changes to a floating window.
Tip
INSIDE OUT See More Rows on Your Screen
You can set the Windows taskbar at the bottom of the screen to automatically hide itself when not in use. Click the Start button, click Control Panel, click Appearance And Personalization, and click Taskbar And Start Menu. (In Windows XP, just click Taskbar And Start Menu in Control Panel.) On the Taskbar tab, select the Auto-Hide The Taskbar check box, and then click OK. Now the taskbar stays hidden and opens only when you move the pointer to the bottom of the screen.

When you click the Minimize button (the one with a small line at the bottom), the workbook collapses to a small title bar.
Minimizing workbooks is a handy way to reduce workspace clutter when you have several workbooks open at the same time. Click the Restore button on the title bar to display the workbook to its former floating size, or click the Maximize button to make the workbook fill the Excel workspace.
You can also drag the borders of a floating window to control its size. The smaller the window, the less you see of the worksheet; however, because you can open multiple windows for the same workbook, you might find it more convenient to view different parts of the workbook, or even different parts of an individual worksheet, side by side in two small windows rather than switch between worksheets or scroll back and forth in one large window.
Tip
INSIDE OUT Microsoft and the SDI
What is SDI? The single document interface (SDI) initiative that Microsoft implemented in its Office programs several versions ago is an option in Excel 2010. Prior to SDI, regardless of the number of documents you had open, the applications were visible and available for task switching in Windows only by pressing Alt+Tab or by using the Windows taskbar. If you had three Excel workbooks open, you saw only one instance of Excel.
Microsoft’s SDI initiative dictates that each document generates its own window, each of which becomes a separate item on the taskbar. Open three Excel worksheets, and you see three items on the taskbar. This is arguably a more realistic way to handle documents, which is why Microsoft did it in the first place. Some, however, might prefer the old method, which reduces the number of open windows on the desktop. In Excel 2010 you have the ability to choose between multiple document interface (MDI) and SDI. (By the way, you never see these terms used anywhere—for good reason: Multiple creates a single window, and single creates multiple windows. Geek double-speak!) To change from SDI (the default) to MDI, click the File tab, and then click Options to display the Excel Options dialog box. Click the Advanced category, scroll down to the Display options, clear the Show All Windows In The Taskbar check box, and then click OK to save your changes. Doing so causes only one Excel item to appear on the Windows taskbar regardless of how many workbooks you have open.



Exploring the Ribbon



After you get the raw data into Excel by whatever means, you’ll spend a lot of time using the ribbon to massage and beautify your data. The ribbon was introduced in Microsoft Office 2007 and was one of the most sweeping user interface (UI) changes ever implemented, redefining the workflow in every Office program. The second generation of the ribbon in Microsoft Office 2010 includes some welcome new features. We’ll take a quick look here, but rest assured that the ribbon will be a hot topic throughout this book. Figure 2-7 shows the ribbon at rest.
[image: The ribbon, which includes what used to be called the menu bar, dominates the top of the Excel window.]

Figure 2-7. The ribbon, which includes what used to be called the menu bar, dominates the top of the Excel window.

The ribbon comprises a number of tabs, each containing several ribbon groups, which in turn contain sets of related controls: commands, buttons, menus, galleries, and Dialog Box Launchers. The hierarchy within and among ribbon tabs is designed to approximate a general “workflow” model, with the most-often used features and options stacked more or less from left to right within and among tabs. For example, the Home tab contains commands you need when you create a new worksheet and start performing tasks such as cutting and pasting, formatting, and sorting. Well to the right of the Home tab, the Review tab contains commands related to documents that are more or less complete, addressing issues such as verifying spelling and protecting the document.
Note
Arguably, the best thing about the 2010 version of the ribbon is that it is now customizable. This is exciting news for die-hard toolbar-modification aficionados such as your friendly Excel book authors. This is explored in detail in Customizing the Ribbon on page 83.

The Ribbon Speaks



For years now, many of us in the computer-book writing business have been anticipating early retirement due to the expected advent of stunningly simple user interfaces and the holy grail of “self-documenting” software. In reality, this goal has proven as elusive as the “paperless office,” so we’ve kept pretty busy. But Office 2010 represents another fine attempt at rendering our jobs obsolete. You can gain helpful information about your immediate surroundings simply by brandishing your pointer. For example, the left side of Figure 2-8 shows the ScreenTip that opens when you rest the pointer anywhere in the Number Format drop-down list. The right side of Figure 2-8 shows what happens when you click the Number Format drop-down list.
The icons representing the various options in the Number Format drop-down list shown in Figure 2-8 are another step in the right documentation direction, although further exploration might be required to discover the meaning of items such as the cryptic “12” icon for Number format. (See Using Accounting Formats on page 327.) And, as always, you can press F1 at any time to open the Excel Help window and gain additional insight.
Note
If you need to maximize your worksheet area, you can temporarily hide the ribbon by double-clicking the active tab. Once hidden, clicking any tab puts the ribbon back into view.

[image: Rest your pointer on an object on the ribbon to display an explanatory ScreenTip. Click any drop-down list on the ribbon to display a menu, list, or gallery of options.]

Figure 2-8. Rest your pointer on an object on the ribbon to display an explanatory ScreenTip. Click any drop-down list on the ribbon to display a menu, list, or gallery of options.


Drop-Down Lists and Dialog Box Launchers



The Number group on the Home tab, shown in Figure 2-8, contains the aforementioned Number Format drop-down list, four regular buttons, and a menu button (the $ sign), which acts like any other button when you click the button proper, but when you click the arrow next to it, it displays a drop-down list of alternate actions for that button. Anytime you see an arrow directly to the right of a button or a box on the ribbon, clicking the arrow reveals more options. (Just to confuse the issue a bit, the Increase Font Size and Decrease Font Size buttons in the Font group display arrows that are identical to the menu arrows but are actually part of the button images and don’t invoke drop-down lists.)
Many groups display a tiny button in the lower-right corner called a Dialog Box Launcher. This is a visual cue telling you there is more you can do there. When you rest the pointer on a Dialog Box Launcher, a ScreenTip opens with details about its function; click the Dialog Box Launcher to display the promised result, as shown in Figure 2-9.
Sometimes Dialog Box Launchers actually launch dialog boxes, as shown in Figure 2-9; other times, clicking the Dialog Box Launcher displays a task pane on the side of the window, as shown in Figure 2-10. In the latter case, the Dialog Box Launcher acts as a toggle—that is, clicking it opens the task pane, and clicking it again closes the task pane.
[image: Rest the pointer on a Dialog Box Launcher for an explanation of its function; click it to open the corresponding dialog box.]

Figure 2-9. Rest the pointer on a Dialog Box Launcher for an explanation of its function; click it to open the corresponding dialog box.

Another way to access advanced options relegated to dialog boxes is to look for commands sporting an ellipsis (…) at the bottom of menus and galleries. For example, at the bottom of the Number Format drop-down list shown in Figure 2-8 is a command called More Number Formats. Just as you can with the Dialog Box Launcher, you can click this command to display the Format Cells dialog box. As was the case in previous versions of Excel, an ellipsis adjacent to the name of a command indicates that clicking that command displays a dialog box with additional options rather than immediately issuing the command.
[image: Clicking some Dialog Box Launchers causes a task pane to open on the side of the window.]

Figure 2-10. Clicking some Dialog Box Launchers causes a task pane to open on the side of the window.


Galleries and Live Preview



The concept of galleries goes way back. The idea is to provide a visual clue about what’s going to happen when you click something, besides just the name of a command or button. Microsoft has done this with fonts for some time now. When you click the Font menu or drop-down list, each font name appears in its own font. Excel 2010 includes a bunch of other galleries that provide similar visuals and adds nifty functionality called live preview. Taking the same example one step further, Figure 2-11 shows the Font drop-down list displaying the available fonts in situ. With live preview, you simply rest the pointer on the font name to momentarily cause selected cells to display that font. (In the figure, the entire worksheet is selected.) Helpfully, the selection highlight temporarily disappears while you are previewing fonts.
The Omnipotent Excel Options Dialog Box
The dialog box that opens when you click the File tab and then click Options is probably the most important dialog box in Excel. As you can see, the Excel Options dialog box contains options that control nearly every aspect of Excel, including general settings such as how many worksheets appear in a default workbook and the name and point size of the default font:
[image: image with no caption]

You’ll see little i (for information) icons adjacent to many of the items shown in the dialog box; rest the pointer on them to display ScreenTips, as shown previously. The Excel Options dialog box also provides special settings for default file-saving formats, worksheet-level and workbook-level display settings, and many other hard-to-classify options. If you take a moment to click each category on the left side of the dialog box and look through the options available, you’ll get an idea of the scope of the program as well as the degree of control you have over your workspace. If you’re unsure about what a particular setting or option does, simply click the Help button (the question mark icon) in the title bar of the dialog box to open the Help system.

As you can see in Figure 2-11, perhaps AR Hermann isn’t the best font choice for a table of sales totals, but it’s easy to get a look at a lot of options this way. The cell contents are not affected; this is simply a way to visualize what would happen if you actually commit by clicking. Have some fun by dragging the pointer up and down the list of fonts, and watch the cell contents change almost as fast as you can drag.
[image: Not only are font names displayed in their respective fonts in the drop-down list, but simply resting the pointer on a font name temporarily displays that font in selected cells (all cells are selected here).]

Figure 2-11. Not only are font names displayed in their respective fonts in the drop-down list, but simply resting the pointer on a font name temporarily displays that font in selected cells (all cells are selected here).

Note
Not all of the seemingly gallery-like items on the ribbon exhibit live preview behavior. For example, you might think the Number Format drop-down list would be an excellent application of live preview, but it doesn’t work that way. As we explain features in detail throughout the book, we’ll point out any live preview opportunities.


Understanding Contextual Tool Sets



Microsoft has been dancing with context sensitivity for several releases now. In Office 2000, Excel shipped with default “learning” menus and toolbars that modified themselves based on usage patterns, which turned out to be somewhat unpopular because commands would tend to “disappear” with lack of use. Some of this functionality carried through to Excel 2003, with a somewhat better implementation. The context sensitivity built into Excel 2007 and 2010 is smarter and, best of all, does not take little-used items away like the previous approaches—in fact, the ribbon and its normal contents remain steadfast, while additional context-triggered tools appear on ribbon tabs that are displayed only when needed. Figure 2-12 shows what happens when you click a chart object.
[image: When you select an object, tabs appear containing tools that apply only to that object. Here, three tabs of chart tools appear on the ribbon when a chart is selected.]

Figure 2-12. When you select an object, tabs appear containing tools that apply only to that object. Here, three tabs of chart tools appear on the ribbon when a chart is selected.

Not only do three new tabs appear on the ribbon in Figure 2-12—Design, Layout, and Format—but a higher-level heading, entitled Chart Tools, is displayed above the new tabs. Headings like this appear over sets of contextually triggered tabs to define their overall function. Chart objects are complex enough that clicking one triggers several tabs’ worth of contextual tools; other objects might generate only one tab. This functionality helps reduce clutter in the interface, taking groups of task-specific tools out of the way until you need them.


Using the Quick Access Toolbar



It’s hard not to think of the ribbon as a toolbar, especially if you skipped an upgrade or two. The ribbon is not a toolbar according to Microsoft, and only one “real” toolbar is left. It’s at the top of the screen, and it’s called the Quick Access Toolbar, as shown in Figure 2-13.
[image: The Quick Access Toolbar sits atop the Excel workspace unless you move it under the ribbon.]

Figure 2-13. The Quick Access Toolbar sits atop the Excel workspace unless you move it under the ribbon.

Note
To suit your work style, you can add buttons and even entire ribbon groups to the Quick Access Toolbar. For more information, see Customizing the Quick Access Toolbar on page 92.

The Quick Access Toolbar is pretty much like toolbars as you knew them, with a few exceptions. You can dock it in only two locations—either above or below the ribbon—unlike previous toolbars that could “float” over the worksheet or be docked at the top, bottom, or sides of the screen. And you cannot close or hide the Quick Access Toolbar.
Tip
INSIDE OUT Toolbar and Ribbon Customization
Some of us have spent a lot of time modifying the UI of pre-2007 versions of Excel by changing and adding toolbars and menus. Since Excel 2007, there has been only one toolbar, and you cannot create new ones. Perhaps not surprisingly, 98 percent of the Excel-using public will not miss this functionality. (This statistic was gleaned from usability surveys.) Those of us in the other 2 percent can customize the Quick Access Toolbar, and in Office 2010, we can tweak the ribbon as well. Hooray! See Customizing the Quick Access Toolbar on page 92 for more information.


Accessing Commands with the Keyboard



When you press the Alt key, Excel activates keyboard command mode and displays little pop-up labels adjacent to each tab and toolbar button, as shown at the top of Figure 2-14.
[image: Press the Alt key to activate keyboard command mode and display pop-up labels showing you the keys you can press to activate the respective tab, button, or command.]

Figure 2-14. Press the Alt key to activate keyboard command mode and display pop-up labels showing you the keys you can press to activate the respective tab, button, or command.

For example, after you press the Alt key to activate the pop-up labels, you can press the N key to display the Insert tab and add pop-up labels to the commands it contains. Then, press the M key—the pop-up letter adjacent to the SmartArt button—to display the SmartArt dialog box, as shown in Figure 2-14. So, instead of reaching for the mouse, simply pressing Alt, N, M gets you there. This makes for extremely fast command access after you learn the right keys for tasks you do often.
Keyboard Command Activation Options
You can use the slash (/) key just like the Alt key to access the Excel command structure. But you can alternatively set a different key to activate menus. Click the File tab, click Options, select the Advanced category, scroll way down to the Lotus Compatibility options, and then type a different character in the Microsoft Excel Menu Key text box.


The Joy of Shortcut Menus



Shortcut menus contain only those commands that apply to the item indicated by the position of the pointer when you activate the menu. Shortcut menus provide a handy way to access the commands most likely to be useful at the pointer’s location and to help minimize mouse movements (which are hard on wrists!).
To access a shortcut menu, right-click. The menu opens adjacent to the pointer, as shown in Figure 2-15.
[image: Right-clicking almost anywhere displays a shortcut menu with pertinent commands.]

Figure 2-15. Right-clicking almost anywhere displays a shortcut menu with pertinent commands.

Shortcut menus can contain many combinations of commands, depending on the position of the pointer and the type of worksheet. For example, if you display a shortcut menu when the pointer is on a cell rather than a column heading, some of the commands change to ones specific to cells rather than columns.
Belly Up to the Mini-Bar
A small floating toolbar opens along with the shortcut menu whenever the selected object can contain any kind of text, as you can see in Figure 2-15. You can control whether the Mini toolbar appears by using the Excel Options dialog box. Click the File tab, and click Options. Then, in the General category, select or clear the Show Mini Toolbar On Selection check box.


Meet the Formula Bar



Worksheet cells are the building blocks of Excel. They store and display the information you enter on an Excel worksheet so you can perform worksheet calculations. You can enter information directly in a cell, or you can enter information through the formula bar, as shown in Figure 2-16.
[image: The formula bar displays the contents of the active cell.]

Figure 2-16. The formula bar displays the contents of the active cell.

The contents of the active cell appear in the formula bar, and the address of the active cell appears in the Name box at the left end of the formula bar. The formula bar split handle and the Insert Function button are always available, but the other two formula-editing buttons appear only while you are entering or editing data in a cell, as shown in Figure 2-16. Click the Cancel button to cancel the current action in the cell, which is the same as pressing the Esc key. Click the Enter button to consummate the current action in the cell, which is the same as pressing the Enter key.
Note
When you press Enter, Excel finishes the action in the active cell and moves the selection down one cell. You can change this behavior by clicking the File tab, clicking Options, and clicking the Advanced category. If you clear the check box labeled “After Pressing Enter, Move Selection,” the active cell does not change after you press Enter. Or, leave the option selected and choose a different direction (Up, Right, or Left) from the drop-down list.

You can drag the formula bar split handle to the left to make more room for formulas or to the right to increase the size of the Name box. Clicking the Insert Function button displays a dialog box that helps you construct formulas. For information about creating formulas and using the Insert Function dialog box, see Chapter 12.
Note
By default, Excel displays the formula bar in your workspace. If you prefer to hide the formula bar, click the View tab, and clear the Formula Bar check box in the Show group. To redisplay the formula bar, simply reverse this process.

Excel 2010 allows you to expand and contract the formula bar to display or hide long formulas. The formula bar split handle helps a bit, but for really long formulas the formula bar is vertically expandable, as shown in Figure 2-17.
When you select a cell containing a long formula, you see only part of the formula in the formula bar. If there is more of the formula to be seen, Excel displays a set of up and down arrows at the right end of the formula bar that you can use to scroll through the formula one line at a time. At the far right end of the formula bar is the Expand Formula Bar button (down arrow), which when clicked expands the formula bar as shown in Figure 2-17. If you need to see more, drag the bottom border of the formula bar as far as you need to. (This particular 100-cell formula is good for illustrating the expanding formula bar, but failure to use the SUM function in this situation might get you drummed out of the Sensible Formulas Guild.) The next time you click the Expand Formula Bar arrow, the bar expands to the last size you specified.
[image: The formula bar expands and contracts to show or hide long formulas.]

Figure 2-17. The formula bar expands and contracts to show or hide long formulas.

Note
Functions are the Clydesdales of Excel—they do most of the heavy work. To learn all about them, see Chapter 13.


Facts About the Status Bar



The status bar, located at the bottom of the Excel window, displays information about what’s happening in your workspace. For example, most of the time, Excel displays the word Ready at the left end of the status bar. When you type, the status bar displays the word Enter; when you double-click a cell that contains data, the status bar displays the word Edit.
Several items appear at the right end of the status bar: a few buttons, a slider, and a display area for various purposes—including summary information, keyboard modes, page numbers, and much more—any of which you can turn on or off. Right-click the status bar anywhere to show the Customize Status Bar shortcut menu filled with options, as shown in Figure 2-18.
[image: You have numerous options for displaying information on the status bar.]

Figure 2-18. You have numerous options for displaying information on the status bar.

All the commands on the Customize Status Bar menu with check marks adjacent to them are turned on by default. Most of the commands on this menu control the display of different types of information, depending on what is selected. Cell Mode refers to the aforementioned Ready/Enter/Edit indicators when working in cells. The icon that looks like a worksheet with a tiny red ball, shown in Figure 2-18 on the left side of the status bar, is a record button for macros. The Macro Recording command controls its display. (If any macros are available, a Play arrow appears next to the icon, the display of which is controlled by the Macro Playback command.) The last three commands on the menu control the display of items on the right end of the status bar. View Shortcuts turns on or off the display of the three buttons (Normal, Page Layout View, and Page Break Preview) visible next to Zoom percentage and the Zoom slider, which also have corresponding commands controlling their display. Drag the Zoom slider to change the percentage, or click the percentage indicator to display the Zoom dialog box for more precision.
Note
For more information about keyboard modes, see Navigating Regions with the Keyboard on page 138. For more about views, see Chapter 11. For more about Macros, see Chapter 27.

Quick Totals on the Status Bar
When you select two or more cells that contain values, Excel displays summary information using those values on the status bar:
[image: image with no caption]

This is the AutoCalculate feature. The status bar normally displays the sum and average of the selected values, as well as the number of cells selected that contain any kind of data (blank cells are ignored). As you can see in Figure 2-18, additional AutoCalculate options are available, including Minimum and Maximum values in selected cells and Numerical Count, which counts only cells containing numbers and ignores cells containing text.


Introducing Backstage View



At first, when you begin working with the “ribbon versions” of Excel (2010 and 2007), it looks like the old menus are still there across the top of the screen—until you start clicking and you see that no menus are dropping down. Even more interesting if you have been using Excel 2007 is that the File menu, which had been removed, is back in Excel 2010 as a tab, and the Office Button, which was where the File menu used to be, is gone. Now, when you click the File tab, what you see is not so much a menu or a dialog box, but a screen full of information and options that Microsoft calls Backstage view. Here you can find the familiar File menu commands, and Backstage view also serves as the access point for most of Excel’s “behind-the-scenes” commands and settings.
Clicking the File tab on the ribbon reveals the default Info screen in Backstage view, as shown in Figure 2-19.
[image: Click the File tab to open Backstage view, which includes the old File menu commands; click it again (or click another tab) to hide it.]

Figure 2-19. Click the File tab to open Backstage view, which includes the old File menu commands; click it again (or click another tab) to hide it.

As you can see, many of the old File menu commands are still here as clickable items on the left side of the screen, and the right side of the screen provides additional clickable items. Clicking Info, Recent, New, Print, Save & Send, or Help controls the content visible on the right side of the screen, which offers pertinent options and commands. Clicking Save, Save As, Open, Close, or Options launches a separate dialog box. You’ll be seeing more of Backstage view and all of its “children” throughout this book.


Exploring File Management Fundamentals



One of the advantages of working with computers is the convenience of electronic files. In this section, we describe both the usual and unusual ways you can manage your Excel files.
Creating Workbooks



To create a new workbook, click the File tab, and then click New to display the Available Templates screen shown in Figure 2-20. With Blank Workbook selected, press Enter (or click the Create button on the right), and a fresh workbook opens. Each new workbook you create in the current Excel session is numbered sequentially: Book1, Book2, and so on.
[image: Click the File tab and then click New to display the Available Templates screen.]

Figure 2-20. Click the File tab and then click New to display the Available Templates screen.

In the Available Templates screen, you can create all kinds of new workbooks using templates or existing workbooks as starting points. The template you select on the left side of the window controls what appears in the sample display on the right. When you click a template icon (other than the Blank Workbook icon), the available options for that category appear in the screen or in a separate dialog box. Click the little Back arrow at the top of the screen to return to the Available Templates screen. The categories include (but are not limited to) the following:
	Blank Workbook Clicking the Blank Workbook icon creates just that—a new blank workbook.

	Recent Templates Clicking Recent Templates, as expected, shows the last few templates you opened.

	Sample Templates Clicking Sample Templates shows the templates that are installed with Excel.

	My Templates Clicking My Templates opens a dialog box displaying the contents of your own personal template treasure trove.

	New From Existing Clicking this icon displays the dialog box shown in Figure 2-21. This dialog box opens any existing Excel file as a template. Two things happen differently here from using the normal Open command: First, instead of opening the actual workbook, it opens a copy of it. Second, when you save the workbook, it appends a number to the end of the file name and displays the Save As dialog box, making it virtually impossible to overwrite the original file.

	Office Online Templates The Online Templates area displays some templates that are available as downloads. Obviously, you need to be connected to the Internet for this. There are literally hundreds of templates online, so this is only a sampling. To zero in a bit more, type keywords into the box labeled “Search Office.com for Templates” to display any relevant templates that are available for downloading.



[image: You can create a copy of any file you select in the New From Existing Workbook dialog box.]

Figure 2-21. You can create a copy of any file you select in the New From Existing Workbook dialog box.

Excel 2010, being more Web connected than ever, takes advantage of this by storing most templates on the Office Online Web site, instead of putting them on your computer. This not only saves a little space on your hard disk but also makes it possible to offer many more templates than would be possible on CDs, makes it easy for developers to keep them up to date, and provides a continually updated source of new templates. Figure 2-22 shows just a few of the templates available in one of the categories.
[image: Microsoft Office Online provides a fortune in template treasures from which to choose.]

Figure 2-22. Microsoft Office Online provides a fortune in template treasures from which to choose.

There are a few templates created when you first install Excel, and these are available when you click the File tab, click New, and then click Sample Templates, as shown in Figure 2-23.
[image: A number of templates are ready and waiting on your computer when you first install Excel.]

Figure 2-23. A number of templates are ready and waiting on your computer when you first install Excel.

Installing Your Own Templates



Creating your own templates is a great idea for worksheets you use a lot. You can click New From Existing in the Available Templates window to open any workbook as a template. Better yet, you can create, organize, and format a workbook the way you want (minus the data), then click the File tab, click Save As, and choose Excel Template in the Save As Type list. When you click the Save button, Excel automatically installs your new workbook in a special folder as a template. You can find this folder in the following locations:
	Windows XP C:\Documents and Settings\<your name>\Application Data\Microsoft\Templates

	Windows 7 or Windows Vista C:\Users\<your name>\AppData\Roaming\Microsoft\Templates



Templates in this folder appear in the New dialog box when you click My Templates in the Available Templates screen, as shown in Figure 2-24.
[image: Your own templates appear in a dialog box when you click My Templates in the Available Templates screen.]

Figure 2-24. Your own templates appear in a dialog box when you click My Templates in the Available Templates screen.

Tip
INSIDE OUT Hidden Windows Folders Revealed
You probably have to change a Windows setting to find the AppData folder (Application Data in Windows XP) because it is normally hidden. To reveal it, navigate to the folder that bears your name in Windows Explorer, as shown in the previous paths. Then, on the Organize menu (the Tools menu in Windows XP), click Folder And Search Options. On the View tab, select Show Hidden Files And Folders. Note that <your name> is the user name you use when logging on to Windows.


Create Your Own Template Tabs



When you click the File tab, click New, and then click My Templates, the New dialog box appears, which derives its contents from a special folder installed by the Microsoft Office system, as described in Installing Your Own Templates on the previous page. You can create your own personalized subfolders in this special folder that in turn become tabs in the New dialog box—but only when they contain valid template files. The name of each folder becomes the title of each new tab. Figure 2-25 shows the New dialog box with a new tab, which appears after creating a folder in the Templates folder and adding an Excel template file.
Note
In versions previous to Excel 2007, you could put any type of Excel file into the Templates folder or any of its subfolders, and Excel would recognize the files and pretend they were templates. This stopped with Excel 2007, and continues in Excel 2010. Only actual template files now show up in the New dialog box.

[image: It’s easy to create your own tabs in the New dialog box.]

Figure 2-25. It’s easy to create your own tabs in the New dialog box.

Tip
INSIDE OUT Office-Wide Templates Tabs
When you create a custom folder within the Templates folder, it is available to other Microsoft Office applications, too. Your custom folder appears as a tab in the New dialog box of every 2010 Office application, but only if the folder actually contains a template in that application’s native format. For example, if you create an Accounting folder in the Templates folder and put a Microsoft Word template in it, the Accounting folder appears as a tab in the New dialog box in Word. If the folder contains only Excel files, the tab does not appear in Word.



Saving Files



Arguably, the most important function of any computer application is preserving data. In Excel, you can save your files in many ways, including by clicking the Save, Save As, Publish, Close, or Exit command and—the easiest way to save—by clicking the Save button on the Quick Access Toolbar.
One other command that saves your workbooks is the Share Workbook command in the Changes group on the Review tab. When you click this command, you save your workbook in shared mode. Besides saving the file, this command makes the workbook available to others on a network, who can then open it and make changes of their own.
Note
For more information, see Sharing Workbooks on a Network on page 860.

The first time you save a file, the Save As dialog box opens, as shown in Figure 2-26.
[image: The Save As dialog box opens when you save a file for the first time.]

Figure 2-26. The Save As dialog box opens when you save a file for the first time.

Note
If you use the same folder most of the time, you can specify that folder as the default location that the Open, Save, and Save As dialog boxes use when you first open them. Click the File tab, click Options, select the Save category, and type the full path and file name for the folder you want to use in the Default File Location text box.

The Windows 7 (or Windows Vista) version of the Save As dialog box has a lot more bells and whistles than previous versions. This is also true with other dialog boxes that are provided by the operating system, including Save and Open. The dialog box has a sophisticated file interface that includes a number of useful features, such as the ability to find files by using a date range you specify using a calendar, as shown in Figure 2-26. For details, click the Help button (the question mark icon) in the Save As dialog box to display the corresponding Windows Help file.
Rules for File Naming



File names in Excel can have up to 218 characters. They can include any combination of alphanumeric characters, spaces, and special characters, with the exception of the forward slash (/), backslash (\), greater-than sign (>), less-than sign (<), asterisk (*), question mark (?), quotation mark (“), pipe symbol (|), colon (:), and semicolon (;). Although you can use any combination of uppercase and lowercase letters, keep in mind that Excel does not distinguish case in file names. For example, to Excel the names MYFILE, MyFile, and myfile are identical.
How Much Disk Space Do You Need?
To ensure that a new version of a file is properly saved before the original is deleted, Excel makes a temporary file when it saves and then deletes the original and renames the temporary file with the original name. This prevents loss of both the original and the version being saved if something goes wrong mid-save. Because of this, you can never open, make changes to, and then save a file that is bigger than half the amount of available space on the disk being used. For example, if you are working with a file on a 1.44 megabyte (MB) floppy disk (yes, people do still use these on occasion), you cannot open, make changes to, and then save a file if it is larger than approximately 720 kilobytes (KB). In this case, you need to make all your changes in a copy of the workbook located on your hard disk and then save it to the floppy disk when you finish. It’s unlikely that you’ll run into this problem on a hard disk, but if you do see symptoms of insufficient space while saving an Excel file, it might be time for a little disk cleanup or to install another disk drive.

The old familiar MS-DOS three-character file name extensions, which now come in a four-character version as well, help identify your Excel files, and they are added automatically when you save a file. Table 2-1 lists Excel extensions in the order in which they appear in the Save As dialog box’s Save As Type list (except for Workspace, which doesn’t work there—see Saving the Entire Workspace on page 60).
Table 2-1. The Excel File Extensions
	Document Type
	Extension

	Workbook
	.xlsx

	Macro-enabled workbook
	.xlsm

	Excel binary workbook
	.xlsb

	Excel 97-2003 workbook
	.xls

	XML data
	.xml

	Template
	.xltx

	Macro-enabled template
	.xltm

	Excel 97-2003 template
	.xlt

	XML spreadsheet 2003
	.xml

	Microsoft Excel 5.0/95 workbook
	.xlt

	Add-in
	.xlam

	Excel 97-2003 Add-in
	.xlm

	Workspace
	.xlw




Tip
INSIDE OUT Hidden File Name Extensions Revealed
File name extensions might not appear with Windows file names, depending on your settings. To display file name extensions, click the Start button, and then click Computer (Control Panel in Windows XP). Next, click Folder And Search Options (located on the Organize menu in Windows 7 or Vista). On the View tab, scroll down and clear the Hide Extensions For Known File Types check box.


File Formats



In addition to providing the file name and location, you can specify a different file format in the Save As dialog box. Click the Save As Type drop-down list, which expands to reveal all the formats in which you can save your files.
The default format is Excel Workbook (XLSX), and you’ll almost always use this option. If you want to export an Excel file to another program, however, you can use one of the other options to convert the file to a format that is readable by that program.
Note
For more information about the Excel export formats, see Importing and Exporting Text Files on page 70.


Ensuring File Compatibility with Previous Versions of Excel



When you open a workbook in Excel 2010 that was created in a previous version of Excel, it automatically opens in Compatibility mode, a condition that is indicated in the Excel title bar, as shown in Figure 2-27. You can always tell by looking at the title bar whether you’ve converted a file to the new format.
[image: Files created by any previous version of Excel open in Compatibility mode.]

Figure 2-27. Files created by any previous version of Excel open in Compatibility mode.

You can work normally with Compatibility mode, and when you save the file, it remains in the old file format. If, however, you make any changes using features that are not compatible with the older version, the Excel Compatibility Checker intervenes when you save and displays a dialog box like the one in Figure 2-28.
[image: The Compatibility Checker opens when you try to save an old-format workbook containing features not supported by the older version of Excel.]

Figure 2-28. The Compatibility Checker opens when you try to save an old-format workbook containing features not supported by the older version of Excel.

The Compatibility Checker lets you know exactly what is causing the problem, so you can click Cancel and rework your worksheet using a different approach or save it anyway. You can click the Find or Fix links in the Compatibility Checker dialog box to highlight or correct each item that is causing compatibility problems. Clicking the Copy To New Sheet button adds a new worksheet to the current workbook entitled Compatibility Report, containing a copy of the information displayed in the dialog box—sort of a compatibility paper trail. If you clear the Check Compatibility When Saving This Workbook check box, this dialog box no longer opens when you save the current workbook. You might prefer this if you plan to repeatedly edit and save without updating the workbook to the new file format. But fear not, you can always look for problems at your convenience; click the File tab, click the Check For Issues button, and then click Check Compatibility to display the same dialog box shown in Figure 2-28.
Tip
INSIDE OUT What Doesn’t Work in Compatibility Mode?
When Compatibility mode is on, Excel disables a number of features that produce results that cannot be transferred to older versions of Excel. You can still click disabled commands, but when you do, Excel displays a ScreenTip explaining why you can’t use them. For example, Excel 2010 allows 64 levels of nesting in formulas (parenthetical expressions within expressions), but previous versions allowed only 7. If you are working on a worksheet where you try to exceed the previous limitation, Excel prevents it and displays an error message:
[image: image with no caption]

Here are some of the things that can trigger compatibility error messages:
	A workbook contains too many rows and/or columns.

	A formula exceeds the maximum allowed number of characters.

	A formula exceeds seven nested levels.

	A formula exceeds the maximum number of arguments in a function.

	A formula contains more than 40 operands.

	A workbook contains too many cross-sheet array formulas.

	A workbook has more than 4,050 unique cell formats.

	A PivotTable field has more than 32,500 unique items.

	A PivotTable item has a string length greater than 255 characters.

	A PivotTable caption has more than 255 characters.

	A PivotTable field list has more than 1,024 fields.



In case you’re wondering how to get out of Compatibility mode, all you have to do is use the Save As command to save the workbook in one of the new file formats, such as XLSX or XLSM, and then close and reopen the new converted file you just saved.

If you need to save files in other formats, the Save As Type drop-down list in the Save As dialog box includes a number of special formats you can choose, including Excel 97-2003 Workbook and Microsoft Excel 5.0/95 Workbook. Users of any of these versions of Excel can open a file saved in this format, but if someone using Excel 95 or Excel 5 saves changes to this file, any features from Excel versions 2000 through 2003, as well as the formatting, are lost. To alleviate this and other problems, you can download the Microsoft Office Compatibility Pack from the Office Online Web site to open and edit Excel 2007 and Excel 2010 files using earlier versions of Excel. When you use these converters, you don’t have to save files in the old file format, and you don’t have to upgrade the old Excel installation. You do, however, have to make sure you have the latest software updates installed on both ends of the transaction.
Note
For more information about the newer, less-restrictive limitations of Excel, see “Increased Capacity and Speed” on page 11.


Understanding the “XL” Formats



Although Microsoft trimmed some of the lesser-used file formats from the last release, the volume of native Excel file formats has swelled somewhat, largely due to accommodating “legacy” file formats—that is, file formats employed in previous versions of Excel. We’ll explain the major differences here:
	Excel Workbook (XLSX) This is the default Excel 2010 (and Excel 2007) file format, which is based on XML and uses ZIP compression for reduced file size and increased security. Unlike the default file format in older versions of Excel (XLS), this format does not support VBA or XLM macro code.

	Excel Macro-Enabled Workbook (XLSM) Microsoft created a completely separate XML-based file type to be used for workbook files containing VBA or XLM macro code. This increases security by making it impossible to inject macro code into non-macro-enabled workbooks and makes for easier identification of files containing code.

	Excel Binary Workbook (XLSB) This is a lean and mean file format designed for the fastest possible loading and saving. It supports all the features of Excel 2010 and also supports macro code, but it is not XML based, does not use compression, and is less secure than XML-based formats.

	Excel Template (XLTX) This is the template version of the Excel 2010 (and Excel 2007) file format. This format does not support VBA or XLM macro code.

	Excel Macro-Enabled Template (XLTXM) This is the template version of the Excel 2010 (and Excel 2007) file format that does allow VBA and XLM macro code.

	Excel 97-2003 Workbook (XLS) This is a legacy file format used by previous versions of Excel.

	Microsoft Excel 5.0/95 Workbook (XLS) This is a legacy file format used by previous versions of Excel.

	Excel 97-2003 Template (XLT) This is a legacy template format used by previous versions of Excel.

	Excel Add-In (XLAM) This is a special type of VBA-enabled workbook that can be loaded as a supplemental program in Excel.

	Excel 97-2003 Add-In (XLM) This is a legacy type of VBA-enabled workbook that can be loaded as a supplemental program in Excel.



In addition to these “XL” file types, there are two XML file types that are somewhat related. XML Spreadsheet 2003 (XML) is the previous XML file format provided as an option in Excel 2003. Another format, XML Data (XML), shares the same extension but produces entirely different results. This format is a proprietary XML format that requires specific programmatic data maps to be present before you can even save the file. You’ll know if you need it.
Tip
INSIDE OUT What Is XML?
The Excel 2010 (and Excel 2007) file format is based on XML, which was created as a way for structured data to be interpreted and was originally envisioned for use on the Web. Excel 2003 introduced XML as an optional file format; Excel 2010 (and Excel 2007) uses XML as the default format, indicated by the file name extension .xlsx. Based on a file format specification called SpreadsheetML, Microsoft’s implementation of XML has undergone significant improvements since being introduced. At first, the format didn’t have, shall we say, sufficient language skills to interpret all of what Excel could do, including objects such as charts and graphics. Now, SpreadsheetML can handle everything Excel can dish out and does so in a much more efficient manner than the old XLS format, resulting in significantly smaller file sizes. The new XML formats also provide improved recovery of damaged files and better overall security. And because SpreadsheetML is part of an overall extensible Open XML format initiative, it’s easier for developers to create ways to hook things together.

Note
For some additional information about XML, see Working with XML Files on page 825.


Specifying the Default File Format



Usually when you save a new workbook, you save it in the Excel Workbook format (XLSX). You can specify a different format as the default for saving files. This might be helpful, for example, if you share files regularly with users of Excel 2003. To do so, click the File tab, click Options, and select the Save category, shown in Figure 2-29.
[image: You can specify the default format to use when saving.]

Figure 2-29. You can specify the default format to use when saving.

The Save Files In This Format drop-down list contains all the same file formats as the Save As Type drop-down list in the Save As dialog box.

Creating Automatic Backup Files



You can have Excel create a duplicate copy of your file on the same disk and in the same folder as the original every time you save. Click the File tab, click Save As, click Tools at the bottom of the Save As dialog box, and click General Options to display the dialog box shown in Figure 2-30. Then select the Always Create Backup check box.
The backup file is a duplicate file that carries the same name as your original, but the name is preceded by Backup of and has the file name extension .xlk.
Caution
Keep in mind that Excel always uses an .xlk extension when creating backup files, regardless of the file type. Suppose you work with a workbook named Myfile.xlsx as well as a template file on disk named Myfile.xltx. and you select the Always Create Backup check box for both. Because only one Myfile.xlk can exist, the most recently saved file is saved as the .xlk file, and Excel overwrites the other file’s backup if one exists.

[image: To display the General Options dialog box, click the File tab, click Save As, and then click Tools, General Options.]

Figure 2-30. To display the General Options dialog box, click the File tab, click Save As, and then click Tools, General Options.


Protecting Files



You can password protect your files by using options in the General Options dialog box shown in Figure 2-30. Choose from two types of passwords: Password To Open and Password To Modify. Passwords can have up to 15 characters, and capitalization matters. Thus, if you assign the password Secret to a file, you can’t reopen that file by typing SECRET or secret.
	Password To Open Excel prompts you to supply the password before reopening the file.

	Password To Modify Anyone can look at the file, but they need the password to edit it.

	Read-Only Recommended This politely suggests that the user open the file as read-only.



Tip
INSIDE OUT Create a Better Password
Although Microsoft has tightened the under-the-hood security measures of Excel over the years, some people delight in finding new and better ways to crack passwords. You can help by simply building better passwords. Make sure your password is eight or more characters long—the longer, the better—and try to use a healthy mix of uppercase and lowercase alphanumeric characters and nonalphanumeric characters. Never use birthdays, anniversaries, or the names of your children or pets as passwords.


Adding Summary Information to Files



When you click the File tab, the Backstage view screen that first appears includes a thumbnail view of the current workbook. Just below the thumbnail, click Properties, and then click Show Document Panel to display the Document Properties panel, which appears below the ribbon, as shown in Figure 2-31. Use this to record general information about the active workbook. If you juggle a lot of files, getting into the habit of adding properties can make it a lot easier to find something later. Windows looks at these property values when you use the Search command to locate files on your computer.
You can quickly view properties for the active workbook by clicking the File tab and looking on the right side of the Info screen. Several properties are displayed there beneath the thumbnail of the workbook. Click Properties, and then click Show All Properties to expand the list visible on the Info screen, as shown in Figure 2-32. It’s a lie, though; not all properties are displayed there. For the rest of the story, you must click Properties, then click Advanced Properties to display a dialog box full of information, also shown in Figure 2-32. Most of the information visible on the Document Properties panel is available and editable on the Summary tab.
[image: Use the Document Properties panel to add descriptive information you can use later when looking for that needle in a file stack.]

Figure 2-31. Use the Document Properties panel to add descriptive information you can use later when looking for that needle in a file stack.

[image: View properties about any file before you open it.]

Figure 2-32. View properties about any file before you open it.


Saving the Entire Workspace



Click the View tab, and then click Save Workspace in the Window group to save a snapshot of your current Excel environment. When you save a workspace, Excel notes the locations of all the workbooks that are currently open, as well as many of the workspace settings, so you can retrieve your files and settings in the same configuration they were in when you saved. Settings that are saved with workspaces include many display and calculation settings. The default file name suggested for a workspace file is Resume.xlw, but you can rename it.
Linking Custom Properties to Cells
You can link your own custom-built properties to named cells on your worksheet. When you do, the value of the custom property becomes whatever the named cell contains and changes whenever the value in the cell changes. First you must name a cell (see Rules for Naming on page 487). Then click the File tab, click Properties (under the worksheet thumbnail), and then click Advanced Properties. On the Custom tab in the Properties dialog box, selecting the Link To Content check box displays the workbook’s defined names in the Value box (which changes to a drop-down list named Source when linking content), as shown in Figure 2-33.
[image: Use named cells to create dynamic properties based on worksheet cells.]

Figure 2-33. Use named cells to create dynamic properties based on worksheet cells.

Select or create a name for the custom property in the Name box. (The Type drop-down list becomes unavailable when you’re linking to content.) When you’ve specified a source (the named cell to which you want to link), click Add, and the custom property appears in the Properties list.
If the link is broken (the defined name is later deleted, for example), the Properties dialog box stores the last value recorded for that property.
If the name defines a range of cells, only the value in the cell in the upper-left corner of the range appears as the property value.



Opening Files



Only slightly less basic than saving files is opening them. Click the File tab, and click Open to display the Open dialog box, shown in Figure 2-34.
[image: Click the arrow next to the Open button for more choices when opening documents.]

Figure 2-34. Click the arrow next to the Open button for more choices when opening documents.

Click one of the icons on the left side of the dialog box to display the corresponding files on the right side. The contents of the Documents folder is displayed when you first open the dialog box, unless you change the default file location. (Click the File tab, click Options, and select the Save category.) Important icons in the list include the following:
	The Recently Changed icon lists the latest files you have edited, in chronological order with the latest first.

	The Recent Places icon lists folders you have navigated to, in chronological order with the latest first.

	The Desktop icon brings you to the top level of your computer’s file system, where you can click your way down through the hierarchy.

	The Documents icon displays the contents of the Documents folder.

	The Computer icon displays all storage locations available on your computer, including disks, CD and DVD drives, and shared folders.



The Views button (to the right above the list window) provides different ways to display files in the dialog box. The Tools button (to the right, below the list window) displays a drop-down list that contains a single command, Map Network Drive, which lets you connect to a location on your network.
The drop-down list to the right of the File Name text box at the bottom of the Open dialog box determines which files are available for selection. The default option is All Excel Files, which displays file names whose extensions begin with xl. You can display specific file types or all files by clicking the arrow to the right of the text box.
Note
To open several files at once, press the Ctrl key, and select each file you want to open.

Notice that headings appear at the top of the file list in the Open dialog box. When you click one of these headings, you sort the files in order, based on that heading. For example, if you click the Date Modified heading, you sort the files in date order. Click the same heading again to re-sort in reverse order. You can further refine your quest by using the hidden menus adjacent to each heading. When you rest the pointer on a heading, a downward-pointing arrow appears to the right of the heading; click it to display a menu of additional options pertinent to that heading, as shown in Figure 2-35.
Note
You can right-click most files listed in the Open and Save As dialog boxes to display a shortcut menu that contains commands you can use with the selected file. For example, you can delete a file displayed in the Open dialog box by using this shortcut menu.

Each heading has its own menu of options, some of which are based on the actual files contained in the current folder. For example, when you click the menu for the Type heading, you can select from the list of file types contained in the folder.
[image: You can specify additional criteria when looking for files in the Open dialog box by using the menu buttons adjacent to each heading in the file list.]

Figure 2-35. You can specify additional criteria when looking for files in the Open dialog box by using the menu buttons adjacent to each heading in the file list.

Special Ways to Open Files



To the right of Open at the bottom of the Open dialog box is a small arrow. Clicking this arrow displays a menu containing the following options:
	Open Read-Only This opens the file so that you cannot save any changes made to it without renaming it.

	Open As Copy This creates a duplicate of the selected file, adds the words Copy of to the file name, and leaves the original untouched.

	Open In Browser This applies only to HTML documents and opens the selected file in your default Web browser.

	Open In Protected View This opens the document for viewing but not editing. All active content is disabled, including any kind of macro or HTML code. Once you have established the bona fides of the file, you can click the Enable Editing button to carry on.

	Open And Repair This is a powerful feature that you can use to try opening corrupted files. For more information, see Recovering Corrupted Files below.

	Show Previous Versions This reveals previous versions of files that are created by Windows Backup or that are created automatically by Windows when System Protection is set to create restore points. (Note that this command does not appear unless you first select a file in the list.) For details on this Windows functionality, click the Help button in the Open dialog box and type “show previous versions.”




Opening Files When You Start Excel



If you have files you need to work on every day, you can store them in a special folder called XLStart. Every time you start Excel, any files in the XLStart folder automatically open.
Note
You can save workspace files in the XLStart folder so that all the files and the workspace setup are automatically loaded each time you start Excel. For more information about workspace files, see Saving the Entire Workspace on page 60.

The XLStart folder is created when you install Excel and is located in the following place:
	Windows XP C:\Documents and Settings\<your name>\Application Data\Microsoft\Excel\XLStart

	Windows 7 or Vista C:\Users\<your name>\AppData\Roaming\Microsoft\Excel\XLStart



If you want to start Excel and simultaneously open files that are in a folder other than the XLStart folder, you can specify an alternate startup folder. Click the File tab, click Options, and select the Advanced category. In the At Startup, Open All Files In text box, under General options, type the full path of the folder. This feature is particularly useful if your computer is connected to a network and you want to open files from a shared folder.

Recovering Corrupted Files



Figure 2-34 shows the Open dialog box, where you can find the Open Options menu (click the arrow next to the Open button) containing the Open And Repair command. This command gives you a fighting chance at either repairing a corrupted file or extracting the data from it if it doesn’t respond to a repair attempt. When you select a file and click the Open And Repair command, the message box shown in Figure 2-36 opens.
[image: The Open And Repair command gives you a ray of hope for recovering lost data.]

Figure 2-36. The Open And Repair command gives you a ray of hope for recovering lost data.

Note
If you can live with a day-old version of the workbook, try using the Show Previous Versions command. Click the File tab, click Open, navigate to the location of the file you want to recover and select it. Then click the arrow next to the Open button at the bottom of the dialog box, and select Show Previous Versions to display any that are available. For details on this Windows functionality, click the Help button in the Open dialog box and type “show previous versions.”

Try the Repair button first, and if Excel still has no luck opening the file, try the Extract Data button, which displays the message box shown in Figure 2-37.
[image: The Extract Data button offers two ways to recover your data.]

Figure 2-37. The Extract Data button offers two ways to recover your data.

You’ll have to make a judgment call here—if you think your formulas will be OK after extraction, click Recover Formulas; otherwise, click Convert To Values. Recovering formulas will probably work unless the formulas include references to cells that were lost in corruption. Whatever you choose, the Extract Data feature pulls all the data from your workbook, including all worksheets and tabs, in the same order in which they appear in the original file. Unfortunately, the recovery process ignores all formatting, charts, and other objects—you can recover only the actual cell contents (the important stuff).
Note that unless the part of the file that became corrupted was the part storing passwords, you probably won’t be able to use this technique to retrieve data from a password-protected file.
Tip
INSIDE OUT Recover Data Using Links
You can try to recover data from a corrupted workbook by using another trick. It is essentially the same trick used by the Excel Open And Repair command, but it still might be worth a try if Open And Repair fails.
First, open two new workbooks. Select cell A1 in one of the workbooks, and then press Ctrl+C to copy. Activate the second workbook, and right-click cell A1. Click Paste Special, and then click the Paste Link button. Next, click the File tab and click Edit Links To Files on the Info screen (this command is in tiny type at the bottom of the shaded area on the right), click Change Source, and locate the corrupted workbook. Click OK, and then click Close to close the Edit Links dialog box.
If luck is with you, data from cell A1 in the lost workbook appears in cell A1, thanks to the linking formula. If it does, press F2 to activate Edit mode, and press F4 three times to change the absolute reference $A$1 to its relative form, A1. Finally, copy the formula down and across until you can see all the data you need to retrieve. Repeat for each worksheet in the workbook. You lose the formatting and formulas, of course, and zeros appear in every blank cell, but at least you can get at the important stuff. Although you can save this worksheet with linking formulas, you might consider converting all the formulas to their underlying values, just in case the original corrupted file has any further degradation. To do so, select all the cells containing the formulas you just created, click Ctrl+C to copy, right-click, click Paste Special, select Values, and then click OK.

Note
For more information about document recovery, see Recovering from Crashes on page 78. For more information about passwords, see Hiding and Protecting Workbooks on page 189.




Importing and Exporting Files



Excel gracefully accepts proprietary data created in many other applications. Excel also makes it easy to import data from text files and helps you parse it into worksheet columns.
Note
Mountains of very specific, sleep-inducing technical details are available about importing and exporting files. If you need details, you should consult Microsoft Office Online (office.microsoft.com). Also, for information regarding sharing data with other Microsoft Office 2010 applications and working with external databases, see Chapter 32, and Chapter 24.

Using the Open and Save As Commands to Import and Export Files



To import a file from another application or from an earlier version of Excel, click the File tab, click Open, and select the file you want to import from the list of files in the Open dialog box. To narrow the list of files and zero in on a specific file type you want to import, use the drop-down list adjacent to the File Name box at the bottom of the Open dialog box, shown in Figure 2-38. When you choose a file type, the Open dialog box displays only files of that type in its list. Keep in mind that it is not necessary to include a file name extension (such as .txt) when you import a file because Excel determines the format of the file by examining the file’s contents, not its name.
To export an Excel file to another application or to an earlier version of Excel, click the File tab, and click Save As. Then select the file type associated with the application you’re exporting to in the Save As Type drop-down list. The available options are similar to the drop-down list shown in Figure 2-38, except the list here contains somewhat different format options for saving. For example, you can easily open any type of Excel file immediately because All Excel Files, which comprises all past and current Excel file types, is selected by default in the Open dialog box. But you must be specific when you save, so you can specify any of 10 different Excel file formats in the Save As dialog box.
[image: Use the drop-down list adjacent to the File Name box to specify files created by a particular application.]

Figure 2-38. Use the drop-down list adjacent to the File Name box to specify files created by a particular application.


Sharing Data with Excel for the Macintosh



Excel for the Macintosh since 1998 has been using the same file format as Windows versions of Excel from Excel 97 through Excel 2003. You can share these files with Macintosh users by simply transferring files from one computer to the other.
To save an Excel 2010 (or Excel 2007) file to share with someone using the Macintosh version of Excel, click the File tab, click Save As, and click the Microsoft Excel 97-2003 Workbook option in the Save As Type drop-down list.
To import Macintosh files to your PC, you first need to transfer the file to your PC via a cable, a disk, a network, an e-mail attachment, a Web site, or a tool such as MacOpener. Exporting files from a Windows version of Excel to the Macintosh version is just as easy as importing Macintosh files. Simply transfer the file from the Windows computer to the Macintosh using your method of choice, and then use the Open command to load it into Excel.
Adjusting Date Values
Although the Windows and Macintosh versions of Excel share many characteristics and capabilities, they do not use the same date system. In the Windows version of Excel, the base date is January 1, 1900. In the Macintosh version, the base date is January 2, 1904. When you transfer files either to or from the Macintosh, Excel maintains the date type by selecting or clearing the Use 1904 Date System check box in the When Calculating This Workbook area in the Advanced category in the Excel Options dialog box. This technique is usually acceptable, but it can cause problems when a date from a Macintosh file is compared with a date from a Windows file. For this reason, we suggest you use the same date setting on all your machines.


Sharing Data Beyond Excel



Yes, some people don’t use Excel, and you might meet one someday. Seriously, plenty of reasons exist for making Excel-based data accessible outside the program, whether or not Excel is available at the destination. Posting data to a Web site or creating data sets for proprietary analysis software are two possible applications where you might want data that can fly free, independent of the Excel mother ship.
Introducing Office Web Apps



Office Web Apps give you a familiar Office experience when you are away from your Office applications on your computer. With your Office files uploaded to a Web storage location such as your own Web site or Windows Live SkyDrive, you don’t need your own computer or software to view and perform light editing of Word 2010, Excel 2010, PowerPoint 2010, and OneNote 2010 files. You just need a computer running a popular Web browser.
Note
For more information about Office Web Apps, see Chapter 26.


Using Web File Formats



Two options in the Save As Type drop-down list in the Save As dialog box produce files that you can use as Web pages: Web Page (HTM, HTML) and Single File Web Page (MHT, MHTML). They produce essentially the same result, the important difference being that the Web Page format saves not only a main HTML file but also a folder containing supporting files that must travel with the main file. As you might expect, the Single File Web Page format manages to cram it all into a single file without using the supporting folder. Single File Web Page has the advantage of being more portable, but Web Page gives you more control over individual elements. A separate cascading style sheet is created using the Web Page format, along with individual HTML files for each worksheet in the workbook. Figure 2-39 shows the contents of the supporting folder that is created after saving a seven-sheet workbook entitled Humongous2010 using the Web Page file format.
[image: The Web Page file format creates a folder full of supporting files to go with the main Web page.]

Figure 2-39. The Web Page file format creates a folder full of supporting files to go with the main Web page.

If you are an HTML aficionado, you can open the supporting files in other programs. For example, if the original workbook contains graphics, Excel saves them as separate image files (JPEG, PNG, or GIF) that you can modify with an image-editing program. Or you can change the fonts used by editing the cascading style sheet with a text editor such as Notepad. This is not work for the timid, of course. The slightest editing error in the HTML code for any of the files has the potential to render them all unusable.

Importing and Exporting Text Files



To export an Excel file as a text file, click the File tab, click Save As, and select one of the following eight text formats from the Save As Type drop-down list. In all of these formats, Excel saves only the current worksheet. Number formatting is preserved, but all other formatting is removed.
	Formatted Text (Space Delimited) (*.PRN) This creates a file in which column alignment is preserved by adding space characters to the data in each column so that each column is always filled to its maximum width.

	Text (Tab Delimited) (*.TXT) This separates the cells of each row with tab characters.

	Unicode Text (*.TXT) This is a worldwide standard text format that stores each character as a unique number; Unicode defines a number for every character in every language and on any computer platform.

	CSV (Comma Delimited) (*.CSV) This separates the cells of each row with commas. Comma-delimited text files are preferable to tab-delimited files for importing into database management programs. (Many database management programs can accept either form of text file, but some accept only .csv files.) Also, many word-processing applications can use .csv files to store the information for mail merge operations.

	Text (Macintosh) (*.TXT) This saves the current worksheet as a tab-delimited text file using the Macintosh character set.

	Text (MS-DOS) (*.TXT) This saves the current worksheet as a tab-delimited text file compatible with the character-based MS-DOS interface.

	CSV (Macintosh) (*.CSV) This saves a comma-delimited text file using the Macintosh character set. The differences between the normal, Macintosh, and MS-DOS variants of each file type have to do only with characters that lie outside the normal 7-bit ASCII range.

	CSV (MS-DOS) (*.CSV) The MS-DOS options use the IBM PC extended character set. (You might see this referred to also as OEM text.) Select one of these options if you intend to import your text file into a non-Windows-based application.



Note
Excel 2010 (and Excel 2007) uses a file format that is incompatible with previous Excel versions. And Excel 2003 shares with its predecessors (Excel 2002, Excel 2000, Excel 97) a file format that is incompatible with even older Excel versions. However, you can use the Save As command and Save As Type list to export Excel 2010 and Excel 2007 workbooks using two formats that play nicely with older versions of Excel: Excel 97-2003 Workbook and Microsoft Excel 5.0/95 Workbook.

Note
If you regularly share files with colleagues using different vintages of the program, you might want to read Ensuring File Compatibility with Previous Versions of Excel on page 52.


Other File Formats



You can use a few other file formats, most of which you won’t even need unless you have a particular program with which you want to share data. Data Interchange Format (DIF) is a legacy format that allows the specification of data in rows and columns, saves only the active worksheet, and does not process graphic content. Symbolic Link (SYLK), a format that dates back to the days of VisiCalc and Multiplan, is a sort of “rich-text format” for spreadsheets that saves only the active worksheet and does not process graphic content. Portable Document Format (PDF) and XML Document (XPS) are formats that allow accurate visual representations of documents to be easily shared across platforms by using free and easily obtainable Web-based viewers.



Using the Help System



Excel was a powerful program right out of the starting gate way back in 1985. Over the years, Excel has developed into an extremely complex and sophisticated application. It’s so complex that most people need to learn only about 20 percent of its capabilities. Many people turn to books like this one to help them make sense of it all. But almost every Excel user turns to the Help system at some point. And after years of working out the kinks, Microsoft has made the Help system more “helpful,” less obtrusive, more comprehensive, and much easier to use.
Help on the Surface



Although the mythical, magical, space-age vision of easily understood, self-documenting software has yet to be fully realized, Microsoft is taking steps in the right direction. Dynamic pop-up labels called ScreenTips have been around for quite a while providing visual clues to elements in the interface. Many of these ScreenTips have increased in size considerably over the years, and they contain more and better information. Simply rest the pointer on any button or command on the ribbon or the Quick Access Toolbar to display a ScreenTip, as shown in Figure 2-40.
[image: Rest the pointer on any command or button on the ribbon or the Quick Access Toolbar to display a ScreenTip.]

Figure 2-40. Rest the pointer on any command or button on the ribbon or the Quick Access Toolbar to display a ScreenTip.

Help in the form of ScreenTips is also available for many items in dialog boxes such as Excel Options. (To open this dialog box, click the File tab, and then click Options.) In this context, look for the little i (for information) icons next to items in the dialog box, which indicate more information is available. Just rest the pointer on the icon to display the ScreenTip, as shown in Figure 2-41.
[image: A little circle icon containing an i means you can see more information by simply resting the pointer on the icon.]

Figure 2-41. A little circle icon containing an i means you can see more information by simply resting the pointer on the icon.


Help in Depth



When you need more information than a ScreenTip can provide, it’s time to invoke the Help dialog box. Simply click the Help button (the question mark icon) that is always available in the upper-right corner of the screen (or any dialog box) to display the Help dialog box. When you first open the dialog box, it attempts to connect to the Microsoft Office Online Web site, as shown at the top in Figure 2-42. If you are connected to the Internet, the dialog box should quickly display an opening menu of topics, similar to the one shown at the bottom in Figure 2-42. As mentioned previously, one of the beauties of Web-based Help is that it can be continually updated, so it is quite possible this opening screen will change in content and appearance over time; more and more Help topics should be added as well.
As long as you have the Help dialog box open and your Internet connection remains active, Web-based Help continues to be available. In the dialog box at the top in Figure 2-42, there is a link labeled Show Me Offline Help From My Computer. If you click this link (or lose your Internet connection), Excel stops trying to connect to the Web and displays the “offline” Help system—that is, only those Help topics installed on your computer. You can also do this manually by clicking Connected To Office.com at the bottom of the Help dialog box and clicking Show Content Only From This Computer.
[image: Your Help system works best when you’re connected to the Web.]

Figure 2-42. Your Help system works best when you’re connected to the Web.

Note
You can prevent Excel from automatically trying to connect to the Web by using the Trust Center dialog box. See Privacy Options on page 119.

You’ll find that a lot of good information is available even when you’re not connected to the Web, but if you can maintain a connection, you’ll probably have a more satisfying experience. Plenty of “bulky” content is available on the Web that isn’t feasible to ship on CD or install on your computer, including templates, sample files, and even interactive quizzes you can take to hone your skills.
Tip
INSIDE OUT 2010: A User-Assistance Odyssey
The implication of the term online Help has changed somewhat over the years. It used to mean that in addition to the primary source of user assistance—the printed manual—how-to topics and explanations of commands and features were available right on your computer by pressing F1. What a concept! Today, the best of Help really is online, and an Internet connection is almost essential—preferably broadband.
Those who write user assistance topics and implement the Help system historically had to limit the amount of actual assistance they could provide, being constrained by the amount of space allocated for Help files on the installation CDs (or floppy disks!). Over the past few Office releases, the need for Help files actually shipped on CD has decreased because of the new user assistance paradigm: Web-based Help. This offers tremendous advantages over “in-the-box” Help. First, instead of having to cram increasing amounts of information into a finite amount of space on a CD, keeping Help files on the Web allows virtually unlimited information to be made available. Second, it allows information to be more up to date, which is actually an incredible understatement.
Consider that under the old paradigm, Help content had to be written early and sent through the editorial pipeline many weeks prior to shipping the software—often before developers were finished tweaking features. (Add another month or so for printed manuals! Remember those?) With the constraints on disk space, tough decisions often were made regarding helpful topics and useful aids such as videos and presentations that would simply have to be eliminated to save room. No wonder Help systems have historically been dissed for being inaccurate and incomplete. Under the new “truly online” Help paradigm, topics that would never have made it onto the CD are instead available on the Web, and user assistance writers can update and add more Help topics, videos, presentations, and templates long after the product ships.

You’ll notice that the Help dialog box has a tiny toolbar with controls that look—and act—similarly to the controls on your Web browser’s toolbar. The first two buttons are Back and Forward, which operate like their browser counterparts—they move you to the next or previous topic in your history list. The Stop button cuts off the data stream in case you want to stop downloading some bulky Web content that is laboring over a slow Internet connection. The Refresh button simply reloads the current topic, which you might want to do if you clicked the Stop button in mid-download. The Home button returns you to the opening Help screen, and the Print button prints the current topic. Clicking the Change Font Size button displays a menu of text size options. The button that looks like a little book is the Hide Table Of Contents button, which controls the display of the side navigation pane, as shown in Figure 2-43. This button is a toggle; that is, clicking it again hides the navigation pane.
[image: Click the book icon to toggle the display of the navigation pane.]

Figure 2-43. Click the book icon to toggle the display of the navigation pane.

The Table Of Contents pane shows you the top-level topics available. Clicking each closed book icon changes it to an open book icon and displays the topics contained beneath the main heading. If you are connected to the Internet, the list of Help topics also includes any additional Web-based topics.
The last button on the toolbar in the Help dialog box is Keep On Top, and it looks like a little pushpin. It is set to “Keep On Top” by default. When the little push pin is displayed diagonally, the dialog box behaves like a normal window, giving way to the active window when you click outside the dialog box. Click the pushpin button to change this behavior so that instead of giving way, the window stays on top of the Excel workspace, allowing you an unobstructed view of Help topics while you work. This button is a toggle; repeated clicking changes the button from “Keep On Top” to “Not On Top.” Whatever setting was active when you close the dialog box persists the next time you open it.
Note
Most dialog boxes include a Help button located in the title bar (identified by a question mark icon). Clicking this button displays a Help topic describing the function of and options within that dialog box. If you click the Help button in a tabbed dialog box, you’ll see information pertaining to that particular tab. A notable exception to this rule is the Help dialog box, where no Help button is visible. (However, click Connected To Office.com at the bottom of the Help dialog box, and you’ll see the Help icon next to the Explain These Options command.)

Because so much Help content is available between the installed Help files and the vast storehouse of possibility on the Web, Microsoft decided to add some search options to the Help dialog box to save you some time. Figure 2-44 shows the Search menu that opens when you click the arrow next to the Search button.
[image: Narrow your results using the Search menu.]

Figure 2-44. Narrow your results using the Search menu.

The Search menu gives you a clue as to how the Help material is set up, all of which can change as time goes by in this “living” Help system. As you can see in Figure 2-44, you can choose between online and offline Help, subdivided into categories. This is handy when searching for Help content because hundreds of templates are available online, apparently loaded with keywords, because many searches return a few Help topics scattered among pages of templates and training links. So, you might find it useful to limit a search for reference information about a ribbon command, for example, by selecting Excel Help from the Search menu, effectively excluding templates and training from the search results.


Recovering from Crashes



In the past, “crash recovery” largely involved an initial flurry of expletives followed by a brisk walk around the office and perhaps a couple of aspirin. Excel 2010 provides something beyond comfort and sympathy for digital mishaps—an actual mechanism that attempts to tuck away open files before the program comes screeching to a halt. And it works pretty well. If Excel encounters a problem, it attempts to save any files that are open at the time the problem occurs, before bad things happen to them when the program crashes and burns.
Understanding AutoRecover



Over the years, Excel has greatly improved its ability to recover lost work after a crash. By default, all unsaved workbooks are backed up automatically every 10 minutes, storing what Excel calls AutoRecover information. This is not the same as saving your workbook, because Excel stores AutoRecover information in a different place with a cryptic file name. You may lose a few minutes worth of work, but you can change the time interval anywhere from 1 to 120 minutes. If Excel or your system crashes, the AutoRecover feature presents a list of rescued versions of all files that were open when the crash occurred the next time you start Excel.
To change settings or turn off AutoRecover, click the File tab, click Options, and select the Save category to display the dialog box shown in Figure 2-45.
AutoRecover File Location is set to a subfolder buried deep in your hard disk—this is OK because you should save the real files elsewhere rather than clutter up your working directories with recovery files. If you want, you can easily change the location. You can also choose to disable AutoRecover for specific workbooks without having to turn it off and on manually. You can use the AutoRecover Exceptions For area in the dialog box to do this. Just select a workbook in which you want to disable AutoRecover from the drop-down list displaying all the currently open workbooks, and select the Disable AutoRecover For This Workbook Only check box. You can do this separately for any open workbook.
[image: With AutoRecover, you can specify how often Excel automatically saves your work.]

Figure 2-45. With AutoRecover, you can specify how often Excel automatically saves your work.


Managing Versions



The AutoRecover feature essentially stores a copy of each unsaved workbook every 10 minutes (unless you specify otherwise). So what happens to these copies? Excel stores one copy of each file you work on—and fail to save—for four days, deleting older copies automatically. Luckily, Excel provides access to these copies. Click the File tab, click Info, and click Manage Versions to display the menu shown in Figure 2-46.
You can use the Delete All Draft Versions command to clean up your hard disk, and more importantly, to remove all copies of sensitive data you don’t want to leave lying around. Clicking the Recover Draft Versions command opens the dialog box shown in Figure 2-47, a version of the Open dialog box, which automatically opens to the specified AutoRecover location.
[image: Even if you don’t open a recovered file immediately, Excel stores a draft for four days.]

Figure 2-46. Even if you don’t open a recovered file immediately, Excel stores a draft for four days.

[image: You can recover recent versions of your workbooks by using the Recover Draft Versions command.]

Figure 2-47. You can recover recent versions of your workbooks by using the Recover Draft Versions command.

When you open a draft, it is in read-only format, and Excel displays “Draft Version” in the message bar, along with a handy Save As button. If you do nothing, the previously scheduled four-day deletion schedule remains, and the draft is removed. Clicking Save As displays the dialog box of the same name, open to your normal documents folder.


Chapter 3. Custom-Tailoring the Excel Workspace



Customizing the Ribbon
Customizing the Quick Access Toolbar
Controlling Other Elements of the Excel 2010 Interface
Enhancing Accessibility
You needn’t settle for the way the Microsoft Excel 2010 command and control system is organized. You can customize the Quick Access Toolbar—and the ribbon more easily now as well—so if you feel that the Microsoft interface designers didn’t exactly have you in mind, you can make a lot of adjustments to Excel 2010.
Customizing the Ribbon



When the ribbon was introduced in Office 2007, it was fixed—you couldn’t modify the user interface unless you were conversant in VBA or XML. In Office 2010, the ribbon is open for interpretation; you can freely rearrange command groups; change the order and position of tabs; remove groups; and create custom commands, groups, and tabs. This is very good news for tool geeks. The bad news: you cannot add or delete commands from existing groups, and you cannot delete existing tabs. But this really isn’t much of a problem; a truly dedicated customizer can create a whole new set of tabs and stick them in front, forcing the default tabs off the screen, or simply hide all the default tabs.
Start by right-clicking anywhere on the ribbon and clicking the Customize The Ribbon command on the shortcut menu that appears. This opens the Excel Options dialog box with the Customize Ribbon category selected (saving you several mouse clicks), as shown in Figure 3-1.
The Customize Ribbon category in the Excel Options dialog box displays two scrollable lists. The Choose Commands From list on the left displays commands you can use to create your own command groups and tabs. The list on the right shows the current contents of the ribbon as a collapsible outline, making it easy to see the ribbon’s structure. The first level of the outline represents tabs, and the second level of the outline represents command groups, corresponding to the labels at the bottom of each group (Clipboard, Font, Alignment, and so on) on the ribbon. Click the plus sign icons to reveal the subordinate groups and commands. Many groups have additional plus signs that expose another level of commands. For example, Figure 3-2 shows the outline for the Font group fully expanded. There are a lot of commands in this one group—more than you can see at once.
[image: The outline on the right side of the dialog box controls the ribbon’s structure.]

Figure 3-1. The outline on the right side of the dialog box controls the ribbon’s structure.

Note
Some items in the outline might be wider than can be displayed in the dialog box at its default size. Just drag any border of the dialog box to make it wider or deeper. The next few figures were created after making the dialog box a bit larger for ease of viewing.

[image: The list on the right is a collapsible outline listing the current contents of the ribbon.]

Figure 3-2. The list on the right is a collapsible outline listing the current contents of the ribbon.

The drop-down list boxes above each list contain categories you use to filter the list of displayed commands. For example, Figure 3-3 shows the drop-down list with one of the more interesting categories selected: Commands Not In The Ribbon. This category is fun to browse just to see what you’ve been missing.
Note
You can clear the check box next to a tab in the outline to hide it on the ribbon; select it to display it. Note that many tabs are dynamic, such as the Add-Ins and Background Removal tabs in Figure 3-1, and all of the Tool tabs in Figure 3-3. Even if they are selected in the outline, they do not appear on the ribbon until they’re needed.

On the right side of the dialog box in Figure 3-3, the Tool Tabs option is selected in the drop-down list. This displays a wealth of “hidden” tabs and groups on the ribbon that are normally invisible but that appear dynamically when the appropriate object or tool is selected.
[image: Choose options from the drop-down lists above to filter the contents of the scrollable lists below.]

Figure 3-3. Choose options from the drop-down lists above to filter the contents of the scrollable lists below.

Identifying Items in the Customize Ribbon and Quick Access Toolbar Categories



Most of the items you can see in the command list on the left side of the Customize Ribbon category in the Excel Options dialog box are buttons. That is, clicking the command button on the ribbon executes the associated command immediately. You can see that some items also have a small icon to the right of the command name in the dialog box. These are called command modifiers, and they tell you that although the item may still be a button, it is also something more, as detailed in Table 3-1. (Note that this also applies to the Quick Access Toolbar category in the Excel Options dialog box. The controls are almost identical to those in the Customize Ribbon category.)
Note
The Quick Access Toolbar is discussed later in Customizing the Quick Access Toolbar on page 92.

If you want a little more information about the commands in the command list, rest the pointer on any command to display a ScreenTip.
Table 3-1. Command Modifiers
	Item
	Description
	Image

	Drop-down list
	A control that displays a menu or palette from which you select an option, such as the Conditional Formatting button on the Home tab
	[image: ]

	Split button
	A two-part item—one side looks and acts like a button, and the other side has a small arrow that displays a drop-down list, such as the Font Color button on the Home tab
	[image: ]

	Edit control
	A control you can type into—for example, the Font drop-down list on the Home tab
	[image: ]

	Ribbon group
	A control that displays a palette of items, such as the “boxed” group of Font controls on the Home tab
	[image: ]





Creating a Custom Ribbon Tab



You can add custom groups to existing tabs, but if you have limited screen real estate, creating your own tabs might make more sense. To do so, first right-click the ribbon, click Customize The Ribbon, and then click the New Tab button. This creates a new top-level outline item provisionally entitled New Tab (Custom). Select New Tab (Custom), and then click the Rename button to display the dialog box shown in Figure 3-4. The new tab is inserted below the selected tab in the outline.
[image: Create a new ribbon tab by clicking the New Tab button, and then click Rename to give it a sensible moniker.]

Figure 3-4. Create a new ribbon tab by clicking the New Tab button, and then click Rename to give it a sensible moniker.

After you create a tab, you need a group, because commands can be added only to groups. Helpfully, a custom group is created automatically whenever you create a custom tab, as shown in Figure 3-4. Even after you rename a tab or a group, (Custom) continues to appear, appended in the outline to any title you provide, which helps to quickly identify your own tabs and groups.
You can reposition any tab or group in the outline by simply dragging it to a new location, or you can select it and click the arrow buttons located to the right of the list box. You cannot reposition commands within preset groups, but you can move groups around from tab to tab all you like.
Note
The first tab in the Customize The Ribbon outline—even a custom tab—becomes the default tab that is active every time you start Excel.


Creating a Custom Command Group



Creating custom command groups is similar to creating custom tabs. First, select the tab where you want the custom group to live, and then click the New Group button in the Excel Options dialog box. (If you created a new tab, a new group already appears on the new tab.) Select your new group, and click the Rename button to display the dialog box shown in Figure 3-5.
[image: Clicking the Rename button with a group selected allows you to select an icon for the group as well.]

Figure 3-5. Clicking the Rename button with a group selected allows you to select an icon for the group as well.

As you can see, you can rename your new group and also assign an icon to it, which is visible only when you add the group to the Quick Access Toolbar. If you look at the Home tab on the ribbon, you’ll notice that most of the commands do not have labels displayed; they appear as buttons. For example, Paste is the only command in the Clipboard group that displays a label; there are no command labels visible at all in the Font, Alignment, and Number groups. The ribbon shown at the top of Figure 3-6 displays a custom Formatting tab populated with border-specific commands with their command labels visible. If you want to create a tab filled with other kinds of Formatting commands, you’ll need a lot more space, and hiding the labels helps a lot.
To hide command labels, right-click the ribbon, click Customize The Ribbon, then right-click any custom group in the outline and click Hide Command Labels. Note that this command appears on the shortcut menu only when you click a custom group. You cannot change the command labels of default groups. The ribbon shown at the bottom of Figure 3-6 shows the result—now there is plenty of space left on the custom Formatting tab for more groups. Notice that hiding the command labels does more than what the command’s name implies; the button icons become considerably smaller as well.
[image: It is a good idea to hide the command labels when you create new groups.]

Figure 3-6. It is a good idea to hide the command labels when you create new groups.

After hiding the command labels so that they are not visible on the ribbon, you can still easily see the command names by resting the mouse pointer over the buttons.

Adding Existing Command Groups to Custom Tabs



When constructing custom tabs, you can take advantage of predefined command groups. Microsoft decided to make the built-in groups noncustomizable partly because a lot of sweat and tears went into creating them as they are today. Decades of usability studies and real-world usage of menus and command trees went into the design of the ribbon, and as such it makes sense for 80 percent of our needs. But we’re talking about the other 20 percent here. Because you can create your own groups anyway, there is no harm in having the default groups fixed—and plenty of good reasons for you to take advantage of them.
Right-click the ribbon, and then click Customize The Ribbon. In the Choose Commands From drop-down list, click All Tabs to display an outline of all the predefined command groups, as shown in Figure 3-7.
[image: Displaying All Tabs reveals all the predefined command groups.]

Figure 3-7. Displaying All Tabs reveals all the predefined command groups.

First, select a tab or group in the outline on the right below which you want to insert a preset group. Next, in the All Tabs list on the left, click the plus sign icons to expand the outline and locate the group you want. Select it, and click the Add button to insert the group into the outline on the right. If you decide you want your inserted groups somewhere else, you can always move them up and down the outline by using the arrow buttons. A well-populated custom Formatting tab is shown in Figure 3-8, along with the outline in the Excel Options dialog box that created it.
[image: The modified outline in the Customize The Ribbon list and its custom tab.]

Figure 3-8. The modified outline in the Customize The Ribbon list and its custom tab.


Resetting and Recycling Your Customizations



When you customize the ribbon, it stays customized; everything is still there the next time you start Excel. But if you ever joke about “hitting the reset button,” well, now you actually have one. In the Customize Ribbon category in the Excel Options dialog box, the Reset button does the eponymous trick, discarding your customizations and returning the ribbon and the Quick Access Toolbar to their original states. The button is also a menu, offering the dual options of resetting only the selected tab (if one is selected) or resetting all customizations (which resets both the ribbon and the Quick Access Toolbar). Before you reset either, though, you might want to save your customization work so that you can retrieve it later. Below the Reset button, the Import/Export button allows you to reuse and recycle your work. This button is also a menu from which you can choose to import or export a special file containing all your customizations. Figure 3-9 shows a version of the File Open dialog box that appears when you choose Import Customization File from the Import/Export menu, with a couple of saved customization files. The first file—Excel Customizations.exportedUI—is the rather clunky default name offered. The proprietary extension for the resulting file—.exportedUI—is appended to any file name you supply.
[image: You can export any number of ribbon customization files for retrieval later.]

Figure 3-9. You can export any number of ribbon customization files for retrieval later.

Using these exported customization files and a Web storage location such as Windows Live SkyDrive, you can store your custom tool sets as well as your workbooks, making them available from any Internet-connected computer in the world running Office 2010.



Customizing the Quick Access Toolbar



The Quick Access Toolbar may be small, but you can pack a lot of tools onto it. If you are stuck using a small screen, or if you prefer an uncluttered workspace, you can set up the Quick Access Toolbar as a sort of “ribbon lite” to help free up some screen real estate.
Positioning the Toolbar



When you first start Excel, the Quick Access Toolbar appears above the ribbon, as shown in Figure 3-10. You can change this so that the toolbar appears below the ribbon. Click the Customize Quick Access Toolbar button (the little arrow at the right end of the toolbar), and click Show Below The Ribbon. When you do, the name of the command changes appropriately, as shown in Figure 3-11.
[image: The Quick Access Toolbar usually appears above the ribbon on the title bar.]

Figure 3-10. The Quick Access Toolbar usually appears above the ribbon on the title bar.

[image: You can move the Quick Access Toolbar below the ribbon.]

Figure 3-11. You can move the Quick Access Toolbar below the ribbon.

Moving the Quick Access Toolbar below the ribbon offers you a couple of advantages. First, it’s closer to the action on the worksheet. Second, more space is available for additional tools, which we discuss in depth in Adding Tools to the Toolbar. The drawback to placing the toolbar below the ribbon is that it takes space away from the worksheet; conversely, the advantage of leaving it at the top of the screen is that it can occupy unused space on the title bar.

Adding Tools to the Toolbar



You get three tools to start with on the Quick Access Toolbar—Save, Undo, and Redo. These are undeniably heavily used commands, but you perform other tasks often too and might like to have them just a click away, readily available regardless of which ribbon tab is currently visible. It’s easy to customize the toolbar, and you have a couple of ways to do it.
Adding Tools as You Work



If you find yourself continually returning to the same tab on the ribbon and using a particular command, you might consider adding it to the Quick Access Toolbar. The easiest way to do this is to right-click the command to display the shortcut menu shown in Figure 3-12.
In Figure 3-12, we added the Switch Windows command to the Quick Access Toolbar by right-clicking the command and clicking Add To Quick Access Toolbar. A button then appears on the toolbar that looks similar to the command on the ribbon. Each new button you add appears to the right of the previous button. Not all toolbar buttons are easy to identify, but you can always rest the pointer on a button to display a ScreenTip explaining its function, as shown at the bottom of Figure 3-12. If you add a lot of buttons, these ScreenTips are indispensable.
[image: Right-click any command or group, and you can add it to the Quick Access Toolbar.]

Figure 3-12. Right-click any command or group, and you can add it to the Quick Access Toolbar.


Removing Tools



You can remove tools from the Quick Access Toolbar by using the same technique you use to add them. Right-click any tool on the toolbar, and click Remove From Quick Access Toolbar.

Adding and Organizing Tools



You can add virtually any command or group to the Quick Access Toolbar by using the right-click technique, but if you want to dig in and really create an organized toolbar, you should use the Excel Options dialog box. Right-click the toolbar, and click Customize Quick Access Toolbar to open the Quick Access Toolbar category in the Excel Options dialog box, shown in Figure 3-13.
As you can see in Figure 3-13, the list on the right shows the buttons currently visible on the toolbar. The controls here work just like the Customize Ribbon category—select any item on the left side, and then click the Add button to add it to the list on the right. Select any item on the right side, and click the Remove button to get rid of it; when you select an item, you can click the up and down arrows to reposition the item in the list. You can always click the Reset button if you want to discard all your changes and return to the original configuration.
[image: The Quick Access Toolbar category in the Excel Options dialog box is the command center for the Quick Access Toolbar.]

Figure 3-13. The Quick Access Toolbar category in the Excel Options dialog box is the command center for the Quick Access Toolbar.

Notice in Figure 3-13 that Separator is the first item in the list on the left. This item is first in each command category, and with it you can insert small vertical bars on the Quick Access Toolbar to visually separate groups of related commands. You can add separators and move them up and down the list on the right side of the dialog box, just as you do with commands. (This item is not available for ribbon customization because you create groups first instead of using separators.)
The items in the Choose Commands From drop-down list include an eponymous item for each of the command tabs visible on the ribbon, plus all the other contextual tabs that appear on the ribbon only when an object is selected, as shown in Figure 3-14. Choose any item from the drop-down menu, and the corresponding list of commands appears in the list below.
[image: Each item in the Choose Commands From drop-down list corresponds to a tab on the ribbon.]

Figure 3-14. Each item in the Choose Commands From drop-down list corresponds to a tab on the ribbon.

Tip
INSIDE OUT Create a Mini-Ribbon
Here is a trick you can use if it just seems like too much bother to click those tabs at the top of the ribbon, or you just want to maximize screen space. Saving a click here and there can make quite a difference if you do a lot of repetitive work. The following illustration shows the Quick Access Toolbar loaded with buttons that correspond to every group on every default tab on the ribbon, which is minimized (double-click any ribbon tab to toggle its display):
[image: image with no caption]

The toolbar shown here includes only buttons that correspond to the command groups (not individual commands) on every default tab. Notice that clicking the Page Setup button displays a drop-down list of commands identical to those in the ribbon group of the same name on the Page Layout tab. To customize the toolbar this way, use the Excel Options dialog box. Although you can build a similar toolbar using the right-click approach, using the dialog box offers the advantage of being able to insert separators between groups of buttons.

Note
You’ll find the Ribbon Group Toolbar.xlsx file with the other examples on the companion Web site.


Too Many Tools?



It is certainly possible to load more buttons onto the Quick Access Toolbar than can fit across the screen, even if you move the toolbar below the ribbon. If this happens, a More Controls button appears at the right end of the toolbar, looking like a fast-forward button (>>). As shown in Figure 3-15, clicking More Controls displays the hidden controls on a drop-down toolbar.
[image: If you add more buttons than can be displayed, click the More Controls button.]

Figure 3-15. If you add more buttons than can be displayed, click the More Controls button.

Note that when the More Controls button appears, the Customize Quick Access Toolbar button (the downward-pointing arrow) that usually appears at the right side of the toolbar moves to the “overflow” area of the toolbar.


Creating Your Own Buttons



Right-click any button on the ribbon, click Customize Quick Access Toolbar, and click the Choose Commands From drop-down list. You’ll see a special option listed there: Macros. Macros are sequences of commands you can create to help perform repetitive tasks. When you select the Macros option, nothing appears on the left side of the dialog box unless a macro-enabled workbook is open and the workbook actually contains macros. All the macros available appear here. Figure 3-16 shows the Customize Quick Access Toolbar list containing a single macro that has been added to the toolbar.
[image: You can add custom buttons to run macros in macro-enabled workbooks.]

Figure 3-16. You can add custom buttons to run macros in macro-enabled workbooks.

You might notice that the Modify button below the list is active when you add a macro to the list on the right side of the dialog box. By clicking it, you can modify the button image displayed on the toolbar if the default image doesn’t do it for you. In case you are wondering, you can modify only custom macro buttons, which is why the Modify button is not available when you select built-in commands. When you click the Modify button, the Modify Button dialog box appears, as shown in Figure 3-17, and allows you to select a different image.
Note
For more information about macro-enabled workbooks, see Saving Files on page 49. For more information about macros and VBA, see Chapter 27.

[image: You can change the default button image for your custom macro-driven buttons.]

Figure 3-17. You can change the default button image for your custom macro-driven buttons.


Saving and Resetting Your Custom Quick Access Toolbar



In the Quick Access Toolbar category of the Excel Options dialog box, the default setting in the Customize The Quick Access Toolbar drop-down list is For All Documents. In this case, Excel saves the configuration of the Quick Access Toolbar when you exit the program. If you want to go back to the way things were, click the Reset menu and choose Reset Only The Quick Access Toolbar or Reset All Customizations (which resets both the ribbon and the Quick Access Toolbar).
If you want to save your custom toolbar so that you can use it again later, there are two ways to do it. The Import/Export button allows you to save or retrieve a special file containing all your customizations (both toolbar and ribbon). Figure 3-9 on page 92 shows a version of the File Open dialog box that appears when you click Import Customization File from the Import/Export menu, displaying files with the extension .exportedUI.
The second way to save a custom toolbar is to attach it to a workbook. To do so, right-click any button or tab, and click Customize Quick Access Toolbar. In the Excel Options dialog box, click the Customize Quick Access Toolbar drop-down list, as shown in Figure 3-18.
You’ll find both a customizations file—MiniRibbon.exportedUI—and a file with an attached toolbar—Ribbon Group Toolbar.xlsx— with the other examples on the companion Web site.
[image: You can configure a custom version of the Quick Access Toolbar that travels with a workbook.]

Figure 3-18. You can configure a custom version of the Quick Access Toolbar that travels with a workbook.

The drop-down list shows two items: For All Documents and For <the active workbook name>. If you select the active workbook, the command list starts out blank, and you can begin adding items from the list on the left. (Even though the list starts out blank, the default tools—Save, Undo, and Redo—always appear at the left end of your custom bar.) Any commands you add to the active workbook’s toolbar are relevant only to the active workbook; they are saved with the workbook and reappear on the toolbar the next time you open the workbook. To remove a custom toolbar configuration from a workbook, select its name in the Customize Quick Access Toolbar drop-down list, and click the Reset button.

Restoring the Toolbar



Now that you’ve thoroughly scrambled the Quick Access Toolbar, perhaps you’re experiencing a bit of remorse. Don’t worry—it’s easy to return it to normal.
	Restoring the toolbar Select Quick Access Toolbar in the Excel Options dialog box, click the Reset button, and select either Reset Only Quick Access Toolbar or Reset All Customizations (which also resets the ribbon). Click Yes to confirm the restoration, and then click OK.

	Removing individual buttons On the Quick Access Toolbar, right-click the button you want to remove and then click the Remove From Quick Access Toolbar command, as shown in Figure 3-19.



[image: You can easily remove any button from the Quick Access Toolbar.]

Figure 3-19. You can easily remove any button from the Quick Access Toolbar.

Tip
INSIDE OUT What Happened to My Custom Toolbars?
Custom toolbars you created and attached to workbooks in versions of Excel prior to 2007 are still accessible, though you might not think so at first glance. If you open an old workbook with attached toolbars, the toolbars won’t appear on the screen. But look at the Add-Ins tab on the ribbon. You might not have seen the Add-Ins tab before, but click this tab, and there they are—your custom toolbars. The following graphic shows an example of way too many custom toolbars on the Add-Ins tab:
[image: image with no caption]

So, all your hard work creating custom toolbars is not lost—provided you attached them to workbooks. After you open a workbook containing attached toolbars, the toolbars continue to appear on the Add-Ins tab each time you start Excel. To get rid of them, right-click any toolbar (each toolbar is a group on the Add-Ins tab), and close it by using the Delete Custom Toolbar command. If the custom toolbar is the only item on the Add-Ins tab, the Add-Ins tab disappears as well.


Exploring Other Toolbar and Ribbon Options



The following are a few more customization options that are quite helpful. Unless otherwise noted, you can find these options by clicking the File menu, clicking Excel Options, and then selecting the General category.
	Show Mini Toolbar On Selection controls the display of the Mini toolbar whenever you right-click a cell or object where its formatting tools are applicable, as shown in Figure 3-20.

	Enable Live Preview allows you to simply rest the pointer on many palette items to show what the effect would look like, without even clicking.

	Color Scheme offers several optional “skin” colors; that is, the background color of the program itself, visible in the title bar, formula bar, Quick Access Toolbar, ribbon, sheet tabs, scroll bars, and headings.

	ScreenTip Style offers three options that apply to the pop-up label that appears when you rest the pointer on any item on the toolbar or the ribbon. You can choose to see only a small label with the name of the item, a larger ScreenTip that includes a description, or no label at all. (For more information, see Enhancing Accessibility on page 107.)



Note
For more information about fonts and formatting and live preview, see Chapter 9.

[image: You can control whether the Mini toolbar appears when you right-click cells or relevant objects.]

Figure 3-20. You can control whether the Mini toolbar appears when you right-click cells or relevant objects.



Controlling Other Elements of the Excel 2010 Interface



In several important locations in Excel, you can control the way your worksheets appear on the screen. These include the View tab on the ribbon, shown in Figure 3-21, and the General and Advanced categories in the Excel Options dialog box. Some options, such as Gridline Color, are self-explanatory; here we’ll talk about options with “issues.”
[image: The View tab on the ribbon contains commands you can use to control the appearance of your workbook.]

Figure 3-21. The View tab on the ribbon contains commands you can use to control the appearance of your workbook.

The Show group on the View tab controls the display of the formula bar as well as the appearance of gridlines, column and row headings, and the ruler (which is active only in Page Layout view). These are the options that are most often used, which is why they appear on the ribbon. But you’ll discover more ways to tweak your UI when you click the File menu and then click Excel Options.
Note
For more about Page Layout view, see Chapter 11. For more about security issues, see Chapter 4.

The Advanced category in the Excel Options dialog box contains three groups of options, shown in Figure 3-22 (you’ll need to scroll down a bit), that control different display behaviors for the program in general and for workbooks and worksheets in particular.
[image: The Advanced category in the Excel Options dialog box includes a number of display options.]

Figure 3-22. The Advanced category in the Excel Options dialog box includes a number of display options.

The Display area, shown scrolled to the top of the dialog box in Figure 3-22, offers display options for the program itself. The options in the Display Options For This Workbook area affect only the workbook selected in the drop-down list, which lists all the currently open workbooks; these options do not change the display of any other workbooks, and they do not affect the way the worksheets look when you print them. Similarly, the options in the Display Options For This Worksheet area apply only to the worksheet you select in the drop-down list.
Displayed vs. Printed Gridlines and Headings
Normally, Excel displays a grid to mark the boundaries of each cell on the worksheet and also displays row and column headings, but these are not printed unless you say so. The grid and headings are usually helpful for selecting and navigating, but you might not want them displayed all the time. The options for these items on the View tab control your screen display, but they do not affect whether these elements will be printed. You can control both display and printing on the Page Layout Tab. In the Sheet Options group, select or clear the View and Print check boxes under Gridlines or Headings. For convenience, the View check boxes under Gridlines and Headings on the Page Layout tab are linked to the Gridlines and Headings check boxes on the View tab.
Note
For more about printing a document, see Chapter 11.


Displaying Underlying Formulas



Usually, cells containing formulas display the results of that formula, not the formula itself. Similarly, when you format a number, you no longer see the underlying (unformatted) value displayed in the cell. You can see the underlying values and formulas only by selecting individual cells and looking at the formula bar or by double-clicking the cell. But what if you want to see more than one formula at once?
By selecting the Show Formulas In Cells Instead Of Their Calculated Results check box in the Excel Options dialog box (shown in Figure 3-22) you can display underlying values and formulas for the worksheet you select in the Display Options For This Worksheet drop-down list. As you can see in the worksheet view shown at the bottom of Figure 3-23, the underlying contents of each cell appear, as in the sum formulas in rows 6 through 10, and all the cells are left aligned. (Excel 2010 ignores any alignment formatting when you select the Show Formulas check box.) In addition, the width of each column on the worksheet approximately doubles to accommodate the underlying formulas. (The actual width of the columns remains unchanged; columns appear wider only on the screen.) When you clear the Show Formulas check box, Excel restores all columns to their former widths.
Note
You can quickly display and hide formulas in your worksheet by pressing Ctrl+’ (a single opening quote), which is located on the tilde key on most keyboards. To redisplay values, press Ctrl+’ again.

[image: Display underlying values and formulas for easier auditing.]

Figure 3-23. Display underlying values and formulas for easier auditing.

Note
If you click the New Window command on the View tab to create two or more windows in which to view the same workbook, you can use different display options in each window. For example, you can display formulas in one window and see the results of those formulas (the usual view) in another window.

The Show Formulas check box is particularly helpful when you need to edit a large worksheet. You can see your formulas without having to activate each cell and view its contents on the formula bar. You can also use the Show Formulas check box to document your work: After you select the Show Formulas check box, you can print your worksheet with the formulas displayed for archiving purposes.

Hiding Zeros



Usually, zeros entered in cells, or the results of formulas that produce zero values, display on your worksheet. Sometimes, especially for presentation purposes, it is helpful to eliminate the clutter of excessive zero values on a worksheet. Under the heading Display Options For This Worksheet in the Advanced category of the Excel Options dialog box, clearing the Show A Zero In Cells That Have Zero Value check box causes any such cells to appear as blank cells on the worksheet. The underlying entries are unaffected, of course. If you edit an entry or if the result of a formula changes so that the cell no longer contains a zero value, the value immediately becomes visible. If the Show Formulas check box is also selected, clearing the Show A Zero In Cells That Have Zero Value check box has no effect on the display.
Caution
If you hide zero values, be careful when editing your worksheet. What appears to be an empty cell might actually contain a formula.

Changing the Display Font
The display font is not only used for all text and numbers you enter in a workbook, but it also determines the font used in row and column headings. You can select fonts to be used when creating new workbooks with the Use This Font and Font Size drop-down lists in the General category in the Excel Options dialog box. The default display font is Body Font, which uses the font defined as such in the current theme. The new display font does not become active until you exit and restart Excel. When you do, the new font is used in all new workbooks you create. You can learn a lot more about formatting and themes in Chapter 9.



Enhancing Accessibility



Excel 2010 and all other Microsoft Office 2010 programs support the Microsoft Active Accessibility (MSAA) specification. This makes various accessibility aids more effective, including screen readers and screen enlargers. For more information, visit the Microsoft Accessibility Web site at www.microsoft.com/enable/.
The following is a list of built-in features that, either by design or by default, enhance the accessibility of Excel:
	The Accessibility Checker New in Excel 2010 is the most visible accessibility feature yet. It appears on the Info screen in Backstage view, and Microsoft calls it the Accessibility Checker. Click the File tab, Info, click the Check For Issues button, and then click Check Accessibility to display the task pane shown in Figure 3-24. This task pane lists all the problematic items identified by the Accessibility Checker in the active workbook; click any item to display an explanation, as shown in Figure 3-24.
[image: The Accessibility Checker lists all the issues found in the current workbook.]

Figure 3-24. The Accessibility Checker lists all the issues found in the current workbook.


	ScreenTips These are the little descriptive labels that appear under toolbar buttons and ribbon controls when you rest the pointer on them. Select one of three display options from the ScreenTip Style drop-down list in the General category in the Excel Options dialog box. For more information, see Exploring Other Toolbar and Ribbon Options on page 102.

	Visceral feedback The Advanced category in the Excel Options dialog box contains two options in the General group: Provide Feedback With Animation and Provide Feedback With Sound. Using these options, when you insert rows or columns, instead of simply appearing, they appear with a flourish, and you hear sounds where you might not expect them, such as when you click the Undo or Redo button. Note that if you select the sound option, you might be prompted to download an add-in from the Microsoft Office Web site that requires that you to exit and restart Excel.

	Function ScreenTips This is a type of pop-up label that displays the syntax and arguments for functions as they are entered or selected on the formula bar or in cells. Select the Show Function ScreenTips check box in the Advanced category of the Excel Options dialog box in the Display group. For more information, see Chapter 13.

	Cell value AutoComplete When entering data in a column, the AutoComplete feature automatically inserts entries in the same column that match the current entry. This option saves keystrokes, for example, when you are repeatedly typing the same entry. In the Advanced category in the Excel Options dialog box, select the Enable AutoComplete For Cell Values check box in the Editing Options group. For more information, see Letting Excel Help with Typing Chores on page 249.

	Gridline color You can change the color of gridlines on individual worksheets. Under Display Options For This Worksheet in the Advanced category in the Excel Options dialog box, click the Gridline Color drop-down list, and then choose a color.

	Colored sheet tabs You can apply color to a single worksheet tab to make it easier to find a key worksheet, or you can assign different colors to each tab. Right-click the worksheet tab you want to color, point to Tab Color, and then click the color you want from the palette.

	Keyboard shortcuts Keyboard shortcuts give you access to any command in Excel using the keyboard. For more information, see Appendix B.

	Scroll and pan If you have a Microsoft IntelliMouse pointing device, you can scroll through a worksheet simply by turning the wheel in the direction you want to scroll. If you press the wheel and drag the mouse, you can pan the worksheet in any direction.

	Zoom You can enlarge the worksheet display up to 400 percent by using the Zoom slider in the lower-right corner of the Excel window, by using the Zoom commands on the View tab on the ribbon, or by holding down Ctrl and turning the wheel on a Microsoft IntelliMouse pointing device.



Ease of Access in Windows 7
Windows 7 (and Windows Vista) includes a number of accessibility options referred to as the Ease Of Access options. You can find these on the Windows 7 Start menu by clicking Control Panel and then clicking Ease Of Access Center to display the dialog box shown here:
[image: image with no caption]

Many of these settings used to be scattered around or available only as add-ins to Windows, so these Ease Of Access options further improve the usability of Excel for folks with varying abilities.


Chapter 4. Security and Privacy



The Trust Center
File Security
Other Security Features
IN this chapter, we cover overall system security issues, including ways to help protect your system against malicious software and how to hide your personal information from unwanted scrutiny. We also discuss using digital signatures to both verify incoming files and certify your own outgoing files. Microsoft Excel 2010 has additional security features you can apply within workbooks, worksheets, and even cells. We discuss these features in Protecting Worksheets on page 170 and in Hiding and Protecting Workbooks on page 189.
The Trust Center



Microsoft consolidated the kind of security features that are common to many Microsoft Office programs in a dialog box it calls the Trust Center. Click the File tab, click Options, and then click Trust Center to display the dialog box shown in the background in Figure 4-1.
This category in the Excel Options dialog box contains links to disclaimers and declarations on the Web. Click the Trust Center Settings button to open the dialog box in the foreground in Figure 4-1, where the security settings live.
Note
If you work in an organization, the Trust Center might contain default settings specified by your network administrator that you cannot (or should not) modify. Contact your friendly internal administrator for more information.

The settings you can configure in the Trust Center determine how Excel responds when you open a file with active content—that is, any external file that contains links or code used to communicate with another location on the Internet or an intranet. When you open such a file, Excel investigates several measures of trustworthiness. Rules exist by which a publisher attains trusted status. Defined as reputable developers, trusted publishers must sign their code by using valid, current digital signatures that are issued by certified certificate authorities such as IntelliSafe. If you open a file that does not meet one of these criteria, a security alert appears, and you need to decide whether to run the active content anyway. But even if you add a publisher, unsigned code from that publisher still triggers a security alert. Most of the areas in the Trust Center dialog box deal with issues that directly affect the triggering of security alerts and the ability to run active content.
[image: The Trust Center dialog box controls many security settings.]

Figure 4-1. The Trust Center dialog box controls many security settings.

When you open a workbook with issues, Excel displays relevant security alerts and messages in the Message Bar, which appears right above the formula bar, as shown in Figure 4-2. Each message corresponds to a problem lurking within the file, and each includes a button offering a possible resolution. As you can see in Figure 4-2, the Message Bar can contain more than one message.
Note
For more information about code signing, see Using Digital Signatures on page 122.

[image: Security alerts and messages appear in the Message Bar.]

Figure 4-2. Security alerts and messages appear in the Message Bar.

Note
When you open a workbook with active content or other issues, any unresolved messages or alerts that appear in the Message Bar also appear in the Info category when you click the File tab.

Trusted Publishers, Locations, and Documents



A “publisher” is a software developer, which can range in relative scale and trustworthiness from a kid with a laptop to Microsoft. You might know the kid, and you might not trust Microsoft. Whatever the case, you can apply your unique level of paranoia by adding or deleting publishers and locations using the first two categories in the Trust Center dialog box. Excel populates the Trusted Publishers list whenever you open a macro or add-in for the first time that triggers a security alert. If you decide to enable the content, Excel adds the publisher to the list. Subsequent active content from the same publisher opens without triggering a security alert.
Trusted locations can be folders on your own hard disk or on a network; the more precise, the better. We recommend you designate trusted locations at the subfolder level—even the default Documents folder (a.k.a. The Folder Formerly Known As My Documents) is too broad, particularly if you work in a networked environment. It is better to designate subfolders of Documents—or better yet, use folders outside the Documents folder entirely—to minimize the ease with which others can locate interesting stuff on your computer to steal or to modify. Several trusted locations are installed with Excel, such as subfolder locations for template and startup files, as shown earlier in Figure 4-1.
Each time you open a document that triggers a security alert and enable its content by clicking the Enable Content button in the Message Bar, you add the name of the document to the Trusted Documents list. The security alert no longer appears on subsequent openings. You can reset the Trusted Documents list (which actually appears nowhere) by clicking the Trusted Documents category in the Trust Center dialog box and clicking the Clear button, shown in Figure 4-3. Here you can also disable Trusted Documents (the feature, not the documents themselves) and choose to allow or deny global “trusted” status to all the documents that exist on your network.
[image: You add to the Trusted Documents list when you enable the active content in a document.]

Figure 4-3. You add to the Trusted Documents list when you enable the active content in a document.


Add-Ins, ActiveX Settings, and Macro Settings



The Add-Ins, ActiveX Settings, and Macro Settings categories in the Trust Center, as shown in Figure 4-4, deal with blocking active content. You have only two choices for add-ins: just disable them all or require them to be from a trusted publisher. If you decide on the latter, you can additionally disable the usual Message Bar notification when an add-in is unsigned.
[image: Using the options in the Add-Ins, ActiveX Settings, and Macro Settings categories, you can enable or disable most types of active content that you might encounter.]

Figure 4-4. Using the options in the Add-Ins, ActiveX Settings, and Macro Settings categories, you can enable or disable most types of active content that you might encounter.

ActiveX controls are more general than add-ins, and they can be designed to run on the Web or on your computer but always within a host application. ActiveX has been the language of choice for many malicious code developers (a.k.a. hackers) because it allows nearly unlimited access to your computer. You should never allow ActiveX controls without restriction—the minimum protection option should be Prompt Me Before Enabling All Controls With Minimal Restrictions. The option that mentions Safe For Initialization (SFI) controls refers to a sort of internal code-signing protocol set by the developer to verify its safety. Choosing this option puts code through a few more levels of restriction. The best solution if you want to stay safe yet you need to use certain ActiveX controls is to set up or utilize a trusted location to store the ActiveX controls you know to be safe.
Tip
INSIDE OUT Of Web Beacons and Homograph Attacks
The word exploits, which used to conjure images of heroic figures and derring-do, has come to describe the actions of malicious software. Phishing is a rather clever type of lure used by hackers trolling for data to reel unsuspecting prey into their virtual creels. Homographs use the extended international character set to create scam Web sites with Uniform Resource Locators (URLs) that replace one or more English-alphabet letters in the real domain names with similar ones from another language’s character set. You see what you think is a trusted URL, but if you access the site, you might end up sharing information with the phishermen instead of the trusted site. Where homographs are designed to lure you in, web beacons might be what you “win” after you get there. These are forms of spyware that infiltrate your system and then just sit there transmitting data—beacons of information—to malicious data-mining operations. These are just a few of the many clever methods being employed to rip you off. The Trust Center addresses some grim realities of this insecure world, but, of course, it shouldn’t be your only line of defense. Unfortunately, every Internet-connected computer needs to have an automatically updating antiviral/firewall application installed to fend off current and future exploits.
You can read more about all this in the Help system. The easiest way to get to the relevant topics is to open the Trust Center dialog box and then click the Help button (the little question mark icon in the upper-right corner) to display a Help topic about the currently active category.

Unlike ActiveX controls, macros are application-specific, but they can be destructive when they emanate from a malicious coder. The Trust Center Macro Settings category reveals options that are similar to those of ActiveX controls, as are the recommendations. The Trust Access To The VBA Project Object Model option is for developers only but might be desirable in a development environment where a shared Visual Basic for Applications project object model is known to be secure and isolated.

Message Bar



The Message Bar category in the Trust Center dialog box simply lets you turn off the display of security alerts in the Message Bar. It does not turn off the actual security features, just the notifications. The Message Bar is ordinarily turned on, unless you opt to disable all macros. ActiveX controls still generate their own security alerts.

External Content



External content comes in many flavors, and people can use it in many ways to implement malicious intent. The Trust Center dialog box can intercept potential problems by blocking external content such as data connections, hyperlinks, and images, all of which can contain or facilitate malicious code. Figure 4-5 shows the External Content category of the Trust Center dialog box.
[image: The External Content category contains settings that control data connections and links.]

Figure 4-5. The External Content category contains settings that control data connections and links.

The real difference between the two sets of External Content options is that data connections are links to data from other programs, such as databases, while workbook links are external references used between Excel workbooks. If you do not control or do not have confidence in the linked or connected sources, it’s best to go with the default settings, prompting you for a decision whenever external content is encountered. As with most of these Trust Center options, allowing all data connections or workbook links is not recommended.

File Block Settings



Excel 2010 allows you to disable the opening and/or saving of any individual file type it recognizes. The File Block Settings category in the Trust Center dialog box, shown in Figure 4-6, includes a list of file types that Excel recognizes, each with check boxes allowing you to block its opening or saving. Use the options below the list to select the way you’d like Excel to handle the opening of selected file types. You can block a file type by clicking Do Not Open Selected File Types or choose to open the file in Protected View, either read-only or editable.
[image: You can choose not to allow normal opening and saving of specific file types.]

Figure 4-6. You can choose not to allow normal opening and saving of specific file types.

If you want to restore the default file-block settings, which include the blockage of several old Excel file formats, click the Restore Defaults button. Some of the listed formats do not include a check box to block saving, either because it doesn’t work (dBase III/IV), or because several older formats have been subsumed into one newer format (Excel 2 through Excel 4 into Excel 95).

Privacy Options



Excel 2010 includes more interactive features than ever. Excel uses the Internet behind the scenes to give you access to all the information you need at a moment’s notice. Many people want to know exactly when their computer is retrieving online information, so Microsoft lets you control these interactions by clicking the File tab, clicking Options, clicking Trust Center, and then clicking Trust Center Settings. In the Trust Center dialog box, click the Privacy Options category to display the dialog box shown in Figure 4-7.
[image: If you are uncomfortable with Excel connecting automatically to the Web, you can specify otherwise.]

Figure 4-7. If you are uncomfortable with Excel connecting automatically to the Web, you can specify otherwise.

The first set of options you see in Figure 4-7 control whether Excel can automatically communicate and share information over the Internet under various circumstances:
	Connect To Office.com For Updated Content When I’m Connected To The Internet You might prefer to take control of Web interactions yourself, for example, if you use a dial-up Internet connection. If you clear this check box, you can still connect to the online Help content from within the Help dialog box. This also controls whether Excel automatically displays Web-based templates in the New category on the File menu.

	Download A File Periodically That Helps Determine System Problems You need to decide whether to allow Microsoft to send diagnostic programs to your computer. If you worry about losing data to system crashes, you can select this check box to aid in any future system rehab and recovery efforts.

	Sign Up For The Customer Experience Improvement Program Over the years, Microsoft’s on-site usability lab has been instrumental in helping refine products based on how people actually work. The Customer Experience Improvement Program is similar, except that instead of conducting tests in a controlled environment on the Microsoft corporate campus, data is accumulated in a collective “lab” that potentially includes your office. The usage data collected by this program is much more useful than that generated in the artificial environment of a laboratory. This program began with Excel 2003 and has been partially responsible for the changes you see in Excel 2010. It’s kind of like installing a Nielsen ratings box on your television—yes, you’re sharing information with them, but maybe the TV shows will get better.

	Automatically Detect Installed Office Applications To Improve Office.com Search Results It’s hard to figure exactly how the applications you have installed might alter search results, but you can make a decision about it nonetheless.

	Check Microsoft Office Documents That Are From Or Link To Suspicious Web Sites This option turns on what Microsoft calls spoofed Web site detection. This refers to a homograph-type phishing scheme using Web domain names that closely resemble trusted sites. It’s often hard to tell the difference with the naked eye, so you can let Excel do it for you. (See the sidebar “Of Web Beacons and Homograph Attacks” on page 116.)

	Allow the Research Task Pane To Check For And Install New Services This option controls whether Excel automatically connects to the Web-based resources necessary for the operation of the tools made available by clicking the Research, Thesaurus, or Translate buttons on the Review tab.

	Allow Sending Files To Improve File Validation If a file fails the built-in file format validation process, you’re prompted to send file validation information to Microsoft if this option remains selected.



For all these privacy issues, Microsoft won’t collect any personal information and promises that participants remain completely anonymous. You might want to return to the Excel Options dialog box and read the linked information in the Trust Center category before deciding whether to select these check boxes.
Tip
INSIDE OUT Of File Format Attacks and File Validation
Another flavor of malicious exploit is the file format attack. New in Excel 2010, Office File Validation helps detect file format attacks, which attempt to insert remotely triggered code bits by modifying the structure of a file. Interestingly, there is a short list of binary file types that are favorites for these attacks, including Excel 97-2003 Workbooks and Templates and Excel 5.0/95 files. Office File Validation checks these and others on the most-wanted list against a predefined set of rules, or schema, that defines the structure of each file type. Validation fails if the file does not conform to the rules. You are prompted to send validation information to Microsoft if a file fails validation. Clear the Allow Sending Files To Improve File Validation option on the Privacy Options page of the Trust Center if you’d rather not share and would rather not see the prompt.




File Security



Legions of hackers are seemingly willing to go to any length to gain bragging rights by creating viruses, breaking firewalls, and thwarting password protection. Excel has always had security features, but Excel 2010 raises the ante a bit to help make your workbooks more secure.
Note
For more about workbook security, see Hiding and Protecting Workbooks on page 189.

Removing Personal Information from Your Workbooks



It’s increasingly important to be sure that you don’t leave helpful tidbits of information lying around for others to abuse. Although it’s up to you to check that you’re not giving away personal information on your worksheets (your password-protected worksheets, of course!), information also lives in places you might forget to look. Excel 2010 includes the Document Inspector, which is designed to look in all the nooks and crannies for you. Click the File tab, click Info, click Check For Issues, and then click Inspect Document to display the dialog box shown in Figure 4-8. (You can also access the Document Inspector by clicking the button of the same name located in the Privacy Options category in the Trust Center dialog box.)
[image: The Document Inspector examines the hidden places in your workbooks where personal data can hide.]

Figure 4-8. The Document Inspector examines the hidden places in your workbooks where personal data can hide.

As you can see in Figure 4-8, data is slippery stuff. The Document Inspector searches and reports on what it finds, as shown on the dialog box on the right of Figure 4-8. You can then click any Remove All button that appears or close the dialog box and edit the area in question. Most of these items are usually perfectly benign, of course. You probably don’t want to purge your headers and footers, for example, unless they contain your address or Social Security number. But if you are sharing data with others, the Document Inspector gives you a quick and easy way to find forgotten personal data you might not otherwise have found.

Using Digital Signatures



Digital signatures are similar to handwritten signatures in that both are intended to provide authenticity to documents. However, although the digital version might include a graphic representation of an actual signature, it also uses cryptography to establish not only a document’s authenticity but also the integrity of the file and the identity of the signer. You can add signatures to your own documents and to others’ as well. One way to use signatures is to verify that others have read a document (or at least opened it) by adding their signatures.
One important fact about digital signatures is that when you digitally sign a workbook, Excel saves it as a read-only document, preventing you from making further changes. Adding a handwritten signature, being typically the last element you add before sending a letter, in this case ensures that it actually is the last step you perform in a workbook. But don’t worry—you can remove and reapply a signature if you need to make changes.
To accomplish all this, you need a valid digital signature, which you must create or obtain separately. Fortunately, Excel provides ways to accomplish this. To begin, click the File tab, click Info, click Protect Workbook, and then click Add A Digital Signature to display the message shown in Figure 4-9.
[image: You can add digital signatures to your workbooks.]

Figure 4-9. You can add digital signatures to your workbooks.

If you don’t yet have your own digital signature, you can click Signature Services From The Office Marketplace to open a Web page where you can select and order one from a number of third-party vendors. Otherwise, clicking OK displays a dialog box where you can choose to use a third-party vendor or create your own digital signature.
Microsoft is careful to point out that creating your own digital signature lets you verify only the authenticity of your own documents, and even then only on your own computer. The upshot is that you might consider purchasing a verifiable signature if you think you need one. If, despite these drawbacks, you still want to create your own digital signature, select Create Your Own Digital ID.
After you create or purchase a digital ID, the dialog box at the top of Figure 4-10 appears when you click Add A Digital Signature. After you click OK, Excel saves the current workbook as read-only; your signature becomes invalid if you further modify the workbook.
[image: For what it’s worth, you can create your own digital signature.]

Figure 4-10. For what it’s worth, you can create your own digital signature.

If you click the Change button in the Sign dialog box shown in Figure 4-10, the second dialog box shown in the figure appears, where you can confirm your signature, or certificate. If you click a listed certificate, the Certificate Details dialog box appears, shown in Figure 4-11, which contains more information about the selected certificate and an Install Certificate button you can use to invoke the Certificate Import Wizard, also shown in the figure. This wizard helps you set up certificate stores on your computer, locations in your system where digital certificates are kept. The default settings are okay unless you have certificate locations on a network or prefer to specify places other than the suggested ones (not recommended).
After a document is digitally signed, [Read-Only] appears in the title bar next to the file name, and a small icon that looks like a certificate ribbon appears next to the word Ready in the status bar. You can click this icon to open and close the Signatures task pane, which you can also open and close by clicking the File tab, clicking Info, clicking Protect Workbook, and clicking View Signatures.
[image: The Certificate Details dialog box has all the information there is.]

Figure 4-11. The Certificate Details dialog box has all the information there is.



Other Security Features



Several security features in Excel are apropos to topics covered in depth elsewhere in this book:
	For more about worksheet security, see Protecting Worksheets on page 170.

	For more about workbook security, see Hiding and Protecting Workbooks on page 189.

	To learn about Information Rights Management, see Controlling Document Access with Information Rights Management on page 874.




Part 2. Building Worksheets




Chapter 5
Chapter 6
Chapter 7


Chapter 5. Planning Your Worksheet Design



Which Data Should Be in Rows, and Which in Columns?
Will You Need to Print the Worksheet?
Who Is the Audience?
Would Your Worksheet Survive Without You?
Does the Worksheet Rely on Imported Data?
Do You Need More Than One Worksheet?
Have You Allowed Room for New Data?
IN this chapter, we pose seven simple questions that might help you greatly when you plan a worksheet. Although it’s not necessary to spend time planning every worksheet you create, a little consideration can be helpful when planning worksheets you need to pass on or share with others.
Which Data Should Be in Rows, and Which in Columns?



Sometimes the answer is rather obvious, but generally speaking, you’ll want the data that is most abundant to fill rows rather than columns. Consider the readability of your data when you make this decision. For example, a month-oriented worksheet like the one shown in Figure 5-1 can work well with the month labels either across the top or down the left side of the worksheet. But in this case, having the month labels down the side makes it easier to view the worksheet on the screen and makes it easier to fit it on a printed page. The worksheet in Figure 5-1 contains only four columns of detail data, but if your worksheet has more categories of detail data than the number of months, you might want to run the months in columns instead.
Usually the detail you accumulate in a worksheet best fits into rows from top to bottom—relatively speaking, a deep and narrow worksheet. It is not unheard of to build a spreadsheet that is shallow and wide (only a few rows deep, with lots of columns), but you might regret it later. A shallow, wide worksheet can be annoying if you must continually pan to the right to find information or if you have to deal with odd column breaks when printing. If you have a wheel mouse, scrolling up and down is extremely easy to do using the wheel, but panning right and left requires clicking and dragging. And after you have the worksheet filled with data, it’s time-consuming to change it—especially when you could have designed it differently from the start.
You might also prefer the worksheet to be long rather than wide so you can use the Page Up and Page Down keys to navigate around the screen. When oriented horizontally, the worksheet shown in Figure 5-1 would still work, as shown in Figure 5-2, but you would have to scroll to the right to view all the data.
[image: Monthly total worksheets are often oriented vertically, as shown here.]

Figure 5-1. Monthly total worksheets are often oriented vertically, as shown here.

[image: Worksheets are often harder to view and print when oriented horizontally.]

Figure 5-2. Worksheets are often harder to view and print when oriented horizontally.

Note
You’ll find the Humongous2010.xlsm, Pacific Sales 2011.xlsm, Team Sales 2011.xlsx, and Alpacas.xlsm files with the other examples on the companion Web site.
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