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Introduction



OS X is an impressive technical achievement; many experts call it the best personal-computer operating system on earth. But beware its name.
The X is meant to be a Roman numeral, pronounced “ten.” Don’t say “oh ess ex.” You’ll get funny looks in public.
In any case, OS X Mountain Lion is the ninth major version of Apple’s Unix-based operating system. It’s got very little in common with the original Mac operating system, the one that saw Apple through the 1980s and 1990s. Apple dumped that in 2001, when CEO Steve Jobs decided it was time for a change. Apple had just spent too many years piling new features onto a software foundation originally poured in 1984. Programmers and customers complained of the “spaghetti code” the Mac OS had become.
On the other hand, underneath OS X’s classy, translucent desktop is Unix, the industrial-strength, rock-solid OS that drives many a Web site and university. It’s not new by any means; in fact, it’s decades old and has been polished by generations of programmers.
Note
Apple no longer refers to its computer operating system as Mac OS X. Now it’s just “OS X,” without the “Mac.” Why? Apple says it’s to match up better with iOS, its operating system for the iPhone and iPad.


The Mac Becomes an iPad



If you could choose only one word to describe Apple’s overarching design goal in Lion and Mountain Lion, there’s no doubt about what it would be: iPad. That’s right. In this software, Apple has gone about as far as it could go in trying to turn the Mac into an iPad.
Two things made the iPad the fastest-selling electronic gadget in history. First, it’s so simple. No overlapping windows; every app runs full screen. No Save command; everything is autosaved. No files or folders. No menus. All your apps are in one place, the Home screen. To beginners, technophobes, and even old-timers, the iPad’s software represents a refreshing decluttering of the modern computer.
The second huge iPad sales point is that multitouch screen. You operate the whole thing by touching or dragging your fingers on the glass. For example, you cycle through screens by swiping. You zoom out on a map, photo, or Web page by pinching two fingers. You rotate a photo by twisting two fingers, and so on.
So Apple thought, if simplicity and touch gestures made the iPad a megahit, why can’t we do the same for the Mac?
And it set out to bring as many of the iPad’s features and as much of its personality to your Mac as possible. Today’s OS X features like Full Screen mode, Auto Save, and Launchpad are total iPad rip-offs; if Apple hadn’t stolen these features from itself, it would surely be suing for copyright infringement. In Mountain Lion, even the app names are the same as what’s on iOS: Reminders, Notes, Notification Center, Game Center, and so on.
UP TO SPEED: What’s Missing
There are 200 new features in Mountain Lion, by Apple’s count. A lot of it is welcome new features. (Check out “what’s new in Mountain Lion” in this book’s index.)
But some of the changes aren’t additions; they’re subtractions. A few traditional features didn’t make the cut. Here’s a list of the most notable excisions.
Some disappeared back in Lion: Front Row, the feature that turned your Mac into a living-room multimedia player; faxing; iSync; and FTP services, no doubt because FTP is not a very secure protocol.
The Sidebar icons in the Finder are no longer in color; they’re all sort of washed out and monochrome, a trend in the Mac OS these days. And the tiny list-view icon of an open folder no longer looks like a tiny open folder.
Some changes are really tiny. The Digital Color Meter utility no longer converts hex colors and can no longer copy color data to the Clipboard. Image Capture has lost its ability to function as a remote-controlled Webcam or nannycam. iPhoto no longer has its own Time Machine mode for recovering lost photos. There’s no more To Do list in Mail. You can no longer zoom into a Quick Look preview.
In Mountain Lion, Web Sharing is gone. The ability to read RSS feeds in Mail and Safari is gone, too. All shreds of Notes and To Dos are gone from Mail (because you now get dedicated Notes and Reminders apps). Techies might mourn the loss of the X11 app and Xgrid support.
Lots of things have been renamed, too, so that they match the iPhone/iPad better: iCal, Address Book, and iChat are now Calendar, Contacts, and Messages.
Some of those losses might sting a little. But in the big Mountain Lion picture, you gain a lot more than you lose.

Apple even brought over the whole multitouch thing to the Mac. No, you don’t touch the screen; you’d get screaming arm pain if you had to spend the day with your arm outstretched, manipulating tiny controls on a vertical surface three feet away. (The resulting ache actually has a name in the computer biz: gorilla arm.)
Instead, you use all those same iPad gestures and more, right on the surface of your laptop trackpad or (if you have Apple’s Magic Mouse) the top surface of the mouse.
All of Mountain Lion’s big-ticket features are intended to work together. For example, suppose you’re looking at a document in full-screen view (feature #1). How are you supposed to switch to the next app? By swiping across the trackpad in the “next app” gesture (feature #2). Then you might pinch four fingers together (feature #3) to open Launchpad so you can open another program.
It’s a new way to work, for sure. And it’s optional. If it doesn’t float your boat, you can ignore all of it (full-screen, gestures, Launchpad, Auto Save). But you should at least make an informed decision—and this book, especially Chapter 0, should come in handy that way.
Note
Truth is, Mountain Lion represents only a gentle continuation of the iPadization that began with OS X 10.7, known as Lion. Often in this book, you’ll read references to “Lion/Mountain Lion,” because they’re fundamentally the same software. Even so, there are enough nips, tucks, and improvements to justify the 20 bucks you just shelled out.


About This Book



You can’t get Mountain Lion on a disc or flash drive; it’s a download-only operating system. In other words, you don’t get a single page of printed instructions.
To find your way around, you’re expected to use Apple’s online help system. And as you’ll quickly discover, these help pages are tersely written, offer very little technical depth, lack useful examples, and provide no tutorials whatsoever. You can’t even mark your place, underline, or read them in the bathroom.
The purpose of this book, then, is to serve as the manual that should have accompanied OS X—version 10.8 in particular.
OS X Mountain Lion: The Missing Manual is designed to accommodate readers at every technical level. The primary discussions are written for advanced-beginner or intermediate Mac fans. But if you’re a Mac first-timer, miniature sidebar articles called Up To Speed provide the introductory information you need to understand the topic at hand. If you’re a Mac veteran, on the other hand, keep your eye out for similar shaded boxes called Power Users’ Clinic. They offer more technical tips, tricks, and shortcuts.
When you write a book like this, you do a lot of soul-searching about how much stuff to cover. Of course, a thinner book, or at least a thinner-looking one, is always preferable; plenty of readers are intimidated by a book that dwarfs the Tokyo White Pages.
On the other hand, Apple keeps adding features and rarely takes them away. So this book isn’t getting any thinner.
Even so, some chapters come with free downloadable appendixes—PDF documents, available on this book’s “Missing CD” page at www.missingmanuals.com—that go into further detail on some of the tweakiest features. (You’ll see references to them sprinkled throughout the book.)
Maybe this idea will save a few trees—and a few back muscles when you try to pick this book up.
About the Outline



OS X Mountain Lion: The Missing Manual is divided into six parts, each containing several chapters:
	Part One covers everything you see on the screen when you turn on an OS X computer: the Dock, the Sidebar, Spotlight, Dashboard, Spaces, Mission Control, Launchpad, Time Machine, icons, windows, menus, scroll bars, the Trash, aliases, the [image: ] menu, and so on.

	Part Two is dedicated to the proposition that an operating system is little more than a launchpad for programs—the actual applications you use in your everyday work, such as email programs, Web browsers, word processors, graphics suites, and so on. These chapters describe how to work with applications in OS X—how to open them, switch among them, swap data between them, use them to create and open files, and control them using the AppleScript and Automator automation tools.

	Part Three is an item-by-item discussion of the individual software nuggets that make up this operating system—the 29 panels of System Preferences, and the 50-some programs in your Applications and Utilities folders.

	Part Four treads in more advanced territory. Networking, file sharing, and screen sharing are, of course, tasks OS X was born to do. These chapters cover all of the above, plus the prodigious visual talents of OS X (fonts, printing, graphics, handwriting recognition), and its multimedia gifts (sound, speech, movies).

	Part Five covers all the Internet features of OS X, including the Mail email program and the Safari Web browser; Messages for instant messaging and audio or video chats; Internet sharing; Apple’s free, online iCloud services; and connecting to, and controlling, your Mac from across the wires—FTP, SSH, VPN, and so on.

	Part Six. This book’s appendixes include guidance on installing this operating system; a troubleshooting handbook; a Windows-to-Mac dictionary (to help Windows refugees find the new locations of familiar features in OS X); and a thorough master list of all the keyboard shortcuts and trackpad/mouse gestures in Mountain Lion.




About→These→Arrows



Throughout this book, and throughout the Missing Manual series, you’ll find sentences like this one: “Open the System folder→Libraries→Fonts folder.” That’s shorthand for a much longer instruction that directs you to open three nested folders in sequence, like this: “On your hard drive, you’ll find a folder called System. Open that. Inside the System folder window is a folder called Libraries; double-click to open it. Inside that folder is yet another one called Fonts. Double-click to open it, too.”
Similarly, this kind of arrow shorthand helps to simplify the business of choosing commands in menus, such as [image: ]→Dock→Position on Left.

About MissingManuals.com



To get the most out of this book, visit www.missingmanuals.com. Click the “Missing CD-ROM” link—and then this book’s title—to reveal a neat, organized, chapter-by-chapter list of the shareware and freeware mentioned in this book.
The Web site also offers corrections and updates to the book. (To see them, click the book’s title, and then click View/Submit Errata.) In fact, please submit such corrections and updates yourself! In an effort to keep the book as up to date and accurate as possible, each time O’Reilly prints more copies of this book, I’ll make any confirmed corrections you’ve suggested. I’ll also note such changes on the Web site so that you can mark important corrections into your own copy of the book, if you like. And I’ll keep the book current as Apple releases more Mac OS 10.8 updates.


The Very Basics



To use this book, and indeed to use a Macintosh computer, you need to know a few basics. This book assumes you’re familiar with a few terms and concepts:
	Clicking. To click means to point the arrow cursor at something on the screen and then—without moving the cursor—press and release the clicker button on the mouse or trackpad. To double-click, of course, means to click twice in rapid succession, again without moving the cursor at all. And to drag means to move the cursor while holding down the button.
When you’re told to ⌘-click something, you click while pressing the ⌘ key (which is next to the space bar). Shift-clicking, Option-clicking, and Control-clicking work the same way—just click while pressing the corresponding key.
(There’s also right-clicking. That important topic is described in depth on The Complicated Story of the Function Keys.)

	Menus. The menus are the words at the top of your screen: [image: ], File, Edit, and so on. Click one to make a list of commands appear.
Some people click and release to open a menu and then, after reading the choices, click again on the one they want. Other people like to press the mouse button continuously after the initial click on the menu title, drag down the list to the desired command, and only then release the mouse button. Either method works fine.

	Keyboard shortcuts. If you’re typing along in a burst of creative energy, it’s disruptive to have to grab the mouse to use a menu. That’s why many Mac fans prefer to trigger menu commands by pressing key combinations. For example, in word processors, you can press ⌘-B to produce a boldface word. When you read an instruction like “press ⌘-B,” start by pressing the ⌘ key, and then, while it’s down, type the letter B, and finally release both keys.
Tip
You know what’s really nice? The keystroke to open the Preferences dialog box in every Apple program—Mail, Safari, iMovie, iPhoto, TextEdit, Preview, and on and on—is always the same: ⌘-comma. Better yet, that standard is catching on in other apps, too, like Word, Excel, and PowerPoint.


	Gestures. A gesture is a swipe across your trackpad (on your laptop, or on an external Apple trackpad) or across the top surface of the Apple Magic Mouse. Gestures have been given huge importance in Lion. Appendix E contains a handy chart of all Lion gestures, or you can get a tutorial of life with gestures in Chapter 0.

	Icons. The colorful inch-tall pictures that appear in your various desktop folders are the graphic symbols that represent each program, disk, and document on your computer. If you click an icon one time, it darkens, indicating that you’ve just highlighted or selected it. Now you’re ready to manipulate it by using, for example, a menu command.

	Dialog boxes. See Figure 1 for a tour of the onscreen elements you’ll frequently be asked to use, like checkboxes, radio buttons, tabs, and so on.



A few more tips on mastering the Mac keyboard appear at the beginning of Chapter 6. Otherwise, if you’ve mastered this much information, you have all the technical background you need to enjoy OS X Mountain Lion: The Missing Manual.
[image: Knowing what you’re doing on the Mac often requires knowing what things are called. Here are some of the most common onscreen elements. They include checkboxes (turn on as many as you like) and radio buttons (only one can be turned on in each grouping).Pressing Return is usually the same as clicking the default button—the lower-right button that almost always means “OK, I’m done here.”]

Figure 1. Knowing what you’re doing on the Mac often requires knowing what things are called. Here are some of the most common onscreen elements. They include checkboxes (turn on as many as you like) and radio buttons (only one can be turned on in each grouping). Pressing Return is usually the same as clicking the default button—the lower-right button that almost always means “OK, I’m done here.”


Part One. The OS X Desktop




Chapter 0
Chapter 1
Chapter 2
Chapter 3
Chapter 4


Chapter 0. The Mountain Lion Landscape



As noted in the Introduction, Apple’s overarching design philosophy in creating its operating system lately has been “Make it more like an iPad.” But what does that mean? Do all the new iPaddish features really add up to a single, flowing, new way of working?
The following pages are a tutorial. They walk you through a typical Mountain-ized working session the way Apple intended you to work. If you follow along, you’ll wind up with a good sense of how much you like (or don’t like) the iPaddified Mac.
Note
In this book, you’ll see touch gestures provided separately for trackpads (either the one on your laptop, or Apple’s external Magic Trackpad) and the Magic Mouse (Apple’s latest mouse, whose surface is touch sensitive).
Why aren’t the gestures identical? Because the Magic Mouse requires at least two fingers to hold, so some of the more multi-fingered gestures aren’t practical. And remember, on the trackpad you need a finger just to move the cursor—and on the Magic Mouse, moving the mouse moves the cursor.


Launchpad



All right. It’s Monday morning. Yawn, stretch, fluff your hair (if any).
You want to start with a quick Web check. And for that, you’ll need Safari, the Mac’s Web browser.
	Put four fingers on the trackpad (thumb and three fingers), and pinch them inward toward the center.
If you have a Magic Mouse, just click Launchpad on the Dock.
Your screen goes dark and fills up with what looks like the Home screen on the iPhone or iPad. You’ve just opened the Launchpad. Here are the icons of all your Mac’s programs, evenly spaced, arrayed (if there are lots of them) on multiple “pages.” Figure 0-1 shows the idea.
Note
The four-finger pinch gesture opens Launchpad only on trackpads. If you don’t have one, click the Launchpad icon on the Dock instead. It looks like a rocket ship ([image: ]).

[image: Launchpad displays all of your programs’ icons at once, neatly spaced and ready to open with a single click. To see more pages full of icons, swipe left or right with two fingers on your trackpad (or with one finger on your Magic Mouse).New in Mountain Lion: The search bar at top.]

Figure 0-1. Launchpad displays all of your programs’ icons at once, neatly spaced and ready to open with a single click. To see more pages full of icons, swipe left or right with two fingers on your trackpad (or with one finger on your Magic Mouse). New in Mountain Lion: The search bar at top.

Suppose, for the sake of this exercise, that you can’t find the Safari icon. It’s on a different page.

	With two fingers on the trackpad, swipe left or right to change “pages.” Stop when you spot Safari.
If you have a Magic Mouse, swipe left or right with one finger.
Tip
This same gesture—swiping left or right—also works as Back or Forward in Safari.

You could, if you like, customize Launchpad just as you would on an iPhone or an iPad. You can drag the icons around, put them on different pages, combine them into folders, or delete them (see Launchpadxx). For now, you just want to open the Web browser.

	Click the Safari icon once.
That’s one difference between opening a program in Launchpad (one click) and in your Applications folder (two clicks).




Full-Screen Mode, Safari



Once Safari opens, you’re ready for your first full-screen experience.
	Click the [image: ] icon in the upper-right corner of the Safari window.
With a smooth animation, your Mac hides the menu bar and the bookmarks bar. The only thing remaining is the address bar. The window’s edges expand all the way to the edges of the screen (Figure 0-2).
Tip
You may as well learn the keyboard shortcut to enter full-screen mode: Control-⌘-F. The same keystroke leaves full-screen mode, but you can also tap the Esc key for that purpose.

[image: This, ladies and gentlemen, is full-screen mode, one of the flagship features of Mountain Lion. The idea is to fight back against the forces of window clutter that have been encroaching on your document windows for years now. Your actual work, your photo or Web page, fills every pixel of that giant screen you paid so much money for.]

Figure 0-2. This, ladies and gentlemen, is full-screen mode, one of the flagship features of Mountain Lion. The idea is to fight back against the forces of window clutter that have been encroaching on your document windows for years now. Your actual work, your photo or Web page, fills every pixel of that giant screen you paid so much money for.

You don’t have to panic, though. The menu bar is still available: Move the pointer to the top of the screen to make the menus reappear.
Tip
Wouldn’t it be nice if there were a keyboard shortcut for bringing the menu bar back—if nothing else, so that you can check your battery level and the time of day? There is—but not one that Apple intended. Just press ⌘-space bar. That’s the keystroke for Spotlight, the Mac’s master search bar—but it also makes the menu bar appear. Press the same keystroke to hide the menu bar again.

For the next demonstration, call up an actual Web page, preferably one with a lot of text on it—www.nytimes.com, for example. Now suppose you want to scroll down the page.

	With two fingers on the trackpad, drag upward.
If you have a Magic Mouse, drag up with one finger.
If you just tried this, you’re no doubt frowning right now. You just scrolled down the page by moving your fingers up. That’s backward, isn’t it?
For your entire computing career so far, you’ve always dragged the scroll bar down to move the contents of the page up—and now, in Lion/Mountain Lion, Apple has swapped the directions. Why would Apple throw such a monkey wrench into your life?
The main reason is (what else?) to make the Mac match the iPad/iPhone, where you drag your finger up to move the page up.
Anyway, you have two choices: You can spend a couple of days getting used to the new arrangement—or you can put things back the way they’ve always been. (To do that, open System Preferences. For a trackpad: Click Trackpad, click Scroll & Zoom, and then turn off “Scroll direction: natural.” For a Magic Mouse: Click Mouse, click Point & Click, and then turn off “Scroll direction: natural.”)
Note
If you have a non-Apple mouse that has a scroll wheel, then the Mouse preference pane doesn’t offer this scroll-direction option. You can still reverse the scroll-direction logic, though, if you’re handy in Terminal (Saving a report).
Just open Terminal and type defaults write ~/Library/Preferences/.GlobalPreferences com.apple.swipescrolldirection -bool false. When you press Return and log out, you’ll find that the time-honored scroll directions have been restored.


	Find a photo or a block of text. With two fingers, lightly double-tap the trackpad.
These are taps, not full clicks. On the Magic Mouse, double-tap with one finger.
Safari neatly magnifies the photo or text block to fill the screen, just as on an iPhone or an iPad. Neat, huh?

	Repeat the double-tap to restore the original size. Click a link to visit a different page.
For this demonstration, it doesn’t make any difference what other Web page you visit. The point is for you to see how cool it is when you swipe your trackpad instead of clicking the Back button.

	Go back to the first page by swiping leftward with two fingers on the trackpad.
On a Magic Mouse, use one finger.
The previous page slides back into view as though it’s a tile sliding back into place. You can swipe the other way, too—to the right—to go forward a page.




Full-Screen Apps, Mission Control



You’re still in Safari, right? And it’s still full screen, right?
But if Safari is full screen, how are you supposed to get to other open programs? That’s what you’ll find out in this exercise. You’ll get to see what it’s like to run multiple full-screen apps.
	Pinch your trackpad with your thumb and three fingers.
Launchpad appears, at your service. (As you may recall, this doesn’t work on the Magic Mouse, so if you’re trackpadless, you’ll have to exit full-screen mode and then click Launchpad on the Dock.)

	Find Calendar.
You may have to change Launchpad “pages” to find it. Swipe horizontally with two fingers (trackpad) or one finger (Magic Mouse) to change pages.

	Click to open Calendar. Make the new window full screen by clicking the [image: ] in the upper-right corner.
In theory, you now have two apps running at full screen: Safari and Calendar. Now comes the fun part.

	With three fingers on the trackpad, swipe left or right.
(On the Magic Mouse, use two fingers.)
The full-screen apps slide into or out of view. If you keep three-finger swiping to the right, you’ll see that Dashboard is all the way at the left end of the “channels” that you’re changing. (If it doesn’t work, somebody might have changed the setting to require four fingers in System Preferences.)
You’ll also discover that any other programs—the ones that aren’t full screen—are gathered onto a single screen, as they have been for years. Each full-screen app is one “screen,” and the Finder and all your other apps huddle on another one. But it doesn’t have to be that way.

	With three fingers on the trackpad, swipe upward.
If you have a Magic Mouse, double-tap (don’t fully click) with two fingers.
You now enter Mission Control, a special screen full of miniatures of all your other screens; see Figure 0-3. (Again, if three fingers doesn’t work, someone might have changed your trackpad preferences to require four fingers.)
Mission Control has all kinds of cool features. It lets you jump to one window in a haystack. It lets you set up multiple virtual screens. It lets you reorganize the full-screen app screens you already have. For the full rundown, jump to page xx173.



In this miniature crash course, you’ve had a glimpse at the future that awaits you: a future of trackpad (or Magic Mouse) finger gestures, full-screen apps, and the new centralized organizing features like Launchpad and Mission Control.
If any of this seems intimidating (or unnecessary), here’s the point to remember: It’s all optional. If you think the Mac works just fine without them, you can ignore the new features and forget about them completely; all the techniques you already know still work just fine.
But if you think you could get efficiency and pleasure out of adopting a couple of these features, then Mountain Lion is ready for you. Full speed ahead!
[image: Here in Mission Control, each full-screen app gets its own “screen,” as indicated by the map at top. But every running program appears here in the main screen area, in miniature. You can click one to jump there, or point and then press the space bar to get a full-size Quick Look.]

Figure 0-3. Here in Mission Control, each full-screen app gets its own “screen,” as indicated by the map at top. But every running program appears here in the main screen area, in miniature. You can click one to jump there, or point and then press the space bar to get a full-size Quick Look.


Chapter 1. Folders & Windows




Getting into OS X



When you first turn on a Mac running OS X 10.8, an Apple logo greets you, soon followed by an animated, rotating “Please wait” gear cursor—and then you’re in. No progress bar, no red tape.
Logging In



What happens next depends on whether you’re the Mac’s sole proprietor or have to share it with other people in an office, school, or household.
	If it’s your own Mac, and you’ve already been through the setup process described in Appendix A, no big deal. You arrive at the OS X desktop.

	If it’s a shared Mac, you may encounter the newly redesigned login screen, shown in Figure 1-1. It’s like a portrait gallery, set against a handsome piece of dark gray linen. Click your icon.
If the Mac asks for your password, type it and then click Log In (or press Return). You arrive at the desktop.



Note
The very first time you run Mountain Lion, you get a huge Scrolling in Mountain Lion warning window. Apple wants to draw your attention to the new drag-up-to-scroll-up behavior of a fresh Mountain Lion installation, which freaks out a lot of baffled customers. For details on this whole reversed-scrolling business (and how to turn it off), see Full-Screen Apps, Mission Control.

Chapter 13 offers much more on this business of user accounts and logging in.
Note
In certain especially paranoid workplaces, you may not see the rogue’s gallery shown in Figure 1-1. You may just get two text boxes, where you’re supposed to type in your name and password. Without even the icons of known account holders, an evil hacker’s job is that much more difficult.

[image: On Macs used by multiple people, this is one of the first things you see upon turning on the computer. Click your name. (If the list is long, you may have to swipe the trackpad to find your name—or just type its first few letters.)Inset: At this point, you’re asked to type in your password. Type it, and then click Log In (or press Return). If you type the wrong password, the box vibrates, in effect shaking its little dialog-box head, suggesting that you guess again.]

Figure 1-1. On Macs used by multiple people, this is one of the first things you see upon turning on the computer. Click your name. (If the list is long, you may have to swipe the trackpad to find your name—or just type its first few letters.) Inset: At this point, you’re asked to type in your password. Type it, and then click Log In (or press Return). If you type the wrong password, the box vibrates, in effect shaking its little dialog-box head, suggesting that you guess again.


The Elements of the OS X Desktop



The desktop is the shimmering, three-dimensional OS X landscape shown in Figure 1-2. On a new Mac, it’s covered by a photo of a spectacular spiral galaxy; if you lean forward and squint, you might just be able to make out Apple’s headquarters. (If you upgraded from an earlier version of OS X, you keep whatever desktop picture you had before.)
If you’ve ever used a computer before, most of the objects on your screen are nothing more than updated versions of familiar elements. Here’s a quick tour.
Note
If your desktop looks even emptier than this—no menus, no icons, almost nothing on the Dock—then somebody in charge of your Mac has turned on Simple Finder mode for you. Details on Use Simple Finder.

The dock



This row of translucent, almost photographic icons is a launcher for the programs, files, folders, and disks you use often—and an indicator to let you know which programs are already open. They appear to rest on a sheet of transparent smoked glass.
In principle, the Dock is very simple:
	Programs go on the left side. Everything else goes on the right, including documents, folders, and disks. (Figure 1-2 shows the dividing line.)

	You can add a new icon to the Dock by dragging it there. Rearrange Dock icons by dragging them. Remove a Dock icon by dragging it away from the Dock—and enjoy the animated puff of smoke that appears when you release the mouse button. (You can’t, however, remove the icon of a program that’s currently open.)
[image: The OS X landscape looks like a more futuristic version of the operating systems you know and love. This is just a starting point, however. You can dress it up with a different background picture, adjust your windows in a million ways, and, of course, fill the Dock with only the programs, disks, folders, and files you need.]

Figure 1-2. The OS X landscape looks like a more futuristic version of the operating systems you know and love. This is just a starting point, however. You can dress it up with a different background picture, adjust your windows in a million ways, and, of course, fill the Dock with only the programs, disks, folders, and files you need.


	Click something once to open it. When you click a program’s icon, a tiny, bright, micro-spotlight dot appears under it to let you know it’s open.
When you click a folder’s icon, you get a stack—an arcing row of icons, or a grid of them, that indicates what’s inside. See Pop-up Dock Folders (“Stacks”) for more on stacks.

	Each Dock icon sprouts a pop-up menu. To see the menu, hold the mouse button down on a Dock icon—or Control-click it, or right-click it. A shortcut menu of useful commands pops right out.

	If you have a trackpad, you can view miniatures of all open windows in a program by pointing to its Dock icon and then swiping down with three fingers. Details on how to turn on this feature are on One-App Exposé.



Because the Dock is such a critical component of OS X, Apple has decked it out with enough customization controls to keep you busy experimenting for months. You can change its size, move it to the sides of your screen, hide it entirely, and so on. Chapter 4 contains complete instructions for using and understanding the Dock.

The [image: ] menu



The [image: ] menu houses important Mac-wide commands like Sleep, Restart, and Shut Down. They’re always available, no matter which program you’re using.

The menu bar



Every popular operating system saves space by concealing its most important commands in menus that drop down. OS X’s menus are especially refined:
	They stay down. OS X menus stay open until you click the mouse, trigger a command from the keyboard, or buy a new computer, whichever comes first.
Tip
Actually, menus are even smarter than that. If you give the menu name a quick click, the menu opens and stays open. If you click the menu name and hold the mouse button down for a moment, the menu opens but closes again when you release the button. Apple figures that, in that case, you’re just exploring, reading, or hunting for a certain command.


	They’re logically arranged. The first menu in every program, which appears in bold lettering, tells you at a glance what program you’re in (Safari, Microsoft Word, whatever). The commands in this Application menu include About (which indicates what version of the program you’re using), Preferences, Quit, and commands like Hide Others and Show All (which help control window clutter, as described on Hiding All Other Programs).
In short, all the Application menu’s commands actually pertain to the application you’re using.
The File and Edit menus come next. The File menu contains commands for opening, saving, and closing files. (See the logic?) The Edit menu contains the Cut, Copy, and Paste commands.
The last menu is almost always Help. It opens a miniature Web browser that lets you search the online Mac help files for explanatory text.

	You can operate them from the keyboard. Once you’ve clicked open a menu, you can highlight any command in it just by typing the first letter (g for Get Info, for example). (It’s especially great for “Your country” pop-up menus on Web sites, where “United States” is about 200 countries down in the list. You can type united s to jump right to it.)
You can also press Tab to open the next menu, Shift-Tab to open the previous one, and Return or Enter to “click” the highlighted command.



Note
The menu bar is partly see-through, for no apparent reason. You can turn that off if you want; open System Preferences→Desktop & Screen Saver→Desktop, and then turn off “Translucent menu bar.”


Disk icons on the desktop



For years, Apple has encouraged its flock to keep a clean desktop, to get rid of all the icons that many of us leave strewn around. Especially the hard drive icon, which had appeared in the upper-right corner of the screen since the original 1984 Mac.
Today, the Macintosh HD icon doesn’t appear on the screen. “Look,” Apple seems to be saying, “if you want access to your files and folders, just open them directly—from the Dock or from your Home folder (Your Home Folder). Most of the stuff on the hard drive is system files of no interest to you, so let’s just hide that icon, shall we?”
Note
If you’d prefer that the disk icons return to your desktop where they used to be, Mountain Lion can accommodate you. Choose Finder→Preferences, click General, and turn on the checkboxes of the disks whose icons you want on the desktop: hard disks, external disks, CDs, and so on.




Windows and How to Work Them



In designing OS X, one of Apple’s key goals was to address the window-proliferation problem. As you create more files, stash them in more folders, and launch more programs, it’s easy to wind up paralyzed before a screen awash with overlapping rectangles.
That’s the problem admirably addressed by Mission Control, described in detail on Mission Control: Death to Window Clutter. Some handy clutter and navigation controls are built into the windows themselves, too. For example:
The Sidebar



The Sidebar (Figure 1-3) is the pane at the left side of every Finder window, unless you’ve hidden it. (It’s also at the left side of every Open dialog box and every full-sized Save dialog box.)
The Sidebar has as many as three sections, each preceded by a collapsible heading.
Note
The little flippy triangles that could collapse (hide) each Sidebar heading are gone. Instead, if you point to a heading without clicking, a tiny Hide or Show button appears. Click it to collapse or expand that heading’s contents.

Here are the headings you’ll soon know and love. (New in Mountain Lion: You can drag these headings up and down in the Sidebar to rearrange them.)
	Favorites. This primary section of the Sidebar is the place to stash things for easy access. You can stock this list with the icons of disks, files, programs, folders, and the virtual, self-updating folders called saved searches.
Each icon is a shortcut. For example, click the Applications icon to view the contents of your Applications folder in the main part of the window. And if you click the icon of a file or a program, it opens.
Here, too, you’ll find the icons for two recent Mac features: All My Files (see the box on the facing page) and AirDrop, the instant-file-sharing feature described on AirDrop.
[image: The Sidebar makes navigation very quick, because you can jump back and forth between distant corners of your Mac with a single click. In column view, the Sidebar is especially handy because it eliminates all the columns to the left of the one you want, all the way back to your hard-drive level. You’ve just folded up your desktop! Good things to put here: favorite programs, disks on a network you often connect to, a document you’re working on every day, and so on. Folder and disk icons here work just like normal ones. You can drag a document onto a folder icon to file it there, drag a document onto a program’s icon to open it with the “wrong” program, and so on.]

Figure 1-3. The Sidebar makes navigation very quick, because you can jump back and forth between distant corners of your Mac with a single click. In column view, the Sidebar is especially handy because it eliminates all the columns to the left of the one you want, all the way back to your hard-drive level. You’ve just folded up your desktop! Good things to put here: favorite programs, disks on a network you often connect to, a document you’re working on every day, and so on. Folder and disk icons here work just like normal ones. You can drag a document onto a folder icon to file it there, drag a document onto a program’s icon to open it with the “wrong” program, and so on.


	Shared. Here’s a complete list of the other computers on your network whose owners have turned on File Sharing, ready for access (see Chapter 14 for details). Back to My Mac (Variations on Screen Sharing) is also listed here.

	Devices. This section lists every storage device connected to, or installed inside, your Mac: hard drives, iPhones, iPads, iPods, CDs, DVDs, memory cards, USB flash drives, and so on. (Your main hard drive doesn’t usually appear here, but you can drag it here.) The removable ones (like CDs, DVDs, i-gadgets) bear a little gray [image: ] logo, which you can click to eject that disk.



Note
If you remove everything listed under one of these headings, the heading itself disappears to save space. The heading reappears the next time you put something in its category back into the Sidebar.

Fine-tuning the Sidebar



The beauty of this parking lot for containers is that it’s so easy to set up with your favorite places. For example:
	Remove an icon by ⌘-dragging it out of the Sidebar entirely. It vanishes with a puff of smoke (and even a little whoof sound effect). You haven’t actually removed anything from your Mac; you’ve just unhitched its alias from the Sidebar.
UP TO SPEED: All My Files
There it is, staring you in the face at the top of the Sidebar in every window: an icon called All My Files. What is this, some kind of geeked-out soap opera?
Nope. It’s a new Lion/Mountain Lion feature that Apple thought you might find handy: a massive, searchable, sortable list, all in a single window, of every human-useful file on the computer. That is, pictures, movies, music, documents—no system files, preference files, or other detritus. No matter what folders they’re actually in, they appear here in a single window. You can summon it whenever you want, just by clicking the All My Files icon in the Sidebar.
When you first open All My Files, it has your files grouped by type: Contacts, Events & To Dos, Images, PDF Documents, Music, Movies, Presentations, Spreadsheets, Developer (which lists HTML Web-site files and Xcode programming files), and Documents (meaning, “everything else”). In icon view—the factory setting—each class of icons appears in a single scrolling row. Use a two-finger scroll (trackpad) or one-finger slide (Magic Mouse) to move through the horizontal list. (If you’d rather not have to scroll, click the tiny Show All button that appears at the right end of each row. Now you’re seeing all of the icons of this type; click Show Less to return to the single-row effect.)
[image: image with no caption]

You can see how this sorting method—which is the new Arrange By command at work (Arrange By and Sort By)—might be useful. Suppose you’re looking for a certain PowerPoint or Keynote presentation, but you can’t remember what you called it or where you filed it. Open All My Files, make sure it’s arranged by Kind, and presto: You’re looking at a list of every presentation file on your Mac. Using Quick Look (Quick Look), you can breeze through them, inspecting them one at a time, until you find the one you want.
Apple thinks you’ll like All My Files as a starting point for standard file-fussing operations so much that All My Files is the window that appears automatically when you choose File→New Finder Window (or press ⌘-N). (Of course, you can change that in Finder→Preferences.)

Tip
You can’t drag items out of the Shared list. Also, if you drag a Devices item out of the list, you’ll have to choose Finder→Preferences→Sidebar and then turn on the appropriate checkbox to put it back in.
Note that the requirement to press the ⌘ key is relatively new. Evidently Apple tech support got one phone call too many from hapless customers who’d dragged stuff off of the Sidebar by accident.


	Rearrange the icons by dragging them up or down in the list. For example, in Mountain Lion, hard drives don’t appear at the top of the Sidebar anymore, but you’re free to drag them back into those coveted spots. (You’re not allowed to rearrange the computers listed in the Shared section, though.)

	Rearrange the sections by dragging them up or down—a new Mountain Lion feature. For example, you can drag Favorites to the bottom but promote the Shared category.

	Install a new icon by dragging it off your desktop (or out of a window) into any spot in the Favorites list of the Sidebar. Press the ⌘ key after beginning the drag. You can’t drag icons into any section of the Sidebar—just Favorites.
Tip
You can also highlight an icon wherever it happens to be and then choose File→Add to Sidebar, or just press ⌘-T.


	Adjust the width of the Sidebar by dragging its right edge—either the skinny divider line or the extreme right edge of the vertical scroll bar, if there is one. You “feel” a snap at the point when the line covers up about half of each icon’s name. Any covered-up names sprout ellipses (…) to let you know there’s more (as in “Secret Salaries Spreadsh…”).

	Hide the Sidebar by pressing ⌘-Option-S, which is the shortcut for the View→Hide Sidebar command. Bring the Sidebar back into view by pressing the same key combination (or by using the Show Sidebar command).
UP TO SPEED: Fixing the Sidebar
Anything you drag out of the Sidebar can be dragged back in again, including the big-ticket items like Applications and Pictures. That’s good to know if you drag something important out of the Sidebar and then change your mind.
Even so, there’s a quicker way to restore the Sidebar to its factory settings.
If you choose Finder→Preferences and then click the Sidebar button, you discover the checkboxes shown here. They let you put back the Apple-installed icons that you may have removed in haste. Just turn on a checkbox to restore its icon to your Sidebar. So if something you expect to see in your Sidebar isn’t there, check back here.
[image: image with no caption]

On the other hand, you may as well streamline your computing life by turning off the checkboxes of icons you never want to see filling your Sidebar.




Tip
You can hide and show the Sidebar manually, too: To hide it, drag its right edge all the way to the left edge of the window. Unhide it by dragging the left edge of the window to the right again.

Then again, why would you ever want to hide the Sidebar? It’s one of the handiest navigation aids since the invention of the steering wheel. For example:
	It takes a lot of pressure off the Dock. Instead of filling up your Dock with folder icons (all of which are frustratingly alike and unlabeled anyway), use the Sidebar to store them. You leave the Dock that much more room for programs and documents.

	It’s better than the Dock. In some ways, the Sidebar is a lot like the Dock, in that you can stash favorite icons of any sort there. But the Sidebar reveals the names of these icons, and the Dock doesn’t until you use the mouse to point there.

	It makes ejecting easy. Just click the [image: ] button next to any removable disk to make it pop out. (Other ways to eject disks are described in Chapter 12.)

	It makes burning easy. When you’ve inserted a blank CD or DVD and loaded it up with stuff you want to copy, click the [image: ] button next to its name to begin burning that disc. (Details on burning discs are in Chapter 12.)

	You can drag onto its folders and disks. That is, you can drag icons onto Sidebar icons, exactly as though they were the real disks, folders, and programs they represent.

	It simplifies connecting to networked disks. Park your other computers’ shared folder and disk icons here, as described in Chapter 14, to shave several steps off the usual connecting-via-network ritual.





Title Bar



The title bar (Figure 1-4) has several functions. First, when several windows are open, the darkened title bar, window name, mini-icon, and colored left-corner buttons tell you which window is active (in front); in background windows, these elements appear dimmed and colorless. Second, the title bar acts as a handle that lets you move the window around on the screen.
You can also move a window by dragging the solid gray strip on the bottom, if there is one, like the Status bar that you can turn on in the Finder or the Safari Web browser.
Tip
Here’s a nifty keyboard shortcut: You can cycle through the different open windows in one program without using the mouse. Just press ⌘-~ (that is, the tilde key, to the left of the number 1 key on U.S. keyboards). With each press, you bring a different window forward within the current program. It works both in the Finder and in your everyday programs, and it beats the pants off using the mouse to choose a name from the Window menu. (Note the difference from ⌘-Tab, which cycles through different open programs.)

After you’ve opened one folder that’s inside another, the title bar’s secret folder hierarchy menu is an efficient way to backtrack—to return to the enclosing window. Get in the habit of right-clicking (or Control-clicking, or ⌘-clicking) the name of the window to access the menu shown in Figure 1-5. (You can release the Control or ⌘ key immediately after clicking.)
[image: When Steve Jobs unveiled Mac OS X at Macworld Expo in 2000, he said his goal was to oversee the creation of an interface so attractive, “you just want to lick it.” Desktop windows, with their juicy, fruit-flavored controls, are a good starting point.]

Figure 1-4. When Steve Jobs unveiled Mac OS X at Macworld Expo in 2000, he said his goal was to oversee the creation of an interface so attractive, “you just want to lick it.” Desktop windows, with their juicy, fruit-flavored controls, are a good starting point.

By choosing the name of a folder from this menu, you open the corresponding window. When browsing the contents of the Users folder, for example, you can return to the main hard drive window by Control-clicking the folder name Users and then choosing Macintosh HD from the menu.
Tip
Keyboard lovers, take note. Instead of using the title bar menu, you can also jump to the enclosing window by pressing ⌘-↑ (up arrow), which is the shortcut for the Go→Enclosing Folder command.
Pressing ⌘-↓ (down arrow) takes you back into the folder you started in, assuming that it’s still highlighted. (This makes more sense when you try it than when you read it.)

Once you’ve mastered dragging, you’re ready for these terrific title bar tips:
	Pressing the ⌘ key lets you drag the title bar of an inactive window—one that’s partly covered by a window in front—without bringing it to the front. (Drag any empty part of the title bar—not the title itself.)
By the way, you can close, minimize, or zoom a background window without the help of the ⌘ key. Just click one of those three corresponding title-bar buttons normally, even if the window you’re working on is in front.
[image: Control-click (or right-click, or ⌘-click) a Finder window’s title bar to summon the hidden folder hierarchy menu. This trick also works in most other OS X programs. For example, you can ⌘-click a document window’s title to find out where the document is actually saved on your hard drive.]

Figure 1-5. Control-click (or right-click, or ⌘-click) a Finder window’s title bar to summon the hidden folder hierarchy menu. This trick also works in most other OS X programs. For example, you can ⌘-click a document window’s title to find out where the document is actually saved on your hard drive.


	By double-clicking the title bar, you minimize the window, making it collapse into the Dock exactly as though you had clicked the Minimize button (assuming you haven’t turned off this feature in System Preferences, of course).

	The Option key means, “Apply this action to all windows in the current program.” For example, Option-double-clicking any title bar minimizes all desktop windows, sending them flying to the Dock.

	Click the [image: ] button in the title bar, if you see one, to open a menu full of commands that let you rewind a document to a previous state. This is part of the new Auto Save feature, and it works only in certain programs; see Auto Save and Versions.




Close Button



As the tip of your cursor crosses the three buttons at the upper-left corner of a window, tiny symbols appear inside them: [image: ], [image: ], and [image: ]. Ignore the gossip that these symbols were added to help color-blind people who can’t distinguish the colors red, yellow, and green. Color-blind people are perfectly capable of distinguishing the buttons by their positions, just as they do with traffic lights.
But for people who aren’t paying attention to button position, these cues distinguish the buttons when all three are identical shades of gray, as they are when you use Graphite mode (Graphic Designers’ Corner: The Gray Look). They also signal when it’s time to click. For example, as described in the previous section, you can use these three buttons even when the window is not at the front. You know the buttons are ripe for the clicking when you see the little symbols appear under your cursor.
POWER USERS’ CLINIC: The Go to Folder Command
Sometimes a Unix tentacle pokes through the friendly OS X interface and you find a place where you can use Unix shortcuts instead of the mouse.
One classic example is the Go→Go to Folder command (Shift-⌘-G). It brings up a box like the one shown here.
The purpose of this box is to let you jump directly to a certain folder on your Mac by typing its Unix folder path. Depending on your point of view, this special box is either a shortcut or a detour.
For example, if you want to see what’s in the Documents folder of your Home folder, you could choose Go→Go to Folder and type this:
/Users/chris/Documents
Then click Go or press Return. (In this example, of course, chris is your short account name.)
In other words, you’re telling the Mac to open the Users folder in your main hard drive window, then your Home folder inside that, and then the Documents folder inside that. Each slash means, “and then open.” (You can leave off the name of your hard drive; that’s implied by the opening slash.) When you press Return, the folder you specified pops open immediately.
Of course, if you really wanted to jump to your Documents folder, you’d be wasting your time by typing all that. Unix (and therefore OS X) offers a handy shortcut that means “home folder.” It’s the tilde character (~) at the upper-left corner of the U.S. keyboard.
To see what’s in your Home folder, then, you could type just that ~ symbol into the Go to Folder box and then press Return. Or you could add some slashes to it to specify a folder inside your Home folder, like this:
~/Documents
You can even jump to someone else’s Home folder by typing a name after the symbol, like this:
~chris
If you get into this sort of thing, here’s another shortcut worth noting: If you type nothing but a slash (/) and then press Return, you jump immediately to the main hard drive window.
Note, too, that you don’t have to type out the full path—only the part that drills down from the window you’re in. If your Home folder window is already open, for example, then you can open the Pictures folder just by typing Pictures.
[image: image with no caption]

But the Go to Folder trick really turns into a high-octane timesaver if you use autocompletion. Here’s how it works: After each slash, you can type only enough letters of a folder’s name to give OS X the idea—de instead of desktop, for example—and then wait a fraction of a second (or, if you’re late for a plane, press the Tab key). OS X instantly and automatically fills in the rest of the folder’s name. It even auto-capitalizes the folder names for you. (In Unix, capitalization matters.)
For example, instead of typing /Applications/Microsoft Office/clipart/standard, you could type nothing more than /ap/mi/cl/st, remembering to press Tab after each pair of letters. Now that’s a way to feel like a Unix programmer.

The most important window gadget is the Close button, the red, droplet-like button in the upper-left corner (Figure 1-4). Clicking it closes the window, which collapses back into the icon from which it came.
Tip
If, while working on a document, you see a tiny dot in the center of the Close button, OS X is trying to tell you that you haven’t yet saved your work. (It doesn’t appear in Autosave programs like TextEdit.) The dot goes away when you save the document.

The universal keyboard equivalent of the Close button is ⌘-W (for window)—a keystroke well worth memorizing. If you get into the habit of dismissing windows with that deft flick of your left hand, you’ll find it far easier to close several windows in a row, because you won’t have to aim for successive Close buttons.
In many programs, something special happens if you’re pressing the Option key when using the Close button or its ⌘-W equivalent: You close all open windows. This trick is especially useful in the Finder, where a quest for a particular document may have left your screen plastered with open windows for which you have no further use. Option-clicking the Close button of any one window (or pressing Option-⌘-W) closes all of them.
On the other hand, the Option-key trick doesn’t close all windows in every program—only those in the current program. Option-closing a Microsoft Word document closes all Word windows, but your Finder windows remain open.
Moreover, Option-closing doesn’t work in all programs.

Minimize Button



Click this yellow drop of gel to minimize any Mac window, sending it shrinking, with a genie-like animated effect, into the right end of the Dock, where it then appears as an icon. The window isn’t gone. It’s just out of your way for the moment, as though you’ve set it on a shelf. To bring it back, click the newly created Dock icon; see Figure 1-6. Chapter 4 has more on the Dock.
Minimizing is a great window-management tool. In the Finder, minimizing a window lets you see whatever icons were hiding behind it. In a Web browser, minimizing lets you hide a window that has to remain open (because you’re waiting for some task to finish) so you can read something else in the meantime.
And now, some Minimize button micro-goodies:
	If you enjoy the ability to roll up your windows in this way, remember that you actually have a bigger target than the tiny Minimize button. The entire title bar becomes a giant Minimize button when you double-click anywhere on it. (That’s an option in the General panel of System Preferences, described in Chapter 9.)
Better yet, you can also minimize the frontmost window of almost any program (including the Finder) from the keyboard by pressing ⌘-M. That’s a keystroke worth memorizing on Day One.
[image: Clicking the Minimize button sends a window scurrying down to the Dock, collapsing in on itself as though being forced through a tiny, invisible funnel. A little icon appears on the lower-right corner of its minimized image to identify the program it’s running in.]

Figure 1-6. Clicking the Minimize button sends a window scurrying down to the Dock, collapsing in on itself as though being forced through a tiny, invisible funnel. A little icon appears on the lower-right corner of its minimized image to identify the program it’s running in.


	Option-clicking one minimized window on the Dock un-minimizes all a program’s windows—at least for Cocoa programs (Documents Across Devices). But if it’s a Carbon program, like old versions of Word, then you have to click the windows one at a time on the Dock to bring them back.
Tip
OS X can change menu commands as you press modifier keys. For example, open a couple of Finder windows and then click the Window menu. Focus your eyes on the Minimize Window command. Now press Option and watch both the wording and the listed keyboard equivalent change instantly to Minimize All (Option-⌘-M).
The Option key works wonders on the File menu, too.


	In the bad old days (up to late 2009), minimizing a bunch of documents could get really messy. Each one flew onto the Dock, putting a new icon there, creating a tighter and tighter squeeze, shrinking the Dock’s icons until they were the size of Tic Tacs.
In Mountain Lion, you can have your document windows minimize themselves into their program’s Dock icon, rather than creating new Dock icons for themselves. That way, your Dock doesn’t get any more crowded, and the icons on it don’t keep shrinking away to atoms.
To turn on this feature, choose [image: ]→System Preferences→Dock. Turn on “Minimize windows into application icon.”
So how do you get those windows back out of the Dock icon? You use Dock Exposé, which is described on One-App Exposé.




Zoom Button



A click on this green geltab (see Figure 1-4) makes a desktop window just large enough to reveal all the icons inside it (or, in programs, large enough to reveal all the text, graphics, or music). If your monitor isn’t big enough to show all the icons in a window, then Zoom resizes the window to show as many as possible.
In either case, a second click on the Zoom button restores the window to its previous size. (The Window→Zoom command does the same thing.)

The Folder Proxy Icon



In the Finder, there’s a tiny icon next to the window’s name (Figure 1-7). It’s a stand-in—a proxy—for that window’s folder itself.
By dragging this tiny icon, you can move or copy the folder into a different folder or disk, into the Sidebar, into the Trash, or into the Dock without having to first close the window.
POWER USERS’ CLINIC: Adjusting the Genie Speed
Apple has a name for the animation you see when you minimize, open, or close a window: the genie effect, because it so closely resembles the way Barbara Eden, Robin Williams, and other TV and movie genies entered and exited their magic lamps and bottles.
But you don’t have to watch the “genie” animation in precisely the same way, day in and day out. You can slow it down or speed it up, like this:
Slow it down. When Steve Jobs first demoed Mac OS X, one of his favorite bits was slowing down the animation so we could see it in graceful slow motion. How did he do that?
If you Shift-click a window’s Minimize button, it collapses into the Dock at about one-tenth its usual speed—an effect sure to produce gasps from onlookers. The Shift key also slows the un-minimizing animation, the one you see when you click a window icon in the Dock to restore it to full size. (Shift-clicking a button to slow down its animation is a running theme in OS X. You’ll find it mentioned in several spots in this book.)
Speed it up. There’s no keystroke for making the animation go faster. You can, however, substitute a faster style of minimizing animation.
To do so, choose [image: ]→Dock→Dock Preferences. From the “Minimize windows using” pop-up menu, choose Scale Effect, and then close the window. Now, instead of collapsing through an invisible funnel, minimized windows simply shrink as they fly down to the Dock, remaining rectangular. The time you save isn’t exactly going to get you home an hour earlier each day, but at least you have the illusion of greater speed.
(Actually, there’s a third animation style, too, but there’s a trick to unleashing it: You need the free utility called TinkerTool. It’s available from this book’s “Missing CD” page at www.missingmanuals.com.)

Tip
You have to hold down the mouse button on the folder proxy icon until the icon darkens before dragging. (It darkens in a fraction of a second.)

[image: When you find yourself confronting a Finder window that contains useful stuff, consider dragging its proxy icon to the Dock. That will install its folder or disk icon there for future use. It’s not the same as minimizing the window, which puts the window icon into the Dock only temporarily. (Note: Most document windows also offer a proxy-icon feature, but it usually produces only an alias when you drag the proxy to a different folder or disk.)]

Figure 1-7. When you find yourself confronting a Finder window that contains useful stuff, consider dragging its proxy icon to the Dock. That will install its folder or disk icon there for future use. It’s not the same as minimizing the window, which puts the window icon into the Dock only temporarily. (Note: Most document windows also offer a proxy-icon feature, but it usually produces only an alias when you drag the proxy to a different folder or disk.)

When you drag this proxy icon to a different place on the same disk, the usual folder-dragging rules apply: Hold down the Option key if you want to copy the original disk or folder; ignore the Option key to move the original folder. (You’ll find details on moving and copying icons in the next chapter.)
Many programs, including Microsoft Word, Preview, TextEdit, and others, offer the same mini-icon in open document windows. Once again, you can use it as a handle to drag a document into a new folder or onto a new disk. Sometimes, doing that really does move the document—but more often, you just get an alias of it in the new location.

The Finder Toolbar



Chapter 4 describes this fascinating desktop-window element in great detail.

Two Clicks, One Window



Double-clicking a folder in a window doesn’t leave you with two open windows. Instead, double-clicking a folder makes the contents of the original window disappear (Figure 1-8).
Tip
If you Option-double-click a folder, you don’t simply replace the contents of a fixed window that remains onscreen; you actually switch windows, as evidenced by their changing sizes and shapes.

[image: To help you avoid window clutter, Apple has designed OS X windows so that double-clicking a folder in a window (top) doesn’t actually open another window (bottom). Every time you double-click a folder in an open window (except in column view), its contents replace whatever was previously in the window. If you double-click three folders in succession, you still wind up with just one open window.]

Figure 1-8. To help you avoid window clutter, Apple has designed OS X windows so that double-clicking a folder in a window (top) doesn’t actually open another window (bottom). Every time you double-click a folder in an open window (except in column view), its contents replace whatever was previously in the window. If you double-click three folders in succession, you still wind up with just one open window.

So what if you’ve now opened inner folder B, and you want to backtrack to outer folder A? In that case, just click the tiny [image: ] button—the Back button—in the upper-left corner of the window, or use one of these alternatives:
	Choose Go→Back.

	Press ⌘-[ (left bracket).

	Press ⌘-↑ (up arrow).

	Choose Go→Enclosing Folder.



None of that helps you, however, if you want to move a file from one folder into the other, or to compare the contents of the two windows. In that case, you probably want to see both windows open at the same time.
You can open a second window using any of these techniques:
	Choose File→New Finder Window (⌘-N).
Tip
What folder contents fill the “new” window that appears when you use this command? Usually, it’s the All My Files folder, showing your entire universe of files.
But you can choose any window you want. To make the change, choose Finder→Preferences. Click the General icon. Change the “New Finder windows show” pop-up menu to whatever folder you’d like to use as the starting point for your computing life. “All My Files” is a good choice; so is your Home folder. But you’re also free to choose your Documents folder, your iDisk, or any folder at all. Now every new Finder window shows you that specified folder, which is a much more useful arrangement.


	⌘-double-click a disk or folder icon.

	Double-click a folder or disk icon on your desktop.

	Choose Finder→Preferences and turn on “Always open folders in a new window.” Now when double-clicked, all folders open into new windows. (This is the option for veteran Mac fans who don’t care for the new behavior.)




Old Finder Mode



The upper-right corner of every Finder window used to contain a little button that looked like a half-inch squirt of Crest toothpaste. Clicking it entered Old Finder Mode.
“Old Finder Mode” (not the technical Apple term) was designed for people who come to OS X from an earlier version, like Mac OS 9, and lose half their hair when they discover how different things are in OS X.
GEM IN THE ROUGH: Multiple Views, Same Folder
If you’ve read this section carefully, you may have discovered a peculiar quirk of the OS X Finder: By choosing File→New Finder Window (or ⌘-double-clicking a disk or folder icon), you open a second, completely independent Finder window. Therefore, if you stop to think about it, there’s nothing to stop you from opening a third, fourth, or fifth copy of the same folder window. Once they’re open, you can even switch them into different views.
Try this, for example: Choose Go→Applications. Choose File→New Finder Window (⌘-N), and then choose Go→Applications again. Using the View menu or the controls in the toolbar, put one of these windows into list view and the other into icon view.
This ability has its advantages. For example, you might decide to open the same window twice while doing some hard drive housekeeping. By keeping a list view open, you can check the Size column as you move your files into different folders (so you can make sure the folders fit onto a blank CD, for example). By keeping a column view open, on the other hand, you gain quicker navigational access to the stuff on your drive.

In this mode, two of the biggest behavioral differences between OS X and its predecessors disappear:
	The Sidebar and the toolbar blink out of sight.

	Double-clicking a folder now works like it did back in 2000. Every time you double-click a folder, you open a new window for it.



The Old Finder Mode button no longer appears, but the mode itself is still available. Press Option-⌘-T, the equivalent for the View→Hide Toolbar command. (Repeat that keystroke or command to turn Old Finder Mode off again.)

Scroll Bars



Here’s one of the biggest changes in Lion/Mountain Lion: Scroll bars don’t appear nearly as often as they used to (see Figure 1-8).
A scroll bar, of course, is the traditional window-edge slider that lets you move through a document that’s too big for the window. Without scroll bars, for example, you’d never be able to write a letter that’s taller than your screen.
On the very first Macs, scroll bars were a necessary evil; those computers were too slow and underpowered to manage visibly moving the contents of the window. That’s why scroll bars were invented in the first place: to give you some feedback about how far you were moving into a document, because the window itself went pure white when you dragged the handle.
[image: In Mountain Lion, scroll bars don’t appear at all while you’re working (bottom); you have that much more screen area dedicated to your work. If you begin to scroll by sliding your fingers across the trackpad or Magic Mouse, only the scroll-bar handle appears, so you know where you are (middle).New in Mountain Lion: If you point to the scroll bar, it fattens up so you can operate it more easily (top).]

Figure 1-9. In Mountain Lion, scroll bars don’t appear at all while you’re working (bottom); you have that much more screen area dedicated to your work. If you begin to scroll by sliding your fingers across the trackpad or Magic Mouse, only the scroll-bar handle appears, so you know where you are (middle). New in Mountain Lion: If you point to the scroll bar, it fattens up so you can operate it more easily (top).

Today, though, you can manipulate the contents of a window and see where you are at all times. Nobody questions the absence of scroll bars on an iPad, right? Because you just push the contents of a window around with your fingers to scroll.
In Mountain Lion, you scroll by pushing two fingers up the trackpad (or one finger up the Magic Mouse) or by turning your mouse’s scroll wheel. You almost never use the antiquated method of dragging the scroll bar’s handle manually, with the mouse.
Tip
More reasons nobody uses the mouse on the scroll bar: You can scroll using the keyboard. Your Page Up and Page Down keys let you scroll up and down, one screen at a time, without having to take your hands off the keyboard. The Home and End keys are generally useful for jumping directly to the top or bottom of your document (or Finder window). And if you’ve bought a mouse that has a scroll wheel on the top, you can use it to scroll windows, without pressing any keys at all.

That’s a long-winded way of explaining why, in most Mountain Lion programs, the scroll bars are hidden. See Figure 1-9 for details.
Note
If the missing scroll bars leave you jittery and disoriented, you can bring them back. Open System Preferences→General and then turn on “Show scroll bars: Always.”


Resizable Edges



For the first 28 years of its existence, the Mac offered only one way to make a window bigger or smaller: Drag the ribbed-looking lower-right corner.
In Mountain Lion, you can drag any edge of a window to change its shape. Just move the pointer carefully to the exact top, bottom, left, or right edge; once its shape changes to a double-headed arrow, you can drag to move that window’s edge in or out.
NOSTALGIA CORNER: How the Scroll Bar Used to Work
If you are that rare, special individual who still operates the scroll bar by clicking it with the mouse, the old-style controls are still around.
For example: Ordinarily, when you click in the scroll bar track above or below the dark gray handle bar, the window scrolls by one screenful. But another option awaits when you choose [image: ]→System Preferences→General and turn on “Jump to the spot that’s clicked.” Now when you click the scroll-bar track, the Mac considers the entire scroll bar a proportional map of the document and jumps precisely to the spot you clicked. That is, if you click at the very bottom of the scroll-bar track, you see the very last page.
No matter which scrolling option you choose in the Appearance panel, you can always override your decision on a case-by-case basis by Option-clicking the scroll-bar track. In other words, if you’ve selected the “Jump to the spot that’s clicked” option, you can produce a “Jump to the next page” scroll by Option-clicking in the scroll-bar track.

Tip
There are a few cool, totally undocumented variations on the window-edge-dragging business. First, if you press the Option key while dragging, you resize the opposite edge simultaneously. For example, if you Option-drag the bottom edge upward, the top edge simultaneously collapses downward.
If you press Shift as you drag, you resize the entire window, retaining its proportions.
And if you Shift-Option drag, you resize the window around its center, rather than from its edges.


Path Bar



This little item appears when you choose View→Show Path Bar. It’s a tiny map at the bottom of the window that shows where you are in the folder hierarchy. If it says Casey→Pictures→Picnic, well, then, by golly, you’re looking at the contents of the Picnic folder, which is inside Pictures, which is inside your Home folder (assuming your name is Casey).
Tip
Each tiny folder icon in this display is fully operational. You can double-click it to open it, Control-click (right-click) it to open a shortcut menu, or even drag things into it.


Status Bar



Out of the box, OS X hides yet another information strip at the bottom of a window: the status bar, which tells you how many icons are in the window (“14 items,” for example) and the amount of free space remaining on the disk. To make it appear, choose View→Show Status Bar.
Tip
The status bar shows you disk-space information for the entire disk, but not how much disk space this particular window’s contents occupy.
To find out that piece of information, make sure no icon in the window is highlighted. Then choose File→Get Info (or press ⌘-I). The resulting Info window, which is described at the end of the next chapter, shows the size of the folder or disk whose window you’re browsing, along with other useful statistics.



The Four Window Views



You can view the files and folders in a desktop window in any of four ways: as icons; as a single, tidy list; in a series of neat columns; or in Cover Flow view, where you can flip through giant document icons like they’re CDs in a music-store bin. Figure 1-10 shows the four views.
Every window remembers its view settings independently. You might prefer to look over your Applications folder in list view (because it’s crammed with files and folders) but view the Pictures folder in icon or Cover Flow view, where the larger icons serve as previews of the photos.
To switch a window from one view to another, just click one of the four corresponding icons in the window’s toolbar (Figure 1-10).
You can also switch views by choosing View→as Icons (or View→as Columns, or View→as List, or View→as Cover Flow), which can be handy if you’ve hidden the toolbar. Or, for less mousing and more hard-bodied efficiency, press ⌘-1 for icon view, ⌘-2 for list view, ⌘-3 for column view, or ⌘-4 for Cover Flow view.
The following pages cover each of these views in greater detail.
[image: From the top: the same window in icon view, list view, column view, and Cover Flow view. Very full folders are best navigated in list or column views, but you may prefer to view emptier folders in icon or Cover Flow views, because larger icons are easier to preview and click. Remember that in any view (icon, list, column, or Cover Flow), you can highlight an icon by typing the first few letters of its name. In icon, list, or Cover Flow views, you can also press Tab to highlight the next icon (in alphabetical order), or Shift-Tab to highlight the previous one.]

Figure 1-10. From the top: the same window in icon view, list view, column view, and Cover Flow view. Very full folders are best navigated in list or column views, but you may prefer to view emptier folders in icon or Cover Flow views, because larger icons are easier to preview and click. Remember that in any view (icon, list, column, or Cover Flow), you can highlight an icon by typing the first few letters of its name. In icon, list, or Cover Flow views, you can also press Tab to highlight the next icon (in alphabetical order), or Shift-Tab to highlight the previous one.

Note
One common thread in the following discussions is the availability of the View Options palette, which lets you set up the sorting, text size, icon size, and other features of each view, either one window at a time or for all windows.
Apple gives you a million different ways to open View Options. You can choose View→Show View Options, or press ⌘-J, or choose Show View Options from the [image: ] menu at the top of every window.


Icon View



In icon view, every file, folder, and disk is represented by a small picture—an icon. This humble image, a visual representation of electronic bits and bytes, is the cornerstone of the entire Macintosh religion. (Maybe that’s why it’s called an icon.)
Icon Size



OS X draws those little icons using sophisticated graphics software. As a result, you can scale them to almost any size without losing quality or clarity. If you choose View→Status Bar so that the bottom-edge strip shown in Figure 1-11 appears, you get a size slider that you can drag to the right or left to make that window’s icons larger or smaller. (For added fun, make little cartoon sounds with your mouth.)
[image: Once you make the status bar appear, you can choose an icon size to suit your personality. For picture folders, it can often be very handy to pick a jumbo size, in effect creating a slide-sorter “light table” effect. Icons can be an almost ridiculously large 512 pixels square.]

Figure 1-11. Once you make the status bar appear, you can choose an icon size to suit your personality. For picture folders, it can often be very handy to pick a jumbo size, in effect creating a slide-sorter “light table” effect. Icons can be an almost ridiculously large 512 pixels square.


Icon Previews



The Mac expands the notion of “an icon is a representation of its contents” to an impressive extreme. As you can see in Figure 1-12, each icon actually looks like a miniature of the first page of the real document.
Because you can make icons so enormous, you can actually watch movies, or read PDF and text documents, right on their icons.
To check out this feature, point to an icon without clicking. A Play button ([image: ]) appears on any movie or sound file; as shown in Figure 1-12, [image: ] and [image: ] page buttons appear on a multipage document (like PDF, Pages, or even presentation documents like PowerPoint and Keynote). You can actually page through one of these documents right there on its icon without having to open the program!
Tip
If you Option-click the little [image: ] and [image: ] buttons on a PDF, PowerPoint, or Keynote icon preview, you jump to the first or last page or slide in the document.

[image: You can page through PDF and presentation icons, or play movies and sounds, right on their icons. (Movie icons even display a circular progress bar so you know how far you are into the video.)]

Figure 1-12. You can page through PDF and presentation icons, or play movies and sounds, right on their icons. (Movie icons even display a circular progress bar so you know how far you are into the video.)


Icon-View Options



OS X offers a number of useful icon-view options, all of which are worth exploring. Start by opening any icon-view window, and then choose View→Show View Options (⌘-J). The dialog box shown in Figure 1-13 appears.
Always open in icon view



It’s easy—almost scarily easy—to set up your preferred look for all folder windows on your entire system. With one click on the Use as Defaults button (described below), you can change the window view of 20,000 folders at once—to icon view, list view, or whatever you like.
The “Always open in icon view” option lets you override that master setting, just for this window.
For example, you might generally prefer a neat list view with large text. But for your Pictures folder, it probably makes more sense to set up icon view, so you can see a thumbnail of each photo without having to open it.
That’s the idea here. Open Pictures, change it to icon view, and then turn on “Always open in icon view.” Now every folder on your Mac is in list view except Pictures.
Note
The wording of this item in the View Options dialog box changes according to the view you’re in at the moment. In a list-view window, for example, it says, “Always open in list view.” In a Cover Flow–view window, it says, “Always open in Cover Flow.” And so on. But the function is the same: to override the default (master) setting.

[image: Drag the “Grid spacing” slider to specify how tightly packed you want your icons to be. At the minimum setting, they’re so crammed it’s almost ridiculous; you may not even be able to see their full names. But sometimes, you don’t really need to. At more a spacious setting (bottom), you get a lot more white space.]

Figure 1-13. Drag the “Grid spacing” slider to specify how tightly packed you want your icons to be. At the minimum setting, they’re so crammed it’s almost ridiculous; you may not even be able to see their full names. But sometimes, you don’t really need to. At more a spacious setting (bottom), you get a lot more white space.


Browse in icon view



This option makes sure that any folders inside the current window open up into icon view, too, even if you’d previously set them to open into some other view. So if you’re looking at your Pictures folder in icon view and you open the Grand Canyon Jaw-Droppers folder inside it, that folder also will be in icon view.

Arrange By, Sort By



For a discussion of these pop-up menus, see Arrange By and Sort By on page 43.

Icon size



It’s super easy to make all your icons bigger or smaller; just drag the Icon Size slider in the lower-right corner of the window.
But for the benefit of old-timers who expect to find that slider here, in the View Options window, well, there’s an identical slider here.

Grid spacing



Listen up, you young whippersnappers! When I was your age, back when computers used Mac OS 9, you could control how closely spaced icons were in a window. Why, if I wanted to see a lot of them without making the window bigger, I could pack ’em in like sardines!
That feature disappeared—for seven years. But back in Mac OS X 10.5, it finally returned. Figure 1-13 shows all.

Text size



Your choices range only from 10 to 16 points, and you still can’t choose a different font for your icons’ names. But using this pop-up menu, you can adjust the type size. And for people with especially big or especially small screens—or for people with aging retinas—this feature is much better than nothing.
In fact, you can actually specify a different type size for every window on your machine. (Why would you want to adjust the point size independently in different windows? Well, because you might want smaller type to fit more into a crammed list view without scrolling, while you can afford larger type in less densely populated windows.)

Label position



Click either Bottom or Right to indicate where you want an icon’s name to appear, relative to its icon. As shown in Figure 1-14 at bottom, this option lets you create, in effect, a multiple-column list view in a single window.

Show item info



While you’ve got the View Options palette open, try turning on “Show item info.” Suddenly you get a new line of information (in tiny blue type) for certain icons, saving you the effort of opening up the folder or file to find out what’s in it. For example:
	Folders. The info line lets you know how many icons are inside each without having to open it up. Now you can spot empties at a glance.

	Graphics files. Certain other kinds of files may show a helpful info line, too. For example, graphics files display their dimensions in pixels.

	Sounds and QuickTime movies The light-blue bonus line tells you how long the sound or movie takes to play. For example, an MP3 file might say “03' 08",” which means 3 minutes, 8 seconds.

	.zip files. On compressed archives like .zip files, you get to see the archive’s total size on disk (like “48.9 MB”).



You can see the effect illustrated in Figure 1-13.

Show icon preview



This option is what makes icons display their contents, as shown in Figures Figure 1-11 and Figure 1-12. If you turn it off, then icons no longer look like miniature versions of their contents (tiny photos, tiny PDF files, and so on). Everything takes on generic icons.
You might prefer this arrangement when, for example, you want to be able to pick out all the PDF files in a window full of mixed document types. Thanks to the matching icons, it’s easy now.

Background



Here’s a luxury that other operating systems can only dream about: You can fill the background of any icon-view window on your Mac with a certain color—or even a photo.
Color coordinating or “wallpapering” certain windows is more than just a gimmick. In fact, it can serve as a timesaving visual cue. Once you’ve gotten used to the fact that your main Documents folder has a sky-blue background, you can look at a screen filled with open windows and pick it out like a sharpshooter. Color-coded Finder windows are also especially easy to distinguish at a glance when you’ve minimized them to the Dock.
[image: The View Options dialog box for an icon view window offers the chance to create colored backgrounds for certain windows or even to use photos as window wallpaper (bottom). Using a photo may have a soothing, comic, or annoying effect—like making the icon names completely unreadable. (Note, by the way, how the icons’ names have been set to appear beside the icons, rather than underneath, in the lower illustration. You now have all the handy, freely draggable convenience of an icon view, along with the more compact vertical spacing of a list view.)]

Figure 1-14. The View Options dialog box for an icon view window offers the chance to create colored backgrounds for certain windows or even to use photos as window wallpaper (bottom). Using a photo may have a soothing, comic, or annoying effect—like making the icon names completely unreadable. (Note, by the way, how the icons’ names have been set to appear beside the icons, rather than underneath, in the lower illustration. You now have all the handy, freely draggable convenience of an icon view, along with the more compact vertical spacing of a list view.)

Note
Background colors and pictures show up only in icon view.

Once a window is open, choose View→View Options (⌘-J). The bottom of the resulting dialog box offers three choices, whose results are shown in Figure 1-14.
	White. This is the standard option (not shown).

	Color. When you click this button, you see a small rectangular button beside the word Color. Click it to open the Color Picker, which you can use to choose a new background color for the window. (Unless it’s April Fools’ Day, pick a light color. If you choose a dark one—like black—you won’t be able to make out the lettering of the icons’ names.)

	Picture. If you choose this option, a “Drag image here” square appears. Now find a graphics file—one of Apple’s in the Desktop Pictures folder, or one of your own, whatever—and drag it into that “well.”
When you click Select, you see that OS X has superimposed the window’s icons on the photo. As you can see in Figure 1-14, low-contrast or light-background photos work best for legibility.
Incidentally, the Mac has no idea what sizes and shapes your window may assume in its lifetime. Therefore, OS X makes no attempt to scale down a selected photo to fit neatly into the window. If you have a high-res digital camera, therefore, you may see only the upper-left corner of your photo in the window. For better results, use a graphics program to scale the picture down to something smaller than your screen resolution.




Use as Defaults



This harmless-looking button can actually wreak havoc on your kingdom—or restore order to it—with a single click. It applies the changes you’ve just made in the View Options dialog box to all icon-view windows on your Mac (instead of only the frontmost window).
If you set up the frontmost window with a colored background, big icons, small text, and a tight grid, and then you click Use as Defaults, you’ll see that look in every disk or folder window you open.
You’ve been warned.
Fortunately, there are two auxiliary controls that can give you a break from all the sameness.
First, you can set up individual windows to be weirdo exceptions to the rule; see Always open in icon view on page 38.
Second, you can remove any departures from the default window view—after a round of disappointing experimentation on a particular window, for example—using a secret button. Choose View→Show View Options to open the View Options dialog box. Now hold down the Option key. The Use as Defaults button magically changes to say Restore to Defaults, which means, “Abandon all the changes I’ve foolishly made to the look of this window.”


Arrange By and Sort By



In OS X Lion, Apple completely replaced the old, complex system for organizing and sorting icons.
Now you can wield two different kinds of control over the files in a Finder window: arranging and sorting.
Tip
You can perform all these obsessive reorganizations in any view: icon view, list view, column view, or Cover Flow view. That’s a big change from the pre-Lion days.

Arranging



Arranging files means, “Put my files into related clumps, separated by headings that identify them.” You can arrange files in any of the views—icon, list, column, Cover Flow—and there are some incredibly useful options here.
For example, you can arrange your documents into Application groups (meaning, which program opens each one); now you can see at a glance which files will open in, say, iTunes when you double-click them. Or you can organize your Pictures folder into Date Added groups, with headings like “Today,” “Last 7 Days,” and “Earlier.”
Figure 1-15 shows a few examples.
Tip
In icon view, the icons under each heading appear in a single row, scrolling off endlessly to the right. Use the usual sideways-scrolling gesture to flip through a row. (That is, swipe to the left on a trackpad with two fingers, or with one finger on a Magic Mouse.)
If you’re not into gestures, or if you don’t have a swipeable input device, click the tiny Show All button at the right end of a row. Now you’ve turned off that one-row-per-heading thing, and all the icons under that heading appear in the usual rows and columns; scroll down to see them all.

Apple wants to make extra, extra sure you’re aware of the new Arrange commands. It gives you four different ways to find them:
	Choose View→Arrange By. Choose one of the criteria from the submenu. Your options are Name (alphabetically); Kind (type of file, like Images, Movies, and Documents); Application (which program opens which documents); Date (Last Opened, Added [to the window], Modified, or Created); Size; or Label (Finder label colors, described on Broken Aliases). Marvel as the Finder puts your files into tidy categorized groups.
Note
When you’re looking at the Applications folder, you get a special choice: Application Category. It clumps your programs by what they do: Productivity, Social Networking, Music, Video, Board Games, Entertainment, Utilities, Reference, Photography, and so on. Pretty cool, actually.

[image: You can view your Finder-window files in neat little groups, separated by headings. Top left: the Applications window, in icon view, arranged by Application Category.Middle: the Documents folder, in list view, arranged by Application (meaning “which program opens this document”).Bottom: the Desktop folder, in column view, arranged by Date Added.]

Figure 1-15. You can view your Finder-window files in neat little groups, separated by headings. Top left: the Applications window, in icon view, arranged by Application Category. Middle: the Documents folder, in list view, arranged by Application (meaning “which program opens this document”). Bottom: the Desktop folder, in column view, arranged by Date Added.


	Choose from the [image: ] icon. This icon appears in the toolbar of every Finder window. It contains the same options listed in the previous paragraph.

	Control-click (or right-click) an empty spot in an icon-view window; choose from the Arrange By shortcut menu. Yep, it’s those same commands yet again.

	In the View Options palette (seen in Figure 1-13), use the Arrange By pop-up menu. Yes, it’s a fourth place to find the same six options.



Note
In each case, you can choose None to turn off the grouping altogether.

Remember, arranging (clumping) is not sorting. You can, in fact, sort the icons differently within each arranged group; read on.

Sorting



Sorting means just what it says (except that it used to be called “arranging”): You can sort your files alphabetically (by Name), chronologically (by Date), in order of hugeness (by Size), and so on. See Figure 1-16.
[image: Use either the View menu or the View Options window (right) to turn on permanent cleanliness mode. You’ve told the Mac to keep these icons on the invisible grid, sorted the way you requested. Just don’t get frustrated when you try to drag an icon and then discover that it won’t budge.]

Figure 1-16. Use either the View menu or the View Options window (right) to turn on permanent cleanliness mode. You’ve told the Mac to keep these icons on the invisible grid, sorted the way you requested. Just don’t get frustrated when you try to drag an icon and then discover that it won’t budge.

You can sort a window whether or not you’ve also arranged (grouped) it. You can even sort by different criteria. For example, you might have the programs in your Applications folder arranged by Application Category, but sorted alphabetically within each category.
Once again, Apple gives you four ways to sort:
	While pressing the Option key, choose View → Sort By. (Pressing Option turns the Arrange By submenu into the Sort By submenu.) Choose one of the criteria: Name, Size, and so on.

	While pressing the Option key, click the [image: ] icon. Once again, the Option key turns the Arrange By options into Sort By options.

	Control-click (or right-click) an empty spot in an icon-view window. Press the Option key. And again, Option turns the Arrange By options into Sort By options.

	In the View Options palette, use the Sort By pop-up menu. Hey, guess what? You didn’t have to press the Option key this time.



Tip
In icon view, you get an additional option: Snap to Grid. It means, “Let me drag these icons into any sequence I want, using the trackpad or mouse.” When you release each drag, the icon jumps into the nearest position on the underlying spacing grid (unless you press the ⌘ key, which gives you full manual control of the icon’s position).
This option appears only if Arrange By is set to None. After all, if you’ve asked the Mac to arrange your icons into groups, then you’ve relinquished control of their grid spacing.


Free dragging—and grid spacing



Whenever you’ve applied an Arrange or a Sort to an icon view, the icons remain rooted to an invisible underlying rows-and-columns grid. You can’t budge them.
Tip
You can, however, control how tight or loose that grid is, using the Grid spacing slider described above.

But there are two situations when you’re allowed to drag icons freely into any order you want:
	Icons never snap to the grid. If both Arrange By and Sort By are set to None, then you can go nuts, freely dragging icons into sloppy, off-the-grid positions.
If, later, you become overwhelmed by shame at your untidiness, you can choose View→Clean Up (if nothing is selected) or View→Clean Up Selection (if some icons are highlighted). Now all icons in the window, or those you’ve selected, jump to the closest positions on the invisible underlying grid.
These same commands appear in the shortcut menu when you Control-click or right-click anywhere inside an icon-view window, which is handier if you have a huge monitor.
(There’s even a Clean Up By submenu in the View menu and the shortcut menu. These commands don’t just put icons back onto the closest grid positions; they put the icons into their proper sorted positions among the other icons—by name, size, date, and so on.)
Tip
If you press Option, then the Mac swaps the wording of the command. Clean Up changes to Clean Up Selection, and vice versa.


	Icons always snap to the grid. If Arrange By is set to None but Sort By is set to Snap to Grid, then you can drag icons into any order you like (that is, not in any particular sorted order)—but they’ll snap to the grid when you let go of the mouse button.



Tip
If you press the ⌘ key as you release the drag, you can reverse the snapping logic. That is, the icons will snap to the grid if Sort By is set to None, but you can drag them freely if it’s set to Snap to Grid. (Don’t press the key until after you’ve begun to drag.)

Although it doesn’t occur to most Mac fans, you can also apply any of the commands described in this section—Clean Up, Arrange, Sort—to icons lying loose on your desktop. Even though they don’t seem to be in any window at all, you can specify small or large icons, automatic alphabetical arrangement, and so on. Just click the desktop before using the View menu or the View Options dialog box.
Note
There’s only one View Options dialog box. Once it’s open, you can adjust the icon sizes or arrangement options of other windows just by clicking them. Each time you click inside a window, the View Options dialog box remains in front, changing to reflect the settings of the window you just clicked.
Incidentally, you can get rid of the View Options box the same way you summoned it: by pressing ⌘-J.




List View



In windows that contain a lot of icons, list view is a powerful weapon in the battle against chaos. It shows you a tidy table of your files’ names, dates, sizes, and so on (Figure 1-17). Very faint alternating blue and white background stripes help you read across the columns.
[image: You control the sorting order of a list view by clicking the column headings (top). Click a second time to reverse the sorting order (bottom). You’ll find the or triangles—indicating the identical information—in email programs, iTunes, and anywhere else where reversing the sorting order of a list can be useful.]

Figure 1-17. You control the sorting order of a list view by clicking the column headings (top). Click a second time to reverse the sorting order (bottom). You’ll find the [image: ] or [image: ] triangles—indicating the identical information—in email programs, iTunes, and anywhere else where reversing the sorting order of a list can be useful.

You get to decide how wide your columns should be, which of them should appear, and in what order (except that Name is always the first column). Here’s how to master these columns.
Sorting the List



Most of the world’s list-view fans like their files listed alphabetically. It’s occasionally useful, however, to view the newest files first, largest ones first, or whatever.
When a desktop window displays its icons in list view, a convenient new strip of column headings appears. These headings aren’t just signposts; they’re buttons, too. Click Name for alphabetical order, Date Modified to view the newest first, Size to view the largest files at the top, and so on.
Don’t miss the tiny [image: ] or [image: ] that appears in the column you’ve most recently clicked. It shows you which way the list is being sorted. When it’s [image: ], then the oldest files, smallest files, or files beginning with numbers (or the letter A) appear at the top of the list, depending on which sorting criterion you have selected.
Tip
It may help you to remember that when the smallest portion of the triangle is at the top ([image: ]), the smallest files are listed first when viewed in size order.

To reverse the sorting order, click the column heading a second time. Now the [image: ] shows you that the newest files, largest files, or files beginning with the letter Z appear at the top of the list.
Note
You can also change the sorting order using the Sort By command described earlier (in the View menu, the [image: ] pop-up menu, or the View Options dialog box). But, honestly, clicking the column headings is much faster.


Arranging the List



You can arrange your list view into groups by name, date, kind, and so on, with tidy headings that help you make sense of it all. This unsung feature is described under “Arrange and Sort By” on Arrange By and Sort By.

Flippy Triangles



One of the Mac’s most attractive features is the tiny triangle that appears to the left of a folder’s name in a list view. In its official documents, Apple calls these buttons disclosure triangles; internally, the programmers call them flippy triangles.
When you click one, the list view turns into an outline, showing the contents of the folder in an indented list, as shown in Figure 1-18. Click the triangle again to collapse the folder listing. You’re saved the trouble and clutter of opening a new window just to view the folder’s contents.
By selectively clicking flippy triangles, you can in effect peer inside two or more folders simultaneously, all within a single list-view window. You can move files around by dragging them onto the tiny folder icons.
Tip
Once you’ve expanded a folder by clicking its flippy triangle, you can even drag a file icon out of the folder so that it’s loose in the list-view window. To do so, drag it directly upward onto the column headings area (where it says Name, for example). When you release the mouse, you see that the file is no longer inside the expanded folder.

[image: Click a “flippy triangle” (left) to see the list of the folders and files inside that folder (right). Or press the equivalent keystrokes: → (to open) and ← (to close).]

Figure 1-18. Click a “flippy triangle” (left) to see the list of the folders and files inside that folder (right). Or press the equivalent keystrokes: → (to open) and ← (to close).

UP TO SPEED: Flippy Triangle Keystrokes
The keystrokes that let you open and close flippy triangles in a list view are worth committing to memory.
First, pressing the Option key when you click a flippy triangle lets you view a folder’s contents and the contents of any folders inside it. The result, in other words, is a longer list that may involve several levels of indentation.
If you prefer to use the keyboard, then substitute → (to expand a selected folder’s flippy triangle) or ← (to collapse the folder listing again). Here again, adding the Option key expands or collapses all levels of folders within the selected one.
Suppose, for example, that you want to find out how many files are in your Pictures folder. The trouble is, you’ve organized your graphics files within that folder in several category folders. And you realize that the “how many items” statistic in the status bar shows only how many icons are visible in the window. In other words, you won’t know your total photo count until you’ve expanded all the folders within the Pictures folder.
You could perform the entire routine from the keyboard like this: Get to your Home folder by pressing Shift-⌘-H. Select the Pictures folder by typing the letter P. Open it by pressing ⌘-O (the shortcut for File→Open) or ⌘-↓. Switch to list view, if necessary, with a quick ⌘-2. Highlight the entire contents by pressing ⌘-A (short for Edit→Select All).
Now that all folders are highlighted, press Option-→. You may have to wait a moment for the Mac to open every subfolder of every subfolder. But eventually, the massive list appears, complete with many levels of indentation. At last, the “items” statistic in the status bar gives you a complete, updated tally of how many files and folders, combined, are in the window.


Your Choice of Columns



Choose View→Show View Options. In the dialog box that appears, you’re offered on/off checkboxes for the different columns of information OS X can show you, as illustrated in Figure 1-19.
[image: The checkboxes you turn on in the View Options dialog box determine which columns of information appear in a list-view window. Many people live full and satisfying lives with only the three default columns—Date Modified, Kind, and Size—turned on. But the other columns can be helpful in special circumstances; the trick is knowing what information appears there.]

Figure 1-19. The checkboxes you turn on in the View Options dialog box determine which columns of information appear in a list-view window. Many people live full and satisfying lives with only the three default columns—Date Modified, Kind, and Size—turned on. But the other columns can be helpful in special circumstances; the trick is knowing what information appears there.

	Date Modified. This date-and-time stamp indicates when a document was last saved. Its accuracy, of course, depends on the accuracy of your Mac’s built-in clock.
Note
Many an up-to-date file has been lost because someone spotted a very old date on a folder and assumed that the files inside were equally old. That’s because the modification date shown for a folder doesn’t reflect the age of its contents. Instead, the date on a folder indicates only when items were last moved into or out of that folder. The actual files inside may be much older, or much more recent.


	Date Created. This date-and-time stamp shows when a document was first saved.

	Date Added. This option shows when a file was added to this folder or window.

	Size. With a glance, you can tell from this column how much disk space each of your files and folders is taking up in kilobytes, megabytes, gigabytes, or terabytes—whichever the Mac thinks you’ll find most helpful.
Tip
For disks and folders, you see only a dash—at first. You can, however, instruct the Mac to reveal their sizes, as described on Rearranging Columns.


	Kind. In this column, you can read what kind of file each icon represents. You may see, for example, Folder, JPEG Image, Application, and so on.

	Version. This column displays the version numbers of your programs. For folders and documents, you just see a dash.

	Comments. This rarely seen column can actually be among the most useful. Suppose you’re a person who uses the Comments feature (highlight an icon, choose File→Get Info, type notes about that item into the Spotlight Comments box). This column displays the first line of those comments about each icon, which comes in handy when tracking multiple versions of your documents, as shown in Figure 1-20.

	Label. Labels are colors and identifying phrases that you can slap onto icons, wherever they appear, to help you categorize and group them. For details, see Broken Aliases.
[image: If your monitor is big enough, you can expand the Comments column to show several paragraphs, all in a single line—enough to reveal the full life history of each icon. (To enter some comments about an icon, type into the Spotlight Comments box in its Get Info, as shown here at bottom.)]

Figure 1-20. If your monitor is big enough, you can expand the Comments column to show several paragraphs, all in a single line—enough to reveal the full life history of each icon. (To enter some comments about an icon, type into the Spotlight Comments box in its Get Info, as shown here at bottom.)

Even with this column turned off, you can still see an icon’s color, of course. But only by turning on this column do you get to see the text phrase you’ve associated with each label.




Other View Options



The View Options for a list view include several other useful settings; choose View→Show View Options or press ⌘-J.
	Always open in list view. Turn on this option to override your system-wide preference setting for all windows. See Always open in icon view on page 38 for details.

	Browse in list view. Ensures that any folder inside this one will also open up in list view, even if its regularly scheduled view is something else.

	Icon size. These two buttons offer you a choice of icon sizes for the current window: either standard or tiny. Unlike icon view, list view doesn’t give you a size slider.
Fortunately, even the tiny icons aren’t so small that they show up blank. You still get a general idea of what they’re supposed to look like.

	Text size. You can change the type size for your icon labels, either globally or one window at a time.

	Show columns. Turn on the columns you’d like to appear in the current window’s list view, as described in the previous section.

	Use relative dates. In a list view, the Date Modified, Date Added, and Date Created columns generally display information in a format like this: “Tuesday, March 5, 2013.” (The Mac uses shorter date formats as the column gets narrower.) But when the “Use relative dates” option is turned on, the Mac substitutes the words “Yesterday” or “Today” where appropriate, making recent files easier to spot.

	Calculate all sizes. See the box below.

	Show icon preview. Exactly as in icon view, this option turns the icons of graphics files into miniatures of the photos or images within.
FREQUENTLY ASKED QUESTION: Calculate All Sizes
When I sort my list view by size, I see only dashes for folder sizes. What am I doing wrong?
Nothing at all; that’s normal. When viewing a Finder window, you see a Size statistic for each file. For folders and disks, however, you’re shown only an uninformative dash.
Most Mac fans study this anomaly momentarily, scratch their chins, and then get back to their work. Former Windows people don’t even scratch their chins; Windows PCs never show folder-size or disk-size information in list views.
Here’s what’s going on: It can take a computer a long time to add up the sizes of all files inside a folder. Your System→Library folder alone, for example, contains over 100,000 files. Instead of making you wait while the Mac does all the addition, OS X simply shows you a dash in the folder’s Size column.
On occasion, however, you really do want to see how big your folders are. In such cases, choose View→Show View Options and turn on “Calculate all sizes.” You see the folder sizes slowly begin to pop onto the screen, from the top of the window down, as the Mac crunches the numbers on the files within. (You’ll know that the crunching is still in progress, because you’ll see the size statistics for some icons appear in light gray. That’s the Mac’s way of saying, “I’m not totally sure about this folder’s size yet.”)
In fact, you can even turn on the “Calculate all sizes” option globally—that is, for all windows. In the Mac operating systems of days gone by, this act would have caused a massive slowdown of the entire computer. But remember that OS X is multithreaded; it has the opposite of a one-track mind. It’s perfectly capable of devoting all its attention to calculating your folder sizes and to whatever work you’re doing in the foreground.
Now consider this anomaly: Suppose you’ve opted to sort a particular window by folder size—in other words, you’ve clicked Size at the top of the column. Turning on “Calculate all sizes” bewilders the unprepared, as folders arbitrarily begin leaping out of order, forcing the list to rearrange itself a couple of times per second.
What’s happening, of course, is that all folders begin at the bottom of the list, showing only dashes in the Size column. Then, as the Mac computes the size of your folders’ contents, they jump into their correct sorted order at what may seem to be random intervals.


	Use as Defaults. Click to make your changes in the View Options box apply to all windows on your Mac. (Option-click this button to restore a wayward window back to your defaults.)




Rearranging Columns



You’re stuck with the Name column at the far left of a window. However, you can rearrange the other columns just by dragging their gray column headers horizontally. If the Mac thinks you intend to drop a column to, say, the left of the column it overlaps, you’ll actually see an animated movement—indicating a column reshuffling—even before you release the mouse button.

Adjusting Column Widths



If you place your cursor carefully on the dividing line between two column headings, you’ll find that you can drag the divider line horizontally. Doing so makes the column to the left of your cursor wider or narrower.
What’s delightful about this activity is watching OS X scramble to rewrite its information to fit the space you give it. For example, as you make the Date Modified (or Created) column narrower, “Saturday, March 9, 2013, 2:22 PM” shrinks first to “Sat, Mar 9, 2013, 2:22 PM,” then to “3/9/13, 2:22 PM,” and finally to a terse “3/9/13.”
If you make a column too narrow, OS X shortens the file names by removing text from the middle. An ellipsis (…) appears to show you where the missing text would have appeared. (Apple reasoned that truncating the ends of file names, as in some other operating systems, would hide useful information, like the numbers at the end of “Letter to Marge 1,” “Letter to Marge 2,” and so on. It would also hide the three-letter extensions, such as Thesis.doc, that may appear on file names in OS X.)
For example, suppose you’ve named a Word document “Justin Bieber—A Major Force for Humanization and Cure for Depression, Acne, and Migraine Headache.” (Yes, file names can really be that long.) If the Name column is too narrow, you might see only “Justin Bieber—A Major…Migraine Headache.”
Tip
You don’t have to make the column mega-wide just to read the full text of a file whose name has been shortened. Just point to the icon’s name without clicking. After a moment, a yellow, floating balloon appears—something like a tooltip in Microsoft programs—to identify the full name.
In fact, now you can move your mouse up or down a list over truncated file names and their tooltip balloons appear instantaneously. (This trick works in list, column, or Cover Flow views—and in Save and Open dialog boxes, for that matter.)



Column View



The goal of column view is simple: to let you burrow down through nested folders without leaving a trail of messy, overlapping windows in your wake.
The solution is shown in Figure 1-21. It’s a list view that’s divided into several vertical panes. The first pane (not counting the Sidebar) shows whatever disk or folder you first opened.
[image: If the rightmost folder contains pictures, sounds, Office documents, or movies, you can look at them or play them, right there in the Finder. You can drag this jumbo preview icon anywhere—into another folder or to the Trash, for example.]

Figure 1-21. If the rightmost folder contains pictures, sounds, Office documents, or movies, you can look at them or play them, right there in the Finder. You can drag this jumbo preview icon anywhere—into another folder or to the Trash, for example.

When you click a disk or folder in this list (once), the second pane shows a list of everything in it. Each time you click a folder in one pane, the pane to its right shows what’s inside. The other panes slide to the left, sometimes out of view. (Use the horizontal scroll bar to bring them back.) You can keep clicking until you’re looking at the file icons inside the most deeply nested folder.
If you discover that your hunt for a particular file has taken you down a blind alley, it’s not a big deal to backtrack, since the trail of folders you’ve followed to get here is still sitting before you on the screen. As soon as you click a different folder in one of the earlier panes, the panes to its right suddenly change, so that you can burrow down a different rabbit hole.
The beauty of column view is that, first of all, it keeps your screen tidy. It effectively shows you several simultaneous folder levels but contains them within a single window. With a quick ⌘-W, you can close the entire window, panes and all. Second, column view provides an excellent sense of where you are. Because your trail is visible at all times, it’s much harder to get lost—wondering what folder you’re in and how you got there—than in any other window view.
Column View by Keyboard



Efficiency fans can operate this entire process by keyboard alone. For example:
	You can jump from one column to the next by pressing the ← or → keys. Each press highlights the first icon in the next or previous column.

	You can use any of the commands in the Go menu, or their keyboard equivalents, or the icons in the Sidebar, to fill your columns with the contents of the corresponding folder—Home, Favorites, Applications, and so on.

	The Back command (clicking the [image: ] button on the toolbar, pressing ⌘-[, or choosing Go→Back) works as it does in a Web browser: It retraces your steps backward. You can repeat this command until you return to the column setup that first appeared when you switched to column view. Once you’ve gone back, in fact, you can then go forward again; choose Go→Forward, or press ⌘-].

	Within a highlighted column, press the ↑ or ↓ keys to highlight successive icons in the list. Or type the first couple of letters of an icon’s name to jump directly to it.

	When you finally highlight the icon you’ve been looking for, press ⌘-O or ⌘-↓to open it (or double-click it, of course). You can open anything in any column; you don’t have to wait until you’ve reached the rightmost column.




Manipulating the Columns



The number of columns you can see without scrolling depends on the width of the window. That’s not to say, however, that you’re limited to four columns (or whatever fits on your monitor). You can make the columns wider or narrower—either individually or all at once—to suit the situation, according to this scheme:
	To make a single column wider or narrower, drag the fine vertical line that separates it from the column to its right (see Figure 1-22).

	To make all the columns wider or narrower simultaneously, hold down the Option key as you drag one of the divider lines.

	To make a column precisely as wide as necessary to reveal all the names of its contents, double-click the divider line on its right side.
POWER USERS’ CLINIC: The Fine Points of the Column-View Triangle
This is really tweaky and geeky, but take a look: There’s a tiny triangle ([image: ]) to the right of every folder’s name in column view. It can be either solid dark or hollow.
If you click a folder, that triangle is dark. But if you highlight a folder by typing a few letters of its name, or by pressing the ↑ or ↓ keys, the triangle remains hollow. (At that point, pressing Tab makes it darken.)
Who cares? Well, it actually makes a difference here and there. When the triangle is dark, the Mac is trying to tell you that the next column to the right is actually selected. Pressing ⌘-A (Select All) at this point, for example, highlights all the icons in that next column. If you press the ↑ or ↓ keys, you walk up and down the list in that next column.
[image: image with no caption]

But when the triangle is hollow, you haven’t left the original column. Pressing the arrow keys walks up and down this list, and ⌘-A highlights everything in this list.
It’s subtle. But cool.


	To make all columns as wide as required—when you absolutely, positively don’t want any names truncated—Option-double-click a column’s right-side divider line.



Tip
If you’re having trouble remembering all of those key and click combinations, you’re not alone. Fortunately, you can use a new right-click trick instead.
If you Control-click (or right-click) the divider line at the right side of a column, you get a shortcut menu that offers these commands: Right Size This Column (make it exactly as wide as necessary), Right Size All Columns Individually (make every column exactly as wide as necessary), and Right Size All Columns Equally (make all columns the same width, based on whatever width is necessary to see all the names in the narrowest one).

[image: When you move your cursor close to one of the vertical dividing lines between columns, the cursor becomes a double-headed arrow. That’s a sign that you can now drag that line to adjust the column width.]

Figure 1-22. When you move your cursor close to one of the vertical dividing lines between columns, the cursor becomes a double-headed arrow. That’s a sign that you can now drag that line to adjust the column width.


Grouping the Column Contents



Yes, the Arrange commands are available to column view, too; you can add those gray category headings to the clumps of files in each window. And, once again, you can also use the Sort By commands to change the sequence of files within each grouping. It all works exactly as described on pages 43–47.

View Options



Just as in icon and list view, you can choose View→Show View Options to open a dialog box—a Spartan one, in this case—offering additional control over your column views.
	Always open in column view. Once again, this option lets you override your system-wide preference setting for all windows. See Always open in icon view on page 38 for details.

	Browse in column view. Ensures that any folder inside this one will open up in column view when double-clicked.

	Arrange By, Sort By. You can put column-view icons into arranged groups—and sort them within those groups—just as described on pages 43–47.

	Text size. Whatever point size you choose here affects the type used for icons in all column views.

	Show icons. For maximum speed, turn off this option. Now you see only file names—not the tiny icons next to them—in all column views. Weird!

	Show icon preview. Turn off this option if you don’t want the tiny icons in column view to display their actual contents—photos showing their images, Word and PDF documents showing their first pages, and so on. You get generic, identical icons for each file type (text, photo, or whatever).

	Show preview column. The far-right Preview column can be handy when you’re browsing graphics, sounds, or movie files. Feel free to enlarge this final column when you want a better view of the picture or movie; you can make it really big.
The rest of the time, though, the Preview column can get in the way, slightly slowing down the works and pushing other, more useful columns off to the left side of the window. If you turn off this checkbox, the Preview column doesn’t appear.



Tip
No matter what view you’re in, remember this: If you ever start dragging an icon and then change your mind, just press the Esc key or ⌘-period, even while the mouse button is still down. The icon flies back to its precise starting place. Or, if you’ve already dragged something to a new window and now you regret it, press ⌘-Z (for Undo). Too bad real life doesn’t have a similar feature.



Cover Flow View



Cover Flow is a visual display that Apple stole from its own iTunes software, where Cover Flow simulates the flipping “pages” of a jukebox, or the albums in a record-store bin (Figure 1-23). There you can flip through your music collection, marveling as the CD covers flip over in 3-D space while you browse.
NOSTALGIA CORNER: Everything Old Is New Again
To many observers, OS X’s column view was one of the most radical new features of the operating system. The truth, however, is that it’s not new at all.
In fact, column view’s most recent ancestor appeared in the NeXT operating system, which Apple bought (along with Steve Jobs, its CEO) in 1997. But column view is even older than that.
[image: image with no caption]

As you can see in this sketch from May 1980, the idea of a single-window, multiple-column view had been kicking around at Apple long before the Macintosh debuted.
In the end, this view was deemed too complex for the original Mac, which finally appeared (with only list and icon views) in 1984. Column view took 17 more years to find its way into the standard Mac OS.

The idea is the same in OS X, except that now it’s not album covers you’re flipping; it’s gigantic file and folder icons.
[image: The top half of a Cover Flow window is an interactive, scrolling “record bin” full of your own stuff. It’s especially useful for photos, PDF files, Office documents, and text documents. When a PDF or presentation document comes up in this virtual data jukebox, you can click the arrow buttons to page through it; for a movie, click the little button to play the video, right in place.]

Figure 1-23. The top half of a Cover Flow window is an interactive, scrolling “record bin” full of your own stuff. It’s especially useful for photos, PDF files, Office documents, and text documents. When a PDF or presentation document comes up in this virtual data jukebox, you can click the arrow buttons to page through it; for a movie, click the little [image: ] button to play the video, right in place.

To fire up Cover Flow, open a window. Then click the Cover Flow [image: ] button in the toolbar. Or choose View→as Cover Flow, or press ⌘-4.
Now the window splits. On the bottom: a traditional list view, complete with sortable, arrangeable columns, exactly as described above.
On the top: the gleaming, reflective-black Cover Flow display. Your primary interest here is the scroll bar. As you drag it left or right, you see your files and folders float by and flip in 3-D space. Fun for the whole family!
The effect is spectacular, sure. It’s probably not something you’d want to set up for every folder, though, because browsing is a pretty inefficient way to find something. But in folders containing photos or movies (that aren’t filled with hundreds of files), Cover Flow can be a handy and satisfying way to browse.
And now, notes on Cover Flow:
	You can adjust the size of the Cover Flow display (relative to the list-view half) by dragging up or down on the grip-strip area just beneath the Cover Flow scroll bar.

	Multipage documents, presentation files, movies, and sounds are special. When you point to one, you get either the [image: ] button (to play a movie or sound) or [image: ] and [image: ] arrow buttons (to flip through a PDF, Pages, PowerPoint, or Keynote document), exactly as you can with icons in icon view.

	You can navigate with the keyboard, too. Any icon that’s highlighted in the list view (bottom half of the window) is also front and center in the Cover Flow view. Therefore, you can use all the usual list-view shortcuts to navigate both at once. Use the ↓ and ↑ keys, type the first few letters of an icon’s name, press Tab or Shift-Tab to highlight the next or previous icon alphabetically, and so on.

	Cover Flow shows whatever the list view shows. If you expand a flippy triangle to reveal an indented list of what’s in a folder, then the contents of that folder become part of the Cover Flow.

	The previews are actual icons. When you’re looking at a Cover Flow minidocument, you can drag it with your mouse—you’ve got the world’s biggest target—anywhere you’d like to drag it: another folder, the Trash, wherever.

	You can use the Arrange and Sort commands. Yes, you can put the list-view portion of the window into tidy groupings—and sort within those groupings—just as described on pages 43–47.




Quick Look



As the preceding several thousand pages make clear, there are lots of ways to view and manage the seething mass of files and folders on a typical hard drive. Some of them actually let you see what’s in a document without having to open it—the Preview column in column view, the giant icons in Cover Flow, and so on.
Quick Look takes this idea to another level. It lets you open and browse a document at nearly full size—without switching window views or opening any new programs. You highlight an icon (or several) and then do one of these things:
	Press the space bar. This is by far the best technique to learn. After all, unless you’re editing a file’s name, what’s the space bar ever done for you in the Finder? Nothing. But in OS X, you can highlight any icon and then tap the space bar for an instant preview.

	Tap with three fingers. Here’s a bonus for laptops, and it’s new in Mountain Lion. Tap an icon with three fingers on the trackpad (don’t fully click down) to open its preview.

	Press ⌘ -Y. Another keystroke for the same function. The space bar is still better, though.

	Click the [image: ] icon at the top of the window. But who uses the mouse anymore?

	Choose File → Quick Look.

	Choose Quick Look from the Action menu ([image: ] ) at the top of every Finder window.

	Control-click (or right-click) an icon; from the shortcut menu, choose Quick Look.



You exit Quick Look in any one of these same ways.
Note
Whenever Quick Look appears in a menu or a shortcut menu, its wording changes to reflect the name of the icon. For example, it might say, “Quick Look ‘Secret Diary.doc.’ ”

[image: Once the Quick Look window is open, you can play a file (movies and sounds), study it in more detail (most kinds of graphics files), or even read it (PDF, Word, and Excel documents). You can also click another icon, and another, and another, without ever closing the preview; the contents of the window simply change to reflect whatever you’ve just clicked. Supertip: Quick Look even works on icons in the Trash, so you can figure out what something is before you nuke it forever.]

Figure 1-24. Once the Quick Look window is open, you can play a file (movies and sounds), study it in more detail (most kinds of graphics files), or even read it (PDF, Word, and Excel documents). You can also click another icon, and another, and another, without ever closing the preview; the contents of the window simply change to reflect whatever you’ve just clicked. Supertip: Quick Look even works on icons in the Trash, so you can figure out what something is before you nuke it forever.

In any case, the Quick Look window now opens, showing a gigantic preview of the document (Figure 1-24). Rather nice, eh?
The idea here is that you can check out a document without having to wait for it to open in the traditional way—at full size. For example, you can read the fine text in a Word or PowerPoint document without actually having to open Word or PowerPoint, which saves you about 45 minutes.
Tip
You can use the usual “next page” gesture (two-finger swipe on a trackpad, one-finger swipe on the Magic Mouse) to page through PDF or iWork documents, or to move among photos if you’ve highlighted a whole bunch.

It’s astonishing how few Mac fans are aware of this incredibly useful feature. Learn it!
What Quick Look Knows



You might wonder: How, exactly, is Quick Look able to display the contents of a document without opening it? Wouldn’t it have to somehow understand the internal file format of that document type?
Exactly. And that’s why Quick Look doesn’t recognize all documents. If you try to preview, for example, a Final Cut Pro video project, a sheet-music file, a .zip archive, or a database file, all you’ll see is a six-inch-tall version of its generic icon. You won’t see what’s inside.
Over time, people will write plug-ins for those nonrecognized programs. Already, plug-ins that let you see what’s inside folders and .zip files await at www.qlplugins.comand www.quicklookplugins.com. In the meantime, here’s what Quick Look recognizes right out of the box:
	Graphics files and photos. This is where Quick Look can really shine, because it’s often useful to get a quick look at a photo without having to haul iPhoto or Photoshop out of bed. Quick Look recognizes all common graphics formats, including TIFF, JPEG, GIF, PNG, RAW, and Photoshop documents.

	PDF and text files. Using the scroll bar, you can page through multipage documents, right there in the Quick Look window.

	Audio and movie files. These begin to play instantly when you open them into the Quick Look window. Most popular formats are recognized (MP3, AIFF, AAC, MPEG-4, H.264, and so on). A scroll bar appears so that you can jump around in the movie or song.

	Pages, Numbers, Keynote, and TextEdit documents. Naturally, since these are Apple programs, Quick Look understands the document formats.

	Microsoft Word, Excel, and PowerPoint documents. Because these formats are so common, OS X comes with a Quick Look plug-in to recognize them. Move through the pages using the vertical scroll bar; switch to a different Excel spreadsheet page using the Sheet tabs at the bottom.

	Fonts. Totally cool. When you open a font file in Quick Look, you get a crystal-clear, huge sampler that shows every letter of the alphabet in that typeface.

	vCards. A vCard is an address-book entry that people can send one another by email to save time in updating their Rolodexes. When you drag a name out of Apple’s or Microsoft’s address books and onto the desktop, for example, it turns into a vCard document. In Quick Look, the vCard opens up as a handsomely formatted index card that displays all the person’s contact information.

	HTML (Web pages) and Safari archived pages. If you’ve saved some Web pages to your hard drive, here’s a great way to inspect them without firing up your Web browser.



In fact, Quick Look has started seeping even faster into other programs—not just the Finder. For example, you can preview any of the following:
	A link in a Mail message. In Mail, there’s a tiny [image: ] next to each Web link. Click it to view the actual Web page it leads to, right there in a pop-up bubble!

	An address in Mail or Safari. If you ever see a street address in an email message or on a Web page, click the tiny [image: ] next to it. You’re offered the options to add this person to your address book, or to see a map of that address in Safari, courtesy of Google Maps.

	An address in Contacts. In the Contacts program, click the label for an address (like “Work” or “Home”); from the shortcut menu, choose Map This Address. You get to see, once again, an aerial photo of that spot in Safari, thanks to Google.

	Anything in the Spotlight menu. When you use the Spotlight search feature described in Chapter 3, point to anything in the results menu without clicking. In a moment, a big Quick Look bubble pops out to the left, showing what’s actually in that document or file.

	Anything in Mission Control, or a Dock menu. You can also tap the space bar to get a Quick Look preview of anything in the Mission Control view (Mission Control: Death to Window Clutter) or the stack, list, or grid of a Dock folder (Pop-up Dock Folders (“Stacks”)).
And you were alive to see the day!




Fun with Quick Look



Here are some stunts that make Quick Look even more interesting:
	Full screen. When you click the Full Screen button ([image: ]), the Quick Look window expands to fill your screen. Keep this trick in mind when you’re trying to read Word, Excel, or PDF documents, since the text is usually too small to read otherwise. (When you’re finished with the closeup, click the Full Screen button again to restore the original Quick Look window, or the [image: ] button to exit Quick Look altogether.)
Tip
How’s this for an undocumented shortcut? If you press Option-space bar, or Option-click the eyeball icon in any Finder window, you go straight into Full Screen mode without having to open the smaller Quick Look window first. Kewl.
(OK, this is actually part of the slideshow feature described below, but it’s also good for super-enlarging a single icon.)


	Share it. Click the [image: ] button in the title bar to open the new Share pop-up menu—a quick way to send this document onto somebody or post it online.

	Open with [Program Name]. This button shows up at the top-right corner of your Quick Look window. It might say, for example, “Open with Preview.”
Handy, really. It says: “Oh, so you’ve been Quick-Looking to find a particular document, and this is the one you wanted? Click me to jump directly into the program that opens it, so you can get to work reading or editing. I’ve just saved you having to close the window and double-click the icon.”
Tip
Actually, you have a much bigger target than the “Open with” button in the corner. You can double-click anywhere in the Quick Look window to open the document (in whatever program is named on the “Open with” button).

Better yet: If you click and hold your cursor on that “Open with” button, you get a secret pop-up menu of other programs that could open the file you’re looking at.

	Keep it going. Once you’ve opened Quick Look for one icon, you don’t have to close it before inspecting another icon. Just keep clicking different icons (or pressing the arrow keys to walk through them); the Quick Look window changes instantly with each click to reflect the new document.




The Quick Look Slideshow



OS X is supposed to be all about graphics and other visual delights. No wonder, then, that it offers a built-in, full-screen slideshow feature.
It works like this: Highlight a bunch of icons, and then open Quick Look. Click the [image: ] (Full Screen) button in the top right corner. The screen goes black, and the documents begin their slideshow. Each image appears on the screen for about 3 seconds before the next one appears. (Press the Esc key or ⌘-period to end the show.) It plays all documents it recognizes, not just graphics.
It’s a useful feature when you’ve just downloaded or imported a bunch of photos or Office documents and want a quick look through them. Use the control bar shown in Figure 1-25 to manage the playback.
[image: Once the slideshow is under way, you can use this control bar. It lets you pause the slideshow, move forward or backward manually, enlarge the current “slide” to fill the screen, or end the show. (The iPhoto button appears only when displaying photos.) The Index view is especially handy. (You can press ⌘-Return to “click” the Index View button.) It displays an array of labeled miniatures, all at once—a sort of Exposé for Quick Look. Click a thumbnail to jump directly to the Quick Look document you want to inspect.]

Figure 1-25. Once the slideshow is under way, you can use this control bar. It lets you pause the slideshow, move forward or backward manually, enlarge the current “slide” to fill the screen, or end the show. (The iPhoto button appears only when displaying photos.) The Index view is especially handy. (You can press ⌘-Return to “click” the Index View button.) It displays an array of labeled miniatures, all at once—a sort of Exposé for Quick Look. Click a thumbnail to jump directly to the Quick Look document you want to inspect.

Note
This same slideshow mechanism is available for graphics in Preview and Mail; Preview even offers crossfades between pictures.



Logging Out, Shutting Down



If you’re the only person who uses your Mac, finishing up a work session is simple. You can either turn off the machine or simply let it go to sleep, in any of several ways.
Sleep Mode



If you’re still shutting down your Mac after each use, you may be doing a lot more waiting than necessary. Sleep mode consumes very little power, keeps everything you were doing open and available, and wakes up almost immediately when you press a key or click the mouse.
To make your machine sleep, do one of the following:
	Close the lid. (Hint: This tip works primarily on laptops.)

	Choose [image: ]→Sleep. Or press Option-⌘-[image: ].

	Press Control-[image: ]. In the dialog box shown in Figure 1-26, click Sleep (or type S).
[image: Once the Shut Down dialog box appears, you can press the S key instead of clicking Sleep, R for Restart, Esc for Cancel, or Return for Shut Down.]

Figure 1-26. Once the Shut Down dialog box appears, you can press the S key instead of clicking Sleep, R for Restart, Esc for Cancel, or Return for Shut Down.


	Press the power button ([image: ] ) on your machine. On desktop models, doing so makes it sleep immediately; on laptops, you get the dialog box shown in Figure 1-26.

	Hold down the Play/Pause button on your remote for 3 seconds. Many Mac models used to come with Apple’s tiny white remote control.

	Just walk away, confident that the Energy Saver setting in System Preferences will send the machine off to dreamland automatically at the specified time.



Tip
Ordinarily, closing your MacBook’s lid means putting it to sleep. And, ordinarily, putting it to sleep means cutting it off fromtthe world. In Mountain Lion, though, a new feature called Power Nap lets your Mac stay connected to your network and to the Internet, even while it’s otherwise sleeping. It can download email, back up your stuff, download software updates, and so on. For details, see Checkbox Options.


Restart



You shouldn’t have to restart the Mac very often—only in times of severe troubleshooting mystification, in fact. Here are a few ways to do it:
	Choose [image: ]→Restart. A confirmation dialog box appears; click Restart (or press Return).
Tip
If you press Option as you release the mouse on the [image: ]→Restart command, you won’t be bothered by an “Are you sure?” confirmation box.


	Press Control-⌘-[image: ].

	Press Control-[image: ] to summon the dialog box shown in Figure 1-26; click Restart (or type R).




Shut Down



To shut down your machine completely (when you don’t plan to use it for more than a couple of days, when you plan to transport it, and so on), do one of the following:
	Choose[image: ]→Shut Down. A simple confirmation dialog box appears; click Shut Down (or press Return).
Tip
Once again, if you press Option as you release the mouse, no confirmation box appears.


	Press Control-Option- ⌘ -[image: ]. (It’s not as complex as it looks—the first three keys are all in a tidy row to the left of the space bar.)

	Press Control-[image: ] to summon the dialog box shown in Figure 1-26. Click Shut Down (or press Return).

	Wait. If you’ve set up the Energy Saver preferences (Color Tab) to shut down the Mac automatically at a specified time, then you don’t have to do anything.




The “Reopen windows” option



In the Shut Down dialog box illustrated in Figure 1-26, you’ll notice one of Lion/Mountain Lion’s most-hyped new features: a checkbox called “Reopen windows when logging back in.” That simple box does something very useful: The next time you start up your Mac, every running program, and every open window, will reopen exactly as they were at the moment you used the Restart or Shut Down command. The new option gives the Mac something like the old Hibernate feature in Windows—and saves you a lot of reopening the next time you sit down to work.
If you turn off that checkbox when you click Restart or Shut Down, then your next startup will take you to the desktop, with no programs running, as though this were still some year between 1984 and 2010. And if you want the Mac to stop asking—if you never want your programs and windows to reopen—open [image: ]→System Preferences→General, and turn off “Restore windows when quitting and re-opening apps.”

Log Out



If you share your Mac, then you should log out when you’re done. Doing so ensures that your stuff is safe from the evil and the clueless even when you’re out of the room. To do it, choose [image: ]→Log Out Casey (or whatever your name is). Or, if you’re in a hurry, press Shift-⌘-Q.
When the confirmation dialog box appears, click Log Out (or press Return) or just wait for 1 minute (a message performs the countdown for you). The Mac hides your world from view and displays the Log In dialog box, ready for its next victim.
Tip
Last time: If you press Option as you release the mouse on the [image: ]→Log Out command, you squelch the “Are you sure?” box.

Logging out is described in much more detail in Chapter 13.


Getting Help in OS X



It’s a good thing you’ve got a book about OS X in your hands, because the only user manual you get with it is the Help menu, a browser-like program that reads a set of help files that reside in your System→Library folder.
Tip
In fact, you may not even be that lucky. The general-information help page about each topic is on your Mac, but thousands of the more technical pages reside online and require an Internet connection to read.

You’re expected to find the topic you want in one of these three ways:
	Use the search box. When you click the Help menu, a tiny search box appears just beneath your cursor (Figure 1-27). You can type a few words here to specify what you want help with: “setting up printer,” “disk space,” whatever.
Tip
You can also hit ⌘-Shift-/ (that is, ⌘-?) to open the help search box. And you can change that keystroke, if you like, in System Preferences→Keyboard.

[image: You don’t have to open the Help program to begin a search. No matter what program you’re in, typing a search phrase into the box shown here produces an instantaneous list of help topics, ready to read.]

Figure 1-27. You don’t have to open the Help program to begin a search. No matter what program you’re in, typing a search phrase into the box shown here produces an instantaneous list of help topics, ready to read.

After a moment (sometimes several moments), the menu becomes a list of Apple help topics pertaining to your search. Click one to open the Help browser described next; you’ve just saved some time and a couple of steps.
Tip
The results menu does not, however, show all of Help’s results—only the ones Apple thinks are most relevant. If you choose Show All Help Topics at the bottom of the menu, the Help browser opens (described below). It shows a more complete list of Help search results.


	Drill down. Alternatively, you can begin your quest for assistance the old-fashioned way: by opening the Help browser first. To do that, choose Help→Help Center. (That’s the wording in the Finder. In other programs, it might say, for example, “Mail Help.” Either way, this command appears only when nothing is typed in the search box. To empty the search box, click the [image: ] button at the right end.)
After a moment, you arrive at the Help browser program shown at top in Figure 1-28. The starting screen offers several “quick click” topics that may interest you—presumably the ones that trigger the most help-hotline calls to Apple. If so, keep clicking text headings until you find a topic you want to read.
GEM IN THE ROUGH: Menu Help in the Help Menu
OS X contains a weird, wonderful little enhancement to its online help system. It helps you find menu commands you can’t find.
You’re floundering in some program. You’re sure there’s a page numbering command in those menus somewhere. But there are 11 menus, and 143 submenus hiding in those menus, and you haven’t got time for the pain.
That’s when you should think of using the Help menu. When you type page number (or whatever) into its search box, the results menu lists, at the top, the names of any menu commands in that program that contain the words you typed. Better still, it actually opens that menu for you, and displays a big, blue, animated, floating arrow pointing to the command you wanted. You’d have to have your eyes closed to miss it.
Simply slide your cursor over, click the menu command you wanted, and get on with your life.
[image: image with no caption]

Supertip: This feature is especially helpful in Web browsers like Safari and Firefox, because it even finds entries in your Bookmarks and History menus!
In Safari, for example, you can pluck a recently visited site out of the hundreds in the daily History submenus, like the “Wednesday, January 4” submenu. You’ve just saved yourself a lot of poking around menus, trying to find the name of a site you know you’ve seen recently.
Ultratip: If you think about it, this feature also means you have complete keyboard power over every menu in every program in the world. Hit ⌘-Shift-/ (that is, ⌘-?) to open the Help search box, type a bit of the command’s name, and then use the arrow keys to walk down the results. Hit Return to trigger the command you want.

You can backtrack by clicking the [image: ] button at the top of the window. And you can always return to the starting screen by clicking the little [image: ] icon at the top.
Tip
Annoyingly, the help window still insists on floating in front of all other windows; you can’t send it to the back like any normal program. Therefore, consider making the window tall and skinny, so you can put it beside the program you’re working in. Drag any edge of the box to change the window’s shape.

[image: The Help Center likes to help with big-ticket computer tasks like joining a network, setting up your email program, or browsing the Web. Once you click a top-tier topic (top), you get a details page (bottom) that offers a list of more finely grained step-by-steps.The Help windows try to be helpful by floating stubbornly in front of all your other windows. That, actually, can be frustrating, since you can’t see the software you’re reading about. Best solution is to make the window narrow and park it at the edge of your screen.]

Figure 1-28. The Help Center likes to help with big-ticket computer tasks like joining a network, setting up your email program, or browsing the Web. Once you click a top-tier topic (top), you get a details page (bottom) that offers a list of more finely grained step-by-steps. The Help windows try to be helpful by floating stubbornly in front of all your other windows. That, actually, can be frustrating, since you can’t see the software you’re reading about. Best solution is to make the window narrow and park it at the edge of your screen.


	Use the “Search Help” blank. Type the phrase you want, like printing or switching applications, into the search box at the top of the window, and then press Return. As you type, a list of proposed matches drops down from the Search box. When you click the closest match, you’re shown a list of help-screen topics that may pertain to what you need; see Figure 1-28 for details.



Note
Actually, there’s one more place where Help crops up: in System Preferences dialog boxes. Click the circled question-mark button ([image: ]) in the lower-right corner of most System Preferences panels to open a help page that identifies each control.

Along the way, keep in mind that you can always bookmark useful Help pages for quick reference later, saving you the trouble of searching or burrowing the next time (Figure 1-29).
[image: Click the new Add Bookmark icon () to flag a page for quick finding later (left). When that later time comes, click the Bookmarks icon () to see a list of all your saved bookmarks; double-click one to jump to its page.]

Figure 1-29. Click the new Add Bookmark icon ([image: ]) to flag a page for quick finding later (left). When that later time comes, click the Bookmarks icon ([image: ]) to see a list of all your saved bookmarks; double-click one to jump to its page.


Chapter 2. Organizing Your Stuff




The OS X Folder Structure



For the first 20 years of the Mac’s existence, you began your workday by double-clicking the Macintosh HD icon in the upper-right corner of the screen. That’s where you kept your files.
These days, though, you’d be disappointed if you did that. All you’ll find in the Macintosh HD window is a set of folders called Applications, Library, Users, and so on—folders you didn’t put there.
Most of these folders aren’t very useful to you, the Mac’s human companion. They’re there for OS X’s own use—which is why, today, the Macintosh HD icon doesn’t even appear on the screen. (At least not at first; you can choose Finder→Preferences and turn the “Hard disks” checkbox back on, if you really want to.)
Think of your main hard drive window as storage for the operating system itself, which you’ll access only for occasional administrative purposes.
Your Home Folder



So where is your nest of files, folders, and so on? All of it, everything of yours on this computer, lives in the Home folder. That’s a folder bearing your name (or whatever name you typed in when you installed OS X).
OS X is rife with shortcuts for opening this all-important folder:
	Choose Go→Home, or press Shift-⌘-H.

	In the Sidebar (Disk icons on the desktop), click the [image: ] icon.



You might also consider adding your Home folder to the Dock (The Dock) or making it the window that appears when you press ⌘-N or choose File→New Finder Window (see Old Finder Mode).
All these steps open your Home folder directly.
If you’re the compulsive sort, you can also navigate to it the long way: Double-click the Users folder, and then double-click the folder inside it that bears your name and looks like a house (see Figure 2-1).
[image: This is it: the folder structure of OS X. For the most part, what you care about are the Applications folder in the main hard drive window and your own Home folder. If you have an administrator account, you can save your documents and park your icons almost anywhere.]

Figure 2-1. This is it: the folder structure of OS X. For the most part, what you care about are the Applications folder in the main hard drive window and your own Home folder. If you have an administrator account, you can save your documents and park your icons almost anywhere.

So why has Apple demoted your files to a folder three levels deep? The answer may send you through the five stages of grief—denial, anger, bargaining, depression, and, finally, acceptance—but if you’re willing to go through it, much of the mystery surrounding OS X will fade away.
OS X has been designed from the ground up for computer sharing. It’s ideal for any situation where different family members, students, or workers share the same Mac.
Each person who uses the computer will turn on the machine to find his own separate desktop picture, set of files, Web bookmarks, font collection, and preference settings. (You’ll find much more about user accounts in Chapter 13.)
Like it or not, OS X considers you one of these people. If you’re the only one who uses this Mac, fine—simply ignore the sharing features. (You can also ignore all that business at the beginning of Chapter 1 about logging in.) But in its little software head, OS X still considers you an account holder and stands ready to accommodate any others who should come along.
In any case, now you should see the importance of the Users folder in the main hard drive window. Inside are folders—the Home folders—named for the different people who use this Mac. In general, nobody is allowed to touch what’s inside anybody else’s folder.
If you’re the sole proprietor of the machine, of course, there’s only one Home folder in the Users folder—named for you. (The Shared folder doesn’t count; it’s described on Sharing Across Accounts.)
Yes, OS X imposes a fairly rigid folder structure. But by keeping such tight control over which files go where, OS X keeps itself pure—and very, very stable. Furthermore, keeping all your stuff in a single folder makes it very easy for you to back up your work. It also makes life easier when you try to connect to your machine from elsewhere in the office (over the network) or elsewhere in the world (over the Internet), as described in Chapter 21.

What’s on Your Hard Drive



If you did want to explore the entirety of OS X, to examine the contents of your hard drive (choose Go→Computer and double-click “Macintosh HD”), you’d find the following folders in the main hard drive window:
	Applications. This folder contains the complete collection of OS X programs on your Mac (not counting the invisible Unix ones). Even so, you’ll rarely open programs by opening this folder; the Dock is a far more efficient launcher, as described in Chapter 4.

	Library. This folder bears more than a passing resemblance to the System Folder subfolders of Macs gone by, or the Windows folder on PCs. It stores components for the operating system and your programs (sounds, fonts, preferences, help files, printer drivers, modem scripts, and so on).
UP TO SPEED: The Computer Window
In your explorations of the Finder’s Go menu, you may have wondered about the command called Computer (Shift-⌘-C). (“Go to Computer? Jeez, I thought I was already at my computer!”)
As in Microsoft Windows, the Computer window holds the icons for all the disks connected to your machine—the hard drive, a CD that you’ve inserted, an iPod, another external hard drive, and so on—as well as an icon called Network. (The Network icon appears even if you’re not, in fact, on a network.) This is the topmost level of your Mac. This is the stuff that can’t be put into any folder at all.
So what’s it for? In some ways, the Computer window is redundant. After all, OS X displays your disk icons on the desktop and in the Sidebar.
But some people, particularly Windows refugees, don’t care for that icons-on-the-desktop feature. In the interest of creating a neater, cleaner desktop, they turn it off (by choosing Finder→Preferences and turning off the three checkboxes under “Show these items on the Desktop”). Furthermore, in the interest of creating neater windows, some people also hide the Sidebar.
In that case, the Computer window still provides access to all your disks.
Otherwise, the Computer window really doesn’t serve much purpose except as a familiar landmark to Windows veterans and Mac fans who grew used to it in the era before the Sidebar came along.


	System. This is Unix, baby. These are the actual files that turn on your Mac and control its operations. You’ll rarely have any business messing with this folder.

	User Information. Here’s a link to a folder that contains random Getting Started guides from Apple, including a user guide for your particular Mac.

	Users. As noted earlier, this folder stores the Home folders for everyone who uses this machine.

	Your old junk. If you upgraded your Mac from an earlier Mac operating system, then your main hard drive window also lists whatever folders you kept there.




What’s in Your Home Folder



Within the folder that bears your name, you’ll find another set of standard Mac folders. (The Mac considers them holy: they have special logos on their folder icons, and you can’t rename them.) OS X creates these folders solely as a convenience:
	Desktop. When you drag an icon out of a window and onto your OS X desktop, it may appear to show up on the desktop. But that’s just an optical illusion, a visual convenience. In truth, nothing in OS X is really on the desktop. It’s actually in this Desktop folder, and mirrored on the desktop area.
The reason is simple enough: Everyone who shares your machine will, upon logging in, see his own stuff sitting on the desktop. Now you know how OS X does it: There’s a separate Desktop folder in every person’s Home folder.
Tip
The fact that the desktop is actually a folder is handy, because it gives you a sneaky way to jump to your Home folder from anywhere. Simply click the desktop background and then press ⌘-↑ (which is the keystroke for Go→Enclosing Folder). Because that keystroke means “open whatever folder contains the one I’m examining,” it instantly opens your Home folder. (Your Home folder is, of course, the “parent” of your Desktop folder.)

UP TO SPEED: The Wacky Keystrokes of OS X
OS X offers a glorious assortment of predefined keystrokes for jumping to the most important locations on your Mac: your Home folder, the Applications folder, the Utilities folder, the Computer window, your iDisk, the Network window, and so on.
Better yet, the keystrokes are incredibly simple to memorize: Just press Shift-⌘ and the first letter of the location you want. Shift-⌘-H opens your Home folder, Shift-⌘-A opens the Applications folder, and so on. You learn one, you’ve learned ’em all. The point here is that Shift-⌘ means places.
The other system-wide key combo, Option-⌘, means functions. For example, Option-⌘-D hides or shows the Dock, Option-⌘-H is the Hide Others command, Option-⌘-+ magnifies the screen (if you’ve turned on this feature), Option-⌘-Esc brings up the Force Quit dialog box, and so on. Consistency is always nice.


	Documents. Apple suggests that you keep your actual work files in this folder. Sure enough, whenever you save a new document (when you’re working in Keynote or Word, for example), the Save As box proposes storing the new file in this folder, as described in Chapter 5.
Your programs may also create folders of their own here. For example, you may find a Microsoft User Data folder for your Outlook/Entourage email, a Virtual Machines folder for use with VMware Fusion, and so on.

	Library. As noted earlier, the main Library folder (the one in your main hard drive window) contains folders for fonts, preferences, help files, and so on.
You have your own Library folder, too, in your Home folder. It stores the same kinds of things—but they’re your fonts, your preferences.
Note
In Mountain Lion, your own Library folder is invisible. But as you’ll soon learn as you peruse this book, having access to it is frequently useful. That’s why Apple gave you a sneaky way to open it even when it’s invisible: Press Option as you open the Go menu in the Finder; choose Library (which doesn’t appear in the menu until you press Option).

Once again, this setup may seem redundant if you’re the only person who uses your Mac. But it makes perfect sense in the context of families, schools, or offices where numerous people share a single machine. Because you have your own Library folder, you can have a font collection that’s “installed” on the Mac only when you’re using it. Each person’s program preference files (the files that determine where Photoshop’s palettes appear, and so on) are stored independently, too. And each person, of course, sees her own email when launching OS X’s Mail program—because mail, too, is generally stored in your personal Library folder.
Other Library folders store your Bookmarks, Web browser plug-ins and cached Web pages, keyboard layouts, sound files, and so on.
FREQUENTLY ASKED QUESTION: Printing a Window—or a List of Files
In Mac OS 9, I could print a Finder window. I’d get a neat list of the files, which I could use as a label for a CD I was going to burn, or whatever. How do I print a Finder window in OS X? (The File→Print command prints a selected document, not the list of files in a window.)
It’s easy enough to make a list of files for printing. Once the window is open on your screen, choose Edit→Select All. Choose Edit→Copy. Now switch to a word processor and paste. (If you’re using TextEdit, use Edit→Paste and Match Style instead.) You get a tidy list of all the files in that window, ready to format and print.
This simple file name list isn’t the same as printing a window; you don’t get the status bar showing how many items are on the disk and how full the disk is. For that purpose, you can always make a screenshot of the window (Screen-Capture Keystrokes) and print that. Of course, that technique is no good if the list of files is taller than the window itself.
Really, what you want is Print Window, a handy shareware program dedicated to printing out your Finder windows, without these workarounds and limitations. You can download it from this book’s “Missing CD” page at www.missingmanuals.com.


	Movies, Music, Pictures. The various OS X programs that deal with movies, music, and pictures will propose these specialized folders as storage locations. For example, when you plug a digital camera into a Mac, the iPhoto program automatically begins to download the photos on it—and stores them in the Pictures folder. Similarly, iMovie is programmed to look for the Movies folder when saving its files, and iTunes stores its audio files in the Music folder.

	Public. If you’re on a network, or if others use the same Mac when you’re not around, this folder can be handy: It’s the “Any of you guys can look at these files” folder. Other people on your network, as well as other people who sit down at this machine, are allowed to see whatever you’ve put in here, even if they don’t have your password. Details on sharing the Mac are in Chapter 13, and those on networking are in Chapter 14.

	Sites. OS X used to have a built-in Web server, software that turns your Mac into a Web site that people on your network—or, via the Internet, all over the world—can connect to. This OS X feature relied on a program called the Apache Web server, which is so highly regarded in the Unix community that programmers lower their voices when they mention it.
The Web server is gone in Mountain Lion, as described in Chapter 21. If you have a Sites folder, it’s where you put the actual Web pages you wanted to make available to the Internet at large—in a previous version of OS X.





Icon Names



Every document, program, folder, and disk on your Mac is represented by an icon: a colorful little picture that you can move, copy, or double-click to open. In OS X, icons look more like photos than cartoons, and you can scale them to practically any size.
An OS X icon’s name can have up to 255 letters and spaces. If you’re accustomed to the 31-character or even eight-character limits of older computers, that’s quite a luxurious ceiling.
If you’re used to Windows, you may be delighted to discover that in OS X, you can name your files using letters, numbers, punctuation—in fact, any symbol except the colon (:), which the Mac uses behind the scenes for its own folder-hierarchy designation purposes. And you can’t use a period to begin a file’s name.
To rename a file, click its name or icon (to highlight it) and then press Return. (Or, if you have time to kill, click once on the name, wait a moment, and then click a second time.)
In any case, a rectangle appears around the name (Figure 2-2). At this point, the existing name is highlighted; just begin typing to replace it. If you type a very long name, the rectangle grows vertically to accommodate new lines of text.
Tip
If you simply want to add letters to the beginning or end of the file’s existing name, press the ← or → key after pressing Return. The insertion point jumps to the beginning or end of the file name.

[image: Click an icon’s name (top left) to produce the renaming rectangle (top right), in which you can edit the file’s name. OS X is kind enough to highlight only the existing name, and not the suffix (like .jpg or .doc).Now begin typing to replace the existing name (bottom left). When you’re finished typing, press Return, Enter, or Tab to seal the deal, or just click somewhere else.]

Figure 2-2. Click an icon’s name (top left) to produce the renaming rectangle (top right), in which you can edit the file’s name. OS X is kind enough to highlight only the existing name, and not the suffix (like .jpg or .doc). Now begin typing to replace the existing name (bottom left). When you’re finished typing, press Return, Enter, or Tab to seal the deal, or just click somewhere else.

You can give more than one file or folder the same name, as long as they’re not in the same folder. For example, you can have as many files named “Chocolate Cake Recipe” as you like, provided each is in a different folder. And, of course, files called Recipe.doc and Recipe.xls can coexist in a folder, too.
As you edit a file’s name, remember that you can use the Cut, Copy, and Paste commands in the Edit menu to move selected bits of text around, just as though you were word processing. The Paste command can be useful when, for instance, you’re renaming many icons in sequence (Quarterly Estimate 1, Quarterly Estimate 2…).
And now, a few tips about renaming icons:
	When the Finder sorts files, a space is considered alphabetically before the letter A. To force a particular file or folder to appear at the top of a list view window, insert a space (or an underscore) before its name.

	Older operating systems sort files so that the numbers 10 and 100 come before 2, the numbers 30 and 300 come before 4, and so on. You wind up with alphabetically sorted files like this: “1. Big Day,” “10. Long Song,” “2. Floppy Hat,” “20. Dog Bone,” “3. Weird Sort,” and so on. Generations of computer users have learned to put zeros in front of their single-digit numbers just to make the sorting look right.
In OS X, though, you get exactly the numerical list you’d hope for: “1. Big Day,” “2. Floppy Hat,” “3. Weird Sort,” “10. Long Song,” and “20. Dog Bone.”

	In addition to letters and numbers, OS X also assigns punctuation marks an “alphabetical order,” which is this: ` (the accent mark above the Tab key), ^, _, -, space, —, —, comma, semicolon, !, ?, ‘, “, (, ), [, ], {, }, @, *, /, &, #, %, +, <, =, ≠, >, |, ~, and $. Numbers come after punctuation; letters come next; and bringing up the rear are these characters: μ (Option-M); π (Option-P); Ω (Option-Z), and [image: ] (Shift-Option-K).

	When it comes time to rename files en masse, add-on shareware can help you. A Better Finder Rename, for example, lets you manipulate file names in a batch—numbering them, correcting a spelling in dozens of files at once, deleting a certain phrase from their names, and so on. You can download this shareware from this book’s “Missing CD” page at www.missingmanuals.com.




Selecting Icons



To highlight a single icon in preparation for printing, opening, duplicating, or deleting, click the icon once. (In a list or column view, as described in Chapter 1, you can also click on any visible piece of information about that file—its size, kind, date modified, and so on.) Both the icon and the name darken in a uniquely OS Xish way.
Tip
You can change the color of the oval highlighting that appears around the name of a selected icon. Choose [image: ]→System Preferences, click General, and use the Highlight Color pop-up menu.

That much may seem obvious. But most first-time Mac users have no idea how to manipulate more than one icon at a time—an essential survival skill in a graphic interface like the Mac’s.
[image: You can highlight several icons simultaneously by dragging a box around them. To do so, drag from outside the target icons diagonally across them, creating a translucent gray rectangle as you go. Any icons or icon names touched by this rectangle are selected when you release the mouse. If you press the Shift or ⌘ key as you do this, then any previously highlighted icons remain selected.]

Figure 2-3. You can highlight several icons simultaneously by dragging a box around them. To do so, drag from outside the target icons diagonally across them, creating a translucent gray rectangle as you go. Any icons or icon names touched by this rectangle are selected when you release the mouse. If you press the Shift or ⌘ key as you do this, then any previously highlighted icons remain selected.

Selecting by Clicking



To highlight multiple files in preparation for moving or copying, use one of these techniques:
	Highlight all the icons. To select all the icons in a window, press ⌘-A (the equivalent of the Edit→Select All command).

	Highlight several icons by dragging. You can drag diagonally to highlight a group of nearby icons, as shown in Figure 2-3. In a list view, in fact, you don’t even have to drag over the icons themselves—your cursor can touch any part of a file’s row, like its modification date or file size.
Tip
If you include a particular icon in your diagonally dragged group by mistake, ⌘-click it to remove it from the selected cluster.


	To highlight consecutive icons in a list. If you’re looking at the contents of a window in list view or column view, you can drag vertically over the file and folder names to highlight a group of consecutive icons, as described above. (Begin the drag in a blank spot.)
There’s a faster way to do the same thing: Click the first icon you want to highlight, and then Shift-click the last file. All the files in between are automatically selected, along with the two icons you clicked. Figure 2-4 illustrates the idea.
[image: Left: To select a block of files in list view, click the first icon. Then, while pressing Shift, click the last one. OS X highlights those files and all the files in between your clicks. This technique mirrors the way Shift-clicking works in a word processor and in many other kinds of programs.Right: To remove one of the icons from your selection, ⌘-click it.]

Figure 2-4. Left: To select a block of files in list view, click the first icon. Then, while pressing Shift, click the last one. OS X highlights those files and all the files in between your clicks. This technique mirrors the way Shift-clicking works in a word processor and in many other kinds of programs. Right: To remove one of the icons from your selection, ⌘-click it.


	To highlight random icons. If you want to highlight only the first, third, and seventh icons in a window, for example, start by clicking icon No. 1. Then ⌘-click each of the others (or ⌘-drag new rectangles around them). Each icon darkens to show that you’ve selected it.
If you’re highlighting a long string of icons and click one by mistake, you don’t have to start over. Instead, just ⌘-click it again so the dark highlighting disappears. (If you do want to start over, you can deselect all selected icons by clicking any empty part of the window—or by pressing the Esc key.) The ⌘ key trick is especially handy if you want to select almost all the icons in a window. Press ⌘-A to select everything in the folder, then ⌘-click any unwanted icons to deselect them.



Tip
In icon view, you can either Shift-click or ⌘-click to select multiple individual icons. But you may as well just learn to use the ⌘ key when selecting individual icons. That way you won’t have to use a different key in each view.

Once you’ve highlighted multiple icons, you can manipulate them all at once. For example, you can drag them en masse to another folder or disk by dragging any one of the highlighted icons. All other highlighted icons go along for the ride. This technique is especially useful when you want to back up a bunch of files by dragging them onto a different disk, delete them all by dragging them to the Trash, and so on.
When multiple icons are selected, the commands in the File and Edit menus—like Duplicate, Open, and Make Alias—apply to all of them simultaneously.
Tip
Don’t forget that you can instantly highlight all the files in a window (or on the desktop) by choosing Edit→Select All (⌘-A)—no icon-clicking required.


Selecting Icons from the Keyboard



For the speed fanatic, using the mouse to click an icon is a hopeless waste of time. Fortunately, you can also select an icon by typing the first few letters of its name.
When looking at your Home window, for example, you can type M to highlight the Movies folder. And if you actually intended to highlight the Music folder instead, then press the Tab key to highlight the next icon in the window alphabetically. Shift-Tab highlights the previous icon alphabetically. Or use the arrow keys to highlight a neighboring icon.
(The Tab-key trick works only in icon, list, and Cover Flow views—not column view, alas. You can always use the ← and → keys to highlight adjacent columns, however.)
After highlighting an icon this way, you can manipulate it using the commands in the File menu or their keyboard equivalents: Open (⌘-O), put it into the Trash (⌘-Delete), Get Info (⌘-I), Duplicate (⌘-D), or make an alias (⌘-L), as described later in this chapter. By turning on the special disability features described on Accessibility, you can even move the highlighted icon using only the keyboard.
If you’re a first-time Mac user, you may find it excessively nerdy to memorize key strokes for jobs the mouse can do. If you make your living using the Mac, however, memorizing these keystrokes will reward you immeasurably with speed and efficiency.


Moving and Copying Icons



In OS X, there are two ways to move or copy icons from one place to another: by dragging them and by using the Copy and Paste commands.
Copying by Dragging



You can drag icons from one folder to another, from one drive to another, from a drive to a folder on another drive, and so on. (When you’ve selected several icons, drag any one of them; the others tag along.) As you drag, you see the ghostly images of all the selected icons moving with your cursor. And the cursor itself sprouts a circled number that reminds you how many files you’re moving.
Tip
You can tell that the copying is under way even if the progress bar is hidden. In Mountain Lion, a tiny progress bar appears right on the icon of the copied material in its new home. You can cancel the process either by pressing ⌘-period or by clicking the [image: ] in the progress window.

GEM IN THE ROUGH: Smart Handling of Identically Named Icons
What if you’re dragging a file or folder into some window—and there’s already a file or folder there with the same name?
In operating systems in days of yore, a warning message appeared. It let you Stop (the whole operation) or Replace (the existing items with the ones you were moving).
Mountain Lion is just a little bit smarter. It offers a third option: Keep Both.
For example, if you drag or paste files of the same name, you’re offered a button called Keep Both Files. If you click it, OS X adds the number 2 (or 3, or 4…) to the end of the incoming file’s name, so you can tell it apart from the existing one in the destination.
Tip: If you’re dragging several files whose names match existing files in the destination folder, then OS X asks you individually about each one (Stop, Replace, Keep Both Files?). If you intend to answer the same way for every single file, save yourself the insanity by turning on the “Apply to all” checkbox before answering the question.
[image: image with no caption]

There’s another, related new feature that comes into play when you paste a folder into a spot where there’s another folder with the same name. In this case, the Mac offers to merge the contents of the two folders.
It might say, for example: “An item named ‘Notes’ already exists in this location. Do you want to replace it with the one you’re moving? Each folder has unique items such as ‘Salary Projections’ and ‘Stealth Projects.doc.’ ” And your choices are Stop, Keep Both, or Replace All. (These options appear only when you’re pasting a folder into a new window—not dragging it. They also appear when you Option-drag a folder into a new window to copy it there, or when you drag it to a different disk.)
If you click Keep Both, the Finder combines the contents of the two folders. The folder you’re pasting disappears, but its contents join the contents of the other folder (the one in the destination window) in blissful harmony.

Understanding when the Mac copies a dragged icon and when it moves it bewilders many a beginner. However, the scheme is fairly simple when you consider the following:
	On a single disk, dragging from one folder to another moves the icon.

	Dragging from one disk (or disk partition) to another copies the folder or file. (You can drag icons either into an open window or directly onto a disk or folder icon.)

	If you press the Option key as you release an icon you’ve dragged, you copy the icon instead of moving it. Doing so within a single folder produces a duplicate of the file called “[Whatever its name was] copy.”

	If you press the ⌘ key as you release an icon you’ve dragged from one disk to another, you move the file or folder, in the process deleting it from the original disk.



Note
This business of pressing Option or ⌘ after you begin dragging is a tad awkward, but it has its charms. For example, it means you can change your mind about the purpose of your drag in mid-movement, without having to drag back and start over.

And if it turns out you just dragged something into the wrong window or folder, a quick ⌘-Z (the shortcut for Edit→Undo) puts it right back where it came from.

Copying or Moving with Copy and Paste



Dragging icons to copy or move them probably feels good because it’s so direct: You actually see your arrow cursor pushing the icons into the new location.
But you pay a price for this satisfying illusion. You may have to spend a moment or two fiddling with your windows to create a clear “line of drag” between the icon to be moved and the destination folder. (A background window will courteously pop to the foreground to accept your drag. But if it wasn’t even open to begin with, you’re out of luck.)
There’s a better way. Use Copy and Paste to move icons from one window into another.
The routine goes like this:
	Highlight the icon or icons you want to move.
Use any of the techniques described starting on Selecting by Clicking.
FREQUENTLY ASKED QUESTION: Dragging to Copy a Disk
Help! I’m trying to copy a CD onto my hard drive. When I drag it onto the hard drive icon, I get only an alias—not a copy of the CD.
Sure enough, dragging a disk onto a disk creates an alias.
But producing a copy of the dragged icon is easy enough: Just press Option or ⌘ as you drag.
Honestly, though: Why are you trying to copy a CD this way? Using Disk Utility (Console) saves space, lets you assign a password, and usually fools whatever software was on the CD into thinking that it’s still on the original CD.


	Choose Edit→Copy.
Or press the keyboard shortcut: ⌘-C.
Tip
You can combine steps 1 and 2 by Control-clicking (or right-clicking) an icon and choosing the Copy command from the shortcut menu that appears—or by using the [image: ] menu. If you’ve selected several icons, say five, then the command says, “Copy 5 items.”


	Open the window where you want to put the icons. Choose Edit→Paste.
Once again, you may prefer to use the keyboard equivalent: ⌘-V. And once again, you can also Control-click (right-click) inside the window and then choose Paste from the shortcut menu that appears, or you can use the [image: ] menu.
If you add the Option key—press Option-⌘-V—you move the icons to the new window instead of copying them. That is, the originals disappear after they appear in the new location. (This might make more sense if you use the menu way: If you open the Edit menu and press Option, you’ll see the Paste Items command change to say Move Items Here.) It took 27 years, but you can finally cut and paste icons, just as in Windows.
You can press ⌘-period to interrupt the process. When the progress bar goes away, it means you’ve successfully transferred the icons, which now appear fully fleshed in the new window.




Dragging from the Title Bar



You may remember from Chapter 1 that the title bar of every Finder window harbors a secret pop-up menu. When you ⌘-click it, you’re shown a little folder ladder that delineates your current position in the folder hierarchy. You may also remember that the tiny icon just to the left of the window’s name is actually a handle that you can drag to move a folder into a different window.
In many programs, you get the same features in document windows, as shown in Figure 2-5. For example, by dragging the tiny document icon next to the document’s name, you can perform these three interesting stunts:
GEM IN THE ROUGH: Icon’s Progress: The Least-Marketed Feature in Mountain Lion
Here’s an unsung little Mountain Lion feature: When you’re copying a file or a folder, a tiny progress bar appears right on the icons as they sit in their new location. Animated and everything!
Doesn’t matter if it’s list view, icon view, or what—you’ll see the progress bar.
[image: image with no caption]

You’ll also see the little [image: ] button at the top left corner. That, of course, means “click me to cancel this copying job, since you obviously don’t know about the ⌘-period keystroke.”
Think of it as a little bit of mistake-recovery insurance, finally on the Mac after almost 30 years.

	Create an alias on the desktop or the Dock. By dragging this icon to the desktop or onto a folder or disk icon, you create an instant alias of the document you’re working on. (If you drag into the right end of the Dock, you can park the document’s icon there, too.) Before Lion’s Resume Windows feature came along, this was a useful feature when, for example, you were about to knock off for the night, and you wanted easy access to the file you’d been working on when you returned the next day.
[image: Top: By dragging the document-window proxy icon, you can create an alias of your document on the desktop or anywhere else. (Make sure the icon has darkened before you begin to drag.)Bottom: If you ⌘-click the name of the document in its title bar, you get to see exactly where this document sits on your hard drive. (Choosing the name of one of these folders opens that folder and switches you to the Finder.)]

Figure 2-5. Top: By dragging the document-window proxy icon, you can create an alias of your document on the desktop or anywhere else. (Make sure the icon has darkened before you begin to drag.) Bottom: If you ⌘-click the name of the document in its title bar, you get to see exactly where this document sits on your hard drive. (Choosing the name of one of these folders opens that folder and switches you to the Finder.)


	Attach a file to an email message. You can drag a document (using its proxy icon as a handle) onto the icon of an email program like Mail or Outlook. That process creates a new, outgoing message with the file you dragged already attached. (If an outgoing message is already open in that program, you can drag the file directly into its window, too.) In either case, use the ⌘-Tab switcher (The “Heads-Up” Program Switcher) in mid-drag to switch programs.

	Launch from a Dock icon. By dragging this title-bar icon onto another program’s Dock icon, you open your document in that other program. For example, if you’re in TextEdit working on a memo and you decide that you’ll need the full strength of Microsoft Word to dress it up, you can drag its title-bar icon directly onto the Word icon in the Dock. Word then launches and opens up the TextEdit document, ready for editing.



Note to struggling writers: Unfortunately, you can’t drag an open document directly into the Trash.

Spring-Loaded Folders: Dragging Icons into Closed Folders



Here’s a common dilemma: You want to drag an icon not just into a folder, but into a folder nested inside that folder. This awkward challenge would ordinarily require you to open the folder, open the inner folder, drag the icon in, and then close both windows. As you can imagine, the process is even messier if you want to drag an icon into a sub-subfolder or a sub-sub-subfolder.
Instead of fiddling around with all those windows, you can instead use the spring-loaded folders feature (Figure 2-6).
It works like this: With a single drag, drag the icon onto the first folder—but keep your mouse button pressed. After a few seconds, the folder window opens automatically, centered on your cursor. In icon and Cover Flow views, the new window instantly replaces the original. In column view, you get a new column that shows the target folder’s contents. In list view, a second window appears.
[image: Top: To make spring-loaded folders work, start by dragging an icon onto a folder or disk icon. Don’t release the mouse button. Wait for the window to open automatically around your cursor.Bottom: Now you can either let go of the mouse button to release the file in its new window or drag it onto yet another, inner folder. It, too, will open. As long as you don’t release the mouse button, you can continue until you’ve reached your folder-within-a-folder destination.]

Figure 2-6. Top: To make spring-loaded folders work, start by dragging an icon onto a folder or disk icon. Don’t release the mouse button. Wait for the window to open automatically around your cursor. Bottom: Now you can either let go of the mouse button to release the file in its new window or drag it onto yet another, inner folder. It, too, will open. As long as you don’t release the mouse button, you can continue until you’ve reached your folder-within-a-folder destination.

Still keeping the button down, drag onto the inner folder; its window opens, too. Now drag onto the inner inner folder—and so on. (If the inner folder you intend to open isn’t visible in the window, you can scroll by dragging your cursor close to any edge of the window.)
Tip
You can even drag icons onto disks or folders whose icons appear in the Sidebar (Chapter 1). When you do so, the main part of the window flashes to reveal the contents of the disk or folder you’ve dragged onto. When you let go of the mouse, the main window changes back to reveal the contents of the disk or folder where you started dragging.

In short, Sidebar and spring-loaded folders make a terrific drag-and-drop way to file an icon from anywhere to anywhere—without having to open or close any windows at all.
When you finally release the mouse, you’re left facing the final window. All the previous windows closed along the way. You’ve placed the icon into the depths of the nested folders.

Making Spring-Loaded Folders Work



That spring-loaded folder technique sounds good in theory, but it can be disconcerting in practice. For most people, the long wait before the first folder opens is almost enough wasted time to negate the value of the feature altogether. Furthermore, when the first window finally does open, you’re often caught by surprise. Suddenly your cursor—mouse button still down—is inside a window, sometimes directly on top of another folder you never intended to open.
Fortunately, you can regain control of spring-loaded folders using these tricks:
	Choose Finder→Preferences. On the General pane, adjust the “Spring-loaded folders and windows” delay slider to a setting that drives you less crazy. For example, if the first folder takes too long to open, then drag the slider toward the Short setting.

	You can turn off this feature entirely by choosing Finder→Preferences and turning off the “Spring-loaded folders and windows” checkbox.

	Tap the space bar to make the folder spring open at your command. That is, even with the Finder→Preferences slider set to the Long delay setting, you can force each folder to spring open when you are ready by tapping the space bar as you hold down the mouse button. True, you need two hands to master this one, but the control you regain is immeasurable.
Tip
The space bar trick works even when the “Spring-loaded folders and windows” checkbox (in Finder→Preferences) is turned off. That’s a handy arrangement, because it means folder windows never pop open accidentally.


	Whenever a folder springs open into a window, twitch your mouse up to the newly opened window’s title bar or down to its information strip. Doing so ensures that your cursor won’t wind up hovering on, and accidentally opening, an inner folder. With the cursor parked on the gradient gray, you can take your time to survey the newly opened window’s contents, and plunge into an inner folder only after gaining your bearings.



Tip
Email programs like Outlook and Mail have spring-loaded folders, too. You can drag a message out of the list and into one of your filing folders, wait for the folder to spring open and reveal its subfolders, and then drag it directly into one of them.



Aliases: Icons in Two Places at Once



Highlighting an icon and then choosing File→Make Alias (or pressing ⌘-L) generates an alias, a specially branded duplicate of the original icon (Figure 2-7). It’s not a duplicate of the file—just of the icon; therefore it requires negligible storage space. When you double-click the alias, the original file opens. (A Macintosh alias is essentially the same as a Windows shortcut.)
[image: Top: You can identify an alias by the tiny arrow badge on the lower-left corner. (Longtime Mac fans should note that the name no longer appears in italics.)Bottom: If the alias can’t find the original file, you’re offered the chance to hook it up to a different file.]

Figure 2-7. Top: You can identify an alias by the tiny arrow badge on the lower-left corner. (Longtime Mac fans should note that the name no longer appears in italics.) Bottom: If the alias can’t find the original file, you’re offered the chance to hook it up to a different file.

You can create as many aliases as you want of a single file; therefore, in effect, aliases let you stash that file in many different folder locations simultaneously. Double-click any one of them and you open the original file, wherever it may be on your system.
Tip
You can also create an alias of an icon by Option-⌘-dragging it out of its window. (Aliases you create this way lack the word alias on the file name—a delight to those who find the suffix redundant and annoying.) You can also create an alias by Control-clicking (or right-clicking) a normal icon and choosing Make Alias from the shortcut menu that appears, or by highlighting an icon and then choosing Make Alias from the [image: ] menu.

What’s Good about Aliases



An alias takes up very little disk space, even if the original file is enormous. Aliases are smart, too: Even if you rename the alias, rename the original file, move the alias, and move the original around on the disk, double-clicking the alias still opens the original file.
And that’s just the beginning of alias intelligence. Suppose you make an alias of a file that’s on a removable disc, like a DVD. When you double-click the alias on your hard drive, the Mac requests that particular disc by name. And if you double-click the alias of a file on a different machine on the network, your Mac attempts to connect to the appropriate machine, prompting you for a password—even if the other machine is thousands of miles away and your Mac must go online to connect.
Here are a couple of ways you can put aliases to work:
	You can file a document you’re working on in several different folders, or place a particular folder in several different locations, for convenience.

	You can use the alias feature to save you some of the steps required to access another hard drive on the network. (Details on this trick are in Chapter 14.)



Tip
OS X makes it easy to find the file an alias “points to” without actually having to open it. Just highlight the alias and then choose File→Show Original (⌘-R), or choose Show Original from the [image: ] menu. OS X immediately displays the actual, original file, sitting patiently in its folder, wherever that may be.

POWER USERS’ CLINIC: Designing Your Own Icons
You don’t have to be content with the icons provided by Microsoft, Apple, or whoever else wrote your software. You can paste new icons onto your file, disk, and folder icons to help you pick them out at a glance.
The easiest way to replace an icon is to copy it from another icon. To do so, highlight the icon you want to copy, hold down the Option key, and choose File→Show Inspector. In the resulting window, click the icon, and then choose Edit→Copy.
Next, click the icon to which you want to transfer the copied picture. Its icon now appears in the Info dialog box that’s still open on the screen. Click the icon in the dialog box, and this time choose Edit→Paste.
If you’d rather introduce all-new icons, you’re welcome to steal some of the beautifully designed ones waiting at www.iconfactory.com and the icon sites linked to it. Once you’ve downloaded these special icon files, you can copy their images from the Get Info window as you would any icon.
To design an OS X icon from scratch, use a graphics program like Photoshop or a shareware app like Pixelmator or GraphicConverter.
Once you’ve saved your icon file, select it, and then copy and paste its icon using the Show Inspector method described above.
Note that you can’t change certain folder icons that OS X considers important, like Applications or System. You’re also not allowed to change icons that belong to other people who share your Mac and sign in under a different name (Chapter 13).
You can, however, change the special OS X folder icons in your Home folder—Pictures, Documents, and so on—and your hard drive icon.


Broken Aliases



An alias doesn’t contain any of the information you’ve typed or composed in the original file. Don’t email an alias to the Tokyo office and then depart for the airport, hoping to give the presentation upon your arrival in Japan. When you double-click the alias, now separated from its original, you’ll be shown the dialog box at the bottom of Figure 2-7.
If you find yourself 3,000 miles away from the hard drive on which the original file resides, click Delete Alias (to delete the orphan alias) or OK (to do nothing, leaving it where it is).
In certain circumstances, however, the third button—Fix Alias—is the most useful. Click it to summon the Fix Alias dialog box, which you can use to navigate the folders on your Mac. When you click a new icon and then click Choose, you associate the orphaned alias with a different file.
Such techniques become handy when, for example, you click your book manuscript’s alias on the desktop, forgetting that you recently saved it under a new name and deleted the older draft. Instead of simply showing you an error message that says “ ‘Enron Corporate Ethics Handbook’ can’t be found,” the Mac displays the box that contains the Fix Alias button. By reassociating the alias with the new document, you can save yourself the trouble of creating a new alias. From now on, double-clicking your manuscript’s alias on the desktop opens the new draft.
Tip
You don’t have to wait until the original file no longer exists before choosing a new original for an alias. You can perform alias reassignment surgery anytime you like. Just highlight the alias icon and then choose File→Get Info. In the Get Info dialog box, click Select New Original. In the resulting window, find and double-click the file you’d now like to open whenever you double-click the alias.



Color Labels



You can tag selected icons with one of seven different labels, each of which has both a text label and a color associated with it.
To do so, highlight the icons. Open the File menu (or the [image: ] menu, or the shortcut menu that appears when you Control-click/right-click the icons). There, under the heading Label, you’ll see seven colored dots, which represent the seven labels you can use. Figure 2-8 shows the routine.
Tip
If you use labels a lot, Control-click (or right-click) a Finder-window toolbar; choose Customize Toolbar; and drag the Label pop-up menu up to your toolbar. The advantage here is that once you’ve selected a label from this pop-up menu, you can reapply it to subsequent icons with one click—you don’t have to open the menu the next time.

What Labels Are Good For



After you’ve applied labels to icons, you can perform some unique file-management tasks—in some cases on all of them simultaneously, even if they’re scattered across multiple hard drives. For example:
	Round up files with Find. Using the Find command described in Chapter 3, you can round up all the icons with a particular label. Thereafter, moving these icons at once is a piece of cake—choose Edit→Select All, and then drag any one of the highlighted icons out of the results window and into the target folder or disk.
Using labels in conjunction with Find like this is one of the most useful and inexpensive backup schemes ever devised: Whenever you finish working on a document that you’d like to back up, Control-click it and apply a label called, for example, Backup. At the end of each day, use the Find command to round up all the files with the Backup label—and then drag them as a group onto your backup disk.
[image: Use the File menu, menu, or shortcut menu to apply label tags to highlighted icons. You can even apply a label within an icon’s Get Info dialog box.Instantly, the icon’s name takes on the selected shade. In a list or column view, the entire row takes on that shade, as shown in Figure 2-9. (If you choose the little X, you remove any labels you may have applied.)]

Figure 2-8. Use the File menu, [image: ] menu, or shortcut menu to apply label tags to highlighted icons. You can even apply a label within an icon’s Get Info dialog box. Instantly, the icon’s name takes on the selected shade. In a list or column view, the entire row takes on that shade, as shown in Figure 2-9. (If you choose the little X, you remove any labels you may have applied.)


	Sort a list view by label. No other Mac sorting method lets you create an arbitrary order for the icons in a window. When you sort by label, the Mac creates alphabetical clusters within each label grouping, visible in Figure 2-9.
This technique might be useful when, for example, your job is to process several different folders of documents; for each folder, you’re supposed to convert graphics files, throw out old files, or whatever. As soon as you finish working your way through one folder, flag it with a label called Done. The folder jumps to the top (or bottom) of the window, safely marked for your reference pleasure, leaving the next unprocessed folder at your fingertips, ready to go.
Tip
In a list view, the quickest way to sort by label is to first make the label column visible. Do so by choosing View→Show View Options and then turning on the Label checkbox.

[image: Top left: In the Labels tab of the Preferences dialog box, you can change the predefined label text. Each label can be as long as you could possibly want it.Bottom right: Now your list and column views reveal meaningful text tags instead of color names.]

Figure 2-9. Top left: In the Labels tab of the Preferences dialog box, you can change the predefined label text. Each label can be as long as you could possibly want it. Bottom right: Now your list and column views reveal meaningful text tags instead of color names.


	Track progress. Use different-colored labels to track the status of files in a certain project. For example, the first drafts have no labels at all. Once they’ve been edited and approved, make them blue. Once they’ve been sent to the home office, make them purple.
(Heck, you could have all kinds of fun with this: Money-losing projects get red tints; profitable ones get green; things that make you sad are blue. Or not.)




Changing Labels



When you install OS X, the seven labels in the File menu are named for the colors they show: Red, Orange, Yellow, and so on. Clearly, the label feature would be much more useful if you could rewrite these labels, tailoring them to your purposes.
Doing so is easy. Choose Finder→Preferences. Click Labels. Now you see the dialog box shown in Figure 2-9, where you can edit the text of each label.


The Trash



No single element of the Macintosh interface is as recognizable or famous as the Trash icon, which appears at the end of the Dock. (It’s actually a wastebasket, not a can, but let’s not quibble.)
You can discard almost any icon by dragging it into the Trash can. When the tip of your arrow cursor touches the Trash icon, the little wastebasket turns black. When you release the mouse, you’re well on your way to discarding whatever it was you dragged. As a convenience, OS X even replaces the empty-wastebasket icon with a wastebasket-filled-with-crumpled-up-papers icon, to let you know there’s something in there.
It’s worth learning the keyboard alternative to dragging something into the Trash: Highlight the icon, and then press ⌘-Delete (which corresponds to the File→Move to Trash command). This technique is not only far faster than dragging, but it also requires far less precision, especially if you have a large screen. OS X does all the Trash-targeting for you.
[image: Top: Your last warning. OS X doesn’t tell you how many items are in the Trash or how much disk space they take up.Bottom: The Get Info window for a locked file. Locking a file in this way isn’t military-level security by any stretch—any passing evildoer can unlock the file in the same way. But it does trigger a warning when you try to put it into the Trash, providing at least one layer of protection against losing or deleting it.]

Figure 2-10. Top: Your last warning. OS X doesn’t tell you how many items are in the Trash or how much disk space they take up. Bottom: The Get Info window for a locked file. Locking a file in this way isn’t military-level security by any stretch—any passing evildoer can unlock the file in the same way. But it does trigger a warning when you try to put it into the Trash, providing at least one layer of protection against losing or deleting it.

Note
If a file is locked, a message appears to let you know; it offers you the chance to fling it into the Trash anyway. That’s a better solution than in older versions of OS X, when you were forced to unlock the file before you could trash it.

Rescuing Files and Folders from the Trash



File and folder icons sit in the Trash forever—or until you choose Finder→Empty Trash, whichever comes first.
If you haven’t yet emptied the Trash, you can open its window by clicking the wastebasket icon once. Now you can review its contents: icons that you’ve placed on the waiting list for extinction. If you change your mind, you can rescue any of these items in any of these ways:
	Use the Put Back command. This feature flings the trashed item back into whatever folder it came from, even if that was weeks ago.
You’ll find the Put Back command wherever fine shortcut menus are sold. For example, it appears when you Control-click the icon, right-click it, or click the icon and then open the [image: ] menu.
Tip
The same keystroke you use to hurl something into the trash—⌘-Delete—also works to hurl it back out again. That is, you can highlight something in the Trash and press ⌘-Delete to put it back where it once belonged.


	Hit Undo. If dragging something to the Trash was something you just did, you can press ⌘-Z—the keyboard shortcut for the Edit→Undo command. (The Finder offers a five-level Undo, meaning that you can retrace your last five actions.)
Undo not only removes a file from the Trash, but also returns it to the folder from which it came. This trick works even if the Trash window isn’t open.
GEM IN THE ROUGH: Opening Things in the Trash
Now and then, it’s very useful to see what some document in the Trash is before committing it to oblivion—and the only way to do that is to open it.
Trouble is, you can’t open it by double-clicking; you’ll get nothing but an error message.
Or at least that’s what Apple wants you to think.
First of all, you can use Quick Look (Quick Look) to inspect something in the Trash.
But if Quick Look can’t open the file—or if you want to edit it instead of just reading it—drag the document onto the icon of a program that can open it. That is, if a file called Don’t Read Me.txt is in the Trash, you can drag it onto, say, the Word or TextEdit icon in your Dock.
The document dutifully pops open on the screen. Inspect, close, and then empty the Trash (or rescue the document).


	Drag it manually. Of course, you can also drag any icon out of the Trash with the mouse, which gives you the option of putting it somewhere new (as opposed to back in the folder it started from).




Emptying the Trash I: Quick and Easy



If you’re confident that the items in the Trash window are worth deleting, use any of these three options:
	Choose Finder→Empty Trash.

	Press Shift-⌘-Delete. Or, if you’d just as soon not bother with the “Are you sure?” message, then throw the Option key in there, too.

	Control-click the wastebasket icon (or right-click it, or just click it and hold the mouse button down for a moment); choose Empty Trash from the shortcut menu.



The Mac asks you to confirm your decision. (Figure 2-10 shows this message.) If you click Empty Trash (or press Return), OS X deletes those files from your hard drive.
Tip
If you’d rather not be interrupted for confirmation every time you empty the Trash, you can suppress this message permanently. To do that, choose Finder→Preferences, click Advanced, and then turn off “Show warning before emptying the Trash.”


Emptying the Trash II: Secure and Forever



When you empty the Trash as described above, each trashed icon sure looks like it disappears. The truth is, though, the data in each file is still on the hard drive. Yes, the space occupied by the dearly departed is now marked with an internal “This space available” message, and in time, new files may overwrite that spot. But in the meantime, some future eBay buyer of your Mac—or, more imminently, a savvy family member or office mate—could use a program like Data Rescue or FileSalvage to resurrect those deleted files. (In more dire cases, companies like DriveSavers.com can use sophisticated clean-room techniques to recover crucial information—for several hundred dollars, of course.)
That notion doesn’t sit well with certain groups, like government agencies, international spies, and the paranoid. As far as they’re concerned, deleting a file should really, really delete it, irrevocably, irretrievably, and forever.
OS X’s Secure Empty Trash command to the rescue! When you choose this command from the Finder menu, the Mac doesn’t just obliterate the parking spaces around the dead file. It actually records new information over the old—random 0’s and 1’s. Pure static gibberish.
The process takes longer than the normal Empty Trash command, of course. But when it absolutely, positively has to be gone from this earth for good (and you’re absolutely, positively sure you’ll never need that file again), Secure Empty Trash is secure indeed.
Tip
You can also direct the Mac to use this secure method all the time. To do that, choose Finder→Preferences, click Advanced, and turn on “Empty Trash securely.”


Locked Files: The Next Generation



By highlighting a file or folder, choosing File→Get Info, and turning on the Locked checkbox, you protect that file or folder from accidental deletion (see Figure 2-10 at bottom). A little [image: ] icon appears on the corner of the full-size icon, also shown in Figure 2-10.
Locked files these days behave quite differently than they did in early OS X versions:
	Dragging the file into another folder makes a copy; the original stays put.

	Putting the icon into the Trash produces a warning message: “Item ‘Shopping List’ is locked. Do you want to move it to the Trash anyway?” If so, click Continue.

	Once a locked file is in the Trash, you don’t get any more warnings. When you empty the Trash, that item gets erased right along with everything else.



You can unlock files easily enough. Press Option-⌘-I (or press Option as you choose File→Show Inspector). Turn off the Locked checkbox in the resulting Info window. (Yes, you can lock or unlock a mass of files at once.)


Get Info



By clicking an icon and then choosing File→Get Info, you open an important window like the one shown in Figure 2-11. It’s a collapsible, multipanel screen that provides a wealth of information about a highlighted icon.
For example:
	For a document icon, you see when it was created and modified, and what programs it “belongs” to.

	For an alias, you learn the location of the actual icon it refers to.

	For a program, you see whether or not it’s been updated to run on Intel-based Macs. If so, the Get Info window says either “Kind: Intel” (requires an Intel Mac) or “Kind: Universal” (runs on Intel and older Macs). If it says “Kind: PowerPC,” then it can’t run in Mountain Lion.

	For a disk icon, you get statistics about its capacity and how much of it is full.

	If you open the Get Info window when nothing is selected, you get information about the desktop itself (or the open window), including the amount of disk space consumed by everything sitting on or in it.

	If you highlight so many icons simultaneously that their Get Info windows would overwhelm your screen, OS X thoughtfully tallies up their information into a single summary window. It shows you how many icons you highlighted, breaks them down by type (“23 documents, 3 folders,” for example), and adds up the total of their file sizes. That’s a great opportunity to change certain file characteristics on numerous files simultaneously, such as locking or unlocking them, hiding or showing their file name suffixes, changing their ownership or permissions (The Get Info method), and so on.
How many icons do you have to highlight to trigger this Multiple Item Info box? That depends on the size of your screen; bigger monitors can hold more Get Info boxes. If you highlight fewer than that magic number of icons, OS X opens up individual Get Info windows for each one.



Tip
You can force the Multiple Item Info dialog box to appear, though, even if you’ve highlighted only a couple of icons. Just press Control-⌘-I. (The Option-⌘-I trick described next works for this purpose, too.)

[image: Top: The Get Info window can be as small as this, with all its information panes collapsed.Bottom: Or, if you click each flippy triangle to open its corresponding panel of information, it can be as huge as this—shown here split in two because the book isn’t tall enough to show the whole thing. The resulting dialog box can easily grow taller than your screen, which is a good argument for either (a) closing the panels you don’t need at any given moment or (b) running out to buy a really gigantic monitor.And as long as you’re taking the trouble to read this caption, here’s a tasty bonus: There’s a secret command called Get Summary Info. Highlight a group of icons, press Control-⌘-I, and marvel at the special Get Info box that tallies up their sizes and other characteristics.]

Figure 2-11. Top: The Get Info window can be as small as this, with all its information panes collapsed. Bottom: Or, if you click each flippy triangle to open its corresponding panel of information, it can be as huge as this—shown here split in two because the book isn’t tall enough to show the whole thing. The resulting dialog box can easily grow taller than your screen, which is a good argument for either (a) closing the panels you don’t need at any given moment or (b) running out to buy a really gigantic monitor. And as long as you’re taking the trouble to read this caption, here’s a tasty bonus: There’s a secret command called Get Summary Info. Highlight a group of icons, press Control-⌘-I, and marvel at the special Get Info box that tallies up their sizes and other characteristics.

Uniwindow vs. Multiwindow



Ordinarily, when you click an icon and then choose File→Get Info, a new dialog box appears for each icon (unless you’ve highlighted a lot of icons, as described above).
But there’s a useful variation on the Get Info dialog box called the Inspector. It’s a single Get Info window that changes, even though it remains open on the screen, as you click different icons. It’s a clutter-free way to explore different files, icons, and disks.
To open the Inspector, highlight an icon and then press Option-⌘-I (or hold down Option and choose File→Show Inspector). The Get Info Inspector window that appears looks slightly different (it has a smaller title bar and a dimmed Minimize button), and it changes to reflect whatever icons you now click.

The Get Info Panels



Apple built the Get Info window out of a series of collapsed “flippy triangles,” as shown in Figure 2-11. Click a triangle to expand a corresponding information panel.
Tip
The title-bar hierarchical menu described on Close Button works in the Get Info dialog box, too. That is, ⌘-click the Get Info window’s title bar to reveal where this icon is in your folder hierarchy.

Depending on whether you clicked a document, program, disk, alias, or whatever, the various panels may include the following:
	Spotlight Comments. Here you can type in comments for your own reference. Later, you can view these remarks in any list view if you display the Comments column—and you can find them when you conduct Spotlight searches (Chapter 3).

	General. Here’s where you can view the name of the icon and also see its size, creation date, most recent change date, locked status, and so on.
If you click a disk, this info window shows you its capacity and how full it is. If you click the Trash, you see how much stuff is in it. If you click an alias, this panel shows you a Select New Original button and reveals where the original file is.The General panel always opens the first time you summon the Get Info window.

	More Info. Just as the name implies, here you’ll find more info, most often the dimensions and color format (graphics only) and when the icon was last opened. These morsels are also easily Spotlight-searchable.

	Name & Extension. On this panel, you can read and edit the name of the icon in question. The “Hide extension” checkbox refers to the suffix on OS X file names (the last three letters of Letter to Congress.doc,for example).
Many OS X documents, behind the scenes, have file name extensions of this kind—but OS X comes factory-set to hide them. By turning off this checkbox, you can make the suffix reappear for an individual file. (Conversely, if you’ve elected to have OS X show all file name suffixes, then this checkbox lets you hide the extensions on individual icons.)

	Open with. This section is available for documents only. Use the controls on this screen to specify which program will open when you double-click this document, or any document of its type.

	Preview. When you’re examining pictures, text files, PDF files, Microsoft Office files, sounds, clippings, and movies, you see a magnified thumbnail version of what’s actually in that document. This preview is like a tiny version of Quick Look (Chapter 1). A controller lets you play sounds and movies, where appropriate.

	Sharing & Permissions. This panel is available for all kinds of icons. If other people have access to your Mac (either from across the network or when logging in, in person), this panel lets you specify who is allowed to open or change this particular icon. See Chapter 13 for a complete discussion of this hairy topic.





Shortcut Menus, Action Menus



It’s part of the Mac’s user-friendly heritage: You can do practically everything using only the mouse. Everything is out front, unhidden, and clickable, whether it’s an icon, button, or menu.
But as in rival operating systems, you can shave seconds and steps off your workload if you master shortcut menus: short menus that sprout out of things you click, offering commands that the software thinks you might want to invoke at the moment, as shown in Figure 2-12.
[image: These pop-up entities used to be called contextual menus, but Apple started calling them “shortcut menus” a few years ago, perhaps because that’s what they’re called in Windows and Unix.]

Figure 2-12. These pop-up entities used to be called contextual menus, but Apple started calling them “shortcut menus” a few years ago, perhaps because that’s what they’re called in Windows and Unix.

To summon one, just right-click or Control-click something—an icon, the desktop, a window, a link in Safari, text in a word processor, whatever. You can also trigger these shortcut menus with special clicks on your trackpad or Magic Mouse; see The Complicated Story of the Function Keys for additional options.
In any case, a menu drops down listing relevant commands: Get Info, Move to Trash, Copy, and so on. You can click the command you want, or type the first couple of letters of it and then tap the space bar.
These menus become more useful the more you get to know them. The trouble is, millions of Mac fans never even knew they existed.
That’s why there’s a second way to access them. At the top of every Finder window, you’ll find a [image: ] pop-up menu that’s technically called the Action menu (shown in Figure 2-12).
It lists the same sorts of commands you’d find in the shortcut menus, but it’s visible, so novices stand a better chance of stumbling onto it.
The Finder shortcut menus offer some of the most useful Mac features ever. Don’t miss these two in particular:
New Folder with Selection



Imagine this: You’ve got a bunch of scattered icons on your desktop, or a mass of related files in a window. You can now highlight all of them; right-click any one of them; and from the shortcut menu, choose “New Folder with Selection (12 items)” (or whatever the number of icons is).
With a cool animation, the Finder visibly throws the selected icons into a brand-new folder. It’s initially named New Folder With Items (duh), but the hard part is over. All you have to do is rename it—and be grateful that you were spared the 736 steps it would have taken you to do the same job manually.

Share [image: ]



Here’s one of Mountain Lion’s headliner new features: a handy pop-up menu filled with ways to send whatever’s highlighted to somebody else. In the case of selected Finder icons, you can zip it away to someone using any of these three methods (see Figure 2-13):
	Email. Yes, it’s the long-awaited “email this file right off the desktop” command. It whips open Mail and creates a new, outgoing message with the selected file (or files) already attached. Address and send, and make a sacrifice to the right-clicky gods.

	Message. This command lets you send a file—a photo or video clip, for example—to somebody’s iPhone. Type a little message and then click Send. Off it goes, just as though you’d sent an iMessage from the Messages app described in Chapter 20.

	AirDrop. AirDrop is a slick, simple way to shoot a file from one Mac to another without involving any setup, network settings, or user accounts. Until Mountain Lion, you had to use the AirDrop window for this, as described on AirDrop.
But in Mountain Lion, you don’t have to budge from your current window. Click the file(s) you want to send, click Share→AirDrop, click the name of the nearby destination Mac, and click Send. Off it goes!
This menu may also offer to send your file to Twitter, Facebook, or (if it’s a photo or video (Flickr or Vimeo).
For details on these and other Share-menu options, see Notes on Disk Swapping.



UP TO SPEED: Compressing, Zipping, and Archiving
OS X comes with a built-in command that compresses a file or folder down to a single, smaller icon—an archive—suitable for storing or emailing. It creates .zip files, the same compression format used in Windows. That means you can now send .zip files back and forth to PC owners without worrying that they won’t be able to open them.
To compress something, Control-click (or right-click) a file or folder and choose “Compress [the icon’s name]” from the shortcut menu. (Of course, you can use the File menu or [image: ] menu instead.)
OS X thoughtfully creates a .zip archive, but it leaves the original behind so you can continue working with it.
Opening a .zip file somebody sends you is equally easy: Just double-click it. Zip!—it opens.

[image: The new Share menu in every Finder window offers direct access to three ways of transmitting a selected file icon to somebody else.Top: For example, you can send a file to somebody’s cellphone or iMessages account. Just specify the lucky winner’s name here—and add a smiley face, if the mood strikes you (use the pop-up menu in the lower right).Bottom: Alternatively, you can send a file to a nearby Mac (running Lion or later) without having to fiddle with network or sharing settings. Just type the name of the Mac you want and then click Send.]

Figure 2-13. The new Share menu in every Finder window offers direct access to three ways of transmitting a selected file icon to somebody else. Top: For example, you can send a file to somebody’s cellphone or iMessages account. Just specify the lucky winner’s name here—and add a smiley face, if the mood strikes you (use the pop-up menu in the lower right). Bottom: Alternatively, you can send a file to a nearby Mac (running Lion or later) without having to fiddle with network or sharing settings. Just type the name of the Mac you want and then click Send.



Chapter 3. Spotlight



Every computer offers a way to find files. And every system offers several different ways to open them. But Spotlight, a star feature of OS X, combines these two functions in a way that’s so fast, so efficient, so spectacular, it reduces much of what you’ve read in the previous chapters to irrelevance.
That may sound like breathless hype, but wait till you try it. You’ll see.

The Spotlight Menu



See the little magnifying-glass icon ([image: ]) in your menu bar? That’s the mouse-driven way to open the Spotlight search box.
The other way is to press ⌘-space bar. If you can memorize only one keystroke on your Mac, that’s the one to learn. It works both at the desktop and in other programs.
In any case, the Spotlight text box appears just below your menu bar (Figure 3-1).
Begin typing to identify what you want to find and open. For example, if you’re trying to find a file called Pokémon Fantasy League.doc, typing just pok or leag would probably suffice. (The search box doesn’t find text in the middles of words, though; it searches from the beginnings of words.)
A menu immediately appears below the search box, listing everything Spotlight can find containing what you’ve typed so far. (This is a live, interactive search; that is, Spotlight modifies the menu of search results as you type.) The menu lists every file, folder, program, email message, Contacts entry, calendar appointment, picture, movie, PDF document, music file, Web bookmark, Microsoft Office document (Word, PowerPoint, Excel, Entourage), System Preferences panel, To Do item, chat transcript, Web site in your History list, and even font that contains what you typed, regardless of its name or folder location.
Note
Apple keeps enhancing Spotlight’s file-finding skills with each new version of OS X. In Snow Leopard, Spotlight starting finding photos according to who is in them (using iPhoto’s Faces feature) or where they were taken (using iPhoto’s Places feature). If you use Messages (Chapter 20), Spotlight also finds the lucky members of your Buddy lists.
Now, in Lion/Mountain Lion, Spotlight also finds things according to their file types (type .doc to find Word files), download source (type cnet.com to find programs you downloaded from that site), sender (a name or email address), and Finder label.

[image: Top: Press ⌘-space bar, or click the magnifying-glass icon, to make the search box appear.Bottom: As you type, Spotlight builds the list of every match it can find, neatly organized by type: programs, documents, folders, images, PDF documents, and so on. But don’t miss what may be one of the most useful tweaks ever: If you’re not sure what something is, point to it without clicking—or pause on it as you walk down the list with the arrow keys. A Quick Look preview pops out to the left. It shows exactly what’s in that movie, picture, document, or whatever. If your search has found an appointment from your calendar, you actually see a slice of that day’s calendar, showing the appointment in context!]

Figure 3-1. Top: Press ⌘-space bar, or click the magnifying-glass icon, to make the search box appear. Bottom: As you type, Spotlight builds the list of every match it can find, neatly organized by type: programs, documents, folders, images, PDF documents, and so on. But don’t miss what may be one of the most useful tweaks ever: If you’re not sure what something is, point to it without clicking—or pause on it as you walk down the list with the arrow keys. A Quick Look preview pops out to the left. It shows exactly what’s in that movie, picture, document, or whatever. If your search has found an appointment from your calendar, you actually see a slice of that day’s calendar, showing the appointment in context!

How to Handle Your Results



If you see the icon you were hoping to dig up, just click it to open it. Or use the arrow keys to walk down the menu, and then press Return to open the one you want.
You can use the new Quick Look preview to see what something is before you take the time to open it, as shown in Figures Figure 3-1 and Figure 3-2. Or check out Figure 3-2 to see how to find out where something is.
If you click an application, it opens. If you select a System Preferences panel, System Preferences opens and presents that panel. If you choose an appointment, the Calendar program opens, already set to the appropriate day and time. Selecting an email message opens that message in Mail or Outlook. And so on.
Spotlight is so fast, it eliminates a lot of the folders-in-folders business that’s a side effect of modern computing. Why burrow around in folders when you can open any file or program with a couple of keystrokes?
Tip
You can drag icons right out of the results list. For example, you can drag one onto the Desktop to park it there; into a window or a folder to move it; into the Trash to delete it; onto the AirDrop icon (in the Sidebar) to hand it over to a colleague; to another disk icon to back it up; and so on.

[image: If you press ⌘-Option as you point to one of the results, you get a line of text beneath the image that identifies the file’s location.]

Figure 3-2. If you press ⌘-Option as you point to one of the results, you get a line of text beneath the image that identifies the file’s location.


Spotlight-Menu Tips



It should be no surprise that a feature as important as Spotlight comes loaded with options, tips, and tricks. Here it is—the official, unexpurgated Spotlight Tip-O-Rama:
	If the very first item—labeled Top Hit—is the icon you were looking for, just press Return to open it. This is a huge deal, because it means that in most cases, you can perform the entire operation without ever taking your hands off the keyboard.
To open Safari in a hurry, for example, press ⌘-space bar (to open the Spotlight search box), type safa, and hit Return, all in rapid-fire sequence, without even looking. Presto: Safari is before you.
And what, exactly, is the Top Hit? OS X chooses it based on its relevance (the importance of your search term inside that item) and timeliness (when you last opened it).
Tip
Spotlight makes a spectacular application launcher. That’s because Job One for Spotlight is to display the names of matching programs in the results menu. Their names appear in the list nearly instantly—long before Spotlight has built the rest of the menu of search results.
If some program on your hard drive doesn’t have a Dock icon, for example—or even if it does—there’s no faster way to open it than to use Spotlight.


	To jump to (highlight) a search result’s Finder icon instead of opening it, ⌘-click its name. Or arrow-key your way to the result’s name and then press ⌘-Return.

	Spotlight’s menu shows you only 20 of the most likely suspects, evenly divided among the categories (Documents, Applications, and so on). The downside: To see the complete list, you have to open the Spotlight window (The Spotlight Window).
The upside: It’s fairly easy to open something in this menu from the keyboard. Just press ⌘-↑ (or ⌘-↓) to jump from category to category. Once you’ve highlighted the first result in a category, you can walk through the remaining four by pressing the arrow key by itself. Then, once you’ve highlighted what you want, press Return to open it.
GEM IN THE ROUGH: Sweet Spotlight Serendipity: Equations and Definitions
Spotlight has two secret features that turn it into a different beast altogether.
First, it’s a tiny pocket calculator, always at the ready. Click in the search box (or press ⌘-space bar), type or paste 38*48.2-7+55, and marvel at the first result in the Spotlight menu: 1879.6. There’s your answer—and you didn’t even have to fire up the Calculator.
(For shorter equations—only a few characters long—the first result in the Spotlight menu shows the entire equation, like .15*234=35.1.)
And it’s not just a four-function calculator, either. It works with square roots: Type sqrt(25), and you’ll get the answer 5. It also works with powers: Type pow(6,6)—that is, 6 to the power of 6—and you’ll get 46656. You can even type pi to represent, you know, pi.
[image: image with no caption]

[image: image with no caption]

You can copy the result to the Clipboard, or even drag it out of the Spotlight bar into another program.
For a complete list of math functions in Spotlight, open Terminal (see Saving a report), type man math, and press Return.
Second, the Spotlight menu is now a full-blown English dictionary. Or, more specifically, it’s wired directly into OS X’s own dictionary, which sits in your Applications folder.
So if you type a word—say, myrmecophile—into the search box, you’ll see the Dictionary definition near the bottom of the results. Point to it without clicking to read the full-blown entry, thanks to the pop-out Quick Look preview. (In this example, that would be: “n: an invertebrate or plant that has a symbiotic relationship with ants.”)

In other words, you can get to anything in the Spotlight menu with only a few keystrokes.

	The Esc key (top-left corner of your keyboard) offers a two-stage “back out of this” method. Tap it once to close the Spotlight menu and erase what you’ve typed, so that you’re all ready to type in something different. Tap Esc a second time to close the Spotlight text box entirely, having given up on the whole idea of searching.

	Think of Spotlight as your little black book. When you need to look up a number in Contacts, don’t bother opening Contacts; it’s faster to use Spotlight. You can type somebody’s name or even part of someone’s phone number.

	If you’re searching for just one word, you’ll see a “Look Up” category near the bottom of the results menu. Click it to open up that word’s definition in the Dictionary program.

	The bottom of Spotlight always lists commands for “Search Web for [your phrase]” and “Search Wikipedia for [your phrase].” They take you straight to the Google search or the Wikipedia (online encyclopedia) results for whatever you typed.

	Among a million other things, Spotlight tracks the keywords, descriptions, faces, and places you’ve applied to your pictures in iPhoto. As a result, you can find, open, or insert any iPhoto photo at any time, no matter what program you’re using, just by using the Spotlight box at the top of every Open File dialog box! This is a great way to insert a photo into an outgoing email message, a presentation, or a Web page you’re designing. iPhoto doesn’t even have to be running.

	Spotlight is also a quick way to adjust one of your Mac’s preference settings. Instead of opening the System Preferences program, type the first few letters of, say, volume or network or clock into Spotlight. The Spotlight menu lists the appropriate System Preferences panel, so you can jump directly to it.

	As shown in Figure 3-2, you get a preview of what’s inside a file listed in the Spotlight menu when you point to it without clicking. But if you add the ⌘ key, you see a tiny line of text below the preview. It tells you the item’s actual name—which is useful if Spotlight listed something because of text that appears inside the file, not its name—and if you wait a moment, you also see its folder path (that is, where it is on your hard drive).
Tip
If you’re in a hurry, just press ⌘-Option as you point. That makes the folder path appear immediately.


	While you’re pointing to something in the results list, you can press ⌘-I to open the Get Info window for it.

	The Spotlight menu lists 20 found items. In the following pages, you’ll learn about how to see the rest of the stuff. But for now, note that you can eliminate some of the categories that show up here (like PDF documents or Bookmarks), and even rearrange them, to permit more of the other kinds of things to enjoy those 20 seats of honor. Details on Customizing Spotlight.

	Spotlight shows you only the matches from your account and the public areas of the Mac (like the System, Application, and Developer folders)—but not what’s in anyone else’s Home folder. If you were hoping to search your spouse’s email for phrases like “meet you at midnight,” forget it.

	If Spotlight finds a different version of something on each of two hard drives, it lets you know by displaying a faint gray hard drive name after each such item in the menu.

	Spotlight works by storing an index, a private, multimegabyte Dewey Decimal System, on each hard drive, disk partition, or USB flash (memory) drive. If you have some oddball type of disk, like a hard drive that’s been formatted for Windows, Spotlight doesn’t ordinarily index it—but you can turn on indexing by using the File→Get Info command on that drive’s icon.



UP TO SPEED: What Spotlight Knows
The beauty of Spotlight is that it doesn’t just find files whose names match what you’ve typed. That would be so 2004!
No, Spotlight actually looks inside the files. It can actually read and search the contents of text files, RTF and PDF documents, documents from iWork, Keynote, Pages, Photoshop, Microsoft Office (Word, Excel, Entourage, and PowerPoint), and so on.
Over time, software companies can release bits of add-on software—plug-ins—that will make their documents searchable by Spotlight, too. Check periodically by Googling, for example, spotlight plug-in and the kind of software you use. For example, free Spotlight plug-ins are available for OmniGraffle, OmniOutliner, TypeIt4Me, MacDraft, REALbasic, Painter, Wolfram Notebook, and many others.
But that’s only the beginning. Spotlight searches files not only for the text inside them, but also for over 125 other bits of text—a staggering collection of information tidbits including the names of the layers in a Photoshop document, the tempo of an MP3 file, the shutter speed of a digital-camera photo, a movie’s copyright holder, a document’s page size, and on and on.
Technically, this sort of secondary information is called metadata. It’s usually invisible, although a lot of it shows up in the Get Info dialog box described in Chapter 2.
You might think that typing something into the Spotlight search box triggers a search. But to be technically correct, Spotlight has already done its searching. In the first 15 to 30 minutes after you install Mountain Lion—or in the minutes after you attach a new hard drive—Spotlight invisibly collects information about everything on your hard drive. Like a kid cramming for an exam, it reads, takes notes on, and memorizes the contents of all your files. (During this time, if you click the [image: ] icon on the menu bar, you’ll be told that Spotlight is indexing the drives.) Once it has indexed your hard drive in this way, Spotlight can produce search results in seconds.
After that initial indexing process, Spotlight continues to monitor what’s on your hard drive, indexing new and changed files in the background, in the microseconds between your keystrokes and clicks in other programs.

Tip
Spotlight can even find words inside files on other computers on your network—as long as they’re also Macs running Mac OS X Leopard (10.5) or later. If not, Spotlight can search only for the names of files on other networked computers.


Advanced Menu Searches



Most people just type the words they’re looking for into the Spotlight box. But if that’s all you type, you’re missing a lot of the fun.
Use quotes



If you type more than one word, Spotlight works just the way Google does. That is, it finds things that contain both words somewhere inside.
But if you’re searching for a phrase where the words really belong together, put quotes around them. You’ll save yourself from having to wade through hundreds of results where the words appear separately.
For example, searching for military intelligence rounds up documents that contain those two words, but not necessarily side by side. Searching for “military intelligence” finds documents that contain that exact phrase. (Insert your own political joke here.)

Limit by kind



You can confine your search to certain categories using a simple code. For example, to find all photos, type kind:image. If you’re looking for a presentation document but you’re not sure whether you used Keynote, iWork, or PowerPoint to create it, type kind:presentation into the box. And so on.
Here’s the complete list of kinds. Remember to precede each keyword type with kind and a colon.
	To find this:
	Use one of these keywords:

	A program
	app, application, applications

	Someone in your address book
	contact, contacts

	A folder or disk
	folder, folders

	A message in Mail
	email, emails, mail message, mail messages

	A Calendar appointment
	event, events

	A Calendar task
	to do, to dos, todo, todos

	A graphic
	image, images

	A movie
	movie, movies

	A music file
	music

	An audio file
	audio

	A PDF file
	pdf, pdfs

	A System Preferences control
	preferences, system preferences

	A Safari bookmark
	bookmark, bookmarks

	A font
	font, fonts

	A presentation (PowerPoint, iWork)
	presentation, presentations



You can combine these codes with the text you’re seeking, too. For example, if you’re pretty sure you had a photo called “Naked Mole-Rat,” you could cut directly to it by typing mole kind:images or kind:images mole (the order doesn’t matter).

Limit by recent date



You can use a similar code to restrict the search by chronology. If you type date:yesterday, then Spotlight limits its hunt to items you last opened yesterday.
Here’s the complete list of date keywords you can use: this year, this month, this week, yesterday, today, tomorrow, next week, next month, next year. (The last four items are useful only for finding upcoming Calendar appointments. Even Spotlight can’t show you files you haven’t created yet.)

Limit by metadata



If your brain is already on the verge of exploding, now might be a good time to take a break.
These days, you can limit Spotlight searches by any of the 125 different info-morsels that may be stored as part of the files on your Mac: author, audio bit rate, city, composer, camera model, pixel width, and so on. Contents has a complete discussion of these so-called metadata types. (Metadata means “data about the data”—that is, descriptive info-bites about the files themselves.) Here are a few examples:
	author:casey. Finds all documents with “casey” in the Author field. (This presumes that you’ve actually entered the name Casey into the document’s Author box. Microsoft Word, for example, has a place to store this information.)

	width:800. Finds all graphics that are 800 pixels wide.

	flash:1. Finds all photos that were taken with the camera’s flash on. (To find photos with the flash off, you’d type flash:0. A number of the yes/no criteria work this way: Use 1 for yes, 0 for no.)

	modified:3/7/12-3/10/12. Finds all documents modified between March 7 and March 10, 2012. You can also type created:6/1/12 to find all the files you created on June 1, 2012. Type modified:<=3/9/12 to find all documents you edited on or before March 9, 2012.
As you can see, three range-finding symbols are available for your queries: <, >, and - (hyphen). The < means “before” or “less than”; the > means “after” or “greater than”; and the hyphen indicates a range (of dates, sizes, or whatever you’re looking for).



Tip
Here again, you can string words together. To find all PDFs you opened today, use date:today kind:PDF. And if you’re looking for a PDF document that you created on July 4, 2012, containing the word wombat, you can type created:7/4/12 kind:pdf wombat—although at this point, you’re not saving all that much time.

Now, those examples are just a few representative searches out of the dozens that OS X makes available.
It turns out that the search criteria codes you can type into the Spotlight box (author:casey, width:800, and so on) correspond to the master list that appears when you choose Other in the Spotlight window, as described on Other. In other words, there are 125 different search criteria.
There’s only one confusing part: In the Other list, lots of metadata types have spaces in their names—pixel width, musical genre, phone number, and so on.
Yet you’re allowed to use only one word before the colon when you type a search into the Spotlight box. For example, even though pixel width is a metadata type, you have to use width: or pixelwidth: in your search.
So it would probably be helpful to have a master list of the one-word codes that Spotlight recognizes—the shorthand versions of the criteria described on Other.
Here it is, a Missing Manual exclusive, deep from within the bowels of Apple’s Spotlight department: the master list of one-word codes. (Note that some search criteria have several alternate one-word names.)
	Real Search Attribute
	One-Word Name(s)

	Keywords
	keyword

	Title
	title

	Subject
	subject, title

	Theme
	theme

	Authors
	author, from, with, by

	Editors
	editor

	Projects
	project

	Where from
	wherefrom

	Comment
	comment

	Copyright
	copyright

	Producer
	producer

	Used dates
	used, date

	Last opened
	lastused, date

	Content created
	contentcreated, created, date

	Content modified
	contentmodified, modified, date

	Duration
	duration, time

	Item creation
	itemcreated, created, date

	Contact keywords
	contactkeyword, keyword

	Version
	version

	Pixel height
	pixelheight, height

	Pixel width
	pixelwidth, width

	Page height
	pageheight, height

	Page width
	pagewidth, width

	Color space
	colorspace

	Bits per sample
	bitspersample, bps

	Flash
	flash

	Focal length
	focallength

	Alpha channel
	alpha

	Device make (camera brand)
	make

	Device model (camera model)
	model

	ISO speed
	iso

	Orientation
	orientation

	Layers
	layer

	White balance
	whitebalance

	Aperture
	aperture, fstop

	Profile name
	profile

	Resolution width
	widthdpi, dpi

	Resolution height
	heightdpi, dpi

	Exposure mode
	exposuremode

	Exposure time
	exposuretime, time

	EXIF version
	exifversion

	Codecs
	codec

	Media types
	mediatype

	Streamable
	streamable

	Total bit rate
	totalbitrate, bitrate

	Video bit rate
	videobitrate, bitrate

	Audio bit rate
	audiobitrate, bitrate

	Delivery type
	delivery

	Altitude
	altitude

	Latitude
	latitude

	Longitude
	longitude

	Text content
	intext

	Display name
	displayname, name

	Red eye
	redeye

	Metering mode
	meteringmode

	Max aperture
	maxaperture

	F-number
	fnumber, fstop

	Exposure program
	exposureprogram

	Exposure time
	exposuretime, time

	Headline
	headline, title

	Instructions
	instructions

	City
	city

	State or province
	state, province

	Country
	country

	Album
	album, title

	Sample rate
	audiosamplerate, samplerate

	Channel count
	channels

	Tempo
	tempo

	Key signature
	keysignature, key

	Time signature
	timesignature

	Audio encoding application
	audioencodingapplication

	Composer
	composer, author, by

	Lyricist
	lyricist, author, by

	Track number
	tracknumber

	Recording date
	recordingdate, date

	Musical genre
	musicalgenre, genre

	General MIDI sequence
	ismidi

	Recipients
	recipient, to, with

	Year recorded
	yearrecorded, year

	Organizations
	organization

	Languages
	language

	Rights
	rights

	Publishers
	publisher

	Contributors
	contributor, by, author, with

	Coverage
	coverage

	Description
	description, comment

	Identifier
	id

	Audiences
	audience, to

	Pages
	pages

	Security method
	securitymethod

	Content Creator
	creator

	Due date
	duedate, date

	Encoding software
	encodingapplication

	Rating
	starrating

	Phone number
	phonenumber

	Email addresses
	email

	Instant message addresses
	imname

	Kind
	kind

	URL
	url

	Recipient email addresses
	email

	Email addresses
	email

	Filename
	filename

	File pathname
	path

	Size
	size

	Created
	created

	Modified
	modified

	Owner
	owner

	Group
	group

	Stationery
	stationery

	File invisible
	invisible

	File label
	label

	Spotlight comments
	spotlightcomment, comment

	Fonts
	font

	Instrument category
	instrumentcategory

	Instrument name
	instrumentname




Boolean searches



What comp sci professors call Boolean searches are terms that round up results containing either of two search terms, both search terms, or one term but not another.
To go Boolean, you’re supposed to incorporate terms like AND, OR, or NOT into your search queries.
For example, you can round up a list of files that match two terms by typing, say, vacation AND kids. (That’s also how you’d find documents coauthored by two people—you and a pal, for example. You’d search for author:Casey AND author:Chris. Yes, you have to type Boolean terms in all capitals.)
Tip
You can use parentheses instead of AND, if you like. That is, typing (vacation kids) finds documents that contain both words, not necessarily together. But the truth is, Spotlight runs an AND search whenever you type two terms, like vacation kids—neither parentheses nor AND is required.

If you use OR, you can find items that match either of two search criteria. Typing kind:jpeg OR kind:pdf turns up photos and PDF files in a single list.
The minus sign (hyphen) works, too. If you did a search for dolphins, hoping to turn up sea-mammal documents, but instead find your results contaminated by football-team listings, by all means repeat the search with dolphins -miami. OS X eliminates all documents containing “Miami.”
Tip
The word NOT works the same way. You could type dolphins NOT miami to achieve the same effect. But the hyphen is faster to type.







End of sample




    To search for additional titles please go to 

    
    http://search.overdrive.com.   
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