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Foreword



In the short but crowded history of consumer technology, only two products ever became so
      common, influential, and powerful that their names become verbs.
Google is one.
Photoshop is the other.
("Did you Google that guy who asked you out?" "Yeah—he's crazy. He Photoshopped his last
      girlfriend out of all his pictures!")
It's safe to say that these days, not a single photograph gets published, in print or
      online, without having been processed in Photoshop first. It's usually perfectly innocent
      stuff: a little color adjustment, contrast boosting, or cropping.
But not always. Sometimes, the editing actually changes the photo so that it no longer
      represents the original, and all kinds of ethical questions arise. Remember when TV
        Guide Photoshopped Oprah's head onto Ann-Margaret's body? When
        Time magazine darkened O.J. Simpson's skin to make him look more
      menacing on the cover? Or when National Geographic moved two of the
      pyramids closer together to improve the composition?
Well, you get the point: Photoshop is magic. Thanks to Photoshop, photography is no longer
      a reliable record of reality.
And now, all that magic is in your hands. Use it wisely.
There's only one problem: Photoshop is a monster. It's
        huge. Just opening it is like watching a slumbering beast heave into
      consciousness. Dudes: Photoshop CS5 has over 500 menu commands.
In short, installing Photoshop is like being told that you've just won a 747 jumbo jet.
      You sit down in the cockpit and survey the endless panels of controls and switches.
        Now what?
You don't even get a printed manual anymore.
If there were ever a piece of software that needed the Missing Manual treatment, it was
      Photoshop. And yet, despite having published over 100 books since I started this series in
      1999, we had never tackled Photoshop. It was the elephant in the room for all those years, and
      it had been bugging me.
Frankly, we were terrified.
But no longer. In 2009, the beast was tamed at last by its new master, Lesa Snider: a
      natural-born Missing Manual author with Photoshop credentials as long as your arm.
She had worked on Missing Manuals, side by side with me in my office, for 4 years, in all
      kinds of editorial and production capacities. And when she wasn't at my place, she was out in
      the real world, teaching Photoshop seminars, writing Photoshop how-to articles for the Web,
      retouching hundreds of photos in Photoshop, and eventually becoming a Photoshop master (which
      I would define as, "anyone who knows what more than 50 percent of those 500 menu commands
      actually do").
The result of all that training was that the Missing Manual mantra ran through her blood:
      make it clear, make it entertaining, make it complete (hence the thickness of the book in your
      hands). And above all, don't just identify a feature: tell us what it's
        for. Tell us when to use it. (And if the answer is, "You'll
        never use it," tell us that, too.)
The resulting book, Photoshop CS4: The Missing Manual, was a
      critical and popular hit. And now Lesa is back, thank heaven, with a new edition to demystify
      Photoshop CS5.
Now, I'll be the first to admit that this book isn't for everybody. In fact, it's aimed
      primarily at two kinds of people: Photoshop beginners and Photoshop veterans.
But seriously, folks. If you're new to Photoshop, you'll find patient, friendly
      introductions to all those nutty Photoshoppy concepts like layers, color spaces, image
      resolution, and so on. And, mercifully, you'll find a lot of loving attention to a
      time-honored Missing Manual specialty—tips and shortcuts. As Photoshop pros can tell you, you
      pretty much have to learn some of Photoshop's shortcuts or it will crush
      you like a bug.
On the other hand, if you already have some Photoshop experience, you'll appreciate this
      book's coverage of CS5's new features. Some of them are pretty sweet indeed. (Content-Aware
      Fill, Puppet Warp, Merge to HDR Pro—mmm.)
In any case, get psyched. You now have both the most famous, powerful, magical piece of
      software on earth—and an 800-page treasure map to help you find your way.
The only missing ingredients are time, some photos to work on, and a little good taste.
      You'll have to supply those yourself.
Good luck!
—David Pogue
David Pogue is the weekly tech columnist for theNew York
          Times, an Emmy-winning TV correspondent (CBS News and CNBC), and the creator of
          the Missing Manual series.
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Congratulations on buying one of the most complicated pieces of software ever created.
      Fortunately, it's also one of the most rewarding. No other program on the market lets you
      massage, beautify, and transform your images like Photoshop. It's so popular that people use
      its name as a verb: "Dude, you Photoshopped the heck out of her!" You'd
      be hard-pressed to find a published image that hasn't spent some quality
      time in this program, and those that didn't probably should have.
The bad news is that it's a tough program to learn; you won't become a Photoshop guru
      overnight. Luckily, you hold in your hot little hands a book that covers Photoshop from a
        practical standpoint, so you'll learn the kinds of techniques you can
      use every day. It's written in plain English for normal people, so you don't have to be any
      kind of expert to understand it. You'll also learn just enough theory (where appropriate) to
      help you understand why you're doing what you're doing.
Note
This book focuses primarily on the standard edition of Photoshop CS5, which runs about
        $700. Adobe also offers Photoshop CS5 Extended, which costs about $1,000 and offers more
        features primarily designed for folks who work in fields like architecture and medical
        science. About This Book lists some of the new Extended-only
        goodies.

What's New in Photoshop CS5



Adobe has added some amazing new features to Photoshop and incorporated many items that
        have been on customers' wishlists for years (such as changing the Fill and Opacity settings
        of several layers at once!). Here's an overview:
	Workspace updates. If you're upgrading from CS4, the
            workspace doesn't look much different than it did, although the Tools icons got a
            facelift to look more modern. Also, the Application bar now includes a live workspace
            switcher (they're really workspace buttons) that you can drag leftward to hold as many
            saved workspaces as you want. In fact, the Hand and Rotate View tools were removed from
            the Application bar to make room for this new feature.
If you're upgrading from CS3 or an older version, your whole Photoshop world now
            exists within a compact frame that you can move around and resize (this was new in CS4
            for Mac users, anyway). Using the Arrange Documents menu (Arranging Open Images), you can see and work with several documents at
            once, whether they're side by side or stacked on top of each other. And you can create
            even more room for your images by collapsing panels with a double-click (Working with Panels). The Application bar (The Application Bar) gives you quick access to zoom controls, extras such
            as guides and grids, as well as screen modes. The Rotate View tool (now
              only in the Tools panel, Zooming with the Navigator Panel) lets you spin your canvas around so you
            can work with it at an angle.
Note
In Photoshop CS4, you could expand or collapse panels with a single-click.
              However, since most folks are used to double-clicking to do things like that, Adobe
              changed panel expand/collapse to a double-click in CS5.


	Mini Bridge. To give you easier access to files
            through Adobe Bridge (see Appendix C, online), Adobe gave Bridge its very own panel
            inside Photoshop. It's named Mini Bridge because of its size and the fact that it can't
            quite do everything Bridge can (although you can still use full-blown Bridge anytime you
            want). You can drag files from the Mini Bridge panel into a Photoshop or In-Design
            window, search for files, get a full-screen preview by pressing the space bar, and run
            commands on multiple files such as the new "Merge to HDR Pro" option you'll read about
            on Creating High Dynamic Range Images.
Speaking of Bridge, the regular version sports an improved Batch Renaming dialog box
            (for renaming multiple files at once), its "Output to PDF" option now lets you add a
            watermark to your files (a slightly opaque symbol or text overlay to discourage image
            theft), plus you can save your custom PDF and web-gallery settings to use again later.
            Yippee!

	Content-Aware Fill. Arguably one of the most useful
            new features in CS5, this option makes zapping unwanted content from photos easier than
            ever. It compares your selection to nearby pixels and attempts to fill the selected area
            so it blends seamlessly with the background. It works with the Spot Healing brush and
            the Edit→Fill command.

	Puppet Warp. If you ever need to move your subject's
            arms, legs, or tail into a better position, this new tool can get it done. You begin by
            dropping markers (called pins) onto the item you want to move, and
            then Photoshop automatically generates anchor points, handles, and a grid-like mesh that
            you use to move and distort the item. It works with pixel-based layers as well as Smart
            Objects.

	New painting tools. The painting engine (the brains
            behind Photoshop's painting features) got an overhaul in CS5 that improves the program's
            overall performance anytime you're using a brush cursor. The new Bristle Tips make
            existing brushes—and tools that use a brush cursor—behave like their real-world
            counterparts, letting you create more natural paint strokes. A new Brush Preset panel
            lets you see what the new bristles look like and the new Mixer Brush lets you mix colors
            right there on your Photoshop canvas. You can even determine how wet the canvas is, how
            much paint you're mixing from canvas to brush, and how many colors you want to load onto
            your brush tip. Heck, there's even a brush-cleaning option that doesn't involve
            turpentine! You can also change brush hardness with the same keyboard shortcut
            (Ctrl-Option-drag on a Mac, or right-click+Alt+drag on a PC). And if you've used the
            Rotate View tool to spin your canvas so it's at a more natural angle, your brushes
              won't rotate.
Other painterly improvements include keyboard shortcut access to a "heads-up"
            version of the Color Picker (it appears on top of your document, making it easier to
            swap color while you're painting), improved support for graphic tablets (like the option
            to make tablet settings override brush settings), and a new sample ring for the
            Eyedropper, which shows the current and new colors, making it easier to grab the color
            you want.

	Refine Edge enhancements. One of the most exciting
            features of CS5 is the Refine Edge dialog box, which was redesigned so it's easier to
            use and now sports several options for making tough selections easier (like hair and
            fur). For example, a new Smart Radius option detects the difference between soft and
            hard edges, and the new Color Decontamination option all but eliminates any leftover
            pixels from the object's original background. You can also control exactly where the new
            selection goes—to the current layer, a new layer, a layer mask, a new layer with a mask,
            a new document, and so on—from within the Refine Edge dialog box!

	HDR Pro. If you're a fan of HDR photography—taking
            multiple exposures and merging them into a single image—you'll love CS5's improvements
            related to it. The "Merge to HDR Pro" dialog box (Using Merge to HDR Pro) was redesigned so it's easier to use, and it includes several useful presets
            (built-in recipes for various HDR settings) for creating beautiful images right out of
            the box. The programming code was revamped so Photoshop merges your images faster, and a
            de-ghosting option was added, which is helpful if something in your image moved or
            shifted between shots. You can also apply HDR settings to normal images by using the new
            HDR Toning option in the Image→Adjustments menu.

	Lens Correction. This filter got an upgrade
              and a new home: It leapt out the Distort filter category right
            into the main level of the Filter menu. The Lens Correction dialog box now lets you
            import specific lens profiles so its distortion-removing voodoo works a lot better and,
            out of the box, the annoying grid option is off so you can actually
              see your image while you're tweaking it—a handy improvement over
            CS4. These lens profiles are also used by other tools such as Auto-Align Layers (Auto-Aligning Layers and Photomerge), "Merge to HDR Pro" (Creating High Dynamic Range Images), and Photomerge for panoramas (Building Panoramas with Photomerge).

	64-bit support in Mac OS X. The new buzzword in
            computing circles is "64-bit." All it really means is that Photoshop lets you open and
            edit huge files—ones that are over 4 gigabytes—as well as use more memory (RAM), which
            can make the program run faster. See the box on What Does "64-bit" Mean?
            for more info.

	Improved Camera Raw. The newest version of the Camera
            Raw plug-in (Opening Raw files) now includes better noise reduction
            for zapping grain introduced by shooting in low light at a high-light sensitivity
            setting (ISO). Other enhancements include more options for adding post-crop vignettes
            (such as a soft, darkened edge) and improved sharpening that pays attention to an
            image's tone, contrast, and fine details. Camera Raw is discussed throughout this book,
            but the bulk of the coverage lives in Chapter 9.

	Layer management. Layers got a few upgrades, too. For
            example, you can now adjust the opacity and fill of multiple layers at once, nest layers
            into a deeper folder structure, save your favorite layer style settings as defaults from
            within the Layer Style dialog box, drag and drop files from your computer's desktop into
            another open Photoshop document, drag content from an open window onto another document
            tab, and so on. Other additions include a ghosted outline as you drag layer content
            using the Move tool (helpful when moving small items), visual feedback when you're
            dragging layer styles from one layer to another (you see a big, partially transparent
              fx as you drag), a new option that lets you control whether or
            not the word "copy" is added to layers' names when you duplicate them, the ability to
            create a layer mask from transparency, and a new Paste Special menu that lets you do all
            kinds of neat pasting tricks (Pasting into a Selection). Whew!

	CS Review. This new online subscription service lets
            folks share and post their projects on the Web so clients and/or colleagues can give
            them feedback. It works with several Adobe Creative Suite programs including Photoshop,
            In-Design, Illustrator, and Premiere.



There are also a few features that you'll only find in Photoshop CS5 Extended:
	Repoussé. This new option (pronounced "Rep-poose-ay")
            lets you easily create 3-D versions of a variety of 2-D items such as text, paths, layer
            masks, and selections. It creates a 3D layer that you can use with Photoshop's full
            arsenal of 3-D tools.

	Enhanced 3-D editing. Adobe has added even more
            features to its 3-D resume, such as the new Ground Plane Shadow Catcher, giving you an
            easy way to generate a realistic shadow cast on the ground (on, in this case, mesh)
            beneath a 3-D object. CS5 also sports faster 3-D Ray Tracer rendering (you can think of
            Ray-Tracing as tracing the path of light rays reflected off an object and back to the
            camera for a more photorealistic look), which lets you render a selection, pause and
            resume rendering, and change render quality. They also added a slew of new materials,
            light sources, and overlays, the ability to change 3-D depth of field, new 3-D
            preferences, and more.



There are also tons of little changes in Photoshop CS5, too, that are the direct result
        of Adobe's customer feedback initiative called Just Do It (JDI). For example, Photoshop now
        automatically saves 16-bit JPEGs as 8-bit (see Setting Size and Resolution
        for more about image bit depth); Adobe added a Straighten option to the Ruler tool
        (finally!); the Crop tool has a rule-of-thirds grid overlay; the Save dialog box includes an
        "apply to all" checkbox; there's a preference that lets you turn off gestures on laptop
        trackpads; the Shadows/Highlight adjustment is set to 35% from the factory instead of
        50%—the list goes on and on. The activation process (Appendix A, online) also got simpler,
        as the program now automatically gets registered and activated when you install it.
With the good comes a little bad: To accommodate the new programming code that allows
        for 64-bit processing on the Mac, some plug-ins and filters now only work in 32-bit mode.
        Thankfully, it's easy to switch between the 32-bit and 64-bit versions of the program (About This Book tells you how), so your favorite add-ons will still work (and
        rest assured those companies are hard at work updating them for 64-bit mode!).


About This Book



Adobe has pulled together an amazing amount of information in its new online help system
        (Appendix B), but despite all these efforts, it's geared toward seasoned Photoshop jockeys
        and assumes a level of skill that you may not have. The explanations are very clipped and to
        the point, which makes it difficult to get a real feel for the tool or technique you're
        learning about.
That's where this book comes in. It's intended to make learning Photoshop CS5
        tolerable—and even enjoyable—by avoiding technical jargon as much as possible and explaining
          why and when you'll want to use (or avoid)
        certain features of the program. It's a conversational and friendly approach intended to
        speak to beginners and seasoned pixel pushers alike.
Some of the tutorials in this book refer to files you can download from this book's
        Missing CD page on the Missing Manuals website (www.missingmanuals.com/cds) so you can
        practice the techniques you're reading about. And throughout the book, you'll find several
        kinds of sidebar articles. The ones labeled "Up to Speed" help newcomers to Photoshop CS5 do
        things or explain concepts that veterans are probably already familiar with. Those labeled
        "Power Users' Clinic" cover more advanced topics for the brave of heart.
Note
Photoshop CS5 functions almost identically on Mac and Windows computers, but the
          screenshots in this book were all taken on a Mac for the sake of consistency. However, the
          keyboard shortcuts for the two operating systems are different, so you'll find both
          included here—Mac shortcuts first, followed by Windows shortcuts in parentheses. In a few
          instances, the locations of certain folders differ and in those cases, you get the
          directions for both operating systems.

Up To Speed: What Does "64-bit" Mean?
The cool phrase in computing circles these days is "64-bit." While that term may sound
          pretty geeky, it's actually not that intimidating. 64-bit programs (a.k.a. "applications"
          or "apps") simply know how to count higher than 32-bit programs.
So what does that mean in practice? 32-bit programs can open and work with files that
          are up to 4 gigabytes in size—which is already huge. 64-bit programs, on the other hand,
          can open files that are way bigger than that, as long as your operating system can handle
          64-bit apps. (Mac OS X 10.5 [Leopard] and Microsoft Windows Vista [the 64-bit version,
          anyway] and later are up to the task.) 64-bit programs can also make use of more memory
          than their 32-bit counterparts, which is crucial when you're working with big honkin'
          files. For example, the 64-bit version of Photoshop lets you use more than 4 gigs of RAM,
          which makes it run faster. (You can change how your machine's memory is allotted by
          tweaking Photoshop's preferences as described on Performance.)
The bottom line is that, if you work with gigantic files, you'll want to use the
          64-bit version of Photoshop. The downside is that some adjustments (like Variations—Inverting Colors), third-party plug-ins (Chapter 19), and filters (Lighting Effects [Render], PatternMaker [Video]) don't work with the 64-bit
          version of the program. But never fear; you can launch the 32-bit version of Photoshop and
          they'll work just fine. When you install Photoshop on a PC, you get two full versions of
          the program in two separate folders: one for 32-bit mode and another for 64-bit mode
          (located in Program Files→Adobe→Photoshop C5 and Program Files (x86)→Adobe→Photoshop CS5,
          respectively). Simply quit one program and then launch the other.
On a Mac, open your Applications folder and then locate the Adobe Photoshop CS5
          folder. Open the folder by double-clicking it, find the application icon (it looks like a
          tiny blue suitcase), click it once to select it and then choose File→Get Info. In the
          resulting dialog box, locate the General section (it's in the middle) and turn on the
          "Open in 32-bit mode" checkbox. Quit Photoshop, relaunch it, and you're all set.
You'll still be able to share Photoshop files with both Mac and PC folks just like you
          always have, and you shouldn't see any big difference in how Photoshop behaves no matter
          which version you use. Unless you plan on working with files that are bigger than 4
          gigabytes, it doesn't really matter whether you use the 64-bit or 32-bit version of
          Photoshop CS5, though the 64-bit version might feel like it runs faster.

About the Outline



This hefty book is divided into six parts, each devoted to the type of things you'll
          do in Photoshop CS5:
	Part One: The Basics. Here's where you'll learn the
              essential skills you need to know before moving forward. Chapter 1 gives you the lay of the land and teaches you
              how to work with panels and make the Photoshop workspace your own. You'll also find
              out the many ways of undoing what you've done, which is crucial when you're still
              learning. Chapter 2 covers how to open and
              view your documents efficiently, and how to set up new documents so you have a solid
              foundation on which to build your masterpieces.
Chapter 3 dives into the most
              powerful Photoshop feature of all: layers. You'll learn about the different kinds of
              layers and how to manage them, the power of layer masks, and how to use layer styles
              for special effects. Chapter 4 explains how
              to select part of an image so you can edit just that area. In Chapter 5, you'll dive headfirst into the science
              of color as you explore channels (Photoshop's way of storing the colors that make up
              your image) and learn how to use channels to create selections; you'll also pick up
              some channel-specific editing tips along the way.

	Part Two: Editing Images. Chapter 6 starts off by explaining a variety of
              ways you can crop images, both in Photoshop and in Camera Raw. The chapter then
              demystifies resolution once and for all so you'll understand how to resize images
              without reducing their quality. In Chapter 7, you'll learn
              how to combine images in a variety of ways, from simple techniques to more complex
              ones. Chapter 8 covers draining, changing,
              and adding color, arming you with several techniques for creating gorgeous
              black-and-white images, delicious duotones, partial-color effects, and more. You'll
              also learn how to change the color of almost anything.
Chapter 9 focuses on color-correcting
              images, beginning with auto fixer-uppers, and then moving on to the wonderfully simple
              world of Camera Raw and the more complicated realm of Levels and Curves. Chapter 10 is all about retouching people and
              is packed with practical techniques for slimming, trimming, and beautifying the faces
              and bodies that grace your pictures. It also explains how to use the Dodge and Burn
              tools in ways that won't harm your images. Chapter 11
              covers all kinds of ways to sharpen images to make them look especially crisp.

	Part Three: The Artistic Side of Photoshop. This
              part of the book is all about creativity. Chapter 12
              explains the many ways of choosing colors for your documents, and teaches you how to
              create a painting from scratch. Chapter 13
              focuses on using the mighty Pen tool to create complex illustrations and selections,
              along with how to use Photoshop's Shape tools. Chapter 14 teaches you the basics of typography and then moves on to how to create and format
              text in Photoshop. You'll find out how to outline, texturize, and place text, among
              other fun stuff. Chapter 15 covers the wide world of
              filters; you'll come away with at least one practical use for one or more of the
              filters in each filter category.

	Part Four: Printing and the Web. In Chapter 16, you'll learn about printing your images, beginning
              with why it's so darn hard to make what comes out of your printer match what you see
              onscreen. You'll learn about the different color modes and how to prepare your images
              for printing, whether you're using an inkjet printer or sending your files to a
              commercial printing press. Chapter 17 focuses on
              preparing images for the Web, and walks you through the various file formats you can
              use, explains how to protect your images online, and shows you how to use Bridge to
              create Web galleries. Rounding out the chapter is info on using the Slice tool on a
              web page design, and step-by-step instructions for creating an animated GIF.

	Part Five: Photoshop Power. This part is all about
              working smarter and faster. It starts with an entire chapter devoted to using actions
                (Chapter 18), which help you automate tasks you
              perform regularly. Chapter 19 covers installing and
              using plug-ins (small programs you can add on to Photoshop) and recommends some of the
              best on the market today.

	Part Six: Appendixes. Appendix A covers installing
              and uninstalling Photoshop. Appendix B gives you some troubleshooting tips, explains
              Photoshop's help system, and points you to resources other than this book. Appendix C
              gets you up to speed on using Adobe Bridge to import, organize, and export your
              images. Appendix D gives you a tour of the mighty Tools panel. And finally, Appendix E
              walks you through Photoshop CS5's 258 menu items.



Tip
All the appendixes are available on this book's Missing CD page at www.missingmanuals.com/cds.


For Photographers



If you're relatively new to digital-image editing or you've always shot film and are
          taking your first brave steps into the world of digital cameras, you'll be amazed at what
          you can do in Photoshop, but there's a lot to learn. By breaking Photoshop down into
          digestible chunks that are most important to you, the learning
          process will feel less overwhelming. (There's no sense in tackling the whole program when
          you'll only use a quarter of it—if that much.)
The most important thing to remember is to be patient and try not to get frustrated.
          With patience and practice, you can master the bits of Photoshop that
          you need to do your job better. And with the help of this book you'll conquer everything
          faster than you might think. As you gain confidence, you can start branching out into
          other parts of the program to broaden your skills. Here's a suggested roadmap for quickly
          learning the most useful aspects of the program:
	Read all of Chapters Chapter 1 and Chapter 2 (or at the very least skim
                them).
These two chapters show you where to find all of Photoshop's tools and features
              and explain how the program is organized. You'll learn how to open, view, and save
              your images, which is vital stuff to know.

	If your photos aren't on your computer already, read
                Appendix C (online) about Adobe Bridge.
Bridge is an amazingly powerful image organizer and browser that can help get your
              images onto your computer. It takes care of importing, renaming, and even backing up
              your precious photos.

	If you're shooting in Raw format (Working with Raw Files) and need to color-correct your images in a
                hurry, skip ahead to the section on editing in Camera Raw in Chapter 9 (Correcting Images in Camera Raw).
This chapter includes an entire section on practical editing techniques you can
              use in Camera Raw, and a quick reference that points you to where you'll find other
              Camera-Raw techniques throughout this book.

	If you're not shooting in Raw and you
                need to resize your images before you edit them, read Chapter 6.
This chapter explains resolution and how to resize images without reducing their
              quality.

	Proceed with Chapters Chapter 8, Chapter 9, and Chapter 10 to learn about color effects,
                color-correcting, and retouching people, respectively.

	When you're ready to sharpen your images, read Chapter 11.

	Finally, when you want to print your photos, read the
                section on printing with an inkjet printer in Chapter 16
                  (Printing on an Inkjet Printer).
This chapter walks you through printing your photos, and includes advice on how to
              print borderless images.



That's all you need to get started. When you're ready to dive more fully into
          Photoshop, pick back up at Chapter 3,
          which covers layers, and then move on through the book as time permits.

The Very Basics



This book assumes that you know how to use a computer and that, to some extent, you're
          an expert double-clicker, drag and dropper, and menu opener. If not, here's a quick
          refresher:
To click means to move the point of your mouse or trackpad cursor
          over an object on your screen and press the left mouse or trackpad button once. To
            right-click means to press the right mouse button once, which
          produces a menu of special features called a shortcut menu. (If
          you're on a Mac and have a mouse with only one button, hold down the Option key while you
          click to simulate right-clicking.) To double-click means to press the
          left button twice, quickly, without moving the mouse between clicks. To
            drag means to click an object and use the mouse to move it while
          holding down the left mouse button. Most selection buttons onscreen are pretty obvious,
          but you may not be familiar with radio buttons: To choose an option,
          you click one of these little empty circles that are arranged in a list. If you're
          comfortable with basic concepts like these, you're ready to get started with this
          book.
You'll find tons of keyboard shortcuts along the way, and they're huge timesavers. If
          you see "Press ⌘-S (Ctrl+S on a PC) to save your file," that means to hold down the ⌘ (or
          Ctrl) key while pressing the S key. Press one and keep holding it as you press the other.
          (This book lists Mac keyboard shortcuts first, followed by Windows shortcuts in
          parentheses.) Other keyboard shortcuts are so complex that you'll need to use multiple
          fingers, both hands, and a well-placed elbow. Use them at your own risk!

About→These→Arrows



In Photoshop CS5: The Missing Manual (and in all Missing Manuals,
          for that matter), you'll see arrows sprinkled throughout each chapter in sentences like
          this: "Choose Filter→Blur→Gaussian Blur." This is a shorthand way of helping you find
          files, folders, and menu choices without having to read through painfully long and boring
          instructions. For example, the sentence quoted above is a short way of saying: "At the top
          of the Photoshop window, locate the Filter menu. Click it and, in the list that appears,
          look for the Blur category. Point to the word Blur without clicking and, in the resulting
          submenu, click Gaussian Blur" (see Figure 1).

About MissingManuals.com



On the Missing Manuals website (www.missingmanuals.com), you'll find this book's Missing CD page, which
          includes links to downloadable images mentioned in this book's tutorials, in case you want
          to practice techniques without using your own photos.
A word about the image files for the tutorials: To make life easier for people with
          dial-up Internet connections, the file sizes have been kept pretty small. This means you
          probably won't want to print the results of what you create (you'll end up with a print
          about the size of a matchbook). But that doesn't really matter because the files are only
          meant for onscreen use. You'll see notes throughout the book about which practice images
          are available for any given chapter.
[image: Choosing Filter→Blur→Gaussian Blur takes you to the menu item shown here.]

Figure 1. Choosing Filter→Blur→Gaussian Blur takes you to the menu item shown here.

On the website, you can also find articles, tips, and updates to this book. If you
          click the Errata link, you'll see any corrections we've made to the book, too; if you find
          something in these pages that you think is wrong, feel free to report it by clicking that
          link. Each time the book is printed, we'll update it with any confirmed corrections. If
          you want to be certain that your own copy is up to the minute, this is where to check for
          any changes. And thanks for reporting any errors or suggesting corrections.
We'd love to hear your suggestions for new books in the Missing Manual line. There's a
          place for that on www.missingmanuals.com, too. And while you're online, you can also register
          this book at www.oreilly.com (you can jump
          directly to the registration page by going here: www.tinyurl.com/yo82k3. Registering means we
          can send you updates about this book, and you'll be eligible for special offers like
          discounts on future editions.

Safari® Books Online



Safari® Books Online is an on-demand digital library that lets you easily search over
          7,500 technology and creative reference books and videos to find the answers you need
          quickly.
With a subscription, you can read any page and watch any video from our library
          online. Read books on your cellphone and mobile devices. Access new titles before they're
          available for print, and get exclusive access to manuscripts in development and post
          feedback for the authors. Copy and paste code samples, organize your favorites, download
          chapters, bookmark key sections, create notes, print out pages, and benefit from tons of
          other timesaving features.
O'Reilly Media has uploaded this book to the Safari Books Online service. To have full
          digital access to this book and others on similar topics from O'Reilly and other
          publishers, sign up for free at http://my.safaribooksonline.com.


Part One. The Basics
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Chapter 1. Photoshop CS5 Guided Tour



Photoshop CS5 is bursting with amazing features that'll help you edit and create your
        very own digital masterpieces. If this is your first foray into the world of Photoshop, all
        these features will be new to you. If you're an experienced pixel pusher, there are some
        surprises waiting for you, too. If you skipped the previous version and are leapfrogging
        from Photoshop CS3 to CS5, Adobe introduced major changes to the work environment in CS4,
        and while these changes make Photoshop easier to use, they take some time to get used
        to.
Throughout the rest of this book, you'll dive much deeper into specific tools and
        techniques, but this chapter gives you a good, solid foundation on which to build your
        Photoshop skills. You'll learn how to work with the Application Frame and Application bar, plus how to wrangle document windows and
        panels. Once you've gotten them placed just right, you'll learn how to save your setup as a
        custom workspace. If you're a beginner, the section on using Undo commands and history
        states will show you how to fix mistakes and back out of almost anything you've done.
        Finally, you'll learn how to fine-tune Photoshop's behavior through preferences and built-in
        tools (called presets) that let you personalize your work environment even more.
Meet the Application Frame



When you launch Photoshop CS5 for the first time, you'll be greeted by the
            Application Frame shown in Figure 1-1 (although if you're restarting
          Photoshop after deleting your preferences as described in Appendix B, online, it'll be
          turned off). It's part of Adobe's effort to consolidate your work environment and lessen
          clutter; the frame confines all things Photoshop to a single resizable and movable window.
          You can grab the whole mess—documents, panels, and all—and move it to one side of your
          screen (or better yet, to another monitor) so it's out of the way. If you open more than
          one document, they're displayed in handy tabs that you can rearrange by dragging.
[image: Click an image's document tab to summon it front and center. Photoshop stores the vast majority of its tools in the panels on the left and right sides of the Application Frame; a full introduction to panels starts on page 19.The upside of using the Application Frame is that all of Photoshop's bits and pieces stay together as you move things around. Resizing the frame also automatically changes the size of your panels and windows to fit within it. Chances are, you'll either love it or hate it. If the latter is the case and you're on a Mac, you can turn if off by choosing Window→Application Frame to make Photoshop switch to the floating-window view you're used to.]

Figure 1-1. Click an image's document tab to summon it front and center. Photoshop stores the
            vast majority of its tools in the panels on the left and right sides of the Application
            Frame; a full introduction to panels starts on page 19. The upside of using the
            Application Frame is that all of Photoshop's bits and pieces stay together as you move
            things around. Resizing the frame also automatically changes the size of your panels and
            windows to fit within it. Chances are, you'll either love it or hate it. If the latter
            is the case and you're on a Mac, you can turn if off by choosing Window→Application
            Frame to make Photoshop switch to the floating-window view you're used to.

Tip
If you need to do some work on your desktop or in another program, you can
            temporarily hide Photoshop. On a Mac, press ⌘-H or click the yellow
            dot at the top left of the Application Frame. Your workspace disappears, but Photoshop
            keeps running in the background. To bring it back to the forefront, click its shrunken
            icon in the Dock. In Photoshop CS5, the first time you press ⌘-H, a dialog box appears
            asking if you'd like to reassign that keyboard shortcut to hide Photoshop instead of
            hiding selections. (To change it back, you can edit your keyboard shortcuts, as
            explained in the box on Customizing Keyboard Shortcuts and Menus, or
            delete Photoshop's preferences as described in Appendix B, online at www.missingmanuals.com/cds.)
If you're on a PC, you can minimize the program by clicking the upper-right – sign
            button and Windows tucks the program down into your taskbar. To get it back, click its
            taskbar icon.

The Application Bar



At the very top of the Application Frame is a row of tools called the
              Application bar (Figure 1-2), which gives you one-click
            access to handy stuff like Adobe Bridge (covered in Appendix C, online), extras (guides,
            grids, and rulers), zoom controls, and more. The real gems, though, are the Arrange
            Documents menu and the new Live Workspace buttons (shown in Figure 1-1 and discussed on Customizing Your Workspace). The Arrange Documents menu lets you organize
            your open documents so you can see them all at one time, which is handy for evaluating
            before and after versions of images or just managing a bunch of open windows (more on
            that in Chapter 2!). A new option in CS5 is the
            CS Live button on the far right, which gives you access to the new CS Review system
            mentioned back on page 4.
[image: The Application bar gives you quick access to both Bridge and Mini Bridge (see Appendix C, online), as well as the Arrange Documents (page 67), Zoom level (page 60), and Screen Mode (page 16) options.In the Windows version of Photoshop CS5, the Application bar is also home to all the program's main menus (File, Edit, Image, Layer, and so on); in the Mac version, those menus appear at the top of your screen instead.]

Figure 1-2. The Application bar gives you quick access to both Bridge and Mini Bridge (see
              Appendix C, online), as well as the Arrange Documents (page 67), Zoom level (page 60),
              and Screen Mode (page 16) options. In the Windows version of Photoshop CS5, the
              Application bar is also home to all the program's main menus (File, Edit, Image,
              Layer, and so on); in the Mac version, those menus appear at the top of your screen
              instead.

Note
In CS4, the Hand and Rotate Canvas tools also roosted in the Application bar.
              However, in CS5 Adobe took them out in order to make room for the new Live Workspace
              buttons shown in Figure 1-1. Flip to
                Customizing Your Workspace for to learn how to customize your
                workspace.


The Almighty Options Bar



Lording over your document window is the Options bar, which lets you customize the
            settings for nearly every tool in the Tools panel (see Figure 1-3 top). This bar automatically
            changes to show settings related to the tool you're currently using. Unfortunately, its
            labels are fairly cryptic, so it can be hard to figure out what the heck all that stuff
            does. Luckily, you can hover your cursor over any item to see a little yellow pop-up
            description called a tooltip (you don't need to click—just don't
            move your mouse for a couple seconds). When you move your cursor away from the item, the
            tooltip disappears.
[image: Top: The Options bar is customization central for whatever tool you're currently using. However, it doesn't have to live at the top of your screen; you can undock it by dragging the tiny dotted lines circled here.Middle: Once you've freed the Options bar, you can drag it anywhere you want by grabbing the dark gray bar on its far left.Bottom: To redock the Options bar, drag it to the top of your screen. Once you see a thin blue line—like the one shown here—release your mouse button.]

Figure 1-3. Top: The Options bar is customization central for whatever tool you're currently
              using. However, it doesn't have to live at the top of your screen; you can undock it
              by dragging the tiny dotted lines circled here. Middle: Once you've freed the
              Options bar, you can drag it anywhere you want by grabbing the dark gray bar on its
              far left. Bottom: To redock the Options bar, drag it to the top of your screen.
              Once you see a thin blue line—like the one shown here—release your mouse
              button.

When you first install Photoshop, the Options bar is perched near the top of the
            screen, beneath the Application bar. If you'd rather put it somewhere else, grab its
            left end and drag it wherever you want, as shown in Figure 1-3 middle. If you decide to put it
            back later (also called docking), drag it to the top of the screen
            (see Figure 1-3 bottom).
Tip
If a tool seems to be misbehaving, it's likely because you changed one of the
              Options bar's settings and forgot to change it back! These settings are "sticky": Once
              you change them, they stay that way until you change them back.


Swapping Screen Modes



Photoshop also includes three different screen modes for your
            document-viewing pleasure. Depending on what you're doing, one will suit you better than
            another. For example, you can make your image take up your whole screen (with or without
            the Application and Options bars), you can hide your panels, and so on (see Figure 1-4).
[image: The many faces of Photoshop: Standard with Application Frame on (top), Full Screen With Menu Bar (bottom left), and Full Screen (bottom right). You can edit images in any of these modes. Also, pressing the Tab key lets you hide or show menus and panels.Flip ahead to page 51 to learn how to open an image. The short version: Choose File→Open, navigate to where the image lives, and then click Open.]

Figure 1-4. The many faces of Photoshop: Standard with Application Frame on (top), Full
              Screen With Menu Bar (bottom left), and Full Screen (bottom right). You can edit
              images in any of these modes. Also, pressing the Tab key lets you hide or show menus
              and panels. Flip ahead to page 51 to learn how to open an image. The short
              version: Choose File→Open, navigate to where the image lives, and then click
              Open.

It's a snap to jump between modes—just press the F key repeatedly (as long as you're
            not using the Type tool—if you are, you'll type a bunch of fs) or
            use the Screen Mode pop-up menu in the Application bar (see Figure 1-2). Your choices are:
	Standard Screen Mode is the view you see when you
                launch Photoshop for the first time. This mode shows menus, the Application Frame,
                the Application bar, panels, and document windows. Use this mode when the
                Application Frame is active and you need to scoot the whole Photoshop
                application—windows and all—around on your monitor.

	Full Screen Mode With Menu Bar completely takes
                over your screen, puts your currently open document in the center on a gray
                background, and attaches any open panels to the left and right edges of your
                monitor. This mode is great for day-to-day editing because you can see all your
                tools and menus without being distracted by the files and folders on your desktop.
                The gray background is also easy on your eyes and a great choice when
                color-correcting your images (a brightly colored desktop can affect your color
                perception).

	Full Screen Mode hides all of Photoshop's menus
                and panels, centers the document on your screen, and puts it on a black background.
                This mode is great for displaying and evaluating your work or for editing
                distraction-free. And the black background really makes images pop off the
                screen!



Tip
You can free up precious screen real estate by pressing the Tab key to hide menus
              and panels. This trick is a great way to get rid of distracting elements when you're
              editing, especially if you've got a small monitor. Pressing Shift-Tab hides everything
              except the Tools panel, Options bar, and Application bar. To show the panels again,
              press Tab or mouse over to the edge of your monitor where the panels should be; when
              you move your mouse away from the panels, they'll disappear again.


Customizing Your Workspace



The folks at Adobe understand that once you arrange your panels just so, you want to
            keep 'em that way. That's why Photoshop lets you save your setup as a
              workspace using the Workspace menu at the top right of the
            Application bar. Once you've created a workspace, it appears as a clickable button in
            the Application bar (see Figure 1-5). To
            swap workspaces, click one of the new Live Workspace presets (built-in settings) to make
            Photoshop rearrange your panels accordingly. Straight from the factory, you see four
            clickable preset buttons: Essentials, Design, Painting, and Photography; however, if you
            click the Workspace menu—or drag the little dividing line next to Essentials
            leftward—you'll see even more.
[image: Most of the preset workspaces are designed to help you perform specialized tasks. For example, the Painting workspace puts the Brushes and Navigation panels at the top right and groups the color-related panels you'll undoubtedly use when painting. Take the built-in workspaces for a test drive—they may give you customization ideas you hadn't thought of.If you're familiar with Photoshop but new to CS5, try out the "New in CS5" workspace. It highlights all the menu items that are new in CS5, which is a great way to see additions at a glance.]

Figure 1-5. Most of the preset workspaces are designed to help you perform specialized tasks.
              For example, the Painting workspace puts the Brushes and Navigation panels at the top
              right and groups the color-related panels you'll undoubtedly use when painting. Take
              the built-in workspaces for a test drive—they may give you customization ideas you
              hadn't thought of. If you're familiar with Photoshop but new to CS5, try out the
              "New in CS5" workspace. It highlights all the menu items that are new in CS5, which is
              a great way to see additions at a glance.

To save your own custom workspace, first get things looking the way you want. (The
            next section has details on working with panels.) Next, click the Workspace menu and
            choose New Workspace (it's at the bottom of the menu). In the resulting dialog box, give
            your workspace a meaningful name and turn on the options for the features you want to
            include. You can pick from panel locations, keyboard shortcuts, and menu settings; just
            be sure to turn on the options for all the features you changed or
            they won't be included in your custom workspace. After you click Save, your custom workspace shows up as the
            leftmost option in the Live Workspaces area, as well as in the Workspace menu.
If you've created some custom workspaces that you'll never use again, you can send
            'em packin'. First, make sure the workspace you want to delete isn't active. Next,
            choose Delete Workspace from the Workspace menu and, in the resulting Delete Workspace
            dialog box, pick the offending workspace and then click Delete. Photoshop will ask if
            you're sure, so you have to click OK to finish it off.
Note
New in Photoshop CS5 is the ability to delete any workspace you want—including the
              presets!




Working with Panels



The far right side of the Application Frame is home to a slew of small windows called
            panels (years ago they were called palettes), which let you work
          with commonly used features like colors, adjustments, layers, and so on. Panels don't have
          to live alone; you can link them together in groups, which you can then move around. Feel
          free to organize the panels however you like and position them anywhere you want. Panels
          can be free floating or docked (attached) to the left, top, or right
          side of your screen.
Photoshop starts you off with three docked panel groups filled with the panels it
          thinks you'll most likely need first. The first group includes the Colors, Swatches, and
          Styles panels; the second group includes Adjustments and Masks; and the third includes
          Layers, Channels, and Paths (there's more on docked panels coming up shortly).
To work with a panel, select it by clicking its tab. Panels are like Silly
          Putty—they're incredibly flexible. You can collapse, expand, move, and resize them or swap
          'em for other panels (the Windows menu lists all the panels in Photoshop). Here's
            how:
	Collapse or expand panels. If the panels are
              encroaching on your editing space, you can shrink them both horizontally and
              vertically so they look and behave like buttons (see Figure 1-6). To collapse a panel
              horizontally into a button nestled against the side of another panel (or the edge of
              your screen), click the tiny double arrow in its top-right corner (click this same
              button again to expand the panel). To collapse a panel vertically against the bottom
              of the panel above it, double-click a blank spot in the dark gray area near the
              panel's tab to make it roll up like a window shade (double-click it again to roll it
              back down). To adjust a panel's width, hover your cursor over its left edge and, when
              your cursor turns into a double-headed arrow, drag left or right to make the panel
              bigger or smaller. Collapsing and expanding panel groups works exactly the same
              way.
[image: Here you can see the difference between expanded (left) and collapsed (right) panels. Double-click the medium gray bar at the top of a panel to collapse it vertically (circled on the left), rolling it up like a window shade; double-click the bar again to expand it. You can also collapse a panel horizontally by clicking the double arrows at the top right of the panel (circled, right), at which point it turns into a small square button.]

Figure 1-6. Here you can see the difference between expanded (left) and collapsed (right)
                panels. Double-click the medium gray bar at the top of a panel to collapse it
                vertically (circled on the left), rolling it up like a window shade; double-click
                the bar again to expand it. You can also collapse a panel horizontally by clicking
                the double arrows at the top right of the panel (circled, right), at which point it
                turns into a small square button.

Note
In Photoshop CS4, you accomplished this panel collapsing and expanding business
                with a single-click; in CS5, it takes a double-click. Flip back
                to What's New in Photoshop CS5 to learn why.


	Modify panel groups. As mentioned earlier, Photoshop clumps frequently used panels into
                panel groups. If you don't use a certain panel in a group, you
              can replace it with one you do use. To remove a panel, click its
              tab and drag it out of the panel group to a different area of your screen (see Figure 1-7 top); then click the tiny
              circle in the panel's top-left corner to close it. (On a PC, click the X button in the
              panel's top-right corner instead.) Don't worry—the panel isn't gone forever; if you
              want to reopen it, simply choose it from the Windows menu.
To add a panel to a group, first make sure the panel is open (if not, select it
              from the Windows menu). Then grab the top of the panel near its tab and drag it into
              the group you want to add it to; when you see a blue outline appear around the panel
              group, release your mouse button (see Figure 1-7 middle).
[image: Top: You can remove panels you don't use to free up space. For example, if you never use the Styles panel (and you probably won't use it much), drag it out of the panel group and close it.Middle: When you're dragging a panel into a panel group, wait until you see a blue line around the inside of the group before you release your mouse button. Here the Kuler panel is being added to a panel group.Bottom: When you release your mouse button, the new panel becomes part of the group. To rearrange panels within a group, drag their tabs left or right.]

Figure 1-7. Top: You can remove panels you don't use to free up space. For example, if you
                never use the Styles panel (and you probably won't use it much), drag it out of the
                panel group and close it. Middle: When you're dragging a panel into a panel
                group, wait until you see a blue line around the inside of the group before you
                release your mouse button. Here the Kuler panel is being added to a panel
                group. Bottom: When you release your mouse button, the new panel becomes part
                of the group. To rearrange panels within a group, drag their tabs left or
                right.


	Dock and undock panels. The first time you open
              Photoshop, it docks three sets of panel groups to the right side of your screen (or Application Frame). But
              you're not stuck with your panels glued to this spot; you can set them free by turning
              them into floating panels. To liberate a panel, grab its tab,
              pull it out of the group it's in, and then move it anywhere you want. When you let go
              of your mouse button, the panel appears where you put it—all by itself.
To undock a whole panel group, click an empty spot in the group's tab area and
              drag it out of the dock (Figure 1-8
              top). Once you release your mouse button, you can drag the panel group around by
              clicking the same empty spot in the tab area. Or, if the group is collapsed, click the
              tiny dotted lines at the top of the group, just below the dark gray bar (Figure 1-8 bottom). To dock the panel (or
              panel group) again, drag it back to the right side of your screen.
[image: Top: To undock a panel or panel group, grab a free area to the right of the tabs at the top of the panel and drag it somewhere else on your screen. To dock it again, drag it to the right side of your screen—on top of the other panels. When you see a thin blue line appear where you want the panel or group to land, release your mouse button.Bottom: You can move vertically collapsed panels in the same way, but you grab them by the row of tiny dots that appears at the top (shown here).]

Figure 1-8. Top: To undock a panel or panel group, grab a free area to the right of the
                tabs at the top of the panel and drag it somewhere else on your screen. To dock it
                again, drag it to the right side of your screen—on top of the other panels. When you
                see a thin blue line appear where you want the panel or group to land, release your
                mouse button. Bottom: You can move vertically collapsed panels in the same way,
                but you grab them by the row of tiny dots that appears at the top (shown
                here).

Getting the hang of undocking, redocking, and arranging panels takes a little
              practice because it's tough to control where the little buggers
                land. When the panel you're dragging is about to join the dock
              area at the right side of your screen (or a different panel group), a thin blue line
              appears showing you where the panel or group will go. Unfortunately, the line can be
              tough to spot because it's so thin and light colored.



Tip
If the thin blue highlight lines are hard to see when you're trying to group or dock
            panels, try dragging the panels more slowly. When you drag the panel into a group or
            dockable area, the blue highlight hangs around longer and the panel itself becomes
            momentarily transparent.

Using the Tools Panel



One of the panels you'll frequent the most is named Tools (Figure 1-9 left); it serves as home base for
            all of Photoshop's editing tools. When you first launch the program, you'll see the
              Tools panel on the left side of your screen, but you can drag it anywhere
            you want by clicking the double row of dots near its top (Figure 1-9 right).
[image: Unfortunately, there's not enough room in the Tools panel for each tool to have its own spot (or the panel would be a mile long), so related tools are grouped together into toolsets. The microscopic black triangle at the bottom right of each tool's button lets you know it represents more than one tool (the Move and Zoom tools are the only ones that live alone). To see the other tools, hold down the tool's button and Photoshop displays a list of the other tools it harbors in a fly-out menu, as shown here (left).Photoshop starts you off with a one-column Tools panel (left), but you can collapse it into two columns (right) by clicking the tiny triangles circled here (click it again to switch back to one column).If you want to undock the Tools panel, grab the dotted bar shown here and drag the panel wherever you want it.]

Figure 1-9. Unfortunately, there's not enough room in the Tools panel for each tool to have
              its own spot (or the panel would be a mile long), so related tools are grouped
              together into toolsets. The microscopic black triangle at the bottom right of each
              tool's button lets you know it represents more than one tool (the Move and Zoom tools
              are the only ones that live alone). To see the other tools, hold down the tool's
              button and Photoshop displays a list of the other tools it harbors in a fly-out menu,
              as shown here (left). Photoshop starts you off with a one-column Tools panel
              (left), but you can collapse it into two columns (right) by clicking the tiny
              triangles circled here (click it again to switch back to one column). If you want
              to undock the Tools panel, grab the dotted bar shown here and drag the panel wherever
              you want it.

Once you expand a toolset, you'll see the tool's keyboard shortcut listed to the
            right of its name. These shortcuts are great timesavers because they let you switch
            between tools without moving your hands off the keyboard. To access a tool that's hidden
            deep within a toolset, add the Shift key to the tool's shortcut and you'll cycle through
            all the tools in that toolset. For example, to select the Elliptical Marquee tool, press
            Shift-M repeatedly until that tool appears in the Tools panel.
Tip
If you need to switch tools temporarily—for a quick edit—you
              can use the spring-loaded tools feature. Just press and hold a tool's keyboard
              shortcut to switch to that tool and then perform your edit. As soon as you release the
              key, you'll jump back to the tool you were using before. For example, if you're
              painting with the Brush and suddenly make an error, press and hold E to switch to the
              Eraser and fix your mistake. Once you release the E key, you're back to using the
              Brush tool. Sweet!

For an overview of all the tools in this panel, check out Appendix D, online. For a
            quick reminder of what each tool does, hover your cursor over its icon for a couple of
            seconds and Photoshop displays a handy tooltip that includes the tool's name and
            keyboard shortcut (you have to keep your mouse perfectly still).
Foreground and background color chips



Photoshop can handle millions of colors, but its tools let you work with only two at a time: a foreground
              color and a background color. Each of these is visible as a square color
                chip near the bottom of the Tools panel (in Figure 1-9 they're black and white,
              respectively). Photoshop uses your foreground color when you paint or fill something
              with color. It uses your background color to do things like set the second color of a
                gradient (a smooth transition from one color to another, or to
              transparency) and erase parts of a locked Background layer (Restacking Layers); it's also helpful when you're running special
              effects like the Clouds filter (Render). In other words, the
              foreground color is where most of the action is. If you want to change either color,
              click its color chip once to make Photoshop open the Color Picker (Choosing Individual Colors), which lets you select another color for
              that particular color chip. To swap your foreground and background colors, click the
              double-headed arrow just above the two chips or press X. (Remember this shortcut; it's
              extremely handy when you work with layer masks, which are discussed in Chapter 3.)


Colors



In the upper-right part of your screen is the Color panel, which also displays your current foreground and background
            color chips. This panel lets you pick a new color for either chip
              without having to open the just-mentioned Color Picker (which
            means Photoshop won't pop open a big dialog box that hides part of your image). The
            Color panel is discussed in Chapter 12 on The Color Panel.
Tip
If you're using the Brush tool, you can summon Photoshop CS5's new onscreen Color
              Picker (Painting from Scratch). Instead of being inside a dialog
              box, it appears to sprout from within your image! To see it for yourself, press B to
              grab the Brush tool and then press and hold Ctrl-Option-⌘ (right-click+Alt+Ctrl on a
                PC).


Swatches



The Swatches panel holds miniature samples of colors, giving you easy access to
            them for use in painting or colorizing your images. This panel also stores a variety of
              color libraries like the Pantone Matching System (special inks used in
            professional printing). You'll learn all about the Swatches panel in Chapter 12 on The Swatches Panel.

Styles



Styles are special effects created with a variety of layer
            styles (Layer Styles). For example, if you've created a glass-button
            look by using several layer styles, you can save the whole lot of 'em as a
              single style—which means you can apply it with a single click
            (instead of adding each layer style individually). You can also choose from tons of
            built-in styles; they're all discussed starting on Using the Styles Panel.

Adjustments



The Adjustments panel gives you one-stop access to all of Photoshop's Adjustment
            layers, as well as their various presets. Instead of making color and lighting changes
            to your original image, you can use Adjustment layers to make the change on a
              separate layer, giving you all kinds of editing flexibility and
            keeping your original image out of harm's way. They're explained in detail in Chapter 3 (The Layers Panel) though you'll see 'em used throughout this book.

Masks



This panel lets you create and fine-tune layer masks. You'll dive headfirst into
            masks in Chapter 3 (Layer Masks: Digital Masking Tape), but, for now, you can think of them as
            digital masking tape that lets you hide the contents of a layer, whether it's an
            adjustment of some sort (a color or lighting change) or parts of an image. This panel
            also gives you access to several ways to fine-tune a mask once you've created
              it.

Layers



The Layers panel is the single most important panel in Photoshop. Layers let you
            work with your images as if they were a stack of transparencies, so you can create one
            image from many. By using layers, you can resize, adjust the opacity, and add layer
            styles to each item independently. Understanding layers is the key
            to Photoshop success, and you'll learn all about them in Chapter 3.

Channels



Channels are where Photoshop stores the color information your images are made from,
            whether that's RGB (red, green, blue), CMYK (cyan, magenta, yellow, black), grayscale,
            and so on. Channels are extremely powerful, and you can use them to edit the individual
            colors in your image, which is helpful in sharpening images, creating selections
            (telling Photoshop which part of an image you want to work with), and so on. Chapter 5 has the scoop on channels.

Paths



Paths are the outlines you make with the Pen and Shape tools. But these aren't your
            average, run-of-the-mill lines—they're made up of points and paths instead of pixels, so
            they'll always print perfectly crisp. You can also make them bigger or smaller without
            losing any quality. You'll learn all about paths in Chapter 13.

Navigator



Think of the Navigator panel as a map. It displays a mini version of your image with
            a frame around the area you're currently zoomed in on. You can use this panel to move
            around in your document and change your zoom level. The Navigator panel is especially
            useful when you're working with huge images and you're zoomed in to work on fine
            details. To see it in action, flip to Chapter 2, Zooming with the Navigator Panel.

Histogram



A histogram is a mountainous-looking graph that represents the color and brightness
            info contained in your image. The left side of the graph shows how much of the image
            falls into the darkest range of colors (shadows), the far right shows the lightest range
            (highlights), and the area in the middle represents colors in between (midtones).
              Histograms are crucial when you're color-correcting images, and they're
            discussed at length in Chapter 9, beginning on
              Using Levels.

Info



The Info panel is your command center for general info about the image you're
            working on. It shows you the color values of certain pixels, your cursor's location
            within the document, image size, and other useful bits of, well, image info. It changes
            on the fly to show info that relates to the currently selected tool and gives you a
            handy tip about using that tool (provided you have that option turned on). You can find
            out more on pages 401 and 404.


The Power of Undo



Thankfully, Photoshop is extremely forgiving: It'll let you back out of almost
          anything you do, which is muy importante when you're first
            learning.
You've got several ways to retrace your steps, including the lifesaving Undo
          command—just choose Edit→Undo or press ⌘-Z (Ctrl+Z on a PC). Unfortunately, the Undo
          command lets you undo only the last edit you made.
If you need to go back more than one step, use the Step Backward
          command—choose Edit→Step Backward or press ⌘-Option-Z (Ctrl+Alt+Z on a PC). Out of the
          box, this command lets you undo the last 20 things you did, one at a time. If you want to
          go back even further, you can change that number by digging into Photoshop's preferences,
          as the next section explains. You can step forward through your edit history, too, by
          choosing Edit→Step Forward or ⌘-Shift-Z (Shift+Ctrl+Z on a PC).
Note
Photoshop lets you undo up to 20 changes, back to the point when you first opened the document,
            meaning you can't close a document and then undo changes you made
              before you closed it.

Changing How Far Back You Can Go



If you think you might someday need to go back further than your last 20 steps, you
            can make Photoshop remember up to 1,000 steps by changing the
            program's preferences. Here's how:
	Open the Preferences dialog box.
On a Mac, choose Photoshop→Preferences and then, in the resulting dialog box,
                click Performance in the left-hand column to see the history preferences.
On a PC, choose Edit→Preferences and, from the resulting submenu, choose
                Performance.

	Look for the History States field in the upper right
                  corner of the Preferences dialog box and then pick the number of Undo steps you
                  want Photoshop to remember.
You can enter any number between 1 and 1,000. While increasing the number of
                history states might help you sleep better, doing so means Photoshop has to keep
                track of that many versions of your document, which requires memory and processing
                power. If you increase this setting and notice that the program is running like
                molasses, try lowering it.

	Click OK when you're finished.




Turning Back Time with the History Panel



The History panel is like your very own time machine. Whereas the Undo and Step
            Backward commands let you move back through changes one step at a time, the History
            panel (see Figure 1-10) kicks it up a
            notch and lets you jump back several steps at once. (You can step
            back through as many history states as you set in Photoshop's preferences.) The History
            panel is much quicker than undoing a long list of changes one by one, and it gives you a
            nice list of exactly what you've done to your image—in
            chronological order from top to bottom—letting you pinpoint the exact state you want to
            jump back to. You can also take snapshots of your image at various points in the editing
            process to make it easier to jump back to the state you want (as explained in a
              moment).
[image: Top: The History panel keeps track of everything you do to your images, beginning with opening them. The tiny pointer (circled) lets you know which editing step you're on. You can also take snapshots of your image at crucial points during the editing process like when you convert it to black and white and add a color tint.Bottom: If you take a snapshot, you can revert to that state later with a single click. For example, if you've given your image a sepia (brown) tint and later changed it to blue, you can easily go back to the sepia version by clicking the snapshot you took, as shown here, without having to step back through all the other changes you made. What a timesaver!]

Figure 1-10. Top: The History panel keeps track of everything you do to your images, beginning
              with opening them. The tiny pointer (circled) lets you know which editing step you're
              on. You can also take snapshots of your image at crucial points during the editing
              process like when you convert it to black and white and add a color tint. Bottom:
              If you take a snapshot, you can revert to that state later with a single click. For
              example, if you've given your image a sepia (brown) tint and later changed it to blue,
              you can easily go back to the sepia version by clicking the snapshot you took, as
              shown here, without having to step back through all the other changes you made. What a
              timesaver!

After you make a few changes to your image, pop open the History panel by choosing
            Window→History to see a list of everything you've done to the image, including opening
            it. To jump back in time, click the step you want to go back to and Photoshop returns
            your image to the way it looked at that point. The tiny pointer in the panel's left
            column (circled in Figure 1-10, top)
            shows which step you selected (and the step itself is highlighted). If you stepped back
            further than you meant to, just pick a more recent step in the list.
If you'd like to see a thumbnail preview at the top of the History panel showing what your image looks like every time you save your
            document, choose History Options from the History panel's menu, and then turn on
            Automatically Create New Snapshot When Saving. Clicking the thumbnail is a fast and easy
            way to jump back to the last saved version of your document without having to close and
            reopen it.
Tip
You can also get back to the last saved version of your document by choosing
              File→Revert (Revert Command).

Taking snapshots of your image along the way lets you mark key
            points in the editing process. A snapshot is more than a preview of your image because
            it also includes all the edits you've made up to that point. Think of snapshots as
            milestones in your editing work: When you reach a critical point that you may want to
            return to, take a snapshot so you can easily get back to that particular version of your
            document. To take a snapshot, click the little camera icon at the bottom of the History
            panel (shown in Figure 1-10). Photoshop
            adds the snapshot to the top of the panel, just below the saved-state thumbnail. The
            snapshots you take appear in the list in the order you took them.
Note
History states don't hang around forever: As soon as you close your document,
              they're history (ha!). If you think you'll ever want to return to an earlier version
              of your document, use the "Create new document from current state" button at the
              bottom of the History panel. That way, you've got a brand-new document to return to so
              you don't have to recreate it.


The History Brush



The History Brush takes the power of the History panel and lets you focus it on
            specific parts of your image. Instead of sending your entire image
            back in time, you can use this brush to paint your edits away
              selectively, revealing the previous state of your choosing. For
            example, you could blur the heck out of a portrait with the Gaussian Blur filter (Skin Softeners) and then use the History Brush to revert to the original,
            sharp version of your subject's face, as shown in Figure 1-11. Of course, you paint away other
            edits, too, like color changes, filter effects, or any other changes you made in
              between.
Note
The Art History Brush works similarly, but it adds bizarre, stylized effects as it
              returns your image to a previous state, as shown in the box on The Art History Brush.

[image: By using the History Brush set to your image's Open state—see step 4 on this page—you can undo all kinds of effects, including a severe Gaussian Blur.]

Figure 1-11. By using the History Brush set to your image's Open state—see step 4 on this
              page—you can undo all kinds of effects, including a severe Gaussian Blur.

Here's how to use the History Brush to undo a serious Gaussian Blur you've
              applied:
	Open an image—in this example, a photo of a person—and run
                  the Gaussian Blur filter.
You'll learn all about opening images on Opening an Existing Document, but, for now, choose File→Open and then
                navigate to where the image lives on your computer. Then choose Filter→Blur→Gaussian
                Blur. (Chapter 15 tells you all about using
                filters.)

	In the resulting dialog box, enter a radius of 20 and then
                  click OK.
Depending on the size of your image, this setting blurs your image pretty
                severely, giving you a lot to undo with the History
                Brush.

	Grab the History Brush by pressing Y and then choose a
                  brush from the Options bar.
Once you've grabbed the History Brush, hop up to the Brush Preset picker in the
                Options bar and pick a large, soft-edged brush (one that's pretty big and blurry
                around the edges). You'll learn about brushes in Chapter 12.

	Open the History panel (choose Window→History) and then
                  click a saved state or snapshot.
This is where you pick which version of the image you want to go back to. Since
                all you've done is open the image and run the Gaussian Blur filter, choose the Open
                state. Just click within the panel's left-hand column next to that state to pick it
                (you'll see the History Brush's icon appear in the column).

	Mouse over to your image and paint over the person's eyes
                  to reveal the unblurred eyes of the original image.
If you keep painting in the same place, you'll expose more and more of the
                original image (it's a gradual change). For example, a quick swipe over the eyes
                reveals traces of the original while a good scrubbing back and forth in one area
                reveals the original in its full glory.



As you can see, you can use the History Brush to easily undo anything you've done; just pick the state you
            want to revert to in the History panel and then paint away!
Power Users' Clinic: Erasing to History
At some point, you'll realize that the perfect fix for your image is something you
              zapped about 10 steps ago. For example, you may change the color of an object only to
              decide later that it looked better the way it was. Argh.
Thanks to Photoshop's "Erase to History" feature, you can jump back in time and
              paint away the edits you no longer want. First, grab the Eraser tool by pressing E and
              then turn on the "Erase to History" checkbox in the Options bar. Next, click the layer
              you want to edit in the Layers panel and then start erasing the areas you want to
              restore to their former glory.
Erasing to history is a really handy way to leave some
              changes in place while recovering your original image in other areas.


Revert Command



If you've taken your image down a path of craziness from which you
              can't rescue it by using Undo or the History panel, you can
            revert back to its most recent saved state by choosing File→Revert. This command opens
            the previously saved version of your image, giving you a quick escape route back to
            square one.
Note
If you haven't made any changes to your image since it was last saved, you can't
              choose the Revert option; it's grayed out in the File menu.



Tweaking Photoshop's Preferences



As you learned earlier in this chapter, Photoshop is pretty darn customizable. In
          addition to personalizing the way your tools behave and how your workspace looks, you can
          make lots of changes using the program's preferences, which control different aspects of
          Photoshop and let you turn features on or off, change how tools act, and fine-tune how the
          program performs on your computer.
To open the Preferences dialog box, choose Photoshop→Preferences (Edit→Preferences→General on a PC),
          or press ⌘-K (Ctrl+K). When you choose a category on the left side of the dialog box, you
          see tons of settings related to that category appear on the right. In the following pages,
          you'll get an idea of the kind of goodies each category contains.
General



The General section in the Preferences dialog box (Figure 1-12) is a sort of catchall for
            preferences that don't fit anywhere else. Most of these options are either
            self-explanatory (Beep When Done, for example) or covered elsewhere in this book. A few,
            however, are worth taking a closer look at.
Unless you tell it otherwise, Photoshop displays the Adobe Color Picker (see Choosing Individual Colors) anytime you choose a color. If you're more
            comfortable using your operating system's color picker instead, you can select it from
            the Color Picker pop-up menu. If you download and install third-party color pickers like
            Painter's Picker (Choosing Individual Colors), they show up in this
            menu, too. However, since the Adobe Color Picker is designed to work with Photoshop and
            all its built-in options, using another color picker may mean losing quick access to
            critical features like Color Libraries (The Eyedropper Tool).
[image: The General section of Photoshop's Preferences dialog box is home to the History Log settings. If you turn on the History Log checkbox, Photoshop keeps track of everything that happens to your images. This is an invaluable tool for folks who need to prove what they've done to an image for billing clients or to produce legal documentation of all the edits they've made to an image (think law enforcement professionals and criminal investigators).]

Figure 1-12. The General section of Photoshop's Preferences dialog box is home to the History
              Log settings. If you turn on the History Log checkbox, Photoshop keeps track of
              everything that happens to your images. This is an invaluable tool for folks who need
              to prove what they've done to an image for billing clients or to produce legal
              documentation of all the edits they've made to an image (think law enforcement
              professionals and criminal investigators).

Note
Trashing Photoshop's preferences file can be a useful troubleshooting technique.
              Download Appendix B, online, for step-by-step details.

Note
Photoshop CS5 has two new options in the General section: Pop-up menu control over the new Heads Up Display (HUD)
              Color Picker that you'll learn about on Painting from Scratch, and
              the option to "Place or Drag Raster Images as Smart Objects". As you'll learn on Using Smart Objects, you'll want to leave the latter option turned on
              for good!

Another notable option in this dialog box involves a couple of cool features called
            animated zoom and flick-panning (both covered in Chapter 2). If your computer is running at a
            snail's pace, try turning off one or both features by turning off their checkboxes (both
            features can really tax slower video cards).

Interface



The Interface preferences control how Photoshop looks on your screen. You can
            squeeze a little more performance out of slower computers by setting the Border pop-up
            menus at the top of the dialog box to None. That way, Photoshop won't waste any
            processing power generating those pretty drop shadows around your images or around the
            Photoshop window itself.
Also, if you're familiar with all of Photoshop's tools and don't care to see the
            little yellow tooltips that appear when you hover over tools and field labels (The Almighty Options Bar), turn off the Show Tool Tips checkbox in the
            middle of the dialog box below the pop-up menus. If you'd like new documents to open in
            separate windows instead of in new tabs, turn off the "Open Documents as Tabs"
            checkbox.
Note
If you use Photoshop on a Mac laptop, there's a new setting in the Interface
              section that'll make you jump for joy. Gesture support for Mac trackpads (Zooming In and Out) was a new and coveted feature in CS4; however, with
              no way to turn it off, folks were constantly zooming and rotating their canvases with
              their trackpads by accident. The only fix was to download a plug-in to disable it and
              few people even knew that existed. Happily, all you have to do in CS5 is turn off the
              Enable Gestures checkbox in the Interface preferences. Yay!


File Handling



The File Handling settings control how Photoshop opens and saves files. If
            you're a Mac person and you plan on working with images that'll be opened on both Macs
            and PCs, make sure Append File Extension is set to Always and that Use Lower Case is
            turned on. These settings improve the chances that your files will open on
              either type of computer without a hassle. (PC users can leave
            their File Handling settings alone because Mac users can open their Photoshop
            files just fine.)
Straight from the factory, Photoshop is set to display a dialog box each time you
            save a file that asks if you want to save your images for maximum compatibility with
              PSD and PSB files (the native Photoshop
            format and the format for really big files, respectively; see Opening an Existing Document). Saving your documents with maximum
            compatibility improves the chances that they can be understood by other programs like
            Adobe InDesign. If that pesky dialog box annoys you, change the "Maximize PSD and PSB
            File Compatibility" pop-up menu to Always and you'll never see the dialog box again
            (plus you'll have the peace of mind that comes with knowing your images will play nice
            with other programs).
Another handy option lies at the very bottom of the dialog box where you can change
            the number of documents Photoshop remembers in its Recent files menu (found by choosing
            File→Open Recent). This field is automatically set to 10, but feel free to change
            it.

Performance



The Performance preferences (Figure 1-13)
            control how efficiently Photoshop runs on your computer. For example, the amount of
            memory the program has to work with affects how well it performs. In the Memory Usage
            section's Let Photoshop Use field, Photoshop's factory setting tells the program to use
            up to 70 percent of your machine's available memory. If you're tempted to increase it to
            100 percent for better performance, don't. Other programs need to use your computer's
            memory, too, and leaving it set to 70 percent ensures that all of them get their fair
            share (after Photoshop takes the biggest chunk, of course).
[image: To add one or more scratch disks (page 35), click the "Active?" column next to each hard drive you want to use, and then drag the hard drives up or down into the order you want Photoshop to use them.Avoid using USB-based hard drives as they tend to be sluggish and can actually make Photoshop run slower.]

Figure 1-13. To add one or more scratch disks (page 35), click the "Active?" column next to
              each hard drive you want to use, and then drag the hard drives up or down into the
              order you want Photoshop to use them. Avoid using USB-based hard drives as they
              tend to be sluggish and can actually make Photoshop run slower.

Note
A new feature of Photoshop CS5 is that you can let the program set optimal Cache
              Levels and Tile Sizes for you. All you have to do is pick the
              kind of document you work on the most. Your options include "Tall and Thin",
              "Default", and "Big and Flat".

The Performance category is also where you can change the number of history
            states that Photoshop remembers, as explained on Changing How Far Back You Can Go. If your computer's hard drive is running
            low on space, consider adding another drive that Photoshop can use as a
              scratch disk—the place where it stashes the bazillions of
            temporary files it makes when you're editing images like those various history states.
            (If you don't have a separate scratch disk, Photoshop stores those temporary files on
            your computer's hard drive, taking up space you could be using for other documents.)
            When you add a new internal hard drive or plug in an external drive, that drive appears
            in the Scratch Disks list shown in Figure 1-13. You can give Photoshop the green
            light to use it by putting a checkmark in the disk's "Active?" column, and dragging it
            upward into the first position. If you go this route, Photoshop will run a little
            zippier because it'll have two hard drives reading and writing info
            instead of one!
If you need to squeeze a little more performance out of your machine, turn off the
            Enable OpenGL Drawing checkbox (see the box on Understanding OpenGL).
            The drawback to turning off this setting is that you won't be able to use features that
            rely on it like flick-panning (Moving Around in Your Image) and Rotate
            View (Zooming with the Navigator Panel).
Note
When it comes to Photoshop's scratch disk, speed matters, and faster is better.
              Since the speed at which the disk spins plays a big role in scratch disk performance,
              stick with disks rated 7200 RPM (revolutions per minute) or faster. Slower 5400 RPM
              disks can take a toll on Photoshop's performance, and 4200 RPM drives
              slow…Photoshop…to…a…crawl.


Cursors



These preferences control how your cursors look when you're working with images.
            There are no right or wrong choices for you to make here, so try out the different
            cursor styles and see what works for you. Photoshop includes two types of cursors:
            painting cursors and everything else. When you choose different options, Photoshop shows
            you a preview of what each cursor looks like. At the bottom of the dialog box is a Brush
            Preview color swatch that controls the color of the brush preview when you resize your
            brush by Ctrl-Option-dragging (Alt+right-click+dragging on a PC) to the left or right.
            To change the swatch's color, click the color chip, choose a new color from the Color
            Picker dialog box, and then click OK. (See Controlling the Brush Cursor's Appearance to learn how these options affect
            the Brush tool.)

Transparency & Gamut



The Transparency settings let you fine-tune what the Background layer looks like
            when part of your image is transparent. Like the cursor settings, these options are
            purely cosmetic, so feel free to experiment. (You'll learn more about transparency and
            the Background layer in Chapter 3.) The
              Gamut Warning option lets you set a highlight color showing where colors in
            your image fall outside the safe range for the color mode you're working in or the
            printer you're using. (Chapter 16 has more about all these
            advanced color issues.)

Units & Rulers



The Units & Rulers preferences (Figure 1-14) let
            you determine the unit of measurement Photoshop uses. The Rulers pop-up menu, not
            surprisingly, controls the units displayed in your document's rulers (see Rulers and Guiding Lines); your choices are pixels, inches, centimeters,
            millimeters, points, picas, and percent. If you work on a lot of documents destined for
            print, inches or picas are probably your best bet. If you create images primarily for
            the Web, choose pixels. Leave the Type pop-up menu set to points unless you need to work
            with type measured in pixels or millimeters, which can be handy if you need to align
            text for a web page layout.
Power Users' Clinic: Customizing Keyboard Shortcuts and Menus
Keyboard shortcuts can make the difference between working fast and working at
              warp speed. They can drastically reduce the amount of time you spend taking your hands
              off the keyboard to use your mouse to do things like choose menu items or grab tools.
              Photoshop has a ton of built-in keyboard shortcuts and menu groups, but that doesn't
              mean you're stuck with 'em. You can reassign shortcuts, add new ones, and show or hide
              menu options. Here's how to add or change keyboard shortcuts:
	Choose Edit→Keyboard Shortcuts to open the "Keyboard Shortcuts and Menus" dialog box.

	Choose which type of shortcuts you want to add or change from the Shortcuts
                  For pop-up menu. You options are Application Menus (like the File and Edit menus),
                  Panel Menus (the menus on the program's various panels), and Tools.

	In the list below the Shortcuts For menu, select the shortcut you want to
                  change.

	Enter a new shortcut in the Shortcut field and then click Accept.

	To save your new shortcut set, click the floppy-disk icon near the top of the
                  dialog box to the right of the Set pop-up menu. In the resulting dialog box, give
                  your custom set of shortcuts a name and then click Save.



To help you remember the new shortcuts, Photoshop lets you print a handy chart to
              tack up on the wall. In the "Keyboard Shortcuts and Menus" dialog box, select your
              custom set from the Set pop-up menu and then click Summarize. In the resulting Save
              dialog box, give the keyboard shortcut list a name, choose where to save it, and click
              Save. Photoshop creates an HTML file that you can open in any Web browser and then
              print. When you're finished, you can impress your colleagues by telling them that you
                reprogrammed Photoshop to do your bidding; unless they've been
              in this dialog box themselves, they'll have no idea how easy this stuff is to
                change.
In the "Keyboard Shortcuts and Menus" dialog box, you can also modify the
              program's menus by clicking the Menus tab near the top of the box. In the Menu For
              pop-up menu, choose Application Menus or Panel Menus, depending on which ones you want
              to tweak. Click the little flippy triangle next to each menu to see the items it
              includes. To hide a menu item, select it and then click its visibility eye; to show a
              hidden item, click within its Visibility column. You can even colorize menu items so
              they're easier to spot. To do that, select the item you want to highlight, click the
              Color column, and then choose a color from the resulting pop-up menu. Click OK and
              enjoy your new customizations.

[image: To really save some time, take a moment to adjust the settings in the New Document Preset Resolutions section. From that point on, Photoshop automatically fills in the New Document dialog box with the settings you entered here (you'll learn about creating new documents on page 41).]

Figure 1-14. To really save some time, take a moment to adjust the settings in the New
              Document Preset Resolutions section. From that point on, Photoshop automatically fills
              in the New Document dialog box with the settings you entered here (you'll learn about
              creating new documents on page 41).

The Column Size settings are handy when you're designing graphics to fit into
            specific-sized columns in a page layout program like Adobe InDesign. Just ask the person
            who's creating the InDesign layout which measurements to use.

Guides, Grid & Slices



These preferences let you choose the colors for your guides (Guides, Grids, and Rulers), gridlines (Smart Guides), and
            slice lines (Slicing an Existing Image). You can also set your
            gridlines' spacing and the number of subdivisions that appear between each major
            gridline with the "Gridline every" and Subdivisions fields, respectively.

Plug-ins



You can make Photoshop do even more cool stuff by installing third-party programs
            called plug-ins. There are so many useful plug-ins that this book
            has an entire chapter devoted to them (Chapter 19). The
              preferences in this category let you store plug-ins somewhere other than the
            Photoshop folder, which can help you avoid losing your plug-ins if you have to reinstall
            Photoshop. Leave both checkboxes in the Extension Panels section turned on so Photoshop
            can connect to the Internet if a plug-in or panel needs to grab information from a
            website. For example, the Kuler panel (Using the Kuler Panel) lets you
            use color themes posted on the Web by folks in the Kuler community. If you turn off
            these checkboxes, Photoshop can't connect to the Internet and you can't use
              Kuler!

Type



Photoshop has an amazing type engine under its hood, and you'll learn all about it
            in Chapter 14. The preferences here let you toggle Smart
            Quotes (the curly kind) on or off, as well as control the Font Preview Size used in the
            Options bar's font menu and in the Character panel (The Character Panel). Because seeing a font in its typeface is so handy when you're choosing fonts, in
            CS5 this option is turned on right out of the box. If you don't want to see typeface
            previews, turn off Font Preview Size to make Photoshop display only the typeface names
              (yawn).
If you work with Asian characters, turn on the Show Asian Text Options checkbox and
            make sure the Enable Missing Glyph Protection checkbox is also turned on. That way you
            won't end up with weird symbols or boxes if you try to use a letter or symbol that isn't
            installed on your machine.


The Preset Manager



Once you get comfortable in Photoshop, you can customize most every tool in the Tools
          panel: the Crop tool, selection tools, healing brushes, the Type tool, gradients, and so
          on. The Preset Manager handles loading, saving, and storing your personalized goodies, as
          well as all the presets (built-ins which you can think of as tool
          recipes, such as gradients, patterns, and so on) that came with the program. You can open
          it by choosing Edit→Preset Manager or by clicking the right-facing triangle at the top
          right of any tool's Preset picker menu in the Options bar, and then choosing Preset
          Manager. (You can also open a tool's Preset picker by choosing Window→Tool
            Presets.)
Each group of settings, like a category of brushes, is called a preset
            library. To see a certain preset library, choose it from the Preset Type
          pop-up menu at the top of the Preset Manager dialog box (Figure 1-15).
Clicking the button that's circled in Figure 1-15 lets you set the category of
          presets you're viewing to the factory-fresh settings (choose "Reset [name of category]"
          and then click OK). You can make these adjustments when you're using the tools themselves,
          but the Preset Manager gives you a bigger preview space, which makes these organizational
          chores a little more tolerable.
Note
In CS5, brushes have a brand-spankin' new preset panel of their very own. Flip ahead
            to Meet the Mixer Brush to see it in action!

Sharing Presets



Once you've made your own recipes for tools, styles, or what have you, feel free to
            share them with the masses. You can share them with other computers (which is handy when
            the whole team needs to use the same color swatches or brushes) and upload them to the
            Web (for the whole world to download).
[image: You can open the Preset Manager panel's menu by clicking the right-facing triangle (circled). This menu lets you change the size of the previews you see in Photoshop's Preset picker menus, as well as reset, replace, and otherwise manage presets for all categories.To save your eyesight, it's a good idea to set the preview size to Large List so you can actually see what your options are.]

Figure 1-15. You can open the Preset Manager panel's menu by clicking the right-facing
              triangle (circled). This menu lets you change the size of the previews you see in
              Photoshop's Preset picker menus, as well as reset, replace, and otherwise manage
              presets for all categories. To save your eyesight, it's a good idea to set the
              preview size to Large List so you can actually see what your options are.

To create a preset library of your own, open the Preset Manager and click the Save
            Set button. In the resulting Save dialog box, give your custom library a name. Photoshop
            automatically saves it in the folders where it stores all custom
            settings unless you pick a different location on your hard drive (which is handy if you
            plan on sharing the library with other folks). When everything looks good, click
              Save.
Tip
If you're saving a custom preset to share with others, save it in a spot that's
              easy for you to find. For example, if you plan on emailing your preset library, your
              desktop may be a good option. If you're sharing your presets with coworkers who work
              in the same office, your local file server works well.

Once you've saved your custom preset library, you can email it to folks or upload it
            to a website for others to download. If you're uploading to the Web, make sure the file
            doesn't have any spaces in its name. For example, instead of calling your file "Dragon
            Scales Brush", name it "DragonScalesBrush".
If you're on the receiving end of a new preset library, open the Preset Manager by
            choosing Edit→Preset Manager and then click the Load button. Navigate to where the
            library lives and click Load. The next time you use a tool that has custom presets,
            you'll see the new library's options in the tool's Preset picker menu.
To add to the fun, you can also rename preset libraries. In the Preset Manager
            dialog box, select the relevant library from the Preset Type pop-up menu and click
            Rename; type a new name in the Name field and click OK. To delete a preset library you
            never use, select it from the Preset Manager's Preset Type pop-up menu and click
            Delete.
Tip
If you've managed to mess up one of Photoshop's built-in preset libraries by
              adding items that don't work the way you want, you can easily restore the original
              libraries: Open the Preset Manager and choose the library you want to reset. From the
              panel's menu (click the button that's circled in Figure 1-15), choose "Reset [type of
              preset]". Photoshop asks if you want to replace the current brushes or append (add to)
              them instead. Click OK to replace the brushes and you'll be back to the factory-fresh
              settings.



Chapter 2. Opening, Viewing, and Saving Files



Chances are good that if you're holding this book, you're spending a lot of time in
        Photoshop. So the ability to shave off a minute here and there from routine stuff can really
        add up. Heck, if you're lucky, you'll save enough time to read a book, ride your bike, or
        catch an episode of The Big Bang Theory
One way to steal back some of that time is to work more efficiently, and that means
        learning a slew of tricks for the less glamorous stuff like opening, viewing, and saving
        files. And since you'll be doing these things so often, it's important to form good habits
        so your documents are set up properly from the get-go. (Indeed, it would be truly
        heartbreaking to find the artwork you've spent weeks creating is too small to print, or you saved the file in such a way that you
        can't change it later on.) Finally, since a key part of working with images is navigating
        vast pixel landscapes, this chapter teaches you some handy ways to move around within your
        images onscreen.
Creating a New Document



Photoshop gives you a variety ways to accomplish most tasks, including creating a new
          document. Sure, you can choose File→New, but it's faster to press ⌘-N (Crtl+N on a PC).
          Either way, you'll be greeted with the New dialog box shown in Figure 2-1.
You'd think naming your document would be simple: Just type something in the Name box
          and you're done, right? Not quite. Here are a few things to keep in mind:
	If you're working on a Mac, don't start your file names with periods. Files whose
              names start with periods are invisible in Mac OS X (meaning neither you nor Photoshop
              can see them), which makes 'em darn hard to work with.
[image: The New dialog box (top) is where life begins for any Photoshop file you create. The settings here let you pick, among other things, your document's size, resolution, and color mode, all of which affect the quality and size of your image; you'll learn more about all these options in the following pages. Whatever you type in the Name box appears in the document's title bar (bottom).]

Figure 2-1. The New dialog box (top) is where life begins for any Photoshop file you
                create. The settings here let you pick, among other things, your document's size,
                resolution, and color mode, all of which affect the quality and size of your image;
                you'll learn more about all these options in the following pages. Whatever you type
                in the Name box appears in the document's title bar (bottom).


	If folks need to open your files on both Mac and Windows machines, don't put
              slashes (/), colons (:), angle brackets (<, >), pipes, (|), asterisks (*), or
              question marks (?) in the file names, either.

	Leave file extensions (the period and three letters at the
              end of the file name, like .psd, .jpg, and so on) on the file name. The file extension
              tells other programs what kind of file it is so they can open it.



Photoshop's Ready-Made Documents



After you've named your document, you need to pick a size for it. You've got two
            choices here: Enter the dimensions you'd like in the Width and Height boxes or pick one
            of Photoshop's canned choices (4"x6" landscape photo, 640x480–pixel web page, and so on)
            from the Preset and Size menus shown in Figure 2-2.
The advantage of picking a canned option is that, in addition to filling in the
            dimensions for you, Photoshop plugs in resolution and color mode settings. You'll learn more about these two options in a minute, but if
            you're new to the program, these presets (document recipes) are a
            great way to make sure you're starting off with a well-configured document. Besides, the
            presets can be helpful even if they're not exactly what you need.
            For example, if you find one that's the right size but the wrong resolution, just select
            it, adjust the resolution, and you're on your way.
Note
One document preset worth remembering is Clipboard: If you copy all or part of an
              image, choosing this preset tells Photoshop to grab that image's settings for you,
              making it super simple to match a document's settings without having to copy them
              first. Who knew?!

[image: Once you make a selection from the Preset menu (which includes different types of paper, electronic formats, and recently used document sizes), Photoshop fills the Size menu and its related fields with the appropriate settings—including Width, Height, Resolution, and Color Mode (page 46). Presets are great timesavers, and they help you avoid mistakes when you're making new documents.]

Figure 2-2. Once you make a selection from the Preset menu (which includes different types of
              paper, electronic formats, and recently used document sizes), Photoshop fills the Size
              menu and its related fields with the appropriate settings—including Width, Height,
              Resolution, and Color Mode (page 46). Presets are great timesavers, and they help you
              avoid mistakes when you're making new documents.

Up To Speed: Stealing Document Settings
Need to create a document that's the same size and resolution as an existing
              document? No problem—just snag one file's settings and use them to make another. You
              can swipe a document's settings in several ways:
	Open the existing document and press ⌘-N (Ctrl+N on a PC) to open the New
                  dialog box. Click the Preset pop-up menu, which lists the names of all open
                  documents. When you pick the one you want, Photoshop adjusts all the dialog box's
                  settings to match.

	With the existing document open, press ⌘-A (Ctrl+A) to select everything in it
                  and then press ⌘-C (Ctrl+C) to copy the document's contents to your computer's
                  memory. Next, choose File→New or press ⌘-N (Ctrl+N on a PC) and Photoshop
                  automatically fills in the document's settings for you.

	If you want to base your new document on the last
                  document you created, hold Option (Alt on a PC) while you choose File→New or press
                  ⌘-Option-N (Ctrl+Alt+N).

	To create a new document that's the same size and resolution as your current
                  selection, create the selection, copy the contents to your computer's memory, and
                  then choose File→New or press ⌘-N (Ctrl+N on a PC). Photoshop creates a document
                  that matches your selection's dimensions perfectly. (See Chapter 4 for the full story on
                  selections.)





Setting Size and Resolution



In Photoshop, size refers to two different things: file size (640 kilobytes or 2.4
            megabytes, for example) and dimensions (like 4"x6" or 640x480 pixels). You'll find
            plenty of advice throughout this book on how to control file size, but here you're
            concerned with the size of your document's canvas.
Photoshop can measure canvas size in pixels, inches, centimeters, millimeters,
            points, picas, and columns. Just pick the one that's appropriate for your project—or the
            easiest for you to work with—from the pop-up menus to the right of the Width and Height
            fields. If you're designing a piece for the Web or a slideshow presentation, pixels are
            your best bet. If you're going to print the image, inches are a common choice. Columns
            come in handy when you're making an image destined for a page-layout program, like Adobe
            InDesign, that has to fit within a specific number of columns.
Note
Photoshop assumes you want to use the same unit (say, inches) to measure width and
              height, so it automatically changes both fields when you adjust one. If you really
                do need to work with different units, just hold the Shift key
              while you pick the second unit to make Photoshop leave the other field alone.

The Resolution field controls the number of pixels per inch or per centimeter in
            your document. High-resolution documents contain more pixels per inch than
            low-resolution documents of the same size. (You'll learn all about resolution in Chapter 6, starting on Pixels and Resolution.)
For now, here's some ready-to-use guidance if you haven't yet mastered the fine art
            of resolution just yet: If you're designing an image that will be viewed only onscreen
            (in a web browser or a slideshow presentation, for example) enter
              72 in the Resolution field—it's really only the pixel dimensions
            that matter in this situation, but you'll learn more about that later. If you're going
            to print the image at home, set the resolution to at least 150 pixels per inch (if it's
            headed to a professional printer, enter 300 instead).
Once you enter values in the Width, Height, and Resolution fields, Photoshop
            calculates the document's file size—the amount of space it takes up
            on your hard drive—and displays it in the New dialog box's bottom-right corner (in Figure 2-1, for example, the file size is
            2.25 megabytes).
Tip
If you don't know the exact size your document needs to be, it's better to make it
              really big; you can always shrink it down later. See Straightening images for more info.

Up To Speed: Understanding Bit Depth
You may have heard the terms "8-bit" and "16-bit" tossed around in graphics
              circles (and neither has anything to do with Photoshop being a 64-bit program, as the
              box on What Does "64-bit" Mean? explains). When people refer to bits,
              they're talking about how many colors an image file contains. Photoshop's color modes
                (Choosing a Color Mode) determine whether your document is an 8-
              or a 16-bit image (other, less common options are 1-bit and 32-bit). Since you'll run
              into these labels fairly often, it helps to understand more about what these numbers
                mean.
A bit is the smallest unit of measurement that computers use
              to store information. Each pixel in an image has a bit depth,
              which controls how much color information that pixel can hold. So an image's bit depth
              determines how much color info the image contains. The higher the bit depth, the more
              colors the image can display. And the more colors in your image, the more info
              (details) you've got to play with in Photoshop.
Understanding bit depth also means you need to know a little about
                channels, where Photoshop stores your image's color info (see
                Chapter 5) on separate layers (Chapter 3). For example, in an RGB image
              you have three channels: one each for red, green, and blue. If you combine the info
              contained in each channel, you can figure how many colors are in your image.
With all that in mind, here's a quick tour of your various bit choices in
              Photoshop:
	In Bitmap color mode, your pixels can be only black or white. Images in
                  this mode are called 1-bit images because each pixel can be only one color—black
                  or white (they're also known simply as bitmap images).

	An 8-bit image can hold two values in each bit, which equals 256 possible
                  color values. Why 256? Since each of the eight bits can hold two possible values,
                  you get 256 combinations. (For math fans: it's two to the eighth power, which
                  equals 256). Images in Grayscale mode contain one channel, so that's 8 bits per
                  channel, equaling 256 colors. Since images in RGB mode contain three channels (one
                  each for red, blue, and green), folks refer to them as 24-bit images (8 bits per
                  channel x 3 = 24), but they're still really just 8-bit images. With 256 combinations for each channel (that's
                    28 x 28 x
                    28), you can have over 16 million colors in your RGB
                  image. Since CMYK images have four channels, folks refer to them as 32-bit images (8 bits per channel x 4 = 32), but again, these are
                    still 8-bit images. Over 200 combinations per channel and
                  four channels add up to a massive number of possible color values, but since
                  you're dealing with printed ink, your color range in CMYK is dictated by what can
                  actually be reproduced on paper, which reduces it to about 55,000 colors.

	16-bit images contain 65,536 colors in a single channel and are
                  produced by some high-end digital cameras (digital single-lens reflex, or dSLR,
                  cameras) shooting in Raw format (Working with Raw Files) or by
                  really good scanners. These files don't look any different from other images on
                  your screen, but they take up twice as much hard drive space. Photographers really
                  like them because the extra colors give them more flexibility when they're making
                  Curves and Levels adjustments (see Chapter 9), even though the larger file sizes can really slow Photoshop down. Also, not
                  all of Photoshop's tools and filters work with 16-bit images, but that list of
                  tools grows with each new version of the program.

	32-bit images, referred to as high dynamic range (HDR), contain more colors
                  than you can shake a stick at. See Creating High Dynamic Range Images for more info.



For the most part, you'll deal with 8-bit images, but if you've got a camera that
              shoots at higher bit depths, by all means, take a weekend and experiment to see if the
              difference in quality is worth the sacrifice of hard drive space (and editing speed).
              And if you're restoring a really old photo, it may be helpful to scan it at a high bit
              depth so you have a wider range of colors to work with. See the box on Scanning 101 for more scanning tips.

Just because you make a document a certain size doesn't mean you can't have artwork
            in that file that's bigger than the document's dimensions. Photoshop is perfectly fine
            with objects that extend beyond your document's edges (also called document
              boundaries), but you can't see or print those parts. It may sound odd, but
            if you paste a photo or a piece of vector art (Opening an Existing Document) that's larger than your document, those
            extra bits will dangle off the edges. To resize your document so you can see
            everything—even the stuff that doesn't quite fit—choose Image→Reveal All to make
            Photoshop modify your document's dimensions so everything fits.

Choosing a Color Mode



The New dialog box's Color Mode field (see Figure 2-1) determines which colors you can
            use in your document. You'll spend most of your time working in RGB mode (which stands
            for red, green, and blue), but you can switch modes whenever you like (see Chapter 16 for more info). The pop-up menu to the right of the
              Color Mode field controls your document's bit depth,
            which is explained in the box on Understanding Bit Depth.
Unless you choose a different color mode, Photoshop automatically uses RGB mode. The
            Color Mode menu gives you the following choices:
	Bitmap restricts you to two colors: black and
                white. (Shades of gray aren't welcome at the Bitmap party.) This mode is useful when
                you're scanning high-contrast items like black-and-white text documents or creating
                graphics for handheld devices that don't have color screens.

	Grayscale expands on Bitmap mode by adding shades
                between pure black and pure white. The higher the document's bit depth, the more
                shades of gray—and so the more details—it can contain. Eight-bit documents include
                256 shades of gray, 16-bit documents extend that range to over 65,000, and 32-bit
                documents crank it up to over 4.2 billion (see the box on Understanding Bit Depth for more on bit depth).

	RGB Color is the color mode you'll use the most,
                and it's also the one your monitor and digital camera use to represent colors. This
                mode shows colors as a mix of red, green, and blue light (RGB Mode vs. CMYK Mode), with each having a numeric value between 0 and
                255 that describes the brightness of each color present (for example, fire-engine
                red has an RGB value of 250 for red, 5 for green, and 5 for blue). As with Grayscale
                mode, the higher your document's bit depth, the more details it can contain. In this
                mode, you can choose among 8-, 16-, and 32-bit documents. (See Chapters Chapter 5, Chapter 9, and Chapter 16 for more on RGB mode.)

	CMYK Color simulates the colors used in printing
                and its name stands for cyan, magenta, yellow, and black ink. It doesn't have as
                many colors as RGB because it's limited to the colors a printer—whether it's an
                inkjet, commercial offset, or digital press—can reproduce with ink and dyes on paper
                (you'll learn more about CMYK in Chapters Chapter 5 and Chapter 16). Chapter 16 explains
                if and when you should switch to CMYK mode.

	Lab Color mode, which is based on the way humans see color, lets you use all the
                colors human eyes can detect. It represents how colors should
                  look no matter which device they're displayed on, whereas RGB and CMYK
                modes limit a file's colors to what's visible onscreen or in a printed document,
                respectively. The downside is that many folks have a hard time learning to create
                the colors they want in Lab mode. You'll find various techniques involving Lab mode
                sprinkled throughout Part 2 of this book.




Choosing Your Background



The New dialog box's Background Contents pop-up menu lets you choose what's on the
            Background layer—the only layer you start out with in a new document. Your choices are
            White, Background Color (which uses the color that the background color chip is set to
              [Foreground and background color chips]), and Transparent (which
            leaves the background completely empty).
What you choose here isn't that crucial—if you change your mind, you can turn off
            the Background layer's visibility (see Hiding and Showing Layers).
            Picking a color is handy if you plan to use images that share a background color, so you
            can preview your artwork. In that case, make sure your background color chip is set to
            the right color before you create your new document and then choose
            Background Color from this menu. The Transparent option is handy if your document is
            part of a bigger project where it'll be placed in front of other documents or images;
            when you choose this option, you see a gray-and-white checkerboard pattern in the Background layer, as explained in the box
            below.
Frequently Asked Question: Seeing Transparency

              Dude, what's up with the gray-and-white checkerboard pattern in my new
                document? I thought it was supposed to be blank!
            
When you tell Photoshop to make your background layer transparent, it fills your
              new document with a checkerboard pattern. Don't worry: That checkerboard is just what
              the program uses to represent transparency on the Background layer. In other words,
              the checkered pattern is just a reminder that there aren't any pixels on that layer to
              hide what's behind your image if you add it to another document later on.
You can change how the checkerboard pattern looks by choosing
              Photoshop→Preferences→Transparency & Gamut (Edit→Preferences→Transparency &
              Gamut on a PC). In the Transparency Settings area, tweak the settings to make the
              squares bigger or smaller or change their colors.
If you can't stand seeing the checkered pattern no matter what it looks like, turn
              it off by setting the Grid Size field to None.


Advanced Options



A quick click of the Advanced button at the bottom of the New dialog box reveals a
            couple of pop-up menus:
	Color Profile. A color
                  profile is a set of instructions that determine how computer monitors
                and printers display or print your document's colors. This menu reflects the profile
                you pick in the Color Settings dialog box, which, unless you changed it, is set to
                "sRGB IEC61966-2.1". Leave this setting alone unless you know you need to use a
                specific color profile for your project; otherwise, your colors may not look the way
                you expect them to on other computers or when they're printed. You'll learn about
                  color profiles in Chapter 16.

	Pixel Aspect Ratio. This setting determines the shape of your pixels by changing their
                size or aspect ratio. This setting gets its name from the term aspect
                  ratio—the relationship between an image's width and height. (For
                example, a widescreen television has an aspect ratio of 16:9.) Out of the box,
                Photoshop's pixels are set to Square. Although square pixels are fine for photos,
                printed images, and onscreen use, they look funky and distorted in video, which has
                a tendency to make everything look short and fat (including people). So if you're
                using Photoshop to work on a movie, try to find out which video format the
                filmmakers are using and then select it here.



Saving your custom settings



If you've gone to the trouble of getting your document's settings just right and
              you expect to create lots of similar documents, save those settings as a preset. Click
              the Save Preset button to open the dialog box shown in Figure 2-3. If you save your settings
                before you click the New dialog box's OK button to create your
              new document, you can choose a descriptive name for your new preset.
[image: Use these checkboxes to tell Photoshop which settings you want it to remember. When you create a new document, the program grabs the settings you don't include from the last new document you made. For example, if you don't include the color profile (by turning on the Profile checkbox shown here), Photoshop assigns the currently active color profile (from Color Settings) to your new image.]

Figure 2-3. Use these checkboxes to tell Photoshop which settings you want it to remember.
                When you create a new document, the program grabs the settings you don't include
                from the last new document you made. For example, if you don't include the color
                profile (by turning on the Profile checkbox shown here), Photoshop assigns the
                currently active color profile (from Color Settings) to your new image.





Saving Files



After you've put a ton of work into whipping up a lovely creation, don't forget to
          save it or you'll never see it again. As in any program, be sure to save early and often
          so your efforts don't go to waste if your computer crashes or the power goes
            out.
The simplest method is to choose File→Save or press ⌘-S (Ctrl+S on a PC). If you
          haven't previously saved the file, Photoshop summons the Save As dialog box so you can
          pick where to save the file, give it a name, and select a file format. If you
            have already saved the file, Photoshop replaces the previously
          saved version with the current version without asking if that's what
          you want to do. In some situations, that's fine, but it can be disastrous if you were
          planning to keep more than one version of your image.
You can play it safe by using the Save As dialog box instead; it
            always prompts you for a new file name (see Figure 2-4), which is handy when you want to
          save another version of your document or save it in a different format. Choose File→Save
          As or press ⌘-Shift-S (Ctrl+Shift+S on a PC) to open the dialog box. From the factory, the
          Format pop-up menu is set to Photoshop, which is good because that format keeps all of
          your layers intact, as you'll soon learn. But, as the next section explains, you can save
          files in lots of other formats, too.
Power Users' Clinic: Going Mobile with Device Central
If you're designing graphics for use on cellphones or other portable devices, you
            can see what your graphics will look like on many of 'em by using Device Central, a
            program that comes with Photoshop. (You need an active Internet connection to use it
            since it downloads handheld device profiles stored online.) It lets you preview all
            kinds of files on a bunch of different simulated gadget screens, and even lets you test
            interactive elements and record videos showing how your images look on specific devices.
            You can use Device Central from the get-go to make sure your file is set up properly and
            take the guesswork out of which size to make your images. Here's how:
	Choose File Device Central and Photoshop opens the big Device Central dialog
                box.

	Select a gadget from the Local Library list on the left side of the Device
                Central window (or Shift-click to choose more than one). If the device you're
                designing for isn't in that list, select it in the Online Library list, drag it into
                the Local Library list, and then select it there.

	Click the Create button at the top right of the Device Central dialog box to
                open a new file in Photoshop tailored to the device(s) you picked. If you picked
                more than one, the dimensions are set to best work on all of them.

	When you're finished editing your mobile masterpiece, choose File→Save For Web
                & Devices (Using the "Save for Web & Devices" dialog box). Be sure
                to pick a file format from the Preset pop-up menu and then click the Device Central
                button at the bottom of the dialog box to preview your document on the device (see
                the figure on Saving and Compressing Your File).




[image: The Save As dialog box lets you save a copy of your file with a different name in a different location and even in a different format.]

Figure 2-4. The Save As dialog box lets you save a copy of your file with a different name in a
            different location and even in a different format.

Note
When you choose Save As in Photoshop CS5, it automatically assumes you want to save
            the document in the original folder from whence it came, instead of, say, the last
            folder you saved a file to. To change this behavior, choose Photoshop→Preferences→File
            Handling (Edit→Preferences→File Handling on a PC) and turn off the "Save As to Original
            Folder" checkbox.

File Formats



You'll learn much more about file formats in Chapters Chapter 16 and Chapter 17, but here's a quick overview. If you remember
            nothing else, remember to save your images as PSD files (Photoshop documents) because
            that's the most flexible format (see the box on Save Your Master).
            That said, sometimes you need to save your document in other formats because of where
            the file is headed. For example, Adobe InDesign (a popular
            page-layout program) is adept at handling PSD files, but QuarkXPress is a little
            different. While Quark can open Photoshop documents, not everyone is comfortable working
              with PSD files in Quark. In that case, try saving your document
            as a TIFF file because nearly every image-handling program ever invented can open
            flattened TIFF files just fine (see Layer Blending for more on
            flattening your documents).
Note
If you need to save a Photoshop document that's bigger than two gigabytes, save it
              as a PSB file instead. That format lets you get past Photoshop's two-GB limit on file
              sizes.

Graphics destined for the Web are a different animal because they're specially
            designed for onscreen viewing and faster downloads. Here's a quick cheat sheet to tide
            you over until you've got time and energy to make your way to Chapter 17:
	JPEG is commonly used for graphics that include a wide range of colors like
                photos. It compresses images so they take up less space, but the smaller file size
                comes at a price: loss of quality.
Note
Photoshop CS5 automatically saves 16-bit JPEGs as 8-bit files. If that
                  sentence is as clear as mud to you, flip back to the box on Understanding Bit Depth to learn more about image bit depth.


	GIF is a popular choice for graphics that include
                a limited number of colors (think cartoon art), when you need to save a transparent
                background, or when you're creating an animation (Animating a GIF).

	PNG is the up-and-comer because it offers true transparency and a wide
                range of colors. It produces a higher-quality image than a JPEG, but it generates
                larger files.



For more on creating and preparing images for the Web, hop over to Chapter 17. If your image is headed for a professional printer,
            visit Chapter 16 instead.
Up To Speed: Save Your Master
Experimenting with your image is fine—until you accidentally ruin the original and
              don't have a backup. To avoid losing a critical file and having to explain to your
              boss, coworkers, or client why the project is behind schedule, save your master file
              as a PSD file so all of your image layers, Adjustment layers (The Layers Panel), Smart Objects (Using Smart Objects), and so on remain intact. It's also a good idea to save a copy somewhere other
              than your hard drive in case something happens to your computer; burn it onto a CD or
              DVD, save it on a Flash drive, or use an online storage service. That way, if
              something goes wrong while you're working on the project, you've always got the
              original to fall back on.
If something does go wrong, duplicate the master file again
              and then work on the copy. There's no point in tempting fate!



Opening an Existing Document



In most programs, opening files is simple and that holds true in Photoshop, too. But
          Photoshop gives you a few more options than you'll find in some other programs because it
          can open files saved in its own format (PSD files) as well as a slew of other formats both
          common and obscure (a feature that makes Photoshop amazingly versatile at working with a
          wide range of images). Even better, if the program doesn't recognize a particular format,
          there's a good chance someone has developed a plug-in (companion program) that can. (See
            Chapter 19 for more than you ever wanted to know about
            plug-ins.)
Photoshop knows how to open Adobe Illustrator, Camera Raw (Working with Raw Files), JPEG, GIF, PNG, TIFF, EPS, and PDF files (Working with PDFs), along with Collada DAE, Google
          Earth 4 KMZ, Scitex CT, Targa, and several other file types most folks have never heard
          of.
You can open files in Photoshop in several ways, including:
	Double-clicking the document's icon, no matter where it's stored on your
              computer.
Up To Speed: Raster Images vs. Vector Images
The images you'll work with and create in Photoshop fall into two categories:
                those made from pixels and those made from paths. It's important to understand that
                they have different characteristics and that you can open them in different
                  ways:
	Raster images are made from tiny blocks of
                    color called pixels, the smallest element of a digital
                    image. The number of pixels in an image depends on the device that captured it
                    (a digital camera or scanner) or the settings you entered when you created the
                    document in Photoshop (Setting Size and Resolution). The size
                    of the pixels depends on the image's resolution (see Pixels and Resolution), which specifies the number of pixels in an
                    inch. Usually pixels are so small that you can't see them individually; but, if
                    you zoom in on a raster image, the pixels appear bigger, and the image starts to
                    look like a bunch of blocks instead of a smooth image.

	Vector images are made up of points and paths
                    that form shapes; these shapes are filled and stroked (outlined) with color. You
                    can create vector images in Photoshop, but they're more commonly made with
                    drawing programs like Adobe Illustrator and Corel-Draw. The paths are based on
                    mathematical equations that tell monitors and printers how to draw the image.
                    Because there aren't any pixels involved, you can make vector images as big or
                    small as you want, and they'll still look as smooth and crisp as the original.
                    Photoshop can open vector images, but unless you open them as Smart Objects
                    (discussed later in this chapter on Opening Files as Smart Objects), Photoshop will turn them into
                    pixel-based raster images. (This process is called
                      rasterizing.)



In the figure below, the upper image is a vector image (the right-hand version
                shows the paths it's made from) and the bottom image is a raster image. Vectors are
                handy when you're designing logos and other illustrations that you might need to
                make bigger at some point. You'll end up working with rasters more often than not
                because photos are raster images and because Photoshop is a
                pixel-based program (as are all image-editing and painting programs). That said, you
                can use some of its tools to draw vectors (see Chapter 13), and it lets you open vector files,
                discussed in the next section. You can also create some amazing artwork by combining
                raster and vector images as described on Combining Vectors and Rasters.
[image: image with no caption]



	Dragging the document's icon into the Photoshop program window.

	Dragging the document's icon onto the Photoshop program icon (the blue square with
              "Ps" on it).

	Ctrl-clicking (right-clicking on a PC) the document's icon and choosing Open
              With→Photoshop CS5 from the resulting shortcut menu.

	Launching Photoshop and then choosing File→Open or pressing ⌘-O (Ctrl+O) to rouse
              the Open dialog box, discussed in the next section.



You can also use Adobe Bridge—or CS5's new Mini Bridge (Running Actions on a Folder)—to preview and open your documents. Head over
          to Appendix, online, to learn about Bridge.
The Open Dialog Box



When you choose File→Open (Ctrl+O on a PC) or press ⌘-O (Ctrl+O), Photoshop brings
            up the dialog box shown in Figure 2-5.
            All you need to do is navigate to a file on your hard drive and then click the Open
            button.
[image: The Open dialog box lets you navigate to the image you want to open. The Format pop-up menu at the bottom left automatically changes to match the format of the document you select.]

Figure 2-5. The Open dialog box lets you navigate to the image you want to open. The Format
              pop-up menu at the bottom left automatically changes to match the format of the
              document you select.

Note
PC users don't get as many options in the Open dialog box as Mac users do. Instead of the Enable pop-up menu, PC
              folks get a "Files of type" menu, and the Format pop-up menu doesn't appear at all.
              Also, the PC version of the Open dialog box hides any files you can't select.

In addition to helping hunt through the murky depths of your hard drive, the dialog
            box lets you limit the files you can open via the Enable pop-up menu. If you use this
            menu to select just the format you want to see, Photoshop will dutifully dim everything
            else (you can't select dimmed items), which is handy when you've saved the same image in
            several different formats—like PSD, JPEG, and TIFF.
Tip
To open more than one file, ⌘-click (Ctrl-click) to select files that aren't next
              to each other in the list or Shift-click to select files that are. When you click
              Open, Photoshop opens each file in a separate tab if you've got the Application Frame
              turned on (Meet the Application Frame), and you've kept Photoshop's
              Interface preferences set to "Open Documents as Tabs" (Interface).

If you leave the Enable pop-up menu set to All Readable Documents (set the "Files of
            type" menu to All Formats on a PC), you're telling Photoshop it's okay to open
              any file format it recognizes. If you try to open a format
            Photoshop should know how to open but for some mysterious reason thinks it doesn't (see
              Opening an Existing Document for a list of formats Photoshop
            recognizes), someone may have saved the document with the wrong file extension. (Since
            all programs, including Photoshop, rely on the file extension to figure out which type
            of document they're looking at, be careful not to change these multi-letter codes that
            appear after a document's name.) If you run into this problem, Mac users can use the
            Format pop-up menu (PC users can choose File→Open As instead) to tell Photoshop which
            format the document should be, and the program will ignore the
            file's extension and try to open it based on the format you pick.
Tip
If you're looking for a specific image but can't remember its name, try using
              Bridge, or CS5's new Mini Bridge (Appendix C, online at www.missingmanuals.com/cds) to find
              it. Bridge shows you a preview of each image along with a ton of other info like
              keywords, ratings, and more. It also gives you filtering and search options to help
              hunt down the image you want.


Opening Files as Smart Objects



Smart Objects are one of those glorious features that make
            Photoshop truly amazing. You'll learn a lot more about Smart Objects in Chapter 3, but here's a quick overview:
            Smart Objects are basically containers that can store raster, vector, or Camera Raw
            files (Working with Raw Files) in their original formats. Smart
            Objects keep track of the original file so you can undo any changes you make to them
            (this process, called nondestructive editing, is discussed at
            length in Chapter 3). In addition to
            the image types just mentioned, you can also import TIFF, PDF, and JPEG files as Smart
              Objects.
To open an image as a Smart Object, choose File→"Open as Smart Object". In the
            resulting dialog box, choose the file you want to open. When you click Open, Photoshop
            opens it as a Smart Object layer in a new document. See Chapter 3 for more about layers and Resizing Smart Objects for the skinny on resizing Smart Objects.
Tip
In CS5 you can make Photoshop open some images as Smart Objects automatically.
              Just choose Photoshop→Preferences→General (Edit→Preferences→General on a PC) and turn
              on the "Place or Drag Raster Images as Smart Objects" checkbox (shown in Figure 1-12, page 32). From then on,
              anytime you choose File→Place, or drag a raster image into the Photoshop window or an
              open document (also new in CS5), it'll open as a Smart Object without you having to
              think twice about it.


Opening Recent Files



This one's a real timesaver. Like many programs, Photoshop keeps track of the
            documents you've recently opened. Choose File→Open Recent to see a list of the last ten
            documents you worked on, with the latest one at the top of the list (see Figure 2-6). If you've moved or renamed the
            file since you last opened it in Photoshop (put it in a different folder on your hard
            drive, say), the program will try to find it for you when you select it from this list.
            If the document isn't on your hard drive anymore, Photoshop displays a message box
            letting you know it can't find the file.
[image: The Open Recent menu option is a handy shortcut for getting at files without traipsing through the Open dialog box. If you want to erase the list, click Clear Recent.]

Figure 2-6. The Open Recent menu option is a handy shortcut for getting at files without
              traipsing through the Open dialog box. If you want to erase the list, click Clear
              Recent.

Tip
If you want Photoshop to remember more (or fewer) than ten files, choose
              Photoshop→Preferences→File Handling (Edit→Preferences→File Handling on a PC) and
              change the number in the "Recent file list contains" field at the bottom of the
              Preferences dialog box. You can set it as low as 2 or as high as 30. Just remember
              that a higher number means a longer list of recent documents to sift
                through!


Working with PDFs



Saving a document as a PDF file is like taking a picture of it so others can open
            the file without needing the program you used to create it—they just need the free Adobe
            Reader (or any other PDF-viewing program, like Preview on the Mac). PDFs can store text,
            images, and even video at a variety of quality settings. PDFs are also
              cross-platform, which means they play nice with both Macs and
            PCs. It's an amazingly useful file format that will only become more common (see Chapter 16 for a peek into the future).
You can open PDFs the same way you open any file: by choosing File→Open, selecting
            the PDF you want, and then clicking the Open button. If someone created the PDF in
            Photoshop, it opens right up. If someone created it in another program, Photoshop
            displays the Import PDF dialog box (Figure 2-7) where you can choose which parts
            of the document you want to import (full pages or just the images), set resolution,
            dimensions, and so on.
[image: If you decide to import multiple pages (as shown here), Photoshop creates a new document for each one. If you're lucky and the person who created the document was a PDF pro, she may have included size-specification goodies like crop size, bleed area, trim, and art size (you'll learn about most of these terms in Chapter 16). If so, you can eliminate some resizing work on imported files by choosing one of the size elements from the Crop To pop-up menu (shown here, right).]

Figure 2-7. If you decide to import multiple pages (as shown here), Photoshop creates a new
              document for each one. If you're lucky and the person who created the document was a
              PDF pro, she may have included size-specification goodies like crop size, bleed area,
              trim, and art size (you'll learn about most of these terms in Chapter 16). If so, you
              can eliminate some resizing work on imported files by choosing one of the size
              elements from the Crop To pop-up menu (shown here, right).


Working with Scanned Images



The Open dialog box isn't the only way to get images into Photoshop. If you have a
            scanner that knows how to talk to Photoshop, you can use it to import images straight
            into the program. But, first, you need to install your scanner's software
              and the Photoshop plug-in for your scanner. (Check the owner's
            manual to learn how to install the software, and then read Chapter 19, which covers plug-ins in detail. To find the
            plug-in for your scanner, check the manufacturer's website for the most recent version.)
            Once everything is all set, you can start importing scanned documents.
To import an image from a scanner into Photoshop, choose File→Import and then select
            your scanner from the resulting list. Each scanner has its own software, so there's no
            standard set of steps to work through—they're all different. Unfortunately, that means
            you have to read the documentation that came with your scanner to figure out how to your
            import files (the nerve!). Nevertheless, the box on Scanning 101
            has some scanning tips for your reading pleasure.
Note
The TWAIN plug-in, which lets Photoshop communicate with your scanner so you can
              see it when you choose File→Import, has been updated for CS5. Because it's an optional
              plug-in for both Macs and Windows, you'll need to fetch it from the Optional plug-ins
              folder on your installation CD (or installation folder, if you downloaded the program)
              in order to install and use it. If you're on a Mac running Snow Leopard (OS X 10.6),
              it'll work with the 64-bit version of Photoshop. If you're running Leopard (OS X
              10.5), you'll need to open Photoshop in 32-bit mode instead (see the box on What Does "64-bit" Mean?).

Up To Speed: Scanning 101
Just because all scanning software is different doesn't mean there aren't a few
              guidelines you can follow to produce good scans. Keep these things in mind the next
              time you crank open your scanner's lid:
	Scan at a higher bit depth than you need for the edited
                    image. Yes, your files will be larger, but they'll contain more color
                  info, which is helpful when you're editing them. (See the box on Understanding Bit Depth for more on bit depth.)

	Scan at a higher resolution than you need for the
                    finished image so your files include more details. You can always lower
                  the resolution later, but you can't increase it… or, rather, you
                    shouldn't increase it without knowing the trick (see the
                  box on Upsampling Without Losing Quality for the scoop).

	If you can use your scanner software to adjust your
                    image's color before you import the file into Photoshop, do it. Making
                  adjustments before you import the image lets you take advantage of all of the info
                  your scanner picked up. The amount of information your scanner passes along to
                  Photoshop when you import the file is almost always less than
                  the amount of info in the original image.





Working with Raw Files



Of all the file formats Photoshop can understand, Raw is the
            most useful and flexible. Professional-grade digital cameras (and many high-end consumer
            cameras, too) use this format. The info in a Raw file is the exact information your
            camera recorded when you took the picture. (Other file formats, like JPEG, compress
            images and in the process slightly reduce the image's quality.) Raw files contain the most detailed information you can get from a digital
            camera, including what's known as metadata (info on all the
            settings your camera used to capture the image like shutter speed, aperture, and so on).
            You can edit Raw files using a Photoshop plug-in called Adobe Camera
              Raw (shown in Figure 2-8),
            which you'll learn more about in Chapter 9.
[image: Raw files get their own editing program called Camera Raw, which launches automatically when you open a Raw file in Photoshop, Bridge, or CS5's new Mini Bridge. Camera Raw is one of the most frequently updated plug-ins known to man—good news, because manufacturers release new camera models faster than photographers can buy 'em! If you've got a brand-new camera, you may have to update the Camera Raw plug-in before you can open your file, which means it's time for a trip to the Adobe Updater program. To run it, choose Help→Updates (Appendix A, online, has more on checking for updates). If there's a newer version of Camera Raw, Photoshop lets you know so you can download and install it.]

Figure 2-8. Raw files get their own editing program called Camera Raw, which launches
              automatically when you open a Raw file in Photoshop, Bridge, or CS5's new Mini Bridge.
              Camera Raw is one of the most frequently updated plug-ins known to man—good news,
              because manufacturers release new camera models faster than photographers can buy 'em!
              If you've got a brand-new camera, you may have to update the Camera Raw plug-in before
              you can open your file, which means it's time for a trip to the Adobe Updater program.
              To run it, choose Help→Updates (Appendix A, online, has more on checking for updates).
              If there's a newer version of Camera Raw, Photoshop lets you know so you can download
              and install it.

Opening Raw files



Opening a Raw file in Photoshop is no different from opening any other kind of
              image except that it opens in the Camera Raw window instead of the main Photoshop
              window. You can open Raw files by:
	Double-clicking the Raw file's icon. Your computer launches Photoshop (if it
                  wasn't running already) and then opens the Camera Raw window.

	Ctrl-clicking (right-clicking on a PC) the Raw file's icon and choosing Open With→Photoshop. (Since Camera
                    Raw is a plug-in that runs inside Photoshop and Bridge, it doesn't get
                  listed separately, but your computer knows to open the file in Camera Raw.)

	Using Bridge to select the file you want to open and then choosing File→"Open
                  in Camera Raw" or pressing ⌘-R (Ctrl+R on a PC). You can also Ctrl-click
                  (right-click) the file in Bridge or CS5's new Mini Bridge and then choose "Open in
                  Camera Raw" from the resulting shortcut menu. (Bridge and Mini Bridge are covered
                  in Appendix C, online.)



Tip
If you've got a bunch of Raw images that need similar edits (cropping,
                color-correcting, and so on), you can open them all at once by Shift or ⌘-clicking
                (Ctrl-clicking on a PC) them in Bridge or Mini Bridge, or by selecting multiple
                  files on your desktop and then double-clicking or dragging them onto the
                Photoshop icon. When you click the Select All button in the top-left corner of the
                Camera Raw window, any edits you make from then on affect all your open images. See
                the box on Processing Multiple Files for more on editing multiple
                files.

Power Users' Clinic: Opening Images as a Stack
If you sprang for Photoshop CS5 Extended (see the Note on Acknowledgements), you've got a bonus feature called
                  Stacks that lets you open multiple images on separate layers
                within the same document. It's a huge timesaver when you need
                to combine several images to make a collage or when you want to make several group
                shots into one perfect shot where everyone's eyes are open and they're all smiling,
                when you're editing individual frames of a video, and so on.
To open a group of images as a Stack, choose File→Scripts→"Load Files into
                Stack". In the resulting Load Layers dialog box, tell Photoshop where the images are
                stored on your hard drive and then click OK.
The Load Layers dialog box's Use pop-up menu lets you choose what you want to
                open: individual images or whole folders of images. If you're combining several
                shots into one, turn on the "Attempt to Automatically Align Source Images" checkbox.
                To convert all the layers into a single Smart Object (Managing Smart Objects) so you can resize the image later, turn on the
                "Create Smart Object after Loading Layers" checkbox.



Duplicating Files



If your client or boss asks you to alter an image and you suspect they'll change
            their mind later, it's wise to edit a copy of the image instead of
            the original file. That way, when they ask you to change everything back, you don't have
            to sweat bullets hunting for a backup of the original or try to recreate the earlier
            version. Duplicating files is also handy when you want to experiment with a variety of
            different effects.
You can duplicate a file by choosing File→Save As and renaming the image, but
            there's a faster way: Make sure the file you want to copy is in the currently active
            window (just click the window to activate it), and then choose Image→Duplicate. In the
            Duplicate Image dialog box (Figure 2-9),
            give your file a new name and then click OK. You've just set yourself up to be the
              office hero.
[image: A duplicate file is exactly the same as the original including layers, layer styles, and so on. If you need to create a single-layer (flattened) version of a file, turn on the Duplicate Merged Layers Only checkbox. (Page 112 has more about flattening files.)]

Figure 2-9. A duplicate file is exactly the same as the original including layers, layer
              styles, and so on. If you need to create a single-layer (flattened) version of a file,
              turn on the Duplicate Merged Layers Only checkbox. (Page 112 has more about flattening
              files.)



Changing Your Image View



Photoshop gives you a variety of ways to look at your images; different views are
          better for doing different things. For example, you can get rid of the Application Frame
            (Meet the Application Frame), view images full screen, zoom in and
          out, or rotate your canvas to view images at an angle. This section teaches you how to do
          all that and more.
Zooming In and Out



Being able to zoom closely into your image is crucial; it makes fixing
            imperfections, doing detailed clean-up work, and drawing accurate selections a hundred
            times easier. One way to zoom is to click with the Zoom tool, which looks like a
            magnifying glass. You can find it at the bottom of the Tools panel or you can grab it by
            pressing Z (see Figure 2-10); simply
            click repeatedly to get as up close and personal to your pixels as you want. When you're
            ready to zoom back out, just Option-click (Alt-click on a PC) instead. You can also zoom
            using your keyboard, which is faster: press ⌘ and the + or – key (Ctrl + or –). To zoom
            in on a specific area, using the Zoom tool, turn off the Scrubby Zoom (Figure 2-10) checkbox in the Options bar and
            then drag with the Zoom tool to draw a box around the pixels you want to look closely
            at. As soon as you let go of your mouse button, Photoshop zooms in until the area you
            selected fills your document window.
Tip
In Photoshop CS5, you can turn off the pixel-grid that you see when you're zoomed
              in 501 percent or more by choosing View→Show→Pixel Grid.

[image: Top: New in Photoshop CS5 is the Scrubby Zoom option, shown here. Instead of clicking like a maniac to zoom in on your image, you can turn it on to simply click and drag left to zoom out, or drag right to zoom in. You can also zoom by selecting an item from the Zoom preset menu in the Application bar (page 14) or by typing a percentage into the lower-left corner of your document window (not shown).Bottom: If you zoom in to 501 percent or closer, you'll get this handy pixel-grid view that lets you edit precisely, pixel by pixel. If you're moving items around, this grid makes it easy to see whether pixels are perfectly aligned horizontally and vertically.]

Figure 2-10. Top: New in Photoshop CS5 is the Scrubby Zoom option, shown here. Instead of
              clicking like a maniac to zoom in on your image, you can turn it on to simply click
              and drag left to zoom out, or drag right to zoom in. You can also zoom by selecting an
              item from the Zoom preset menu in the Application bar (page 14) or by typing a
              percentage into the lower-left corner of your document window (not
              shown). Bottom: If you zoom in to 501 percent or closer, you'll get this handy
              pixel-grid view that lets you edit precisely, pixel by pixel. If you're moving items
              around, this grid makes it easy to see whether pixels are perfectly aligned
              horizontally and vertically.

If your computer can handle OpenGL (see the box on Understanding OpenGL), you can hold down your mouse button—while the Zoom
            tool is active to fly into your image, zooming to a maximum of
            3,200 percent; simply Option-click (Alt-click) and hold down your mouse button to zoom
            back out. This animated zooming makes you feel like you're flying into and out of your
            image—and it saves you several mouse clicks along the way.
When you have the Zoom tool active, the Options bar gives you the following
            choices:
	Resize Windows To Fit. If you want Photoshop to
                resize your document window to accommodate the current magnification level, turn on
                this checkbox. You can also access it by choosing Photoshop→Preferences→General
                (Edit→Preferences→General on a PC) and turning on the Zoom Resizes Window checkbox;
                however, as of this writing the two settings cancel each other out.

	Zoom All Windows. Turn on this checkbox to use
                the Zoom tool to zoom in on all open windows by the same amount simultaneously. This
                setting is helpful if you've opened a duplicate of your image as described in the
                steps on Whitening Teeth. You can also use the Window→Arrange menu
                to do pretty much the same thing. Your options there include:
	Match Zoom. Zooms all open windows to the
                    same magnification level.

	Match Location. Zooms to the same spot in
                    each window.

	Match Rotation. Rotates each window's canvas
                    to the same angle.

	Match All. Does all of the above.




	Scrubby Zoom. New in Photoshop CS5, this option
                lets you click and drag to do your zooming. Once you turn it on, click and hold down
                your mouse button while dragging left to zoom out of your image, or right to zoom
                in.



Tip
If you've got a scroll wheel on your mouse, you can use that to zoom, too. Just choose
              Photoshop→Preferences→General (Edit→Preferences→General on a PC), turn on "Zoom
                with Scroll Wheel" in the Options section, and then click OK.

Power Users' Clinic: Zooming with Mac Gestures
If you use a MacBook, MacBook Air, or MacBook Pro with a multitouch trackpad,
              you've got yet another way to zoom in or out of your images: use
              the finger pinch gesture even if the Zoom tool isn't active. You can also flick left
              or right with two fingers to move across your image or twist with your finger and
              thumb to rotate the canvas.
If your Mac includes a multitouch trackpad, you can see examples of each of these
              gestures in the Keyboard & Mouse Preference Pane. From the [image: ] menu, choose System Preferences→Keyboard & Mouse, and then
              select the Trackpad tab. Click an item in the action list on the left side of the
              dialog box to see that gesture in action.
Zooming with gestures is all well and good… that is, until you accidentally zoom
              or rotate your canvas (Zooming with the Navigator Panel) by
              accident. That's why Adobe added the ability to turn this behavior
                off in Photoshop CS5. Choose Photoshop→Preferences→Interface
              (Edit→Preferences→Interface on a PC) and turn off "Enable Gestures" as described in
              the note on Interface.

	Actual Pixels. Click this button to see your
                image at 100 percent magnification. You can do the same thing by pressing ⌘-1
                (Ctrl+1 on a PC), by double-clicking the Zoom tool, by entering
                  100 into the zoom percentage field at the bottom-left corner
                of the document window, or by choosing View→Actual Pixels.

	Fit Screen. Clicking this button makes Photoshop
                resize the active image window to fit the available space on your screen and fit the
                image inside the document window. You can also press ⌘-0 (Ctrl+0) or choose
                View→"Fit on Screen". This is incredibly handy when you're using Free Transform
                (pages 95 and 263) on an image that's larger than your document size—it's tough to
                grab bounding-box handles if you can't see 'em!

	Fill Screen. This button enlarges your image to
                the largest possible dimensions within the window. Clicking Fill Screen makes your
                image a little bigger than it gets when you use Fit Screen because it uses all the
                available vertical space.

	Print Size. If you click this button, Photoshop
                makes your image the size it'll be when you print it; you can do the same thing by
                choosing View→Print Size.



Keep in mind that the resolution settings for your monitor can make the print size
            sample look bigger or smaller than it really will be, so use this feature only as an
            approximation.
Tip
If your image is smaller than the document window (meaning you see a gray border
              around the edges of the image) or if the document window itself is smaller than the
              available space in the Application Frame (Meet the Application Frame), you can double-click the Hand tool in the Tools panel to make Photoshop enlarge
              your image to fill the document window.

Gem In The Rough: The Status Bar: Document Info Central
At the bottom of each document window is the status bar,
              shown in the figure below, which gives you a quick peek at important info about your
              document. When you first start using Photoshop, the status bar shows the size of your
              document (K stands for kilobytes and M for megabytes). If you don't see any status
              information, your document window may be too small. Just drag outward from the
              lower-right edge of the window so it's big enough for you to see it.
Click the little triangle to the status bar's right (circled) and you get a menu
              that lets you control what the bar displays. Here's what you can choose from:
	Adobe Drive connects to Version Cue servers.
                  Version Cue is Adobe's method of attaching versions and enabling asset management
                  throughout all of its programs. However, Adobe discontinued Version Cue in
                  Photoshop CS5.

	Document Sizes displays the approximate size of
                  your image for printing (on the left) and the approximate saved size of your image
                  (on the right).

	Document Profile shows the color profile (Printer-Friendly Resizing and File Formats) for your image.

	Document Dimensions displays the width and
                  height of your image.

	In Photoshop CS5 Extended, Measurement Scale
                  shows the scale of pixels compared with other units of measurement. For example,
                  an image from a microscope can measure objects in microns, and each micron can
                  equal a certain number of pixels.

	Scratch Sizes tells you how much memory and hard disk space is being used to
                  display your open images.

	Efficiency lets you know if Photoshop is
                  performing tasks as fast as it possibly can. A number below 100 percent means
                  Photoshop is running slowly because it's relying on scratch-disk space (Performance).

	Timing shows how long it took Photoshop to
                  perform the most recent activity.

	Current Tool displays the name of the selected
                    tool.

	32-bit Exposure lets you adjust the preview
                  image for 32-bit HDR images (see Creating High Dynamic Range Images).



[image: image with no caption]



Moving Around in Your Image



Once you've zoomed in on your image, you can use the Hand tool to move to another
            area without zooming back out. Grab this tool from the Tools panel or the Application
            bar, or just press and hold the space bar on your keyboard (unless you're typing with
            the Type tool—then you'll just type a bunch of spaces). When your cursor turns into a
            hand, hold your mouse button down and then drag to move your image. When you get to the
            right spot, just let go of your mouse button.
Tip
If you press and hold the Shift key while you're using the Hand tool, Photoshop
              moves all of your open window content at the same time. (You can do the same thing by
              turning on the Scroll All Windows checkbox in the Options bar.)

In Photoshop CS5, you get a couple of other ways to move around your document:
              flick-panning and the birds-eye view
            feature. If you've got a computer that can run OpenGL (see the box on Understanding OpenGL), you can use
            these fast and efficient ways to move around your image. Here's how they work:
	Flick-panning lets you "toss" an image from one
                side of the document window to the other. Just grab the Hand tool, click your image,
                and hold down the mouse button. Then, quickly move your mouse in the direction you
                want to go and then release your mouse button—the image slides along and slowly
                comes to a stop. You can do the same thing by holding your space bar and moving your
                mouse quickly while you hold the mouse button down.



Tip
If you're not a fan of flick-panning, you can turn it off by choosing
              Photoshop→Preferences→General (Edit→Preferences→General on a PC) and, in the resulting
              dialog box, turn off the Enable Flick Panning checkbox.

Up To Speed: Understanding OpenGL
OpenGL is a technology that helps newer computers draw
              graphics faster and more efficiently. (To learn more about it, go to www.opengl.org.) You can tell whether your
              computer uses OpenGL by going to Photoshop→Preferences→Performance
              (Edit→Preferences→Performance on a PC). If the Enable OpenGL Drawing checkbox is
              turned on, you're all set. If it's not checked but you can turn
              it on, then do it. If the checkbox is grayed out (meaning you can't turn it on), then
              your computer's video card isn't fast enough or doesn't have enough memory to run
              OpenGL—bummer.
If your computer can't run OpenGL, some Photoshop features will take a long time
              to run, and others, like flick-panning, canvas rotating, and pixel-grid overlay (Figure 2-10), won't work at all. Other
              nifty CS5 features that require OpenGL include the new "heads-up display" Color Picker
                (Painting from Scratch), the Eyedropper tool's Sample Ring (The Eyedropper Tool), and the ability to resize a brush and change its
              hardness using the same keyboard shortcut (see the Tip on Tip).

	Birds-eye view lets you zoom out of your document
                quickly to see the whole thing. To use it, just press and hold the H key and click
                your image: you'll get an instant aerial view of your image with a box marking the area you're zoomed in on. Let go of the H key
                (and your mouse button) to zoom back in.




Zooming with the Navigator Panel



You can think of the Navigator panel as your one-stop zooming shop. If you want to
            know exactly which part of an image you're zoomed in on, it can
            show you. To open it, choose Window→Navigator. The panel displays a smaller version of
            your image called a thumbnail and marks the area you're zoomed in
            on with a red box called the proxy preview. At the bottom of the
            panel, the zoom field shows your current magnification level. You can zoom into or out
            of your image by clicking the zoom buttons at the bottom of the panel (they look like
            little mountains) or by using the slider nestled between them (see Figure 2-11). To zoom to a specific level,
            enter a number in the zoom field.
[image: As you zoom in on your image, the proxy preview box shrinks because you're looking at a smaller area. You can also drag the box around to cruise to another spot in your image.To make the Navigator panel bigger, drag its bottom-right corner downward. You can change the color of the proxy preview box by choosing Panel Options from the top-right corner of the Navigator panel's menu: just click the red color swatch, pick another color from the resulting Color Picker, and then click OK.]

Figure 2-11. As you zoom in on your image, the proxy preview box shrinks because you're
              looking at a smaller area. You can also drag the box around to cruise to another spot
              in your image. To make the Navigator panel bigger, drag its bottom-right corner
              downward. You can change the color of the proxy preview box by choosing Panel Options
              from the top-right corner of the Navigator panel's menu: just click the red color
              swatch, pick another color from the resulting Color Picker, and then click OK.


Rotating Your Canvas



If you're an artist, you're gonna love this feature! The Rotate View tool rotates
            your canvas—without harming any pixels—so you can edit, draw, or paint at a more natural
            angle (see Figure 2-12). It's like
            shifting a piece of paper or angling a painting canvas, but it doesn't rotate the actual
            image—just your view of the image. If you're using a graphics
            tablet (see the box on The Joy of Painter) and you skipped upgrading
            to CS4, this feature alone may be worth the price of CS5. Bear in mind, though, that
            your computer needs to be able to run OpenGL (Moving Around in Your Image) for this feature to work. To use it, select
            it from within the Hand tool's toolset at the bottom of the Tools panel.
Note
MacBook, MacBook Air, and MacBook Pro users with multitouch trackpads (see the box on Zooming with Mac Gestures) can rotate the canvas by using the two-finger
              rotate gesture.

[image: Grab the Rotate View tool, mouse over to your image, and then drag diagonally up or down to rotate it. When you start to drag, you see a compass that shows how far from "north" you're rotating the canvas. If you're not the dragging type, you can type a number into the Options bar's Rotation Angle field or spin the little round dial to the field's right. To straighten your canvas, click the Reset View button in the Options bar. To rotate all open images, turn on the Rotate All Windows checkbox.In CS5, if you rotate your canvas and then paint with the Brush tool (or any tool that uses a brush cursor), your brush won't rotate like it used to. Yay!]

Figure 2-12. Grab the Rotate View tool, mouse over to your image, and then drag diagonally up
              or down to rotate it. When you start to drag, you see a compass that shows how far
              from "north" you're rotating the canvas. If you're not the dragging type, you can type
              a number into the Options bar's Rotation Angle field or spin the little round dial to
              the field's right. To straighten your canvas, click the Reset View button in the
              Options bar. To rotate all open images, turn on the Rotate All Windows
              checkbox. In CS5, if you rotate your canvas and then paint with the Brush tool
              (or any tool that uses a brush cursor), your brush won't rotate like it used to.
              Yay!



Arranging Open Images



The Application Frame (Meet the Application Frame) and tabbed
          document workspace help you keep track of several open documents. If you turn off the
          Application Frame, your documents can get scattered across your screen. However, you can
          herd those open windows together by using the list of commands that appears when you
          choose Window→Arrange (see Figure 2-13).
          Here are your choices:
	Cascade stacks your windows on top of each other,
              putting the largest one on the bottom and the smallest on the top.

	Tile resizes your windows to identical sizes and
              arranges them in rows and columns.



[image: You can use the Arrange command to create order out of chaos by tiling (top) or cascading (bottom) your windows. You can also use the Arrange Documents menu (shown opened here) in the Application bar to view your windows in a variety of ways.You can't cascade tabbed documents because they're attached (or rather, docked) to the top of your Photoshop workspace. The fix is to choose Window→Arrange→Float in Windows first, and then choose Cascade.]

Figure 2-13. You can use the Arrange command to create order out of chaos by tiling (top) or
            cascading (bottom) your windows. You can also use the Arrange Documents menu (shown
            opened here) in the Application bar to view your windows in a variety of ways. You
            can't cascade tabbed documents because they're attached (or rather, docked) to the top
            of your Photoshop workspace. The fix is to choose Window→Arrange→Float in Windows first,
            and then choose Cascade.

Up To Speed: Document Size vs. Canvas Space
One thing that's super confusing to Photoshop beginners is the difference between
            document size (also known as image size) and canvas size. In Photoshop, the
              canvas is the amount of editable area in your document (it's the
            same as your document's dimensions) and you can add to or subtract from it anytime. By
            doing so, you'll add or subtract pixels from your image, which either increases or
            decreases the document size.
For example, say you're designing a poster for a chili cook-off and you're
            experimenting with the design. Instead of limiting your work area to the final size of
            the poster, you can make your canvas bigger than that (Resizing the Canvas) so you have room to spread out and try different
            design ideas. Once you've nailed down the final design, you can crop (Cropping Images) or trim (Cropping with Selection Tools)
            it back down to size.

	Float in Window puts the current document in its
              own window if it's part of a tabbed group of documents that share the same
              window.

	Float All Windows splits all tabbed documents out
              into their own windows and cascades the new windows.

	Consolidate All to Tabs groups your open images in
              a single, tabbed window (as shown in Figure 2-14, top left).



[image: Photoshop's tabbed document feature is a handy way of organizing open windows. You can slide the tabs left or right to rearrange them or drag a tab out of the window group to create a floating window (top). To redock a floating window, just drag its tab back into the main tab area (middle).You can close all tabbed documents by choosing File→Close All. If the program sees that you've edited some or all of the images, it asks if you'd like to save the images before closing them. New in CS5 is the option to apply your answer to all images by turning on the new "Apply to all" checkbox, shown here (bottom).]

Figure 2-14. Photoshop's tabbed document feature is a handy way of organizing open windows. You
            can slide the tabs left or right to rearrange them or drag a tab out of the window group
            to create a floating window (top). To redock a floating window, just drag its tab back
            into the main tab area (middle). You can close all tabbed documents by choosing
            File→Close All. If the program sees that you've edited some or all of the images, it
            asks if you'd like to save the images before closing them. New in CS5 is the option to
            apply your answer to all images by turning on the new "Apply to all" checkbox, shown
            here (bottom).

Tip
You can cycle through all your open documents by using the ⌘-~ keyboard shortcut
            (Ctrl+Tab on a PC). To cycle through documents in the reverse order, press Shift-⌘-~
            (Shift+Ctrl+Tab). This is especially handy when you're in Full Screen Mode, as described
            on Swapping Screen Modes.


Guides, Grids, and Rulers



Placing all the components of your design in just the right spot can be challenging,
          and if you're a real stickler for details, close enough isn't good enough. This section
          teaches you how to use Photoshop's guides, grids, and rulers to get everything positioned
            perfectly. Adobe calls these little helpers
            Extras and you can access them in the Application bar's Extras
          pop-up menu, shown on The Almighty Options Bar in Chapter 1.
Rulers and Guiding Lines



Positioning objects on your canvas properly can make the difference between a basic
            design and a masterpiece. The quickest way to position and align objects is by drawing a
            straight line to nestle them against. You can do just that using Photoshop's nonprinting
              guides—vertical and horizontal lines you can place anywhere you
            want (see Figure 2-15).
[image: Guides help you position items exactly where you want 'em. Here the green guides help you make sure all the text is the same width and the edges of the poster are kept free of clutter. The guides won't show up when you print the image, so you don't have to worry about deleting them.To create a guide in a certain spot in your document, choose View→New Guide and enter the position in the resulting dialog box.If you have trouble grabbing a guide, try making your document window bigger than your canvas (drag any edge of the document window, or its lower-right corner, diagonally). That way your guides extend beyond the canvas so they don't overlap other elements that you might accidentally select and move.]

Figure 2-15. Guides help you position items exactly where you want 'em. Here the green guides
              help you make sure all the text is the same width and the edges of the poster are kept
              free of clutter. The guides won't show up when you print the image, so you don't have
              to worry about deleting them. To create a guide in a certain spot in your
              document, choose View→New Guide and enter the position in the resulting dialog
              box. If you have trouble grabbing a guide, try making your document window bigger
              than your canvas (drag any edge of the document window, or its lower-right corner,
              diagonally). That way your guides extend beyond the canvas so they don't overlap other
              elements that you might accidentally select and move.

Before you can create guides, you need to turn on Photoshop's rulers. The fastest
            way to do that is by pressing ⌘-R (Ctrl+R on a PC), but you can also turn them on by
            choosing View→Rulers or selecting Rulers from the Extras pop-up menu in the Application
            bar. Whichever method you use, the rulers appear on the top and left edges of your image
            window. The units you see on the rulers are controlled by the settings in the Units
            & Rulers preferences (Units & Rulers).
Once you've turned rulers on, you can add a guide by clicking in either the horizontal or vertical ruler, and then dragging it into your document as shown in Figure 2-15. After you've drawn a guide, you
            can:
	Move a guide by grabbing the Move tool (see
                Appendix D, online) from the Tools panel or by pressing V, and then dragging the
                guide to a new position (your cursor turns into a double-sided arrow like the one
                circled in Figure 2-15).

	Snap objects to your guides by turning on Photoshop's snap feature. This
                feature makes it super easy to align objects because, when they get close to one of
                your guides, they jump to it as if they were magnetized. To turn on this behavior,
                choose View→Snap To→Guides. You can tell that an object has snapped to the nearest
                guide because it pops into place. After the object aligns to a guide, you can move
                it along that line to snap it into place with other guides, too. If you don't want
                an object aligned with a certain guide, just keep moving it—it'll let go of the
                guide as soon as you move it far enough.



Note
You can make objects snap to grids (Smart Guides), layers (Chapter 3), slices (Chapter 17), and the edges of your document. Just go to
              View→Snap To and choose the elements you want objects to align with. For example,
              choosing both Guides and Layers makes the object you're moving snap to guides
                and the edges of objects on other layers.

	Hide the guides temporarily by pressing ⌘-;
                (Ctrl-; on a PC).

	Delete a guide by dragging it back where it came
                from (into the ruler area).

	Delete all guides by choosing View→Clear
                Guides.



Smart Guides



Smart Guides are a little different from regular guides in
              that they automatically appear onscreen to show the spatial relationship between
              objects. For example, they pop up when objects are aligned or evenly spaced in your
              document. As you drag an object, Smart Guides appear whenever the current object is
              horizontally, vertically, or centrally aligned with other objects on other layers. To
              turn on Smart Guides, choose View→Show→Smart Guides. You can see them in action in on
                Aligning layers.

Using the Document Grid



If you want lots of guides without all the work of placing
              them, you can add a grid to your image by choosing View→Show→Grid (see Figure 2-16). Straight from the factory,
              Photoshop's gridlines appear an inch apart with four subdivisions, although you can
              change that spacing by choosing Photoshop→Preferences→Guides, Grid & Slices (Edit→Preferences→Guides, Grid & Slices on a PC), as Figure 2-16 explains.
[image: Photoshop's grid is helpful when you need to align lots of different items, like the text shown here.In the Preferences dialog box, adjust the gridline marks by changing the "Gridline every" field and use the pop-up menu next to it to choose the unit of measurement the grid uses: pixels, inches, centimeters, millimeters, points, picas, or percent. Just below the "Gridline every" field is the Subdivisions field, which you can use to set how many lines appear between each gridline—if any.]

Figure 2-16. Photoshop's grid is helpful when you need to align lots of different items,
                like the text shown here. In the Preferences dialog box, adjust the gridline
                marks by changing the "Gridline every" field and use the pop-up menu next to it to
                choose the unit of measurement the grid uses: pixels, inches, centimeters,
                millimeters, points, picas, or percent. Just below the "Gridline every" field is the
                Subdivisions field, which you can use to set how many lines appear between each
                gridline—if any.



The Ruler Tool



In addition to the rulers you learned about earlier, Photoshop also gives you a
            virtual tape measure: the Ruler tool. It lets you measure the distance between two
            points in your document, and in Photoshop CS5 you can also use it to straighten your image,
            as shown in Figure 2-17. To use it for
            measuring, grab the tool (it's hiding in the Eyedropper toolset and it looks like a
            little ruler) by pressing Shift-I repeatedly, and then click and hold your mouse button
            where you want to start measuring. Drag across the area or object with your mouse and
            you'll see a line appear in your document. To draw a perfectly straight horizontal or
            vertical line, press and hold the Shift key as you drag. When you release your mouse
            button, Photoshop displays the measurement between the start and end points of the line
            in the Options bar. Figure 2-17 has the
            scoop on how to use this tool to straighten your image.
[image: Top: Folks have been asking for an image straightening-tool for years, and in CS5 they get their wish. To use the Ruler tool to straighten your image, select it from the Tools panel and then drag to draw a line across an area that should be straight, such as this girl's waist.Middle: In the Options bar, click the Straighten button to make Photoshop straighten and crop your image.Bottom: If you want your image straightened but not cropped, Option-click (Alt-click on a PC) the Straighten button instead. Or, if you forget to press Option (Alt), you can undo the crop by pressing ⌘-Z (Ctrl+Z).]

Figure 2-17. Top: Folks have been asking for an image straightening-tool for years, and in CS5
              they get their wish. To use the Ruler tool to straighten your image, select it from
              the Tools panel and then drag to draw a line across an area that should be straight,
              such as this girl's waist. Middle: In the Options bar, click the Straighten
              button to make Photoshop straighten and crop your image. Bottom: If you want your
              image straightened but not cropped, Option-click (Alt-click on a PC) the Straighten
              button instead. Or, if you forget to press Option (Alt), you can undo the crop by
              pressing ⌘-Z (Ctrl+Z).

Note
You can also straighten your images using Camera Raw, as explained on Cropping and Straightening in Camera Raw.

The Options bar's measurements can be a little confusing. Here's what they
            mean:
	X and Y. These axes mark the
                horizontal and vertical coordinates (respectively) at the start of your ruler line.
                For example, if you start your line at the 4-inch mark on the horizontal ruler and
                the 7-inch mark on the vertical ruler, your coordinates are X: 4 and Y: 7.

	W and H. Calculates the distance your line has
                traveled from the X and Y axes.

	A. Displays the angle of your line relative to
                the X axis.

	L1. Shows the length of the line you drew.

	L2. You see a number here only if you use a
                virtual protractor. (Thought you left protractors behind in
                high school, didn't you? Quick refresher: Protractors help you measure angles.) To
                create a protractor, Option-drag (Alt-drag on a PC) at an angle from the end of your
                ruler line (or just double-click the line and drag). This number represents the
                angle between the two lines.

	Use Measurement Scale. Turn on this checkbox to
                copy the unit of measurement set in your preferences (choose
                Photoshop→Preferences→Units & Rulers or Edit→Preferences→Units & Rulers on a
                PC). You can change the units you see in the Info panel by choosing Panel Options
                from the Info panel's menu.

	Clear. Any ruler line you draw hangs around until
                you tell it to go away by clicking this button in the Options bar or draw another
                ruler line. But the line won't print even if you forget to clear it, so don't lose
                any sleep over it.



Tip
To reposition a ruler line, just grab one of its end points and drag it to another
              position.



Chapter 3. Layers: The Key to Nondestructive Editing



Photoshop gives you two ways to edit your files: the destructive way and the
        nondestructive way. Destructive editing means you're changing your
        original image—once you exceed the limit of your History panel (Changing How Far Back You Can Go), those changes are (gulp) permanent.
          Nondestructive editing means you're not changing the original file
        and you can go back to it at any time. Folks new to image editing tend to use the first
        method and experienced pixel-jockeys the second—and you'll likely see a tiny cloud of
        smugness floating above the latter.
When you're working in Photoshop, you need to keep your documents as flexible as
        possible. People (even you!) change their minds hourly about what looks good, what they
        want, and where they want it—all of which is no big deal if you're prepared for that. If
        not, you'll spend a ton of time redoing what you've done from scratch.
        To avoid this kind of suffering, you can use layers, a set of stackable
        transparencies that together form your whole image (see Figure 3-1). Layers are your Golden Ticket to
        nondestructive editing.
With layers, you can make all kinds of changes to your image without altering the
        original. For example, you can use one layer to color-correct your family reunion photo
          (Chapter 9), another to whiten Aunt Bessie's teeth
          (Whitening Teeth), and yet another to add a photo of the Great Pyramid,
        making your reunion look like it was in Egypt instead of at the local park (Sky Swapping). Using layers also lets you:
	Resize an object independently of everything else in your document, without changing
            the document's size (Setting Size and Resolution).

	Move an object around without moving anything else (Moving and Aligning Layers).

	Combine several images into one document to make a collage (Moving layers between documents).
[image: You can think of layers as a stack of slides. If a layer is partially transparent, you can see through the transparent areas to the layer below. If you look down through the top of the stack (a bird's-eye view), you see a single image even though it's made from many different slides (this kind of image is called a composite).]

Figure 3-1. You can think of layers as a stack of slides. If a layer is partially
              transparent, you can see through the transparent areas to the layer below. If you look
              down through the top of the stack (a bird's-eye view), you see a single image even
              though it's made from many different slides (this kind of image is called a
              composite).


	Hide parts of your image so you can see through to layers below (Layer Masks: Digital Masking Tape).

	Change the opacity of a layer to make it more or less see-through (Tweaking a Layer's Opacity and Fill).

	Change the way colors on various layers interact with each other (Layer Blend Modes).

	Fix the color and lighting of your whole photo (or just parts of it) without harming
            your original (see Figure 3-27 on Fixing exposure with masks).



The best part about using layers is that once you save your document as a PSD file
          (Working with PDFs), you can close it, forget about it, and open it next
        week to find your layers—and all of your changes—intact. Learning to love layers is your key
        to a successful Photoshop career: They let you edit with maximum flexibility.
Throughout this chapter, you'll learn about the different kinds of layers, when to use
        them, and how to create them. You'll also find out about the fun and useful features that
        tag along with layers like layer styles and layer masks. By the time you're done, you'll be
        shouting the praises of nondestructive editing from the highest rooftop! (Whether you do it
        smugly is up to you.)
Layer Basics



Layers come in many flavors, all of which have their own special purpose. They
            include:
	Image layers. These layers are pixel-based (Opening an Existing Document), and you'll work with them
                all the time. If you open a photo or add a new empty layer and
              paint on it (Chapter 12), you've got yourself an Image
              layer.

	Type layers. Photoshop text isn't made from pixels,
              so it gets its own special kind of layer. Anytime you grab the Type tool and start
              pecking away, Photoshop creates a Type layer for you automatically. See Chapter 14 for the full story on creating type in
              Photoshop.

	Shape layers. These layers are vector-based (Opening an Existing Document),
              meaning they're not made from pixels. Not only can you create useful shapes quickly
              with these babies, you can resize 'em without losing quality, and
              you can change their fill color by double-clicking their layer thumbnails (The Layers Panel). Photoshop creates a Shape layer automatically anytime
              you use a shape tool, unless you change the tool's mode, as explained in Chapter 13 (Photoshop's Drawing Modes).

	Fill layers. When it comes to changing or adding color to your image, these layers
              are your best friends. They let you fill a layer with a solid color, gradient, or
              pattern (shown later in this chapter), which comes in handy when you want to create
              new backgrounds or fill a selection with color. Just like Shape layers, you can
              double-click a Fill layer's thumbnail to change its color anytime you want. The next
              time you're tempted to add an empty layer and fill it with color (Filling a Layer with Color), try using one of these layers instead.

	Adjustment layers. These ever-so-useful layers let you apply color and lighting changes to
              the layer directly below them, but the actual changes happen on the Adjustment layer.
              For example, if you want to change a color image to black and white, you can use a
              Black & White Adjustment layer (Black & White Adjustment Layers) and the color removal will
              happen on its own layer, leaving your original unharmed. These layers don't contain
              any pixels, just instructions that tell Photoshop what changes you want to make. You
              can access these handy helpers in the Adjustments panel on the right side of your
              screen (if you don't see it, choose Window→Adjustments) or via the Adjustment layer
              menu at the bottom of your Layers panel (it looks like a half-black/half-white circle), as well as in
              the Layer menu (choose Layer→New Adjustment layer). There are 15 kinds of Adjustment
              layers, and you'll learn how to use them in Part 2 of this book.

	Smart Objects. Adobe refers to this kind of layer
              as a container, though "miracle layer" is a better description.
              Smart Objects let you work with files that weren't created with Photoshop, like Raw
                (Working with Raw Files) and vector files (Opening an Existing Document). The best thing about a Smart Object is
              that you can swap and resize its content without trashing its quality (as long as you
              don't exceed the file's original pixel dimensions, unless it's a vector). Flip to
                Using Smart Objects for more info.

	3D and Video layers. In the extended version of Photoshop (see the Note on Acknowledgements), you can import 3D and video files into their own
              special layers, which is helpful if you want to do some custom painting and
              transforming of individual video frames or 3D objects. For the scoop on 3D and more on
              video, head to this book's Missing CD page at www.missingmanuals.com/cds. You can
              also learn about video at www.PhotoshopforVideo.com.



The Layers Panel



No matter what kinds of layers your document contains, the one that's most important
            to you at any given time is the currently active layer. You can tell which layer is
            active by peeking at the Layers panel where Photoshop highlights the active layer, as
            shown in Figure 3-2. Regardless of which
            tool you're wielding, your changes will affect only that layer
            (save for the Pen tool, which creates paths [see Installing New Brushes]). To open the Layers panel, click its tab in the panel dock on the right side of your
            screen, or choose Window→Layers.
[image: In your Layers panel, Photoshop highlights the currently active layer as shown here. Each kind of layer has its own little preview called a layer thumbnail (circled).If you're trying to use a tool and Photoshop doesn't seem to be responding, take a peek in your Layers panel and make sure you've got the right layer selected. Nine times out of ten, you'll find that you don't!]

Figure 3-2. In your Layers panel, Photoshop highlights the currently active layer as shown
              here. Each kind of layer has its own little preview called a layer thumbnail
              (circled). If you're trying to use a tool and Photoshop doesn't seem to be
              responding, take a peek in your Layers panel and make sure you've got the right layer
              selected. Nine times out of ten, you'll find that you don't!

Tip
To make the layer thumbnails bigger so they're easier to see, open the Layers
              panel's menu shown in Figure 3-2 and
              choose Panel Options. You'll see a list of thumbnail sizes to choose from; Large is a
              good option (but if Photoshop starts running like molasses, change it back to a
              smaller option).


Selecting Layers



About the easiest thing you'll ever do in Photoshop is select a layer—just mouse
            over to the Layers panel and click the layer you want. However, just because it's easy
            doesn't mean it's not important. As you learned in the last section, whatever you're
            doing in Photoshop affects only the currently active layer—the one
            that's selected.
As your document gets more complex and your Layers panel starts to grow (and it
            will), it can be hard to figure out which layer each part of your image lives on. If you
            want, you can make Photoshop guess which layer an object is on:
            Press V to activate the Move tool, head up to the Options bar at the top of your screen,
            turn on the Auto-Select checkbox, and then choose Layer from the pop-up menu to its
            right (the other option, Group, is discussed on Grouping Layers into Folders).
Now when you click an object in your document, Photoshop selects the layer it
              thinks the object is on (it'll do this next time you use the Move
            tool, too, unless you turn off the Auto-Select option). The program may or may not guess
            right, and it really works only if your layers don't completely cover each other up. If
            you've got a document full of isolated objects—ones without backgrounds—on different
            layers, give it a shot. If you're working on a multilayered collage, forget it. For
            those reasons, you usually want to leave Auto-Select turned
            off.
Tip
You can have Photoshop narrow down your layer-hunting options by prodding it to
              give you a list of layers it thinks your object is on. Press V to
              select the Move tool, Ctrl-click (right-click) an object in your document, and then
              choose one of the layers from the resulting shortcut menu. (Note that this trick works
              only if you click an area that's more than 50 percent opaque.)

Selecting multiple layers



You'd be surprised how often you need to do the same thing to more than one layer.
              If you want to rearrange a few of them in your layers stack (Restacking Layers), move them around in your document together (Moving and Aligning Layers), or resize them simultaneously (Resizing and Rotating Layers), you need to select them first. Photoshop
              lets you select as few or as many as you want, though how you go about it depends on
              where they live in your Layers panel and which kind of layers they are. Here's
                how:
	Consecutive layers. To select layers that are
                  next to each other in the Layers panel, click the first one and then Shift-click
                  the last one; Photoshop automatically selects everything in between (see Figure 3-3 left).

	Nonconsecutive layers. To select layers that
                    aren't next to each other, click the first one's name and
                  then ⌘-click (Ctrl-click on a PC) the rest of them (see Figure 3-3 right).
[image: You can select consecutive layers (left) or random layers (right). To avoid loading the layer as a selection (page 137) when you're selecting nonconsecutive layers, make sure you ⌘-click (Ctrl-click) the area to the right of the layer thumbnail, as shown here.]

Figure 3-3. You can select consecutive layers (left) or random layers (right). To avoid
                    loading the layer as a selection (page 137) when you're selecting nonconsecutive
                    layers, make sure you ⌘-click (Ctrl-click) the area to the right of the layer
                    thumbnail, as shown here.


	Similar layers. To select layers similar to the
                  active layer, choose Select→Similar Layers. This command is handy, for example, if
                  you want to select all the Type layers so you can change the font (The Face of Type) or all the Shape or Fill layers to change their
                  color (Filling a Layer with Color).

	All layers. To select the whole kit and
                  caboodle, choose Select→All Layers. Choosing Deselect→All Layers (you guessed it)
                  deselects everything.

	Linked layers. If you've linked any layers
                  together (Linking and Locking Layers), you can select them all
                  by choosing Layer→Select Linked Layers (you can also find this command in the
                  Layers panel's menu).



Note
Selecting a layer is completely different from
                loading a layer's contents as a selection. When you load a layer as a selection, you
                see marching ants running around whatever is on that layer. Selecting a layer simply
                makes that layer active so you can perform other edits. See Chapter 4 for more on selections.



Adding New Layers



Most of the time, Photoshop creates new layers for you, like
            when you copy and paste an image (Copying and Pasting Layers), create
            text (Creating and Editing Text), and so on. But if you want to do
            something like paint with the Brush tool—to colorize a grayscale image (Colorizing Images), say—you need to create a new layer. Otherwise, you'll
            paint on or over your original image. Photoshop CS5 gives you five ways to create a new
              layer:
	Click the "Create a new layer" button at the bottom of the Layers panel (it
                looks like a piece of paper with a folded corner).

	Choose Layer→New→Layer.

	Choose New Layer from the Layers panel's menu.

	Press Shift-⌘-N (Shift+Ctrl+N on a PC).

	New in CS5, you can drag a file from your desktop into an open Photoshop
                document; the item you dragged appears on its own layer in the document—as a Smart
                Object to boot! (See the tip on page 55 for more on this new feature.)



Power Users' Clinic: Shortcuts for Selecting and Moving Layers
It's a little-known fact that you can use keyboard shortcuts to select and move layers. This trick can be a real
              timesaver since you don't have to lift your hands from your keyboard. It's also
              helpful when you're creating actions and don't want Photoshop to capture a layer's
              name (see Chapter 18). Here's the rather
              complicated list of shortcuts:
	To select the layer below the current layer, press Option-[ (Alt+[ on a PC).
                  To select the layer above the current layer, press Option-] (Alt+]).

	To grab a bunch of layers in a row, select the first layer and then press
                  Option-Shift-[ (Alt+Shift+[) to select layers below the first one, or
                  Option-Shift-] (Alt+Shift+]) to select layers above it. This shortcut lets you
                  grab one layer at a time. Just type the shortcut again to grab another
                  layer.

	To select the top layer in your Layers panel, press Option-. (Alt+.)—that's
                  Option or Alt plus the period key. To select the bottom layer, press Option-,
                  (Alt+,)—Option or Alt plus the comma key.

	To select all the layers between the currently active layer and the top layer,
                  press Option-Shift-. (Alt+Shift+.)—Option or Alt plus Shift and the period
                  key.

	To select all the layers between the currently active layer and the bottom
                  layer, press Option-Shift-, (Alt+Shift+,)—Option or Alt plus Shift and the comma
                  key.

	To select every layer except the locked Background layer,
                  press ⌘-Option-A (Ctrl+Alt+A). If you've unlocked the Background layer (Restacking Layers), it gets selected, too.

	To move the current layer up one slot in your layer stack, press ⌘-] (Ctrl+]).
                  To move it down one slot, press ⌘-[ (Ctrl+[).

	To move the current layer to the top of the layer stack, press Shift-⌘-]
                  (Shift+Ctrl+]). To move it to the bottom of the layer stack, press Shift-⌘-[
                  (Shift+Ctrl+[).




When you click the "Create a new layer" button, Photoshop creates an empty layer called Layer
              1. If you already have a layer called Layer 1,
            Photoshop names the new one Layer 2, and so on. If you use the menu
            options or keyboard shortcut, the program displays the New Layer dialog box (Figure 3-4) where you can name the layer,
            color-code it (Naming and Color-Coding Layers), choose its blend mode
              (Layer Blend Modes), set its opacity, and use it in a clipping mask
            (see the box on Clipping Masks).
Tip
If your fingers are flexible enough, you can create a new layer
                and bypass the New Layer dialog box by pressing
              Shift-Option-⌘-N (Shift+Alt+Ctrl+N on a PC). This shortcut is handy if you want to
              make new layers and don't care what they're called.

[image: In the New Layer dialog box (top), you can give your layer a name and a colored label. Color-coding layers makes them easier to spot in a long Layers panel (bottom). You can double-click a layer's name to rename it, and turn its visibility on or off by clicking the little eyeball to the left of its thumbnail. The new layer's thumbnail shown here is the checkerboard pattern (see the box on page 47) because the layer is empty and transparent.]

Figure 3-4. In the New Layer dialog box (top), you can give your layer a name and a colored
              label. Color-coding layers makes them easier to spot in a long Layers panel (bottom).
              You can double-click a layer's name to rename it, and turn its visibility on or off by
              clicking the little eyeball to the left of its thumbnail. The new layer's thumbnail
              shown here is the checkerboard pattern (see the box on page 47) because the layer is
              empty and transparent.

Tip
If you want to create a new layer below the one you're
              currently on, ⌘-click (Ctrl-click) the "Create a new layer" button at the bottom of
              the Layers panel. This shortcut saves you the extra step of dragging the new layer to
              a lower position later. This tip, when it's used over the course of a year, has been
              known to produce an entire vacation day! (But if the only layer
              in your document is the locked Background layer, you've got to double-click it to make
              it editable before you can add a new layer below it.)


Hiding and Showing Layers



The little visibility eye to the left of each layer lets you turn that layer off and
            on (Figure 3-4, bottom). Photoshop calls
            this incredibly useful feature hiding. For example, hiding layers
            lets you:
	See an instant before-and-after preview. If you've spent some time color-correcting (Chapter 9) or retouching people (Chapter 10) on duplicate layers, hiding
                those layers is an easy way to see the effect of your handiwork.

	Experiment with different looks. If you're trying
                out different backgrounds, you can add them all to your document and turn them on
                one at a time to see which one looks best.

	See what you're doing. When you're working on a
                document that has a bunch of layers, some of them may hide an area you need to see
                or work on. The solution is to hide in-the-way layers while you're working on those
                parts of the image and then turn them back on when you're done.

	Print certain layers. Only layers that are
                visible in your document will print, so if you want to print only parts of your
                image, hide the other layers first.



To hide a layer, simply click the little eye to the left of its layer thumbnail; to
            show it again, click the empty square where the visibility eye used to be. To hide
              all layers except one, Option-click (Alt-click on a PC) the
            visibility eye of the one layer you want to see. You can show the other layers again by
            Option-clicking (Alt-clicking) that same layer's visibility eye again. Alternatively,
            you can Ctrl-click (right-click) a layer's visibility eye (or the spot where it used to
            be if the layer is turned off) and choose "Show/Hide this layer" or "Show/Hide all other
            layers" from the shortcut menu. You can also find the Show/Hide layer command in the
            Layer menu.
Tip
To hide or show several layers, drag up or down over the visibility eyes in the
              Layers panel while you hold down your mouse button.


Restacking Layers



Once you start adding layers, you can rearrange their stacking
              order—the order they're listed in the Layers panel—to control what's
            visible and what's not. When you think about stacking order, pretend you're peering down
            at your Layers panel from above: The layer at the very top can hide any layers below it.
            For example, if you fill a layer with color (Filling a Layer with Color) and then place it above another layer containing a photo, the color will completely
            cover the photo. But if you've merely painted a swish or two with the Brush tool, your
            brushstrokes will cover just that part of your photo.
You can rearrange your layers manually, or make Photoshop do it for you:
	By dragging. Click a layer's thumbnail and drag
                it up or down to change its position as shown in Figure 3-5. When you get it in the right
                place, let go of your mouse button. (Technically, you can click
                  anywhere to grab the layer, but targeting the thumbnail is a
                good habit to get into, lest Photoshop thinks you want to rename it instead.)
[image: To rearrange layers, drag a layer's thumbnail up or down. When you drag, your cursor turns into a tiny closed fist as shown here (left). When you see the dividing line between the layers darken (left), let go of your mouse button to make the layer hop into place (right).New in Photoshop CS5, you see a ghost image of the layer you're dragging, which is helpful visual feedback.]

Figure 3-5. To rearrange layers, drag a layer's thumbnail up or down. When you drag, your
                  cursor turns into a tiny closed fist as shown here (left). When you see the
                  dividing line between the layers darken (left), let go of your mouse button to
                  make the layer hop into place (right). New in Photoshop CS5, you see a ghost
                  image of the layer you're dragging, which is helpful visual feedback.


	Using the Arrange command. If you've got one or
                more layers selected, you can choose Layer→Arrange to move them somewhere else in
                the layers stack. Depending on that layer's location in your Layers panel, you can
                choose from:
	Bring to Front moves the layer all the way to
                    the top of the layers stack. Keyboard shortcut: Shift-⌘-] (Shift+Ctrl+] on a
                    PC).

	Bring Forward moves the layer up one level.
                    Keyboard shortcut: ⌘-] (Ctrl-]).

	Send Backward sends the layer down one level.
                    Keyboard shortcut: ⌘-[ (Ctrl-[).

	Send to Back sends the layer all the way to
                    the bottom of the layers stack. Keyboard shortcut: Shift-⌘-[
                    (Shift+Ctrl-[).

	Reverse. If you've got two or more layers
                    selected (Selecting Layers), this command inverts the stacking
                    order of the selected layers. You probably won't use this command very often,
                    but give it a try just for fun; it can produce some mildly interesting results
                    (Photoshop doesn't have a keyboard shortcut for this one).






Note
If you've got a long Layers panel, these keyboard shortcuts can save you lots of
              time.

The only layer you can't move around (at least not without
            giving it some special treatment) is the Background layer. The
              Background layer isn't really a layer, although it looks like one. It
            behaves a little differently from other layers, as the box on The Background Layer and You explains, so if you want to rearrange it in
            your Layers panel, you have to double-click its thumbnail (circled back in Figure 3-2) and rename it in the resulting
            New Layer dialog box. When you click OK, it becomes a normal, everyday layer that you
            can put wherever you want.
Up To Speed: The Background Layer and You
Only a handful of image file formats understand Photoshop's layer system: PSD (Photoshop) files and TIFF files are the two
              most popular. Most other image file formats can handle only flat
              images (unlayered files). If you save a multilayered PSD file as a JPEG, EPS, or PNG
              file, for example, Photoshop flattens it, smashing all the layers into one. (See Layer Blending for more on
              flattening files.)
When you open an image created by a device or program that
                doesn't understand layers, like your digital camera or desktop
              scanner, Photoshop opens it as a flat image named Background. Though it looks like a
              regular layer, it's not nearly as flexible as the layers you create in Photoshop. For
              example, you can paint on it with the Brush tool ((Re)Introducing the Brush Tool), make a selection and fill the selection
              with color (Filling a Selection with Color), or use any of the
              retouching tools (Chapter 10) on it, but
              you can't use the Move tool to make it hang off the edges of your document or make any
              part of it transparent—if you try to use the Eraser tool, nothing happens other than
              painting with the background color (and you can almost hear
              Photoshop snickering at your efforts). Also, if you make a selection and press Delete
              (Backspace on a PC), Photoshop fills that area with the color of your background chip
                (Foreground and background color chips).
When you create a new document in Photoshop, the program
              opens a more universally compatible flat file containing a single Background layer. You can convert the Background layer into a fully
              editable and movable layer in a couple of different ways. The easiest method is to
              double-click the Background layer in your the Layers panel, give it a new name in the
              resulting New Layer dialog box, and then click OK. You can also select the Background
              layer in the Layers panel and then choose Layer→New→"Layer from Background". Or you
              can ⌘-click (right-click) the Background layer and choose "New layer from Background"
              from the resulting menu.
If you want, you can convert a normal layer into a Background layer by choosing
              Layer→New→"Background from Layer", but it's tough to think of a reason why you'd want
              to.
The only way to create a new document without a Background
              layer is to choose Transparent from the Background Contents pop-up menu (see Choosing Your Background). Otherwise, you're doomed to double-clicking
              and renaming the Background layer each time you create a new document.

To really understand how layer stacking works, it helps to put
            theory into practice. Let's say you want to make a photo look like one side fades to
            white and then add some text on top of the white part. To do that, you need to place the
            photo at the bottom of the layers stack, the white paint layer in the middle, and the
            text layer at the top (see Figure 3-6).
Here's a quick lesson in how to softly fade your photo to white and then add some
            text to it:
	Open a soon-to-be-faded photo and add a new layer to the
                  document.
To safeguard your photo, you need to put the white paint on another layer. Press
                ⌘-Shift-N (Ctrl+Shift+N on a PC) to create a new layer, give it a clever name like
                  white fade, and then click OK.
[image: The stacking order of your layers determines what you can and can't see.Top: With the Type layer at the top of the stack, you can see the text because it's sitting above everything else. And because the white fade layer is partially transparent (you can tell by the checkerboard pattern in its thumbnail), you can see through it to the photo at the bottom of the stack.Bottom: If you drag the Type layer below the white fade layer, you can't see the text anymore because it's hidden by the white paint.Once you get the hang of using gradient masks (page 287), you can substitute a Solid Fill Adjustment layer for the white fade image layer shown here. Because Adjustment layers automatically come with their own layer masks, you'll save the step of adding one yourself, plus you'll gain the ability to change the fade's color by double-clicking the Adjustment layer's thumbnail. Sweet!]

Figure 3-6. The stacking order of your layers determines what you can and can't
                  see. Top: With the Type layer at the top of the stack, you can see the text
                  because it's sitting above everything else. And because the white fade layer is
                  partially transparent (you can tell by the checkerboard pattern in its thumbnail),
                  you can see through it to the photo at the bottom of the stack. Bottom: If
                  you drag the Type layer below the white fade layer, you can't see the text anymore
                  because it's hidden by the white paint. Once you get the hang of using
                  gradient masks (page 287), you can substitute a Solid Fill Adjustment layer for
                  the white fade image layer shown here. Because Adjustment layers automatically
                  come with their own layer masks, you'll save the step of adding one yourself, plus
                  you'll gain the ability to change the fade's color by double-clicking the
                  Adjustment layer's thumbnail. Sweet!


	Set your foreground color chip to white.
Peek at the color chips at the bottom of your Tools panel (Foreground and background color chips). If they're black and white,
                just press X to flip-flop them until white hops on top. If the chips are other
                colors, press D to set them back to the factory setting of black and white.

	Grab the Gradient tool and set it to create a "Foreground
                  to Transparent" linear gradient.
Press G to select the Gradient tool and then head up to the Options bar at the
                top of your screen. Open the Gradient picker (near the left end of the bar) by
                clicking the down arrow next to the gradient preview and click once on the
                "Foreground to Transparent" swatch (second from the left in the top row). Move your
                mouse just a hair to the right in the Options bar to the gradient style buttons and
                click the first one, named Linear Gradient. (For more on gradients, see pages 287,
                334, and 363.)

	Back in your document, create a white-to-transparent
                  fade.
To paint a good-sized chunk of white, place your mouse near the right side of
                the photo (just past center) and then drag to the left for about a quarter of an
                inch and release your mouse button. The farther you drag, the wider the faded area.
                Don't worry if you don't get it right the first time; just keep clicking and
                dragging until you get the look you want.
Tip
If you want to start over, select all by pressing ⌘-A (Ctrl+A on a PC) and
                  then press Delete (Backspace) to zap everything on the layer so you can start your
                  white gradient from scratch.


	Press T to grab the Type tool and add some
                text.
You haven't learned about the Type tool yet, but be brave and press T to
                activate it and then hop up to the Options bar and pick a font and type size from
                the pop-up menus (see Chapter 14 for a proper
                introduction to the Type tool). Click once on your document where you want the text
                to begin and start typing. When you're finished typing, click the little checkmark
                at the top right of the Options bar to let Photoshop know you're done (pressing
                Enter on the numeric keypad—not Return—or selecting another tool works, too).



You're finished! If you want to move the text around, you can temporarily select the
            Move tool by holding down the V key. When your cursor turns into a little arrow, click
            and move your mouse to move the text.
If you followed these steps in order, you won't need to rearrange your layers in the Layers panel, but if you do, just grab the layer's thumbnail and drag it
            either up or down to change its position By the way, this technique is great for making
            your own personalized postcards and invitations.

Duplicating and Deleting Layers



Duplicating a layer comes in handy when you want to do something destructive like
            sharpen an image (Chapter 11) or soften Great Grandma's
            skin (Skin Softeners). By duplicating the layer first, you can work on
            a copy of the image instead of the original. But duplicating isn't
            limited to whole layers; you can duplicate just part of a layer.
            That technique comes in handy when you want to whiten teeth or make multiple copies of
            an object and move it around (like the hippy chicks in Figure 3-7).
[image: By selecting each of the silhouettes (top) and then pressing ⌘-J (Ctrl+J on a PC), you can jump copies of them onto their own layers (bottom). To move them around in your document, select one of the new layers, press V to grab the Move tool, and then drag to reposition the selected figure. Chapter 4 has more on how to make selections.If you'd like, you can ask Photoshop CS5 to automatically add the word "copy" to duplicated layers' names. Just open the Layers panel's menu and choose Panel Options and then turn on the "Add 'copy' to Copied Layers and Groups" checkbox at the bottom of the resulting dialog box.]

Figure 3-7. By selecting each of the silhouettes (top) and then pressing ⌘-J (Ctrl+J on a
              PC), you can jump copies of them onto their own layers (bottom). To move them around
              in your document, select one of the new layers, press V to grab the Move tool, and
              then drag to reposition the selected figure. Chapter 4 has more on how to make
              selections. If you'd like, you can ask Photoshop CS5 to automatically add the
              word "copy" to duplicated layers' names. Just open the Layers panel's menu and choose
              Panel Options and then turn on the "Add 'copy' to Copied Layers and Groups" checkbox
              at the bottom of the resulting dialog box.

Note
You can follow along by visiting this book's web page at www.missingmanuals.com/cds and
              downloading the file Chicks.jpg.

You can duplicate a layer in a gazillion ways:
	Press ⌘-J (Ctrl+J on a PC) or choose Layer→New→"Layer via
                  Copy" to copy the selected layer onto another layer just like it.

	Drag the original layer atop the "Create a new layer"
                  button at the bottom of the Layers panel. When Photoshop highlights the button (which looks like a piece of
                paper with a folded corner), let go of your mouse button.

	Option-drag (Alt-drag on a PC) the layer somewhere else in
                  your Layers panel. Your cursor turns into a double black-and-white arrowhead as soon as
                you start to drag. When you let go of your mouse button, Photoshop duplicates the
                layer.

	Choose Duplicate Layer from the Layers panel's menu (Figure 3-2) or choose Layer→Duplicate
                  Layer. This method gives you a chance to name your layer, as well as send
                it to a new document. If you choose to send it to a new document, pick an open
                document from the Destination section's Document pop-up menu or choose New to create
                a new document (enter a name for the new document in the Name field).

	Ctrl-click (right-click on a PC) the layer in your Layers
                  panel. From the resulting shortcut menu, choose Duplicate Layer.

	To duplicate part of layer, create a selection using any
                  of the tools discussed in Chapter 4 and
                  then press ⌘-J (Ctrl+J) to move your selection onto its own layer. If you
                want to delete the selected area from the original layer and
                  duplicate it onto another layer at the same time, press
                Shift-⌘-J (Shift+Ctrl+J). You can think of this trick as a cut
                to another layer since you'll have a hole in the original layer where the selection
                used to be.



Adding layers can really increase your document's file size, so
            if you have a slow computer or very little memory (RAM), you'll want to delete layers
            you don't need. To delete a layer, select it in the Layers panel and then:
	Press Delete (Backspace on a PC). This is the
                fastest deletion method in the West.

	Drag it onto the trash can at the bottom of the Layers
                  panel. The layer vanishes before your eyes.

	Click the trash can. When Photoshop asks if
                you're sure you want to delete the layer, click Yes and turn on
                the "Don't show again" checkbox if you don't want to see this confirmation box in
                the future.
Tip
If you delete a layer and then wish you had it back, just use Photoshop's Undo
                  command: Choose Edit→Undo or press ⌘-Z (Ctrl+Z on a PC).


	Ctrl-click (right-click on a PC) near the layer's name in
                  the Layers panel and choose Delete Layer from the shortcut menu. Be sure to click near the layer's name—if you
                click its thumbnail you won't see the Delete Layer item in the shortcut menu. When
                Photoshop asks if you really want to delete the layer, click Yes to send it
                packin'.

	Choose Layer→Delete or open the Layers panel's menu and
                  choose Delete Layer. You'll get a confirmation dialog box this way, too, so just smile
                sweetly, click Yes, and be on your way.



Tip
If you've hidden multiple layers (Hiding and Showing Layers), you can delete them
              all at once by opening the Layers panel's menu and choosing Delete→Hidden Layers (hey,
              if you're not using 'em, you might as well toss 'em!). Getting rid of extra layers
              shortens your Layers panel and reduces your document's file
              size.


Copying and Pasting Layers



You can use the regular ol' copy and paste commands to move whole or partial layers
            between Photoshop documents:
	To copy part of a layer into another document,
                create your selection first and then press ⌘-C (Ctrl+C on a PC) to copy it. Then
                open the other document and press ⌘-V (Ctrl+V); Photoshop pastes those pixels onto a
                new layer.

	To copy and paste a whole layer into another
                  document, choose Select→All (or press ⌘-A [Ctrl+A]) to select the layer
                and then press ⌘-C (Ctrl+C). Next, click the other document's window and press ⌘-V
                (Ctrl+V) to add the layer to that document's Layers panel.



Photoshop CS5 also includes a new Paste Special option in the Edit menu, which is
            incredibly handy when you're combining images. It's discussed at length in Chapter 7 on Pasting into a Selection.
Tip
When you copy an image from another program and paste it into a Photoshop
              document, it lands on its very own layer. If the pasted image is
                bigger than your document, you may need to resize the layer
              using Free Transform (pages 95 and 263).


Filling a Layer with Color



One of the most common things you'll do with a new layer is fill it with color. If
            you've hidden your image's original background (Hiding and Showing Layers) or added an interesting edge effect (see Figure 12-22 on Making an object sparkle), for example, you can spice things up by adding
            a solid-colored background. Photoshop gives you a couple of different ways to tackle
            this task:
	Fill an existing layer with color. After you've
                created a new layer using one of the methods listed on Adding New Layers, choose Edit→Fill. In the resulting Fill dialog box
                  (Figure 3-8), pick a color from
                the Use pop-up menu and then click OK. You can also fill a layer with your
                foreground color by pressing Option-Delete (Alt+Backspace on a PC).
Note
If you increase your canvas size (Resizing the Canvas) after
                  you've filled a layer with color, you'll need to refill the layer or it'll be
                  smaller than your document and you'll see the contents of layers below it peeking
                  through. To avoid this extra step, use a Fill layer, as discussed in the following
                  bullet point.

[image: The Use pop-up menu lets you tell Photoshop to fill a layer with your foreground or background color (page 24) or summon the Color Picker (page 493) by choosing Color.]

Figure 3-8. The Use pop-up menu lets you tell Photoshop to fill a layer with your
                  foreground or background color (page 24) or summon the Color Picker (page 493) by
                  choosing Color.


	Create a Fill layer. If you're not sure which
                color you want to use, choose Layer→New Fill Layer and pick Solid Color. In the New
                Layer dialog box that appears, name the layer and then click OK. Photoshop then
                displays the Color Picker so you can choose the fill color you want. If you decide
                to change the fill color, double-click the Fill layer's thumbnail and Photoshop
                opens the Color Picker so you can choose a new color or steal one from the image
                itself (as shown in Figure 3-9).
                Fill layers also come with their own layer masks, making it super simple to hide
                part of the layer if you need to.



[image: Top: Dragging your new Fill layer to the bottom of the layers stack creates a solid-colored (in this case, white) background for your image. If you want to change the color, double-click the Fill layer's thumbnail (circled) to pop open the Color Picker.Bottom: If you want to get super creative, you can snatch color from your image by mousing over to it while the Color Picker is open (your cursor changes into an eyedropper, circled). Click once to select the color you want and then click OK to close the Color Picker.Finally, if you want to hide part of the new color for any reason (say, to create a color fade), just paint in the included layer mask (see page 113).]

Figure 3-9. Top: Dragging your new Fill layer to the bottom of the layers stack creates a
              solid-colored (in this case, white) background for your image. If you want to change
              the color, double-click the Fill layer's thumbnail (circled) to pop open the Color
              Picker. Bottom: If you want to get super creative, you can snatch color from your
              image by mousing over to it while the Color Picker is open (your cursor changes into
              an eyedropper, circled). Click once to select the color you want and then click OK to
              close the Color Picker. Finally, if you want to hide part of the new color for
              any reason (say, to create a color fade), just paint in the included layer mask (see
              page 113).

One of the many advantages of using Fill Layers is that, unlike regular layers, they fill the
              whole layer with color even if you enlarge your canvas. In
            addition to using Fill layers to create solid backgrounds, you can use them to fill a
            layer with a gradient or a repeating pattern, as shown in Figure 3-10.

Tweaking a Layer's Opacity and Fill



All layers begin life at 100 percent opacity, meaning you can't see through them
            (except where they're empty, as shown in Figure 3-6). If you want to make a layer
            semitransparent, you can adjust its Opacity setting. Lowering a layer's opacity is a
            good way to lessen the strength of a color or lighting adjustment (Chapter 9), the amount of sharpening you applied to a
            duplicate layer (Chapter 11), and so on.
[image: Fill layers aren't just for adding solid color; you can use them to create a gradient- or pattern-filled background as shown here (top and bottom, respectively). If you want to change the gradient or pattern, just double-click its layer thumbnail to make Photoshop display the appropriate dialog box—Gradient Fill or Pattern Fill.You can also add a Fill layer by using the Adjustment layer menu at the bottom of the Layers panel (it looks like a half-black/half-white circle). You'll find Solid Color, Gradient, and Pattern listed at the very top of the resulting menu.]

Figure 3-10. Fill layers aren't just for adding solid color; you can use them to create a
              gradient- or pattern-filled background as shown here (top and bottom, respectively).
              If you want to change the gradient or pattern, just double-click its layer thumbnail
              to make Photoshop display the appropriate dialog box—Gradient Fill or Pattern
              Fill. You can also add a Fill layer by using the Adjustment layer menu at the
              bottom of the Layers panel (it looks like a half-black/half-white circle). You'll find
              Solid Color, Gradient, and Pattern listed at the very top of the resulting
              menu.

The Opacity and Fill settings live at the top of your Layers panel (see Figure 3-11). The Fill setting is different
            from the Opacity setting in that it doesn't affect the whole layer. For example, if you
            create a Shape layer or Type layer (see pages 76–77), lowering its Fill setting will
            lower only the opacity of the color inside the shape or letters,
            not the opacity of any layer styles you've added (Layer Styles).
To change Opacity or Fill, mouse over to your Layers panel, select the layer you
            want to tweak, and then:
[image: If you lower the opacity of the white fade layer to 50 percent, as shown here, the white paint becomes partially transparent, letting you see through to the photo layer below. If you want to look like a real Photoshop pro, hover your cursor near the word Opacity. You'll get a little scrubby cursor that you can drag to the left or right to lower or raise the layer's opacity (you can even drag the scrubby cursor off the Layers panel if you want to).This trick works for any setting in the program with similar controls, too, including the Fill setting, most everything in the Options bar (no matter which tool is active), the Character and Paragraph panels, and more!]

Figure 3-11. If you lower the opacity of the white fade layer to 50 percent, as shown here,
              the white paint becomes partially transparent, letting you see through to the photo
              layer below. If you want to look like a real Photoshop pro, hover your cursor near the
              word Opacity. You'll get a little scrubby cursor that you can drag to the left or
              right to lower or raise the layer's opacity (you can even drag the scrubby cursor off
              the Layers panel if you want to). This trick works for any setting in the program
              with similar controls, too, including the Fill setting, most everything in the Options
              bar (no matter which tool is active), the Character and Paragraph panels, and
              more!

Tip
In Photoshop CS5 you can change the opacity and/or fill of multiple layers at once; just Shift- or ⌘-click
              (Ctrl-click on a PC) to select more than one layer and then adjust the Opacity or Fill
                settings.

	Enter a new value in the Opacity or Fill field.
                Double-click the current value in either field to highlight it, enter a new value,
                and then press Return (Enter on a PC).

	Use the field's slider. Click the down arrow to
                the right of the Opacity or Fill field (on a PC, the arrow points to the right) and
                drag the resulting slider to the left or right to decrease or increase that setting,
                  respectively.

	Use your keyboard. Press V to activate the Move
                tool (think "moVe") and change the Opacity by typing 1 for 10
                percent, 2 for 20 percent, 35 for 35
                percent, and so on (type 0 for 100 percent). If you've got any
                other tool selected besides the Move tool, you'll change the opacity setting for
                that particular tool instead. (You can use the same keyboard
                trick to adjust the Opacity settings for the Fill tool, too; just hold down the
                Shift key while you type the numbers.




Resizing and Rotating Layers



If you want to resize the contents of a layer—or many layers—without changing the size of your document, you
            can use the Free Transform tool (shown in Figure 3-12). (You'll learn a lot more about
            this tool in Chapter 6, so consider this a sneak
            peek.) To resize or rotate a layer, follow these steps:
	In the Layers panel, select the layers you want to adjust
                  (see Selecting Layers for the scoop on selecting multiple
                  layers).

	Press ⌘-T (Ctrl+T on a PC)
                  to summon the Free Transform tool.
Photoshop puts a box (called a bounding box) lined with
                small square white handles around the content of your layer(s) (Figure 3-12).
Note
If you're resizing a Smart Object (Resizing Smart Objects),
                  the little handles are black instead of white. The difference is purely
                  cosmetic—they work exactly the same.

[image: You can drag any of the bounding box's square handles to resize your object. To adjust all four sides of the box simultaneously, hold down Option (Alt on a PC) as you drag a corner handle.Don't forget to press Return (Enter) when you're finished because Photoshop won't let you do anything else while you've got an active bounding box.]

Figure 3-12. You can drag any of the bounding box's square handles to resize your object.
                  To adjust all four sides of the box simultaneously, hold down Option (Alt on a PC)
                  as you drag a corner handle. Don't forget to press Return (Enter) when you're
                  finished because Photoshop won't let you do anything else while you've got an
                  active bounding box.


	Drag one of the corner handles inward to make the layers
                  smaller.
Grab any of the white corner handles and drag diagonally inward to make the
                layers smaller. If you want to resize the object proportionately so it doesn't get
                squished or stretched, hold down the Shift key as you drag.

	To rotate the layers, position your cursor outside the bounding box and when it
                  turns into a curved, double-head arrow, drag up or down in the direction you want
                  to turn the layers.

	Press Return (Enter on a PC) or double-click inside the
                  bounding box to let Photoshop know you're done.



Tip
To see the Free Transform tool's resizing handles all the time, press V to grab
              the Move tool and then turn on the Show Transform Controls checkbox in the Options
              bar. Seeing the handles is handy if you're jumping between layers to resize or rotate objects and don't want to stop and summon Free
              Transform each time.

Do you risk reducing your image's quality by resizing layers this way? Sure. Anytime you alter pixel size, you change the
            quality a little bit, too, whether it's a single layer or your whole document. But as
            long as you decrease the layer's size, you won't lose much quality
            (though you don't want to decrease its size repeatedly—try to do it
            once or twice and be done with it). You definitely risk losing quality if you
              increase the size of a pixel-based Image layer because when
            pixels get bigger, they also get blockier.
That said, if you're working with a Smart Object (Using Smart Objects), Shape layer (Photoshop's Drawing Modes), or Type layer (Chapter 14), you've got no worries; you can resize those
            babies all day long—larger or smaller, as many times as you want—and you won't affect
            the quality, which is why you want to use those kinds of layers whenever you can.
            (However, you don't want to enlarge a raster-based Smart Object beyond its original
            dimensions; Automated Resizing with the Image Processor explains
            why.)
Tip
The rest of the transform tools, including Skew, Distort, and so on, work on
              layers, too. See The Transformers for details.


Moving and Aligning Layers



One of the many advantages of using layers is that you can scoot 'em around
            independent of everything else in your document. To move a layer, you have to select it
            in your Layers panel first. Press V to grab the Move tool and drag the layer wherever
            you want. For example, if you want to move the text in Figure 3-11 a bit to the left, press V and
            drag it to a new spot. To move the layer in a perfectly vertical or horizontal line,
            hold down the Shift key while you drag. You can also nudge the layer by using the arrows
            on your keyboard (holding down the Shift key while you press the arrow keys scoots the
            layer by 10 pixels per keystroke).
Note
In Photoshop CS5, it's easier than ever to see what you're
              doing as you move layers in your document. As soon as you start dragging, you'll see a
              slightly transparent, dark gray border around the item appear atop your document—it
              moves as you drag. This is extremely helpful when you're moving items that are really
              small, and thus easy to lose sight of.

If you want to move only part of a layer, select that portion
            first using one of the methods explained in Chapter 4. Then you can grab the Move tool and move
            just the selected bits.
Aligning layers



When you need to position layers, Photoshop has several tools that can help you
              get them lined up just right. If you're trying to align one layer perfectly with the
              layer below, it's a good idea to lower the top layer's opacity temporarily (Tweaking a Layer's Opacity and Fill) so you can actually
                see the layer below.
Photoshop tries to help you align layers by snapping the one
              you're moving to the boundaries (content edges) of other
              layers. As you drag a layer with the Move tool, Photoshop tries to pop the layer into
              place when you get near another layer's edge (if you want to make the program stop
              popping them into place, choose View→Snap). If you'd like to see
              the boundaries of your layer, press V to activate the Move tool, hop up to the Options
              bar, and turn on the Show Transform Controls checkbox (Figure 3-13).
[image: Most folks have never seen these alignment tools, but they're there! If you forget what each button is for, hover your cursor over it and, within a second or two, Photoshop displays a yellow tooltip telling you what that button does. Figure 3-14 shows you what these buttons do.]

Figure 3-13. Most folks have never seen these alignment tools, but they're there! If you
                forget what each button is for, hover your cursor over it and, within a second or
                two, Photoshop displays a yellow tooltip telling you what that button does. Figure
                3-14 shows you what these buttons do.

In addition to snapping and showing you boundaries, Photoshop offers you the
              following alignment helpers:
	Alignment tools. If you need to align the edges
                  of more than one layer, these tools come in handy. You'll see them in the Options
                  bar at the top of your screen when the Move tool is active
                    and you have more than one layer selected (see Figure 3-13 for details). You can also
                  find them by choosing Layer→Align (you still need to have more than one layer
                  selected, but you don't have to activate the Move tool). Figure 3-14 shows you what each
                  alignment button does.
[image: Each of these guitars lives on its own layer, so you can see the effect of Photoshop's various alignment tools.]

Figure 3-14. Each of these guitars lives on its own layer, so you can see the effect of
                    Photoshop's various alignment tools.


	Distribute tools. Nestled snugly to the right of the alignment tools are the
                  distribute tools (Figure 3-13)
                  Their mission is to evenly space the contents of the selected layers based on each layer's horizontal or vertical center (you need
                  to have at least three layers selected to use them). For
                  example, these options are handy when you're designing buttons for website navigation because you
                  can distribute space between them equally.

	Smart Guides. Unlike the regular guides you learned about in Chapter 2 (Guides, Grids, and Rulers), Smart Guides show up automatically anytime
                  you drag a layer near another layer's boundaries (see Figure 3-15). They're extremely helpful
                  when you're manually aligning layers with the Move tool since they make it easier
                  to position layers precisely in relation to each other. To turn them on, choose
                  View→Show→Smart Guides.
[image: When you turn on Smart Guides, Photoshop alerts you with a thin red line anytime you approach the boundaries of another layer so you know if you're about to move past its edge.]

Figure 3-15. When you turn on Smart Guides, Photoshop alerts you with a thin red line
                    anytime you approach the boundaries of another layer so you know if you're about
                    to move past its edge.


	Auto-alignment. If you choose Edit→Auto-Align Layers, Photoshop does the aligning for you by looking at
                  the corners and edges of objects on the selected layers. This command is really handy when you're combining images into
                  a panorama (see Building Panoramas with Photomerge), but it
                  doesn't work on Adjustment layers, Smart Objects, or Vector layers.



Workaround Workshop: When Layers Won't Align
If you try to align the bottoms of two Type layers using the Align Bottom Edges command, you may run into trouble. If there's a
                  descender (a letter that goes below the baseline, like the
                letters y and p) in one layer but not the
                other, the two layers won't align properly because their bottoms aren't even. The
                fix is to replace the troublesome letter(s) temporarily with one that doesn't have a
                descender and then click the Align Bottom Edges button. Once
                the layers are aligned, you can change the letter(s) back. It's not elegant, but it
                works.
Photoshop can also do strange things when you're using the alignment tools on
                layers that have layer masks (Layer Masks: Digital Masking Tape).
                Instead of aligning the layers according to what you've hidden with the mask (which
                is probably what you're trying to do), Photoshop tries to align the layers using the
                actual pixel information (it pays no attention to the mask). In that case, you may
                need to turn on Rulers (Rulers and Guiding Lines), create a few
                guides (Guides, Grids, and Rulers), and manually align the layers
                with the Move tool (Moving and Aligning Layers).


Moving layers between documents



In addition to copying and pasting layers from one document to another (as
              described back on Copying and Pasting Layers), you can also drag and
              drop them straight from your Layers panel to another document, as shown in Figure 3-16. Photoshop leaves the layer in
              your original document and places a copy in the target document,
              so you don't have to worry about losing anything from either file. This technique is
              really helpful if you want to create a collage (Chapter 7),
              swap backgrounds, or share color corrections across documents. Here's how to move a
              layer from one document to another:
	Open the documents you want combine.

	Click the Arrange Documents button at the top of your
                    screen (Arranging Open Images) and choose one of the 2-Up
                    display options or "Float All in Windows" from the pop-up menu.
To drag from one document to the other, it's often easier if you can
                    see both documents, as explained in Figure 3-16. Choosing either the 2-Up
                  display options or "Float All in Windows" makes Photoshop rearrange your document
                  windows so you can see them both at the same time. (Arranging Open Images has more on display options.)

	Click the document that contains the layer you want to
                    move and then drag the layer's thumbnail onto the other
                  document.
As you drag, your cursor turns into a tiny closed fist, as you can see in
                    Figure 3-16. When Photoshop
                  highlights the inside border of the destination window with a faint black outline,
                  let go of your mouse button to make Photoshop add the layer to that
                  document.



Tip
To center the moved layer perfectly in its new home, hold the Shift key as you
                drag the layer between documents.


Exporting layers to separate files



If you've got a bunch of layers that you want to separate into individual files
              (with each layer in its own file), choose File→Scripts→"Export Layers to Files". In
              the resulting dialog box (Figure 3-17),
              use the Destination field to tell Photoshop where you want it to save the files. In
              the File Name Prefix box, create a naming scheme (Photoshop uses whatever you enter in
              the prefix field as the first part of your file names), and, in the File Type pop-up
              menu, choose a file format. When you're finished, click Run and sit back while
              Photoshop does all the work.
[image: Top: To combine two images into one document, first arrange your workspace so that you can see both windows. Then drag one layer's thumbnail from your Layers panel into the other document.Bottom: When you release your mouse button, the new layer appears in the other document's Layers panel, as shown here. In Photoshop CS5, you also drag from your document area onto another open document's tab.]

Figure 3-16. Top: To combine two images into one document, first arrange your workspace so
                that you can see both windows. Then drag one layer's thumbnail from your Layers
                panel into the other document. Bottom: When you release your mouse button, the
                new layer appears in the other document's Layers panel, as shown here. In Photoshop
                CS5, you also drag from your document area onto another open document's tab.
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