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Preface



Millions of Microsoft Excel users are busy creating and sharing spreadsheets every day. Indeed, the spreadsheet has grown from a powerful convenience to a transformative foundation for many businesses, driving decision-making around the planet.
Although Excel is a critical tool, many Excel users know only about a subset of its functionality. They utilize the pieces they need, often reusing more complex pieces from existing templates, and don't dive too deeply into everything Excel has to offer. Odds are good that no single user actually needs every feature in Excel, so this approach is pretty reasonable. At the same time, though, it means a lot of people never get far enough along the learning curve to see the techniques they can use to make their work much easier.
With the release of MS Office 2007 comes a new version of Excel. There are many changes with Excel 2007, the most obvious being the new user interface. The introduction of the ribbon provides a results-oriented interface that presents tools when you need them, in a clear and organized fashion. The size of a spreadsheet has also been greatly increased, with the number of columns now well over 16,000 and the number of rows over 1,000,000. The total amount of memory that Excel can use has also been increased and is limited only by the maximum available memory Windows will allow on your PC.
Other improvements include easier use of PivotTables, conditional formatting and named ranges, live visual previews, predefined style galleries, table formats, and SmartArt graphics allowing you to use more complicated graphics in your spreadsheets. As most of us are usually required to work across a range of applications, share workbooks, and connect with the Web, Excel 2007 makes this much more user-friendly and easy to manage.
In this book, we have again used real-life situations for the content. Excel 2007 has been used as a base for almost all of the hacks, although most of the hacks can be used in previous versions as well and a few are specific to earlier versions. Differences are highlighted in the text and most of the old menu items can still be found, just in a different place and possibly named slightly differently.
Why Excel Hacks?



Although it's possible to accomplish an enormous amount of work using a relatively simple subset of Excel's capabilities, the software offers a lot of powerful techniques that can leapfrog your work beyond the ordinary without requiring that you spend years using and studying Excel. However, most people focus on the content they create—data and formulas, with the occasional chart—so moving to more advanced levels of Excel usage seems difficult.
There are lots of ways to take advantage of Excel's capabilities to greatly extend your ability to create great spreadsheets, but that don't require years of study. These tools, or hacks—quick and dirty solutions to problems, or clever ways of doing things—were created by Excel users looking for simple solutions to complex issues. The hacks in this book are designed to show you what's possible and how to make them work immediately.
You can benefit from these hacks in two important ways. First, you can use the hacks directly as you build and improve your spreadsheets. Second, by studying the hacks and possibly learning a little Visual Basic for Applications (VBA) code, you can customize the hacks to meet your needs precisely.


Getting and Using the Hacks



To save you the time and effort of typing scripts and spreadsheets by hand, all the hacks (except those that are only a few lines long or use only the GUI) are available for download from the authors' web site at http://www.ozgrid.com/BookExamples/excel-hack2-examples.htm.
You'll undoubtedly want to cut and paste from the examples and modify their contents to make them fit your spreadsheets more precisely. Excel spreadsheets are tremendously diverse, and you'll want to change things to make them fit your work.

How to Use This Book



Although this book is divided into chapters, as described in the following section, you can use it in a variety of different ways. One approach is to think of the book as a toolbox and start by becoming familiar with the tools in each chapter. Then, when a need arises or a problem occurs, you can simply use the right tool for the job. Or, you might decide to browse through the book or read it from cover to cover, studying the procedures and scripts to learn more about Excel. Some of the hacks are helpful in this area because they contain tutorials about complex subjects or well-documented scripts. You also might pick one chapter and see what you find useful to your current situation or what you might find helpful in the future.

How This Book Is Organized



Whichever way you choose to use this book, you will probably want to familiarize yourself with the contents first, so here's a brief synopsis of each chapter and what you'll find:
	Chapter 1, Reducing Workbook and Worksheet Frustration
	Workbooks and worksheets are the primary interface to data in Excel, but sometimes this set of giant open grids doesn't do precisely what you want. These hacks enable you to manage how users interact with work-sheets, help you find and highlight information, and teach you how to deal with debris and corruption.

	Chapter 2, Hacking Excel's Built-in Features
	Excel includes many built-in features for analyzing and managing data. However, these features often have limitations. The hacks in this chapter enable you to extend and automate these features, moving beyond the limited tasks they were designed to perform originally.

	Chapter 3, Naming Hacks
	Although cell references such as A2 and IV284:IN1237 are certainly useful, as spreadsheets become larger, it's often easier to reference information by name. These hacks show you not only how to name cells and ranges, but also how to create names that adapt to the data in your spreadsheet.

	Chapter 4, Hacking PivotTables
	For many Excel users, PivotTables already seem like a complicated but magical hack. The hacks in this chapter teach you how to get the most out of PivotTables by showing you how to extend them and avoid the problems that make them frustrating.

	Chapter 5, Charting Hacks
	Excel's built-in charting capabilities are very useful, but they don't always provide the best method for viewing spreadsheet data. These hacks teach you how to tweak and combine Excel's built-in charting capabilities so that you can create customized charts.

	Chapter 6, Hacking Formulas and Functions
	Formulas and functions are at the heart of most spreadsheets, but sometimes the way Excel handles them just isn't quite what you want. These hacks cover subjects ranging from moving formulas around to dealing with datatype issues to improving recalculation time.

	Chapter 7, Macro Hacks
	Macros (and VBA) are Excel's escape hatch, enabling you to build spreadsheets that go well beyond Excel's own capabilities or develop spreadsheets that look more like programs. These hacks help you make the most of macros, from managing them to using them to extend other features.

	Chapter 8, Cross-Application Hacks
	Although most spreadsheets are self-contained, this chapter shows you how you can work with other Microsoft Office applications to get information into and out of your spreadsheets and into and out of other programs.




Windows, Macintosh, and Earlier Excel Versions



The hacks in this book were written for Excel 2007 and were tested on previous versions of Excel for Windows and on a Macintosh using Excel 2004. Where steps or menu options differ, the main text shows how to accomplish the task in Excel 2007, with instructions for "pre-2007" called out in notes or parentheses.
Most of the differences between the Windows and Mac platform versions are cosmetic, and most involve changes to key combinations and the occasional menu. Where the key combinations differ, they are written with the Windows modifier first, as in Alt/Command(⌘)-Q, which means Alt-Q for Windows and ⌘-Q on the Macintosh. There are a few cases, especially in the Visual Basic Editor (VBE), where the interfaces look different and have different menu choices, and these are explained on first encounter. There are also a few Windows-only hacks, using the Windows registry and other features that are supported only on Windows versions of Excel. These are noted in the text.
Macintosh users with one-button mice should also note that holding down the Control key while clicking is the equivalent of right-clicking. (Macintosh users with two or more buttons can just right-click.) Recent models of Apple MacBook and MacBook Pros allow you to specify a right-click by holding two fingers on the trackpad and clicking. You must enable this in System Preferences.
Most of the hacks should work with any version of Excel from Excel 97 onward; the text will indicate when this isn't the case. Whenever possible, screenshots were taken using Excel 2007, but the figures are not an indicator of which hacks work with which versions.

Conventions Used in This Book



The following typographical conventions are used in this book:
	Plain text
	Indicates cell identifiers, named ranges, menu titles, menu options, menu buttons, and keyboard accelerators (such as Alt and Ctrl).

	Italic
	Indicates new terms, URLs, email addresses, filenames, file extensions, pathnames, directories, and variables in text.

	Constant width
	Used for commands, options, switches, variables, attributes, keys, functions, types, classes, namespaces, methods, modules, properties, parameters, values, objects, events, event handlers, XML tags, HTML tags, macros, the contents of files, and the output from commands.

	Constant width bold
	Used to show commands or other text that should be typed literally by the user, as well as to emphasize important lines of code.

	Constant width italic
	Used in examples, tables, and commands to show text that should be replaced with user-supplied values.

	↵
	A carriage return (↵) at the end of a line of code is used to denote an unnatural line break—that is, you should not enter these as two lines of code, but as one continuous line. Multiple lines are used in these cases due to page width constraints.



You should pay special attention to notes set apart from the text with the following icons:
Tip
This icon signifies a tip, suggestion, or general note.

Warning
This icon indicates a warning or caution.

The thermometer icons, found next to each hack, indicate the relative complexity of the hack:
[image: Conventions Used in This Book]
 beginner 
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 moderate 
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 expert
The following icons, found below each hack, indicate which versions of Excel are compatible with the hack:
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Works with all versions of Excel
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Works with Excel 2007
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Works with versions of Excel prior to 2007
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Works with Excel 2003
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Works with Excel 2000

Using Code Examples



This book is here to help you get your job done. In general, you may use the code in this book in your programs and documentation. You do not need to contact us for permission unless you're reproducing a significant portion of the code. For example, writing a program that uses several chunks of code from this book does not require permission. Selling or distributing a CD-ROM of examples from O'Reilly books does require permission. Answering a question by citing this book and quoting example code does not require permission. Incorporating a significant amount of example code from this book into your product's documentation does require permission.
We appreciate, but do not require, attribution. An attribution usually includes the title, author, publisher, and ISBN. For example: "Excel Hacks, Second Edition, by David and Raina Hawley. Copyright 2007 O'Reilly Media, Inc., 978-0-596-52834-8."
If you feel your use of code examples falls outside fair use or the permission given above, feel free to contact us at permissions@oreilly.com.

Safari® Enabled



When you see a Safari® Enabled icon on the cover of your favorite technology book, that means the book is available online through the O'Reilly Network Safari Bookshelf.
Safari offers a solution that's better than e-books. It's a virtual library that lets you easily search thousands of top tech books, cut and paste code samples, download chapters, and find quick answers when you need the most accurate, current information. Try it for free at http://safari.oreilly.com.

How to Contact Us



Please address comments and questions concerning this book to the publisher:
O'Reilly Media, Inc.
1005 Gravenstein Highway North
Sebastopol, CA 95472
800-998-9938 (in the United States or Canada)
707-829-0515 (international or local)
707-829-0104 (fax)


We have a web page for this book, where we list errata, examples, and any additional information. You can access this page at:
http://www.oreilly.com/catalog/9780596528348/


A collection of spreadsheet files for each individual hack is available at:
http://www.ozgrid.com/BookExamples/excel-hack2-examples.htm


Visit the official web site of the Hacks series of books:
http://www.hackszine.com


To comment or ask technical questions about this book, send email to:
bookquestions@oreilly.com


For more information about our books, conferences, Resource Centers, and the O'Reilly Network, see our web site at:
http://www.oreilly.com



Chapter 1. Reducing Workbook and Worksheet Frustration



Hacks 1–16



Excel users know that workbooks are a powerful metaphor. But many users are equally aware that dealing with workbooks can cause a huge number of snags. The hacks in this chapter will help you avoid some of these snags while taking advantage of some of the more effective but often overlooked ways in which you can control your workbooks.
Before we leap into the hacks, though, it's worth taking a quick look at some basics that will make it much easier to create effective hacks. Excel is a very powerful spreadsheet application, and you can do incredible things with it. Unfortunately , many people design their Excel spreadsheets with little foresight, making it difficult for them to reuse or update the spreadsheets they've so carefully built. In this section, we provide several tips you can follow to ensure that you're creating spreadsheets that are as efficient as possible.
The 80/20 Rule



Perhaps the most important rule to follow when designing a spreadsheet is to take a long-term view and never assume you will not need to add more data or formulas to your spreadsheet because chances are good that you will. With that in mind, you should spend about 80 percent of your time planning your spreadsheet and about 20 percent implementing it. Although this can seem extremely inefficient in the short run, we can assure you that the long-term gain will far outweigh the short-term pain and that the planning gets easier after you've done it for a while. Remember that spread-sheets are about making it easy for users to get correct information, not just about presenting information that looks good only once.

Structural Tips



Without a doubt, the number one mistake most Excel users make when creating their spreadsheets is that they do not set up and lay out the data in the manner in which Excel and its features expect. Here are, in no particular order, some of the most common mistakes users make when setting up a spreadsheet:
	Unnecessarily spreading data over many different workbooks

	Unnecessarily spreading data over numerous worksheets

	Unnecessarily spreading data over different tables

	Having blank columns and rows in tables of data

	Leaving blank cells for repeated data



The first three items on the preceding list add up to one thing: you should always try to keep related data in one continuous table. Time and time again we see spreadsheets that do not follow this simple rule and thus are limited in their ability to take full advantage of some of Excel's most powerful features, including PivotTables, subtotals, and worksheet formulas. In such scenarios, you can use these features to their full potential only when you've laid out your data in a very basic table.
It is no coincidence that Excel spreadsheets can comprise 1,048,576 rows (65,536 pre-2007) but only 16,384 columns (256 pre-2007). With this in mind, you should set up tables with column headings going across the first row of your table and related data laid out in a continuous manner directly underneath their appropriate headings. If you find you are repeating the same data over and over for two or more rows in one of these columns, resist the temptation to use blank cells to indicate repetition.
Make sure your data is sorted whenever possible. Excel has a rich set of lookup and reference formulas, some of which require that your data be sorted in a logical order. Sorting also will speed the calculation process of many functions significantly.

Formatting Tips



Moving beyond structure, formatting also can cause problems. Although a spreadsheet should be easy to read and follow, this should rarely be at the expense of efficiency. We are big believers in "keeping it simple." Far too many people spend tremendous amounts of time formatting their spread-sheets. Although they don't necessarily realize it, this time frequently comes at the expense of efficiency. Often the overuse of formatting adds size to your workbook, and although your workbook might look like a work of art to you, it might look terrible to someone else. Some very good universal colors to consider using in your spreadsheets are black, white, and gray.
It is always a good idea to leave at least three blank rows above your table (at least three, preferably more). These can then be used for criteria for features such as Advanced Filter and Database functions.
People also tinker with the alignment of cell data. By default, numbers in Excel are right-aligned and text is left-aligned, and there are good reasons to leave it this way. If you start changing this formatting, you will not be able to tell at a glance if the contents of a cell are text or numeric. It is very common for people to reference cells, which look like numbers but in reality are text. If you have altered the default alignment, you will be left scratching your head. Perhaps headings are an exception to this rule.
Format cells as text only when completely necessary. All data entered into cells formatted as text become text, even if you meant for them to be numbers or dates. Worse still, any cell housing a formula that references a text-formatted cell also will be formatted as text. Generally, you do not want formula cells to be formatted as text!
Merged cells can also cause problems. The Microsoft knowledge base is full of frequently encountered problems with merged cells. As a good alternative, use "Center across selection," found under Home → Alignment Group. The arrow in the bottom right will display the Format dialog with the Alignment tab active. Use the Horizontal drop-down to select Center Across Selection or right-click and choose Format Cells from the shortcut menu (pre-2007, Format → Cells).

Formula Tips



Another enormous mistake users often make in Excel formulas is referencing entire columns. This forces Excel to examine potentially thousands, if not millions, of cells it otherwise could have ignored.
Assume, for example, that you have a table of data ranging from cell A1 to cell H1000. You might decide you want to use one or more of Excel's lookup formulas to extract the required information. Because your table might continue to grow (as you add new data), it is common to reference the entire table, incorporating all rows. In other words, your reference might look something like A:H, or possibly A1:H65536. You would use this reference so that when new data is added to the table, it will be referenced in the formulas automatically.
This is a very bad habit to form and you should almost always avoid it. You still can eliminate the need to constantly update your formula references to incorporate new data as it is added to a table by using dynamic named ranges.
Another common problem with poorly designed spreadsheets is painfully slow recalculation. Many people suggest that shifting calculation mode into Manual via the Office button → Excel → Formulas (pre-2007, Tools → Options → Calculations; Mac OS X, Excel → Preferences → Calculation) will solve this problem.
However, this is generally very poor advice, fraught with potential disasters. A spreadsheet is all about formulas and calculations and the results they produce. If you are running a spreadsheet in manual calculation mode, sooner or later you will read some information from your spreadsheet that will not have been updated. Your formulas might be reflecting old values and not the updated values because when you go into manual calculation mode, you must force Excel to recalculate by pressing the F9 key ( ⌘-= on Mac OS X). However, it is very easy to forget to do this! Think of it this way. If your car brakes were rubbing and slowing down your car, would you disconnect the brake pedal and rely on the hand brake instead of fixing the problem? Most of us wouldn't dream of doing this, but many people don't hesitate to put their spreadsheets into manual calculation mode. If you need to run your spreadsheet in manual calculation mode, you have a design problem. Address it properly and do not use a "Band-Aid" approach.
Array formulas are another common cause of trouble. They are best suited to referencing single cells. If you use them to reference large ranges, do so as infrequently as possible. When large numbers of arrays reference large ranges, your workbook's performance will suffer, sometimes to the point where it becomes unusable and you are forced to run your spreadsheet in manual calculation mode.
Excel's database functions provide many alternatives to array formulas, as discussed in "Sum or Count Cells While Avoiding Error Values" [[Hack #79]]. Also, the Excel Help offers some good examples on how you can use these formulas on large tables of data to return results based on multiple criteria. Another alternative that is often overlooked is the use of Excel's PivotTable feature, discussed in Chapter 4. Although PivotTables might seem very daunting when first encountered, we highly recommend that you familiarize yourself with this powerful Excel feature because once you master PivotTables, you will wonder how you survived without them!
At the end of the day, if you remember nothing else about spreadsheet design, remember that Excel works best when all related data is laid out in one continuous table. That should make the rest of your hacking much easier.



Hack #1. Create a Personal View of Your Workbooks



[image: Create a Personal View of Your Workbooks]
Excel enables you to have multiple workbooks showing simultaneously, and to have a customized view of your workbooks arranged in different windows. Then you can save your view workspaces as .xlw files and use them when it suits you.
Sometimes when working in Excel, you might need to have more than one workbook open on your screen to make it easier to use or view data from multiple workbooks. The next few paragraphs describe how to do this in a neat and organized way.
First, open all the workbooks you will need.
Tip
To open more than one workbook at a time, select the Office button → Open…, press the Ctrl key (⌘ key on the Mac) while selecting the workbooks you want to open, and then click Open (pre-2007, select File → Open).

From any of the workbooks (it doesn't matter which one), select Windows → View → Arrange All (pre-2007, select Window → Arrange). If "Windows of active workbook" is checked, uncheck it, and then select the window arrangement you prefer and click OK.
If you select Tiled, you will be presented with your workbooks in a tiled fashion, as shown with blank workbooks in Figure 1-1.
Selecting Horizontal gives you a view of your workbooks in a single stack, one on top of the other, as in Figure 1-2.
Checking the Vertical option will place all your open workbooks side by side, as shown in Figure 1-3.
Finally, as shown in Figure 1-4, selecting the Cascade option will layer all open workbooks one on top of the other.
Once your workbooks are displayed in your preferred view, you can easily move data between them (e.g., copy, paste, drag and drop).
If you think you might want to return to a view you created, you can save this preferred view as a workspace. To save a workspace, simply select Windows → Save Workspace (pre-2007, File → Save Workspace), enter the workspace's filename in the File Name box, and click OK. When saving your workspace, the file extension will be .xlw rather than the standard .xlsx of Excel 2007. To restore your Excel workspace to one full window of a particular workbook, just double-click the title bar (on the Mac, click the green Zoom button in the upper left of the window) appearing on any one of your workbooks. You can also click the Maximize button on any of the windows in your workspace. Close your workbooks as usual when you're finished.
[image: Four workbooks in a tiled view]

Figure 1-1. Four workbooks in a tiled view

[image: Four workbooks in a horizontal view]

Figure 1-2. Four workbooks in a horizontal view

[image: Four workbooks in a vertical view]

Figure 1-3. Four workbooks in a vertical view

[image: Four workbooks in a cascade view]

Figure 1-4. Four workbooks in a cascade view

Zoom button in the upper left of the window) appearing on any one of your workbooks. You can also click the Maximize button on any of the windows in your workspace. Close your workbooks as usual when you're finished.
Whenever you need to open those same workbooks, simply open the .xlw file, and the view you initially set up will be magically restored for all workbooks. If you need to open just one of those workbooks, open the file as usual. Any changes you make to the workbooks in the .xlw file will be saved automatically as you close the workspace as a whole, or you can save workbooks individually.
If you spend a small amount of time setting up some custom views for repetitive tasks that require multiple open workbooks, you'll find that these tasks become easier to manage. You might decide to use different views for different repetitive tasks, depending on what the task is or how you're feeling that day.

Hack #2. Enter Data into Multiple Worksheets Simultaneously
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It's fairly ordinary to need some data to be duplicated in multiple worksheets. You can use Excel's tool for grouping so that data entered in one workbook can be entered into multiple worksheets simultaneously. But there is also a quicker and more flexible approach that uses a couple of lines of Visual Basic for Applications (VBA) code.
Excel's built-in mechanism for making data go to multiple places at once is a feature called Group. It works by grouping the worksheets together so that they're all linked within the workbook.
Grouping Worksheets Manually



To use the Group feature manually, simply click the sheet into which you will be entering the data, and press the Ctrl key (the ⌘ key on the Macintosh) while clicking the Name tabs of the worksheets where you want the data to go. When you enter data into any cells on your worksheet, they will be entered automatically in the other grouped worksheets. Mission accomplished.
To ungroup your worksheets, either select one worksheet that is not part of the group, right-click any Name tab and select Ungroup Sheets, or Ctrl/⌘-click the sheets you added to the group.
Warning
When your worksheets are grouped together, you can look up to the title bar and see the word Group in square brackets. This lets you know your worksheets are still grouped. Unless you have eagle eyes and a mind like a steel trap, however, it is highly likely that you won't notice this or that you'll forget you have your worksheets grouped. For this reason, we gently suggest you ungroup your sheets as soon as you finish doing what you need to do.

Although this method is easy, it means you need to remember to group and ungroup your sheets as needed or else you will inadvertently overtype data from another worksheet. For example, you might want the simultaneous entries to occur only when you are in a particular range of cells. However, simultaneous data entries will occur regardless of the cell you are in at the time.

Grouping Worksheets Automatically



You can overcome these shortcomings by using some very simple VBA code. For this code to work, it must reside within the private module for the Sheet object. To quickly go to the private module, right-click the Sheet Name tab and select View Code. You can then use one of Excel's sheet events—which are events that take place within your worksheet, such as changing a cell, selecting a range, activating, deactivating, and so on—to move the code into the private module for the Sheet object.
Tip
In most cases, you will be taken directly to the private module when you right-click on a workbook or worksheet and select View Code. You can confirm that you're in the private module by looking at the state of the drop-down menu in the upper left of the code window—this window is usually labeled something like "Workbook - sheetname(Code)". If the drop-down menu says "Workbook" or "Worksheet," then you in the private module. If it says "(General)," change it before typing in the code.

To enable grouping, first name the range of cells you want to have grouped so that the data shows automatically on other worksheets.
Enter this code into the private module:
	Private Sub Worksheet_SelectionChange(ByVal Target As Range)
	 If Not Intersect(Range("MyRange"), Target) Is Nothing Then
	 'Sheet5 has purposely been placed first as this will
	 'be the active sheet we will work from
	 Sheets(Array("Sheet5", "Sheet3", "Sheet1")).Select
	 Else
	 Me.Select
	 End If
	End Sub
In this code, we used the named range MyRange. (If you aren't familiar with named ranges, see "Address Data by Name" [[Hack #44]].) Change MyRange to the range name you are using on your worksheet. Also change the three sheet names in the code, as shown in Figure 1-5, to the sheet names you want to be grouped. When you're done, either click the View Microsoft Excel tool, close the module window, or press Alt/⌘-Q to get back to Excel, then save your workbook.
[image: Code for automatically grouping worksheets]

Figure 1-5. Code for automatically grouping worksheets

It is important to note that the first sheet name used in the array must be the sheet housing the code, and thus the worksheet on which you will enter the data.
Once the code is in place, each time you select any cell on the worksheet, the code checks to see whether the cell you selected (the target) is within the range named MyRange. If it is, the code will automatically group the worksheets you want grouped. If it isn't, it will ungroup the sheets simply by activating the sheet you are already on. The beauty of this hack is that there is no need to manually group the sheets and therefore run the risk of forgetting to ungroup them. This approach can save lots of time and frustration.
If you want the same data to appear on other sheets but not in the same cell addresses, use code like this:
	Private Sub worksheet_Change(ByVal Target As Range)
	 If Not Intersect(Range("MyRange"), Target) Is Nothing Then
	 With Range("MyRange")
	 .Copy Destination:=Sheets("Sheet3").Range("A1")
	 .Copy Destination:=Sheets("Sheet1").Range("D10")
	 End With
	 End If
	End Sub
This code also needs to live within the private module of the Sheet object. Follow the steps described earlier in this hack to get it there.


Hack #3. Prevent Users from Performing Certain Actions
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Although Excel provides overall protection for workbooks and worksheets, this blunt instrument doesn't provide limited privileges to users—unless you do some hacking.
You can manage user interactions with your spreadsheets by monitoring and responding to events. Events, as the term suggests, are actions that occur as you work with your workbooks and worksheets. Some of the more common events include opening a workbook, saving it, and closing it. You can tell Excel to run some Visual Basic code automatically when any one of these events is triggered.
Warning
Users can bypass all these protections by disabling macros entirely. Click the Office button and choose Excel Options → Trust Center → Trust Center Settings and press the Macro and press the Macro Settings Button (pre-2007, Tools → Macro → Security). If their security is set to "Disable all macros with notification" (Medium in pre-2007 versions), they'll be notified of macros in the workbook upon opening it and will be offered the opportunity to turn them off. A security setting of "Disable all macros without notification" (High in older versions) will simply turn them off automatically. On the other hand, if using the spreadsheet requires the use of macros, users might be more likely to have macros turned on. These hacks are a convenience and do not provide heavy-duty data security.
On Mac OS X, you cannot control macro protection at this level of detail. Instead, you can select Excel → Preferences → Security and toggle the setting "Warn before opening a file that contains macros."

Preventing Save As… in a Workbook



You can specify that any workbook be saved as read-only by choosing Office button → Save → Tools Button → General Options and enabling the "Read-only recommended" checkbox (pre-2007, File → Save As → Tools [Options on the Mac] → General options in the Save options dialog). Doing so can prevent a user from saving any changes he might make to the file, unless he saves it with a different name and/or in a different location.
Sometimes, however, you might want to prevent users from being able to save a copy of your workbook to another directory or folder with or without a different name. In other words, you want users to be able to save on top of the existing file and not save another copy elsewhere. This is particularly handy when more than one person is saving changes to a workbook because you do not end up with a number of different copies of the same workbook, saved with the same name in different folders.
The Before Save event you'll be using has existed since Excel 97. As its name suggests, this event occurs just before a workbook is saved, enabling you to catch the user before the fact, issue a warning, and stop Excel from saving.
Warning
Before trying this at home, be sure to save your workbook first. Putting this code into place without having saved will prevent your workbook from ever saving.

To insert the code, open your workbook and choose Developer → Visual Basic, then select View → Code, and double-click on ThisWorkbook in the Project Explorer (pre-2007, right-click the Excel icon immediately to the left of the File menu item on the worksheet menu bar, and select View Code, as shown in Figure 1-6).
Tip
You might have to enable the Developer tab (not standard in Excel 2007) by selecting Office button → Excel Options → Popular, checking the option "Show Developer tab in the Ribbon" and clicking OK.

[image: Quick access menu (in Excel 2003) to the private module for the workbook object]

Figure 1-6. Quick access menu (in Excel 2003) to the private module for the workbook object

Tip
This shortcut isn't available on the Mac. You'll have to open the Visual Basic Editor (VBE) by pressing Option-F11, or by selecting Tools → Macro → Visual Basic Editor. Once you're there, Ctrl-click or right-click This Workbook in the Projects window.

Type the following code into the VBE, as shown in Figure 1-7, and press Alt/⌘-Q to get back to Excel proper, then save your workbook:
	Private Sub workbook_BeforeSave(ByVal SaveAsUI As Boolean, _
	 Cancel As Boolean)
	Dim lReply As Long
	 If SaveAsUI = True Then
	lReply = MsgBox("Sorry, you are not allowed to save this " & _
	 "workbook as another name. Do you wish to save this " & _
	 "workbook?", vbQuestion + vbOKCancel)
	 Cancel = (lReply = vbCancel)
	 If Cancel = False Then Me.Save
	 Cancel = True
	 End If
	End Sub
[image: Code once it's entered into the private module (ThisWorkbook)]

Figure 1-7. Code once it's entered into the private module (ThisWorkbook)

Give it a whirl. Select Office button → Save (pre-2007, File → Save) and your workbook will save as expected. However, select Office button → Save As (pre-2007, File → Save As…) and you'll be informed that you're not allowed to save this workbook under any other filename, unless you've disabled macros.
Tip
Note that when you save a workbook in Excel 2007 and it contains either macros or code, you will be prompted to save your workbook as an Excel macro-enabled workbook (*.xlsm) and will be unable to save in the standard Excel file format (*.xlsx).


Preventing Users from Printing a Workbook



Perhaps you want to prevent users from printing your workbook—and probably having it end up in a recycling bin or left on a desk somewhere in plain sight. Using Excel's Before Print event, you can stop them in their tracks. Enter the following code, as before, into the VBE:
	Private Sub workbook_BeforePrint(Cancel As Boolean)
	 Cancel = True
	 MsgBox "Sorry, you cannot Print from this workbook", vbInformation
	End Sub
Press Alt/⌘-Q when you're done entering the code to get back to Excel, then save your workbook. Now each time users try to print from this workbook, nothing will happen. The MsgBox line of code is optional, but it's always a good idea to include it to at least inform users so that they do not hassle the IT department, saying there is a problem with their program!
If you want to prevent users from printing only particular sheets in your workbook, use this similar code instead:
	Private Sub workbook_BeforePrint(Cancel As Boolean)
	 Select Case ActiveSheet.Name
	 Case "Sheet1", "Sheet2"
	 Cancel = True
	 MsgBox "Sorry, you cannot print this sheet from this workbook", _
	vbInformation
	 End Select
	End Sub
Notice you've specified "Sheet1" and "Sheet2" as the only cases in which printing should be stopped. Of course, these can be the names of any sheets in your workbook; to add more sheets to the list, simply type a comma followed by the sheet name in quotation marks. If you need to prevent the printing of only one sheet, supply just that one name in quotes and drop the comma.

Preventing Users from Inserting More Worksheets



Excel lets you protect a workbook's structure so that users cannot delete worksheets, rearrange the order in which they appear, rename them, and so forth. Sometimes, though, you want to prevent just the addition of more worksheets, while still allowing other structural alterations.
The following code will get the job done:
	Private Sub Workbook_NewSheet(ByVal Sh As Object)
	 Application.DisplayAlerts = False
	 MsgBox "Sorry, you cannot add any more sheets to this workbook", _
	 vbInformation
	 Sh.Delete
	 Application.DisplayAlerts = True
	End Sub
The code first displays the message box with the message and then immediately deletes the newly added sheet when the user clicks OK from the message box. The use of Application.DisplayAlerts = False stops the standard Excel warning that asks users if they really want to delete the sheet. With this in place, users will be unable to add more worksheets to the workbook.
Another way to prevent users from adding worksheets is to select Review → Changes → Protect Workbook, and then press the Protect Structure and Windows button (pre-2007, Tools → Protection → Protect Workbook…, ensure that the Structure checkbox is checked, and click OK). However, as mentioned at the beginning of this hack, Excel's worksheet protection is a rather blunt instrument and will also prevent many other Excel features from working.


Hack #4. Prevent Seemingly Unnecessary Prompts



[image: Prevent Seemingly Unnecessary Prompts]
Excel's chattiness can get a little old, always prompting you to confirm actions you just asked it to perform. Quit the conversation and let Excel get back to the action.
The types of prompts we are talking about are those that ask you whether you want to enable macros (when you do not have any), or whether you are sure you want to delete a worksheet. Here is how to get rid of the most common prompts once and for all.
Enabling Macros When You Don't Have Any



Excel's memory is like a steel trap when it comes to remembering that you recorded a macro in your workbook. Unfortunately, its memory of macros persists even though you might have since deleted one or more macros via Developer → Macros or Alt/Option-F8 (pre-2007, Tools → Macro → Macros). Reopen the workbook and you'll still be prompted to enable macros, even though there are none to enable.
Tip
You'll be prompted to enable macros only if your security level is set to "Disable all macros with notification" (Medium in pre-2007 versions). If it's set to "Enable all macros" (Low in pre-2007 versions), macros are enabled without a peep; if it's set to "Disable all macros without notification" (High in pre-2007 versions), macros are disabled automatically for your protection.

When you record a macro, Excel inserts a Visual Basic module to hold your commands and home-brewed functions. Upon opening a workbook, Excel checks for the presence of modules, whether empty or macro-filled. Deleting a workbook's macros deletes any code within the module, not the module itself—kind of like drinking the last of the milk, yet putting the empty carton back in the fridge. To avoid the unnecessary macro prompt, you need to remove the module. Here's how to do that.
Open the VBE by selecting Developer → Visual Basic under Code options or by pressing Alt/Option-F11 (pre-2007, Tools → Macro → Visual Basic Editor and select View → Project Explorer).
Tip
On the Macintosh and in Excel 2007, the Projects window is always open, so you don't need to open the Project Explorer.

You'll see a window like the one shown in Figure 1-8.
[image: Project Explorer modules]

Figure 1-8. Project Explorer modules

Find your workbook in the Project Explorer and click the plus sign (+) to its left to expose the workbook's component parts, particularly the modules if they are not already showing. Right-click each module in turn and choose Remove Module from the context-sensitive menu. Decline the offer to export the modules. Before blithely removing modules that might contain useful code, double-click each module in turn to make certain you don't need them. Press Alt/⌘-Q as usual to get back to Excel's spreadsheet view.

Prompting to Save Nonexistent Changes



You might have noticed that sometimes simply opening a workbook and taking a look around is enough to trigger Excel to prompt you to save changes to your personal macro workbook—despite the fact that you've made no changes whatsoever. Whether you know it or not, you most likely have a volatile function within your personal macro workbook.
A personal macro workbook is a hidden workbook created the first time you record a macro (Tools → Macro → Record New Macro) and specify "Personal Macro Workbook" in the "Store Macro in" drop-down menu. It is opened each time you use Excel. A volatile function (or formula) is one that automatically recalculates each time you do almost anything in Excel, including opening and closing either the workbook or the entire application. Two of the most common volatile functions are the Today( ) and Now( ) functions.
So, although you might believe you've made no changes to the workbook at hand, those volatile functions running in the background might have. This counts as a change and triggers Excel's prompt to save said invisible changes.
If you want Excel to stop prompting you to save changes you didn't make, you have a couple of options open to you. The most obvious is not to store volatile functions within your personal macro workbook in the first place, and to delete any volatile functions that are already there. Or, if you need volatile functions, you can use this rather simple snippet of code to circumvent the check by tricking Excel into thinking your personal macro workbook has been saved the moment it opens:
	Private Sub Workbook_BeforeClose(Cancel As Boolean)
	    Me.Saved = True
	End Sub
This code must live in the private workbook module of your personal macro workbook. To get there from any workbook, select View → Unhide under Window options (pre-2007, Window → Unhide), select Personal.xls from Unhide Workbook, and click OK. Visit the VBE and enter the aforementioned code. Press Alt/⌘-Q to get back to Excel when you're done.
Of course, if you have a volatile function that you want to recalculate and you want to save the changes, you need to explicitly tell Excel to do so:
	Private Sub Workbook_BeforeClose(Cancel As Boolean)
	    Me.Save
	End Sub
This macro will save your personal macro workbook automatically each time it is opened.

Stopping Excel's Warning Prompts for Recorded Macros



One of the many drawbacks of recorded macros is that, although they're pretty good at mimicking just about any command, they tend to forget your responses to prompts. Delete a worksheet and you're prompted for confirmation; run a macro for the same and you'll still be prompted. Let's turn off those prompts.
Select Developer → Macros under Code options or Alt/Option-F8 (pre-2007, Tools → Macro → Macros) to bring up a list of your macros. Make sure "All Open Workbooks" is selected in the Macros In: box's pull-down menu. Select the macro you're interested in and click the Edit button. Put the cursor before the very first line of code—i.e., the first line without an apostrophe in front of it—and prepend the following:
	Application.DisplayAlerts = False
At the very end of your code, append the following:
	Application.DisplayAlerts = True
Your macro should look something like this:
	Sub MyMacro( )
	'
	' MyMacro Macro
	' Deletes the Active worksheet
	'

	'
	 Application.DisplayAlerts = False
	 ActiveSheet.Delete
	 Application.DisplayAlerts = True
	End Sub
Note that you've turned alerts back on at the end of your macro to re-enable standard Excel prompts while working in Excel. Leave this out, and you'll see no alerts at all, not even those that might have been good to include.
Warning
If your macro does not complete for any reason—a runtime error, for instance—Excel might never get to the line of code that turns alerts back on. If this happens, it's probably wise to quit and restart Excel to set things back to the way they were.

Now you know how to use Excel without prompts. Be aware, though, that these prompts are there for a reason. Make sure you fully understand the purpose of a prompt before summarily turning it off.


Hack #5. Hide Worksheets So That They Cannot Be Unhidden



[image: Hide Worksheets So That They Cannot Be Unhidden]
Sometimes you want a place for information that users can't read or modify. Build a backstage into your workbook, a place to keep data, formulas, and other minutiae consumed by, but not seen in, your sheets.
A useful practice when setting up a new Excel workbook is to reserve one worksheet for storing information users do not need to see: formula calculations, data validation, lists, useful variables and special values, sensitive data, and so forth. Although you can hide the sheet by selecting View → Hide under Window options (pre-2007, Format → Sheet → Hide), it's a good idea to ensure that users can't unhide it by selecting View → Unhide under the Window options (pre-2007, Format → Sheet → Unhide …).
You can, of course, simply protect the worksheet. However, this still leaves it in full view—sensitive data, scary formulas, and all. Also, you can't protect a cell linked into any of the controls available to you from the Forms toolbar.
Instead, we'll fiddle with the worksheet's Visible property, making it xlVeryHidden. Go to Developer → Visual Basic or Alt/Option-F11 to get to the VBE (pre-2007, go to Tools → Macro → Visual Basic Editor and make sure the Project Explorer window is visible by selecting View → Project Explorer). Find the name of your workbook within the Project Explorer and expand its hierarchy by clicking the + to the left of the workbook's name. Expand the Microsoft Excel Objects folder within to reveal all your workbook's worksheets.
Select the sheet you want to hide from the Project Explorer and reveal its properties by selecting View → Properties Window (or by pressing F4). Make sure the Alphabetic tab is selected, and look for the Visible property at the very bottom. Click the value box on the right associated with the Visible property and select the last option, 2-xlSheetVeryHidden, as shown in Figure 1-9. Press Alt/⌘-Q to return to Excel, then save your changes. The sheet will no longer be visible via the Excel interface and won't appear as a choice under View → Unhide under Window options (pre-2007, Format → Sheet → Unhide…).
Warning
Once you have selected 2 -xlSheetVeryHidden from the Properties window, it might appear as though your selection had no effect. This visual bug sometimes occurs and shouldn't concern you; if the sheet no longer appears when you select View → Unhide under Window options (pre-2007, Format → Sheet → Unhide…) you know it had the desired effect.

[image: Properties window of a worksheet having its visible property set to 2 - xlSheetVeryHidden]

Figure 1-9. Properties window of a worksheet having its visible property set to 2 - xlSheetVeryHidden

To reverse the process, simply follow the preceding steps, this time selecting -1-xlSheetVisible.

Hack #6. Customize the Templates Dialog and Default Workbook



[image: Customize the Templates Dialog and Default Workbook]
If you tend to perform the same tasks or use the same spreadsheet layouts again and again, you can build your own Template tab into Excel's standard Insert Template dialog to provide a quick starting point.
Imagine you have a spreadsheet containing days of the year and formulas summarizing various data for the days. You have formatted this spreadsheet beautifully with your company colors, logo, and required formulas, and you need to use it on a daily basis. Instead of reinventing the wheel (or copying and deleting what you don't need) each day, you can save yourself a lot of time and trouble by creating a template.
Excel's worksheet and workbook templates provide you with a running start on your next project, enabling you to skip the initial setup, formatting, formula building, and so on. Saving a template worksheet simply means opening a new workbook, deleting all but one worksheet, and then creating the basic template you will be using. Once you're finished, select Office button → Save As… (pre-2007, File → Save As…) and choose Excel Template (Template on Mac OS X) from the dialog's Save As Type (Format on Mac OS X) drop-down list. If your template is to be a workbook template—i.e., it will contain more than one worksheet—again add a new workbook, make all the necessary changes, select Office button → Save As…, and save as an Excel template.
Template in hand, you can create a clone at any time by either selecting the Office button → New (pre-2007, File → New…; File → Project Gallery on the Mac) and selecting a workbook template, or by right-clicking the Worksheet tab and selecting Insert… from the context sensitive menu to insert a new worksheet from a template. Wouldn't it be nice, though, to have those templates available to you right from Excel's standard Insert Template dialog, or to set your preferred workbook as the default? You can, by creating your own Template tab.
Warning
This hack assumes you have a single installation of Excel running on your computer. If you have multiple copies or versions of Excel installed, this may not work.

Creating Your Own Template Tab



If you have a slew of templates—workbooks, worksheets, or both—that you use on a regular basis, you can group them together to make it easier for you to manage them.
From within any workbook, choose the Office button → Save As… (pre-2007, File → Save As…). Then, from the Files of Type pop-up menu, select Excel Template (.xltx); for older versions, select Template (.xlt). By default Excel will select the standard Templates folder in which all your home-grown templates are kept.
If you want to create tabs in which to store your templates, create a subfolder by using the New Folder button.
Tip
On Mac OS X, Excel 2004 defaults to your My Templates directory for saving new templates, so this step is not needed.

Now, go to the Office button, select New, and click the "My templates" option button (for Excel 2000 and above, choose General Templates from the New Workbook dialog that will appear; for older versions, select File → New… on the worksheet menu bar). You should now see the tab you created (named Ozgrid in the screen shot in Figure 1-10) on the dialog floating over your screen. You also should now see your Template workbooks and worksheets, as long as you saved them to this folder.
Tip
In Excel 2007, as a default if you do not create any tabs, your templates are stored under "My templates" in the My Templates tab.

[image: The Templates dialog]

Figure 1-10. The Templates dialog


Using a Custom Default Workbook



Starting Excel opens a blank default workbook called Book1 containing three blank worksheets. This is fine and dandy if you want a clean slate each time you start Excel. If you're like us, however, you tend to favor one workbook over the others. So, for us, opening Excel involves dismissing the default workbook and searching for our regular workbook. It sure would be handy to have that favored workbook open at the outset, ready for action.
To do so, save your default workbook (template) in the XLSTART folder (generally found in C:\Documents and Settings\Owner\Application Data\Microsoft\Excel>\XLSTART in Windows, and in Applications/Microsoft Office 2004/Office/Startup/Excel under Mac OS X). Once you have done this, Excel will automatically use whichever workbook(s) you have in there as the default.
Tip
The XLSTART folder is where your personal macro workbook is created and saved automatically when you record a macro. The personal macro workbook is a hidden workbook. You also can have your own hidden workbooks open in the background if you want by opening the required workbook, selecting View → Hide under Window options (pre-2007, Window → Hide), closing Excel, and clicking Yes to save changes to the workbook you just hid. Now place this workbook in your XLSTART folder. All the workbooks you hide and place within the XLSTART folder will open as hidden workbooks each time you start Excel.
Don't be tempted to place too many workbooks into this folder, especially large ones, as all of them will open when you start Excel. Too many open workbooks can greatly slow down Excel's performance.

Naturally, if you change your mind and decide to go back to a blank default workbook, simply remove the appropriate workbook or workbook template from the XLSTART folder.


Hack #7. Create an Index of Sheets in Your Workbook



[image: Create an Index of Sheets in Your Workbook]
If you've spent much time in a workbook with many worksheets, you know how painful it can be to find a particular worksheet. An index sheet available to every worksheet is a navigational must-have.
Using an index sheet will enable you to quickly and easily navigate throughout your workbook so that with one click of the mouse you will be taken exactly where you want to go, without fuss. You can create an index in a few ways: by hand, auto-generated by code, or as a context-sensitive menu option.
Creating an Index Sheet by Hand



You might be tempted to simply create the index by hand. Create a new worksheet, call it Index or the like, enter a list of all your worksheets' names, and hyperlink each to the appropriate sheet by selecting Insert → Hyperlink under Link options (pre-2007, Insert → Hyperlink…) or by pressing Ctrl/⌘-K. Although this method is probably sufficient for limited instances in which you don't have too many sheets and they won't change often, you'll be stuck maintaining your index by hand.

Auto-Generate an Index Using VBA



An alternative is to use VBA to auto-generate the index. The following code will automatically create a clickable, hyperlinked index of all the sheets you have in the workbook. The index is re-created each time the sheet that houses the code is activated.
This code should live in the private module for the Sheet object. Insert a new worksheet into your workbook and name it something appropriate—Index, for instance. Right-click the index sheet's tab and select View Code from the context menu or select Alt/Option-F11.
Enter the following Visual Basic code:
	Private Sub Worksheet_Activate( )
	Dim wSheet As Worksheet
	Dim l As Long
	l = 1
	 With Me
	 .Columns(1).ClearContents
	 .Cells(1, 1) = "INDEX"
	 .Cells(1, 1).Name = "Index"	
	 End With

	 For Each wSheet In Worksheets
	 If wSheet.Name <> Me.Name Then
	 l = l + 1
	 With wSheet
	 .Range("A1").Name = "Start" & wSheet.Index
	 .Hyperlinks.Add Anchor:=.Range("A1"), Address:="", SubAddress:= _
	 "Index", TextToDisplay:="Back to Index"
	 End With
	 Me.Hyperlinks.Add Anchor:=Me.Cells(l, 1), Address:="", _
	 SubAddress:="Start" & wSheet.Index, TextToDisplay:=wSheet.Name
	 End If
	 Next wSheet
	End Sub
Press Alt/ ⌘-Q to get back to your workbook and then save your changes. To make the code run, you will first need to deactivate your worksheet (select another sheet) and select the index sheet.
Notice that in the same way you name a range of cells, the code names cell A1 on each sheet Start, plus a unique whole number representing the index number of the sheet. This ensures that A1 on each sheet has a different name. If A1 on your worksheet already has a name, you should consider changing any mention of A1 in the code to something more suitable—an unused cell anywhere on the sheet, for instance.
Warning
Be aware that if you select the Office button → Prepare → Properties → Document Properties → Advanced Properties ([pre-2007, File → Properties → Summary) and enter a URL as a hyperlink base, the index created from the preceding code might not work. A hyperlink base is a path or URL that you want to use for all hyperlinks with the same base address that are inserted in the current document.


Link to the Index from a Context Menu



The third way of constructing an index is to add a link to the list of sheets as a context-menu item, keeping it just a right-click away. We'll have that link open the standard workbook tabs command bar. You generally get to this command bar by right-clicking any of the sheet tab scroll arrows on the bottom left of any worksheet, as shown in Figure 1-11.
[image: Tabs command bar displayed by right-clicking the sheet scroll tabs]

Figure 1-11. Tabs command bar displayed by right-clicking the sheet scroll tabs

To link that tab's command bar to a right-click in any cell, enter the following code in the private module of ThisWorkbook:
	Private Sub Workbook_SheetBeforeRightClick _
	(ByVal Sh As Object, ByVal Target As Range, Cancel As Boolean)
	Dim cCont As CommandBarButton
	 On Error Resume Next
	 Application.CommandBars("Cell").Controls("Sheet Index").Delete
	 On Error GoTo 0
	 Set cCont = Application.CommandBars("Cell").Controls.Add _
	 (Type:=msoControlButton, Temporary:=True)
	 With cCont
	 .Caption = "Sheet Index"
	 .OnAction = "IndexCode"
	 End With
	End Sub
Next, you'll need to insert a standard module to house the IndexCode macro, called by the preceding code whenever the user right-clicks in a cell. It is vital that you use a standard module next, as placing the code in the same module as Workbook_SheetBeforeRightClick will mean Excel will not know where to find the macro called IndexCode.
Select Insert → Module and enter the following code:
	Sub IndexCode( )
	 Application.CommandBars("workbook Tabs").ShowPopup
	End Sub
Press Alt/⌙-Q to get back to the Excel interface, then save your workbook.
Now, right-click within any cell on any worksheet and you should see a new menu item called Sheet Index that will take you right to a list of sheets in the workbook.





End of sample




    To search for additional titles please go to 

    
    http://search.overdrive.com.   
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1 |Order 1D Employee Customer Order Date Shipped Date Sub Total Shipping FTaxes  Order Total _ Ship NamiShip Addr Paid Date _ Status
2 81 2 3 25/04/2006 0 0 0 0 Thomas A 123 3rd Street New
3 80 2 4 25/04/2006 380 0 0 380 Christina 1123 4th Street New
4 ” 2 6 23/06/2006  23/06/2006 2430 0 0 2490 Francisco 123 6th Sti 23/06/2006 Closed
s 7 1 29 5/06/2006  5/06/2006 1560 200 o 1760 500 Jung 1789 29th s 5/06/2006 Closed
6 7 9| 26 5/06/2006  5/06/2006 2250 60 0 2310 Runliu 789 26thS 5/06/2006 Closed
¥ 7% 9| 25 5/06/2006  5/06/2006 660 5 0 665 John Rodr 789 25th S 5/06/2006 Closed
8 s 4 8 5/06/2006  5/06/2006 510 50 0 560 Elizabeth.123 8th Sti 5/06/2006 Closed
9 7 6 6 8/06/2006  8/06/2006 510 300 0 810 Francisco 123 6th St 8/06/2006 Closed
10 B 7 9 5/06/2006  5/06/2006 96.5 100 0 196.5 Sven Mor1 123 9th Sti 5/06/2006 Closed
1 k2 1 28 7/06/2006  7/06/2006 230 40 0 270 Amritanst 789 28th S 7/06/2006 Closed
12 n 1 1 24/05/2006 736 0 0 736 Anna Bed: 123 1st Street New
13 70 1 11 24/05/2006 800 0 0 800 Peter Krsc 123 11th Street New
14 ) 1 10 24/05/2006 525 0 0 52.5 Roland Wi123 10th street New
5 8 1 7 24/05/2006 o o Ming-Yang 123 7th Street New
16 67 4 10 24/05/2006  24/05/2006 200 9 0 209 Roland W:123 10th S 24/05/2006 Closed
17 66, 3 8 24/05/2006  24/05/2006 5 0 Elizabeth 123 8th Sti 24/05/2006 New
18 65 9| 28 11/05/2006  11/05/2006 10 0 Amritanst 789 28th S 11/05/2006 New
19 64 8 6 9/05/2006  9/05/2006 12 0 Francisco 123 6th Sti 9/05/2006 New
20 63 4 3 25/04/2006  25/04/2006 620 7 0 627 Thomas A 123 3rd St 25/04/2006 Closed
2 ) 3 29 12/04/2006  12/04/2006 7 o S00.Jung L789 29th § 12/04/2006 New
2 61 9| 4 7/04/2006  7/04/2006 4 0 Christina 1123 4th Sti 7/04/2006 New
23 60 6 8 30/04/2006  30/04/2006 1392 50 0 1442 Elizabeth . 123 8th Sti 30/04/2006 Closed
2 59 4 12 22/04/2006  22/04/2006 5 0 John Edw: 123 12th S 22/04/2006 New

: — 3 422000006 _22/04/2008.__3520 5 0 3575 Christina 1123 4th Sti 22/04/2006 Closed
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HawLegjs Brewery

Description Quantity _ Use By Date _ Location
Vodka 20 710412007 Warehouse 1
Bourbon 30 10772007 BottieShop
Crown Lager 45 12001/2007 BottieShop
Scotch 25 10062007 Warehouse 3
Wailby 28 1/09/2007 Front Bar
Baileys Irish Cream 30 1005/2007 BottleShop
Galliano 45 101/2007 Warehouse 3
Kaluha 32 100212007 BottieShop
Crown Lager 21 3/0512007 Warehouse 3
Emu Export 45 50032007 BotlleShop
Baileys Irish Cream 28 11102007 FrontBar
Swan Lager 3 4002/2007 Warehouse 1
Swan Lager 20 1/11/2007 Warehouse 1
Heinekin Lager 15 100712007 BottieShop
Swan Gold 31 200712007 FrontBar
Bourbon 25 19/0412007 Front Bar
Galliano 32 140082007 Warehouse 1
Crown Lager 15 29/10/2007 Warehouse 1
Vodka 30 1/03/2007 FrontBar
Vodka 23 140032007 Warehouse 3
Crown Lager 45 16/11/2007 BottleShop
Wailbu 30 70092007 Warehouse 1
Crown Lager 20 5/10/2007 Bottieshop
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A B [ D E. G

1 | Staff Payroll Nx|Title [~ |First Name ~|Last Name | Department |-7| Role | Date of Bir x|
2 31256 Ms Aleisha Fenlon Administration  Secretary 7/04/1

5 31267 Ms Ashley Fresh Finance Personal Assistant 9/03/1971
6 31267 Miss Jemma Roberts Maintenance Clerk 5/12/1961
8 31589 Ms Maddison Dawson Finance Supenvisor 2/06/1970
) 31658 Mr Fred Oates Finance Accountant 19/12/1982
1 31687 Mr Michael Thurley Maintenance Leading Hand 15/04/1979
12 31689 Miss Patricia Smith Administration  Supenvisor 11/07/1979,
13 31854 Mr Jack Blythe Administration  Assistant 7/04/1964
15 34589 Ms Jennifer Briggs Maintenance Storeman 30/01/1968
16 34895 Ms Angela Morris Maintenance Clerk 21/06/1983
17 37896 Ms Kirstyn McGinley Administration  Receptionist 29/09/1974
18 38976 Ms. Katelyn Chell Administration  Personal Assistant 3/02/1964
19 40056 Ms Aleisha Fenlon Administration  Secretary 7/04/1963
22 43296 Ms Ashley Hammer Finance Personal Assistant 9/03/1971
] 44376 Miss Jemma Roberts Maintenance Clerk 5/12/11961
i 46536 Ms Maddison Dawson Finance Supenvisor 2/06/1970
26 48696 Mr Fred Oates Finance Accountant 19/12/1982
28 50856 Mr Michael Thurley Maintenance Leading Hand 15/04/1979
29 51936 Miss Patricia Smith Administration  Supenvisor 11/07/1979
30 53016 Mr Jack Blythe Administration  Assistant 7/04/1964
32 56176 Ms. Jennifer Briggs Maintenance Storeman 30/01/1968
33 56256 Ms. Angela Morris Maintenance Clerk 21/06/1983
34 57336 Ms Kirstyn McGinley  Administration  Receptionist 29/09/1974
35 58416 Ms. Katelyn Chell Administration  Personal Assistant 3/02/1964
36 59496 Ms Aleisha Fenlon Administration  Secretary 7/04/1963
9| 62736 Ms Ashley Hammer __Finance Personal Assistal 9/03/1971
e R L
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2 [Fredl  Fred il
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A B C D E 3 G H

1 HawLekjs Brewery

2 | STOCKLIST

3 Item No. Description Quantity  Use By Date Location Alcohol Content  Size Cost Total

4 71256 Crown Lager 50 7/04/2007 Warehouse 1 High 700ml $33.00 $1,650.00
5 71264 Scotch 20 1/07/2007 BottleShop Low. Carton Cans $34.50 $690.00
6 71267 Crown Lager 45 12/01/2007 BottleShop Medium Carton Bottles. $55.00 $2,475.00
7 71267 Mailbu 28 1/09/2007 Front Bar High 700ml $27.00 $756.00
8 71267 Scotch 25 1/06/2007 Warehouse 3 Low 700ml $38.00 $950.00
g 71268 Baileys Irish Cream 30 1/05/2007 BottleShop High 700ml $35.00 $1,050.00
10 71589 Galliano 45 1/01/2007 Warehouse 3 High 700ml $37.00 $1,665.00
1 71645 Kaluha 32 1/02/2007 BottleShop High 700ml $42.00 $1,344.00
12 71658 Crown Lager 21 3/05/2007 Warehouse 3 Low Carton Cans $55.00 $1,155.00
13 71687 Baileys Irish Cream 28 1/10/2007 Front Bar High 700ml $35.00 $980.00
14 71687 Emu Export 45 5/03/2007 BottleShop High Carton Cans $28.00 $1.260.00
15 71689 Swan Lager 3 4/02/2007 Warehouse 1 Medium Carton Bottles. $26.50 $79.50
16 71854 Matilda Bay Draught 20 1/11/2007 Warehouse 1 High Carton Bottles. $27.00 $540.00
17 72897 Heinekin Lager 45 1/07/2007 BottleShop High Carton Cans $56.20 $2,529.00
18 74589 Bourbon 3 16/09/2007 Front Bar High Carton Cans $25.00 $775.00
19 74895 Bourbon 25 19/03/2007 Front Bar Low. 700ml $34.50 $862.50
20 77896 Galliano 32 14/08/2007 Warehouse 1 High 700ml $37.00 $1,184.00
21 78976 Crown Lager 15 29/10/2007 Warehouse 1 Medium Carton Bottles. $55.00 $825.00
2 80056 More and more beer 30 1/03/2007 Front Bar Low. 700ml $33.00 $990.00
23 81136 Vodka 28 14/03/2007 Warehouse 3 High 700ml $33.00 $924.00
24 82216 Crown Lager 45 16/11/2007 BottleShop High Carton Bottles. $55.00 $2,475.00
25 83296 Mailbu 30 7/09/2007 Warehouse 1 Low. 700ml $27.00 $810.00
26 84376 Crown Lager 20 5/10/2007 Bottleshop High Carton Bottles. $55.00 $1,100.00
i 84442 Kaluha 29 1/02/2007 BottleShop High 700ml $42.00 $1,210.65

4 49 1] Sheeti ~ Sheets ¥4 T e i






OEBPS/httpatomoreillycomsourceoreillyimages51855.png
A
AdaFay

Fae

Assign Macro

Macro name:

Feguest

asinne vieske

45/ e Haris

72| Shenn Golds

0]l

2| Meaghan Guerin

0 | lumevisns

| ool wtnans

2 | sisentinte

| 2t orseiMeranan

rtRoster2

[This Workboak

Macros n

Description






OEBPS/httpatomoreillycomsourceoreillyimages51647.png.jpg
A | B E F
1 Drop
2
4 [Product 2 55.00 750.00 850.00 1,125 50 | Grand Total
5 |Gold 6753 6753]
6 Junior 330 330]
7 |Life 10 110]
8 Silver 4500 4500|
9 Theatre 3400 3400]
10 Grand Total 440 4500 3400 6753 15093]
1" PivotTable Field List %
12
3 Choose s o add toreport: [T
14
15 (] Commission :l
16 S product
17 [ Amount
18 [Months
19 O Years -
20 —_——
2t Drag folds etween areas below:
§§ ¥ ReportFiter | ColumnLabels
2 o —
25 0 Fonias % vaues
2 Produt v | | Sumof Anount
Z EE T |






OEBPS/httpatomoreillycomsourceoreillyimages51859.png
E AR [HEL X
T e Mo Cranse From Prvous reh
Mo [oum ot
[Feee

[Sum of Amount

Designed by OzGrid Business Applications 2004

Experts in Microsoft Excel@®
ittt zon






OEBPS/httpatomoreillycomsourceoreillyimages51697.png
! J K
SIEEREET) ScaleLabel X ‘ ScafeLael ¥ ‘ Scalel abel Text
Gas p2 10 (03 D2)2)+02 0 =83
Electricity [0.15 1125 =((04-D3)12)+D3 O =84
Water 012 90 =((D5-D4)2)+D4 O =85
Food 03 25 (DB-D5Y2)+D5 0
Travel 007 525 =((D7-DB)2)+D6 O =87
Other 016 120 |-BA+D7 =C8|-DB-07 =((8-D7)2)+07 D =88
20
.
20
E s
H . . + Seriest
& 1m +
El
o
o 02 04 05 08 1 12






OEBPS/httpatomoreillycomsourceoreillyimages51827.png.jpg
Selecta ariteria

>

Selecta Date
19/2/2007

373






OEBPS/httpatomoreillycomsourceoreillyimages51913.png
Weekly report
Raina [raina@ozgrid.com]

This message was sent with High importance,

Sent Wed 11/04/2007 1240 P
Toi

“consult@xidenris.com' raina @ozgrid.com'; 'dave @ozgrd. con' raining@ozgrid.com; support @ozgrid.com'; sftwaresales @ozgrid.con';
“forum @ozgrd.com'; development @ozgric. con'; consutancy @ozgrid.com'; help@oegrid.com; vba @ozgrc.com’

CiMessage | [ sneetto 146)

The weekly report as per agreement.
Kind regards,
Michael






OEBPS/httpatomoreillycomsourceoreillyimages51857.png
Project - VBAProject | [userForm

ik -l
=] - Option Explicst =N []
& funcres (FUNCRES> ] lpenctvate
= & vBaProject (Book2 Private Sub Userfor_Click() e
55 Micosoft Excel O I
Sheet1 (shest | End Sub lKeyDown
48] Thsworkbook ferress
= & Fors ey | |
Layout
B serfomt ) eadown
Ll ] ouseliove.
IMouseUp.






OEBPS/httpatomoreillycomsourceoreillyimages51767.png
[ 4] A B & G H 1 J K M
|1] Male  Female

| 2 |ageGroup1 4% s5%

| 3 |ageGroup2  ss%  as%

| 4 |ageGroup3 65%  35%

5 |AgeGroupa 5% 25%

6| o% 20% 0% 60% 0%

[

|8 |

B

| 10]

u

= Female
2

13| B Male
1]

jE5 -100% 75% -50% -25% 0%  25% S0% 75% 100%

19

e






OEBPS/httpatomoreillycomsourceoreillyimages51807.png
umbers

500
750
2345
10.00
9.96
600

ing Every 3rd Cell
3545

E F G
Criteria "™ [this cel cannot have
FALSE | fre s headng a5 o






OEBPS/httpatomoreillycomsourceoreillyimages51899.png
B Si | D

YEAR: =2007 DEPT: =Lab AMOUNT: >500

vear [ Dept Amount =
2007 Lab 520
2007 Lab 620
2007 Lab 530

2007 Lab. 654





